Beantwortet

Alexa spielt erst bei Wiederholung des Befehls den Titel


Abzeichen

Hallo zusammen,

seitdem ich auf S2 gegangen bin, habe ich folgendes Problem. 

Alexa bitte ich, einen bestimmten Titel abzuspielen. Sie bestätigt das dann, indem sie Titel und Interpret wiederholt. Danach kommt allerdings keine Musik. Anschließend muss ich die Anfrage erneut stellen, Alexa wiederholt, was sie verstanden hat und dann kommt auch die Musik. Inzwischen habe ich herausgefunden, dass diese Sache auftritt, wenn ich vorher per App Musik ausgewählt und abgespielt  hatte. Danach funktioniert die Sprachbedienung immer erst beim zweiten Anlauf, dann aber dauerhaft. Zumindest solange, bis ich wieder die App benutzt habe. Dieses Problem gab es mit der alten Software nicht.

Mit dem Sonos-Support habe ich bereits alle möglichen Lösungen ausprobiert und alles was mit Skills und Accounts zu tun hat neu installiert. Vielleicht ist jemand hier im Forum schon auf dieses Problem gestoßen und kann mir helfen. 

Bin für Hilfe dankbar!

icon

Beste Antwort von Nils S 21 Dezember 2020, 16:14

Es wird irgendwie nicht einfacher, sondern immer kurioser...

@Itchy300 @trick17 

Hallo zusammen,

ich bin mir nicht sicher, ob ihr das gleiche Problem habt. Ein grundsätzliches Problem ist mir nicht bekannt.

 

Ich schlage vor ihr ruft uns noch mal an und wir schauen es uns gemeinsam an. Eventuell müssen wir das Netzwerk genauer analysieren.

Rufnummer hier - Nummer für DE z. B.: 0800 9 444 999

 

Grundsätzlich gilt bei Alexa die Anleitung: https://support.sonos.com/s/article/3516?language=de

 

Liebe Grüße

Nils

Original anzeigen

51 Antworten

Abzeichen +2

Hallo zusammen,

seitdem ich auf S2 gegangen bin, habe ich folgendes Problem. 

Alexa bitte ich, einen bestimmten Titel abzuspielen. Sie bestätigt das dann, indem sie Titel und Interpret wiederholt. Danach kommt allerdings keine Musik. Anschließend muss ich die Anfrage erneut stellen, Alexa wiederholt, was sie verstanden hat und dann kommt auch die Musik. Inzwischen habe ich herausgefunden, dass diese Sache auftritt, wenn ich vorher per App Musik ausgewählt und abgespielt  hatte. Danach funktioniert die Sprachbedienung immer erst beim zweiten Anlauf, dann aber dauerhaft. Zumindest solange, bis ich wieder die App benutzt habe. Dieses Problem gab es mit der alten Software nicht.

Mit dem Sonos-Support habe ich bereits alle möglichen Lösungen ausprobiert und alles was mit Skills und Accounts zu tun hat neu installiert. Vielleicht ist jemand hier im Forum schon auf dieses Problem gestoßen und kann mir helfen. 

Bin für Hilfe dankbar!

 

Hallo 🙋🏼‍♂️ 

bin gerade auf der Suche nach dem gleichen Fehler auf deinen Beitrag gestoßen. 
Das mit dem verwenden der App und dann tritt der Fehler wieder auf, kann ich zwar nicht bestätigen, aber es passiert so ziemlich jedes Mal. Außer wenn ich dann auf der gleichen Sonos einen anderen Befehl über ein Album gebe, funktioniert es beim ersten Mal. 
Aber wenn ich schon länger keinen Befehl mehr gegeben hab, muss ich ihn wieder zwei mal ausführen, dass Alexa es auch tatsächlich abspielt. 
 

Hast du hier schon eine Lösung gefunden? 
Komischerweise hat auf deinem Beitrag niemand geantwortet, was echt komisch in der SONOS Community ist.  

 

Hoffe du hast das Problem bereits gelöst und lässt mich daran teilhaben. Ist nämlich echt nervig. 
 

Viele Grüße 

Manuel 

Abzeichen

Hallo, das Problem konnte ich mit dem Sonos-Support klären. Leider hatte das jede Menge Zeit und Nerven gekostet. Und ja, mich hat auch gewundert, dass im Forum niemand helfen konnte... 

Kurz gesagt: angeblich hat das nichts mit S2 zu tun sondern damit, wie Spotify funktioniert. Für Spotify handelt es sich beim Abspielen über die App am Handy und beim Abspielen über Sonos/Alexa jeweils um unterschiedliche Geräte. Das beschriebene Verhalten würde nicht auftreten, wenn man einen Spotify-Familyaccount verwenden würde. Damit können mehrere Spotifystreams gleichzeitig - auf Handy UND Sonos - abgespielt werden. Dann funktioniert Alexa direkt beim ersten Befehl. Ich bin bei meinem Einzelaccount geblieben und habe als Standard Amazon Music gesetzt. Damit habe ich deutlich seltener das Problem. Trotzdem bin ich sicher, dass es vorm Update auf S2 ohne das Wiederholen des Befehls mit einem Einzelaccount ging. Der Support hatte mich x-mal zum Neueinrichten etc aufgefordert, bis denen die Lösung eingefallen war. Hoffe, ich konnte dir helfen.

Abzeichen +2

Tja, dann ist das nicht die Lösung. Ich habe einen Family Account. Meine Frau ihren eigenen Spotify Account im SONOS System inkludiert. 
Dieser wird aber nur dann aktiv, wenn sie von ihrem Handy aus, Musik aus der SONOS App startet. Beim Sprachbefehl wird der Account von mir verwendet. Will heißen, wenn ich im Auto unterwegs bin und über Spotify Musik höre, und meine Frau zuhause über den Alexa Sprachbefehl Musik abspielt, stoppt bei mir im Auto Spotify und meine Frau hört zuhause über meinen Account. Nur wenn sie die Musik über ihr Handy startet, kann ich im Auto wieder ohne Störungen weiter hören. Das ganze hat aber nichts damit zu tun, warum Alexa den Befehl beim ersten Mal nickt ausführt. 
Dass ich mit einem Account nicht gleichzeitig auf zwei Geräten hören kann, das ist von Spotify so gesteuert, aber was soll das mit dem Sprachbefehl zu tun haben. 

Auch habe ich diesen Family Account schon vor S2 gehabt und da war das Problem definitiv nie!!!! 
Also mit einem Family Account ist das Problem somit auch nicht behoben. 
 

Es kann doch nicht sein, dass dieses Problem sonst niemand kennt. Weiß @Superschlumpf vielleicht eine Lösung? Sorry für die Markierung 🙈

 

Viele Grüße 

Manuel 

@trick17, man kann nur über das Sonossystem verschiedene Streams starten, wenn man ein Einzelabo hat, das war schon unter S1 so. Spotify Connect greift über die Spotify-Cloud auf die Spotifyapp zu, das merkt Spotify natürlich, es erfolgt im Hintergrund eine Verifizierung des Accounts und die Wiedergabe wird auf ein Gerät begrenzt, wenn es sich um kein Familienabo handelt.

Abzeichen

Ich hatte jedenfalls an meinem einzelnen Spotifyaccount nichts geändert und nur S2 installiert. Danach funktionierte Alexa nicht mehr wie vorher mit S1. Und vorher konnte ich über die App streamen und Alexa ansprechen woraufhin der Handystream beendet wurde und die Musik auf Sonos startete. Gleichzeitig auf zwei Geräten streamen ging auch mit S1 nicht.

Dass ich mit einem Account nicht gleichzeitig auf zwei Geräten hören kann, das ist von Spotify so gesteuert, aber was soll das mit dem Sprachbefehl zu tun haben.

 

Spotify Connect und Sprachsteuerung erfolgen beide über die Cloud und unterliegen denselben Bedingungen, gilt bei Spotify leider auch fürs Familienabo.

Vielleicht funktioniert es so.

Ein anderes Amazon Alexa-Konto mit Sonos verwenden

 

Und natürlich sollte das Familienmitglied über seinen eigenen Account auf Sonos zugreifen.

Mehrere Konten für denselben Musikdienst verwenden

Abzeichen

Dass ich mit einem Account nicht gleichzeitig auf zwei Geräten hören kann, das ist von Spotify so gesteuert, aber was soll das mit dem Sprachbefehl zu tun haben.

 

Spotify Connect und Sprachsteuerung erfolgen beide über die Cloud und unterliegen denselben Bedingungen, gilt bei Spotify leider auch fürs Familienabo.

Vielleicht funktioniert es so.

Das heißt doch dann, dass die Aussage des Supports falsch ist? Mit einem Familyaccount würde ich ja das Ausgangsproblem nicht beheben können. Oder verstehe ich das falsch?

Ich habe meinen obigen Beitrag noch ergänzt. Man braucht verschiedene Amazon- resp. Googlekonten.

Abzeichen +2

Ich glaube wir reden aneinander vorbei. 
Mir ist bewusst dass Spotify je Account egal ob Family oder nicht nur auf einem Gerät wieder gegeben werden kann. Um das geht es auch gar nicht. 
es ist auch völlig egal, dass wenn jemand bei mir zuhause Alexa anspricht, das ganze dann von meinem Account aus gestartet wird. Das macht mir auch nix. Das kann eben damit behoben werden in dem man die Musik per App startet. 
 

Mir geht es darum, dass Alexa beim ersten Befehl den Befehl zwar wiederholt und es quasi bestätigt, aber ihn dann nicht ausführt. Der gleiche Befehl dann ein zweites Mal hintergefeuert, mit der gleichen Bestätigung von Alexa und schon geht es. Das ist das, was mich stört. Und das kann nicht an dem Account von Spotify liegen. Das ging unter S1 auch wunderbar. Dann hätte dieses Problem hier auch schon bestehen müssen. 

Abzeichen +2

 

Und natürlich sollte das Familienmitglied über seinen eigenen Account auf Sonos zugreifen.

Mehrere Konten für denselben Musikdienst verwenden

Wir haben auf SONOS zwei Spotify Accounts hingelegt. Daher funktioniert es ja auch, wenn meine Frau über ihr Handy startet, weil hier eben ihr Spotify Account hinterlegt ist. 

Ah verstehe, kommt manchmal vor, kann verschiedene Ursachen haben. Handelt es sich dabei um eine bestimmte Quelle, z.B. einen Radiosender?

Abzeichen +2

Ah verstehe, kommt manchmal vor, kann verschiedene Ursachen haben. Handelt es sich dabei um eine bestimmte Quelle, z.B. einen Radiosender?


Ich glaube bei radiosendern ist mir das auch schon passiert. Aber wo es definitiv der Fall ist, wenn ich aus Spotify Musik abrufe. Sei es ein Album, oder auch eine Playlist. Es ist prinzipiell egal was aus Spotify. Alexa wiederholt den Befehl in gänzlicher Richtigkeit. Fügt bei der Rückbestätigung auf meinem Befehl sogar noch den richtigen Interpreten hinzu, den ich bei gewissen Alben weg lasse, wo ich weiß, dass Alexa auch ohne Interpreten im Befehl das richtige Album abspielt. Aber sie spielt danach nichts ab. Wiederhole ich den Befehl genauso wieder, bestätigt ihn Alexa auch Wort für Wort genauso und spielt dann die Musik ab. 

  • Spotify hat anscheinend mit Sonos-Firmware v10.4 die Art und Weise geändert, wie es sich mit Sonos verbindet, es könnte demnach daran liegen.
  • Oder daran, dass Spotify das Problemkind unter den Musikdiensten ist; in dem Fall als Erstes https://status.sonos.com/ aufrufen, ob Probleme bekannt sind. Wenn nicht, eine Diagnose absetzen und mit dem Support sprechen.
  • Und man darf nicht vergessen, dass Amazon laufend an Alexa herumschraubt, das sorgt ebenfalls häufig für irritierendes Verhalten.
Abzeichen +2

Aber mir stellt sich dann die Frage, warum das ganze nicht mehr bemängeln, sich beschweren oder um Hilfe suchen. Ich mein, so wie ich das sehe sind Trick17 und ich die einzigen beiden, die das Problem zu haben scheinen. 
also dann kann es ja nicht an Spotify oder Alexa liegen. Weil dann hätten alle die gleiche Version von Spotify oder eine Alexa die von Amazon etwas umgebaut wurde und somit dieses Problem. 
daher bin ich eben davon ausgegangen, dass es ein stationäres Problem sein muss. Oder vielleicht ein Bug im skill, der durch beenden und neu Verknüpfen behoben ist. Das hat aber leider keine Veränderung gebracht, der Fehler bleibt. 

Aber mir stellt sich dann die Frage, warum das ganze nicht mehr bemängeln, sich beschweren oder um Hilfe suchen. Ich mein, so wie ich das sehe sind Trick17 und ich die einzigen beiden, die das Problem zu haben scheinen. 
 

 

Ihr seid nicht die ersten, die das ansprechen, und kommt auch bei anderen Diensten vor und lässt sich nicht auf eine einzige Ursache festlegen. Manchmal ist es das Heimnetz, manchmal muss man Alexa neu autorisieren (in dem Fall vorher z.B. aus der Spotifyapp und von allen Amazon-Apps, einschl. Alexa-App und Audible, abmelden), manchmal ist es ein Ausfall des Dienstes und wenn es sich um einen Radiosender handelt, der über einen eigenen Skill verfügt, muss man diesen aus der Alexa-App entfernen.

 

Unser einziges “Handbuch” ist Beheben von Problemen mit Amazon Alexa in Sonos, was im Grunde auf Rätselraten hinausläuft, da wir nicht über das Hintergrundwissen des Supports verfügen.

Abzeichen +2

Hmmm. Naja schade dass das keine genaue Lösung zu geben scheint. 
Ich werde mich morgen mal aus allen Apps abmelden, den Sonos Skill entfernen und dann alles wieder neu verbinden. Habe aber irgendwie nicht viel Hoffnung in den Plan. 
 

Danke aber für deine Hilfe. 
 

Viele Grüße und noch einen schönen Abend. 

Abzeichen

Hmmm. Naja schade dass das keine genaue Lösung zu geben scheint. 
Ich werde mich morgen mal aus allen Apps abmelden, den Sonos Skill entfernen und dann alles wieder neu verbinden. Habe aber irgendwie nicht viel Hoffnung in den Plan. 
 

Danke aber für deine Hilfe. 
 

Viele Grüße und noch einen schönen Abend. 

Das hatte ich alles schon, unter Anleitung des Supports, bereits (mehrfach) gemacht. Bei mir hat sich dadurch nichts geändert. 

Benutzerebene 7
Abzeichen +3

@Itchy300 

@trick17 

Hallo ihr beiden… um ehrlich zu sein, habe ich auch keine Idee, woran es höchstwahrscheinlich liegt.

:-(

Abgesehen davon, dass Spotify und auch Amazon bzgl. Alexa imo häufig im Hintergrund Dinge ändern, wäre meine einzige Idee, dass in der Alexa App der gleiche Account Spotify Account hinterlegt ist, der parallel auf einem anderen Gerät verwendet wird. Ich könnte mir vorstellen, dass beim ersten Versuch per Alexa zunächst die Wiedergabe auf dem anderen Gerät gestoppt wird und blöderweise ein weiterer Versuch notwendig ist, um dann per Alexa über den Amazon Account, der mit dem gleichen Spitify Konto verbunden ist, den Inhalt zu starten. 
Helfen könnte imo nur, DAS Spotify Konto mit der Alexa App zu verbinden, das üblicherweise auch in Sonos genutzt wird. 
 

Bei einem Spotify Einzelaccount sollte aber der Wechsel zwischen Sonos App Wiedergabe und Alexa Wiedergabe ohne Probleme funktionieren. Wenn auf einem anderen Gerät wie Smartphone etc. der gleiche Account aktuell genutzt wird, kommt es durch den Wechsel auf Alexa ggf. zu dem Stoppen. 
Gruß,

Ralf

Abzeichen +2

@Itchy300

@trick17

Hallo ihr beiden… um ehrlich zu sein, habe ich auch keine Idee, woran es höchstwahrscheinlich liegt.

:-(

Abgesehen davon, dass Spotify und auch Amazon bzgl. Alexa imo häufig im Hintergrund Dinge ändern, wäre meine einzige Idee, dass in der Alexa App der gleiche Account Spotify Account hinterlegt ist, der parallel auf einem anderen Gerät verwendet wird. Ich könnte mir vorstellen, dass beim ersten Versuch per Alexa zunächst die Wiedergabe auf dem anderen Gerät gestoppt wird und blöderweise ein weiterer Versuch notwendig ist, um dann per Alexa über den Amazon Account, der mit dem gleichen Spitify Konto verbunden ist, den Inhalt zu starten. 
Helfen könnte imo nur, DAS Spotify Konto mit der Alexa App zu verbinden, das üblicherweise auch in Sonos genutzt wird. 
 

Bei einem Spotify Einzelaccount sollte aber der Wechsel zwischen Sonos App Wiedergabe und Alexa Wiedergabe ohne Probleme funktionieren. Wenn auf einem anderen Gerät wie Smartphone etc. der gleiche Account aktuell genutzt wird, kommt es durch den Wechsel auf Alexa ggf. zu dem Stoppen. 
Gruß,

Ralf


Hallo Ralf 🙋🏼‍♂️
danke für die Idee. Hört sich auch logisch an, aber an dem liegt es leider auch nicht. 
Selbst wenn an einem anderen Gerät schon länger nichts mehr angespielt wurde tritt das Problem auf. 
Bestes Beispiel: gestern Abend wieder zweimal den Befehl gegeben. Heute früh im Bad, hatte sie es erst falsch verstanden und beim zweiten Befehl abgespielt. Dann bin ich runter (oben an der Sonos per Hand gestoppt) und unten mit Alexa das selbe wieder als Befehl ausgegeben. Selbes Problem wieder. Erst beim zweiten Mal spielt sie es ab. Da war dazwischen definitiv kein anderes Gerät dazwischen. 
 

Es ist echt mehr als nervig. 

 

Meldet euch von der Spotifyapp und allen Amazon-Apps ab, die auf dem Mobilgerät (einschl. Alexa-App und Audible) installiert sind und entfernt danach in der Alexa-App den Sonos Skill und führt im Anschluss den Autorisierungsprozess für Alexa noch einmal durch.

  • Aktiviere den Sonos Skill erneut: Öffne die Alexa App und tippe im Menü auf die obere linke Seite. Tippe auf Skills und Spiele > Deine Skills > Sonos > Skill deaktivieren. Sobald du den Sonos Skill ausgeschaltet hast, tippe auf Skill aktivieren.

 

Ich mag die Alexa-App auf iOS/Android nicht und gehe dafür lieber auf alexa.amazon.de. Dort unter ‘Smart Home’ den Sonos Skill entfernen und unter Skills wieder heraussuchen, die Autorisierung muss man danach in iOS/Android abschließen, aber da wird man angeleitet.

Abzeichen

Über die Sonos-App bekomme ich diese Fehlermeldung angezeigt wenn ich das erste Mal mit Alexa spreche. Bei der Wiederholung des Befehls geht es dann normal und der Titel wird abgespielt.

 

Abzeichen +2

Über die Sonos-App bekomme ich diese Fehlermeldung angezeigt wenn ich das erste Mal mit Alexa spreche. Bei der Wiederholung des Befehls geht es dann normal und der Titel wird abgespielt.

 

Das würde auf die Vermutung von Ralf passen. Nur spielt bei mir im anderen Raum oder auf einem anderen Gerät nichts. 
vielleicht gibt Spotify dann einfach nur vor oder glaubt dass noch jemand spielt (also ein Bug in Spotify) und daher dann das Problem 🤷🏼‍♂️
 

aber dann müssten ja alle diesen Bug haben? 🤷🏼‍♂️

Abzeichen +2

Soooo… Ich setze jetzt noch eins drauf. 

Habe, aufgrund von trick17´s Screenshot, ob bei mir die gleiche Meldung kommt. So, gesagt getan. 

App geöffnet und los sollte es gehen. Momentan lief noch eine andere Playlist, wohl bemerkt, wurde dieses Playlist, bzw. das Lied ebenfalls kurz vorher mit Alexa gestartet. Eigentlich bin ich davon ausgegangen, dass es jetzt ohne Probleme funktionieren würde. 

Tja… was soll ich sagen, eine Fehlermeldung wie bei trick17 kam nicht. Alexa quitierte wie immer meinen Befehl mit der Wiederholung des Befehls. Musik blieb aber aus. Im Display der App erscheinte auch das Cover des gewünschten Albums, aber die Musik war gestoppt. Also der Balken für die Musik lief nicht. Händisch hätte ich das Album dann einfach mit der Playtaste starten können…. 
Also, wenn Spotify hier irgend ein Problem mit einem anderen Gerät hätte, warum spielt es dann vorhin die Lieder ab und beim nächsten Befehl verweigert Spotifiy. 

Es könnte höchstens sein, dass vorhin die Box im Esszimmer den Befehl entgegen nahm und den neuen Befehl die Box im Wohnzimmer. Aber Esszimmer, Küche und Wohnzimmer laufen als Gruppe in der Sonos App. Auch habe ich diese Boxen in der Alexa-App als Gruppe geschalten, weil ich somit mit “Alexa Lautstärke 2” alle Boxen gleichzeitig die Lautstärke verändere und nicht nur die Box, die mich gerade aufnimmt. 

Aber selbst wenn es eben jetzt eine andere Box aufgenommen hat, hatte ich dieses Problem (sorry, dass ich es wieder ausspreche) unter S1 definitiv nicht. Auch hier hatte ich schon diese Boxen im Einsatz… 

 

Es wird irgendwie nicht einfacher, sondern immer kurioser...

  1. Wenn man unter seinem Amazonkonto “Meine Inhalte & Geräte → Datenschutzeinstellung → Alexa Datenschutz → Sprachaufnahmen-Verlauf” aufruft, findet man den Verlauf der ‘Kommunikation’ mit Alexa, dort ist je auch das Gerät aufgeführt, das angesprochen wurde
  2. Innerhalb von 15 Minuten eine Diagnose absetzen, den Support kontaktieren, einen Screenshot der Sprachaufnahmen sowie die Diagnosenummer bereithalten

 

Mehr fällt mir nicht ein.

Abzeichen +2
  1. Wenn man unter seinem Amazonkonto “Meine Inhalte & Geräte → Datenschutzeinstellung → Alexa Datenschutz → Sprachaufnahmen-Verlauf” aufruft, findet man den Verlauf der ‘Kommunikation’ mit Alexa, dort ist je auch das Gerät aufgeführt, das angesprochen wurde
  2. Innerhalb von 15 Minuten eine Diagnose absetzen, den Support kontaktieren, einen Screenshot der Sprachaufnahmen sowie die Diagnosenummer bereithalten

 

Mehr fällt mir nicht ein.

Also, ich habe jetzt versucht kontakt aufzunehmen, aber irgendwie funktioniert der Live-Chat nicht. Die Diagnosedatei mit der Nummer 1738810910 habe ich geschickt. Kannst du das irgendwie weiterleiten? Den Screenshot von Alexa habe ich auch da und kann dann gerne eingereicht werden. 

Danke dir für die Hilfe. 

Antworten