Verzögerte Wiedergabe innerhalb einer Gruppe

  • 15 September 2023
  • 20 Antworten
  • 318 Ansichten

Abzeichen

Hallo Sonos-Community,

ich bitte die gesammelte Schwarmintelligenz um Unterstützung bei meinem Problem.

Ich habe mehrere Sonos-Lautsprecher welche u.a.  im Erdgeschosses als Paar verbunden sind.

1x Sonos One SL Küche (Paar)

1x Sonos One SL Essen (Paar incl. Sub Gen.3)

1x 5.1 Wohnzimmer (Arc incl. One SL, incl. Sub Gen.3)

1x Sonos One SL Terrasse (Paar)

1x Sonos Gästebad

 

Das gesamte Sonos Netz wird angesteuert über einen Boost an der Fritz-Box (Kanal 6). (Abstand ca. 10 cm)

Sind also alle Lautsprecher im „LAN“ und auch mit WM:0  aufgeführt.

Insgesamt sind derzeit 19 Lautsprecher, im Haus, vorhanden.

Bei den Lautsprechern für Küche, Essen und Terrasse habe ich einen Reset bereits durchgeführt.

 

Nun zum Problem.

Wenn ich eine Gruppe der o.g. Lautsprecher erstelle, habe ich ein Abspielproblem mit den Titeln von Spotify.  Es ist egal ob ich eine Gruppe Küche, Essen und Terrasse, oder nur Küche und Essen, oder … erstelle.

Wenn ein Titel von Spotify läuft und ich klicke auf nächster Titel, dann wird der Titel sofort in einem Paar (z,B. Terrasse) abgespielt, bei den anderen Gruppen verzögert sich aber der Abspielvorgang um mehrere Sekunden. Es kann auch sein, dass der Titel auf der Terrasse (innerhalb der erstellten Gruppe) läuft und auf den anderen Lautsprecher läuft noch der alte Song, bis der Neue Titel dann kommt. Auch ist es möglich, dass der Titel nur in einem Sonoslautsprecher (obwohl es ein Paar ist) läuft und erst Sekunden später läuft der Titel auf beiden Lautsprechern.

Ich weiß nicht wie ich es noch beschreiben soll und hoffe, dass es etwas verstanden wird.

 

Kennt jemand dieses Problem, kann mir jemand helfen.

 

Vielen Dank für nützliche Tipps. Ich habe Sonos schon sehr lange und bin derzeit etwas frustriert.


Dieser Beitrag ist geschlossen für weitere Beiträge

20 Antworten

Hallo @redbac , Dein Problem sind mit aller Wahrscheinlichkeit die WLAN-Versorgungs-Strecken über das “sogenannte” SONOS-Net (sprich das SONOS-eigene WLAN). Das kann an der Sende- und Empfangs-Feldstärke der jeweiligen SONOS-Geräte (Nodes) selbst liegen, oder auch durch Störungen von Außen (anderen oder eigenen WLANs) hervorgerufen werden.

Wenn Du magst poste einfach mal einen Screen-Shot Deiner SONOS-Network-Matrix. Einfach in einem Browser (am besten am PC/NB) einfach mal “IP-ADRESSE:1400/support/review” aufrufen. - als “IP-ADRESSE” verwendest Du die von einem Player (z. Bsp. der Arc). Unten in der Seite dann auf “Network-Matrix” klicken.

Und beschreibe in der Antwort dann mal welche Komponenten sich noch in Deinem Netzwerk befinden und wie die Eingestellt sind. - Switche, APs … und WLAN-Einstellung (Kanal / Bandbreite). 

Abzeichen

Hallo Peter,

danke für die schnelle Rückmeldung.

Die Matrix habe ich mir schon mal angesehen. Ist aber extrem viel! (leesbar?!)

Vom Boost zum ersten Sonos Lautsprecher sind es  ca. 3 Meter und dann ist man schon in der Küche und alle weiteren Lautsprecher in einem Umkreis von ca. 5-6 Metern.

An der Fritzbox sind 2 Repaeter im Mash angeschlossen. Einer davon ist auch im Wohnzimmer 1200AX. Alle mit akuteller SW.

Das Frequenband hatte ich eigenltich aif 2,4 gesetzt und 5 GHz deaktiviert. War jetzt wieder an und hab es wieder deaktiviert.

Die Funkleinstellung steht auf manuell und ist auf Kanal 6.

Es gibt 2 Smate Heizkörpertermostate von AVM und einen Geschirrspühler.

Das TV Gerät ect. ist per Lan angeschlossen.

Reicht das erstmal an Infos? Hab ich was vergessen?

Danke fürs helfen.

René

...

Die Matrix habe ich mir schon mal angesehen. Ist aber extrem viel! (leesbar?!)

… leesbar … eher nicht ;-(

Aufgefallen ist mir nur, dass keiner der Geräte die Rolle der STP-Root-Bridge belegt !?
Die sollte eigentlich bei der BOOST sein, da die ja Deinen Aussagen zu folge am LAN hängt, es sei denn Du hast einen Managed-Switch im Einsatz, oder AVM verwendet jetzt auch STP im Mesh und hat die Fritte (den Switch darin) als Root-Bridge deklariert !?

Und einige Verbindungen zwischen den Nodes sind natürlich schon grenzwertig. - allerdings kann ich die nicht entziffern wegen der Auflösung.

Da musst Du ggf. mal selbst schauen. Wie man die Matrix liest solltest Du ja wissen … oder nachfolgend nachlesen 

» fragen zur farbe der network-matrix

 

Vom Boost zum ersten Sonos Lautsprecher sind es  ca. 3 Meter und dann ist man schon in der Küche und alle weiteren Lautsprecher in einem Umkreis von ca. 5-6 Metern.

Das kannst Du in der Matrix dann ja mal nachvollziehen.
Man sieht ja wie, wer, mit wem verbunden ist. » STP state: forwarding 

 

An der Fritzbox sind 2 Repaeter im Mash angeschlossen. Einer davon ist auch im Wohnzimmer 1200AX. Alle mit akuteller SW.

Das sollte prinzipiell zunächst keinerlei Auswirkungen haben, es sei denn die Funken auf dem selben Kanal wie SONOS.

 

Das Frequenband hatte ich eigenltich aif 2,4 gesetzt und 5 GHz deaktiviert. War jetzt wieder an und hab es wieder deaktiviert.

Die Funkleinstellung steht auf manuell und ist auf Kanal 6.

Hast Du nicht oben geschrieben dass SONOS (also das SONOS-Net, sprich das SONOS-WLAN) auf Kanal 6 eingestellt ist !?
Das wäre suboptimal.
Fritte und SONOS sollten auf 1, 6 und 11 verteilt sein. - am besten auf 1 und 11 wenn dort nicht die “lieben Nachbarn” sich tummeln.

 

Es gibt 2 Smate Heizkörpertermostate von AVM und einen Geschirrspühler.

Die arbeiten ja entweder via WLAN oder im DECT. - also unproblematisch.

 

Das TV Gerät ect. ist per Lan angeschlossen.

… und was ist ect. ?!?

 

 

Abzeichen

Hallo Peter,

zunächst, sorry - ich habe eher wenig Zeit und kann mich nur Minuten rausnehmen um mich um das Proglem zu kümmern. Grundsätzlich wäre mir eigentlich ein Techniker lieber, aber den gibt es ja leider nicht. UND - technisch bin ich leider auch nicht so gut.

Aber nun zu deinen Infos.

Zunächst habe ich nun den Boost einfach mal um ca. 20 cm nach oben gesetzt um zu sehen ob dadurch die orangenen Felder in der Matrix weniger werden. Hierbei hab ich Sie auch resetet. Sieh da - es ist nur noch ein Lautsprecher, welcher am entferntesten ist, orange. Ob das Zufall ist oder wirklich damit zusammen hängt, kannst womöglich Du besser erkennen.

In diesem Zusammenhang - würde ein 2ter Boost Sinn machen?

Zu deinen Antworten hab ich eine Frage. Ich habe die Fritzbox auf Kanal 6 eingestellt.

Somit sind doch die Repeater auch auf Kanal 6. Zumindest gehe ich davon aus.

 

An der Fritzbox hängt noch ein Switch für den Fernseher und TV Box.

Ansonsten, sind eigentlich keine Geräte da, die vor der Problematik noch nicht da waren.

Kannst Du mit meinen Angaben was anfangen?

Danke nochmals fürs helfen.

René

Zunächst habe ich nun den Boost einfach mal um ca. 20 cm nach oben gesetzt um zu sehen ob dadurch die orangenen Felder in der Matrix weniger werden. Hierbei hab ich Sie auch resetet.

Ein Reset (also Werk-Einstellung) wäre nicht nötig, ein Reboot ebenfalls eigentlich nicht. - schaden tut’s aber auch nicht.

Interessant wäre noch ob die Rolle der “Root-Bridge” in der SONOS-Matrix bei einem der Geräte jetzt auftaucht ?!

 

Sieh da - es ist nur noch ein Lautsprecher, welcher am entferntesten ist, orange. Ob das Zufall ist oder wirklich damit zusammen hängt, kannst womöglich Du besser erkennen.

das ist mit Sicherheit kein Zufall und doch ein gutes Ergebnis.
Manchmal reichen ein paar Zentimeter um den RSSI erheblich zu ändern / verbessern / verschlechtern.

 

In diesem Zusammenhang - würde ein 2ter Boost Sinn machen?

Ein BOOST nicht wirklich, da das unwirtschaftlich und IMO rausgeschmissenes Geld wäre, es sei denn es ist die einzige und wirklich letzte Möglichkeit. Es reicht nämlich vollkommen aus einen (oder auch mehrere) Deiner vorhandenen Geräte / Lautsprecher per LAN zu versorgen. - die machen dann genau das selbe wie die BOOST und geben zusätzlich noch Musik von sich.

Und das ist bei Deiner SONOS-System-Größe mit Garantie sinnvoll.

Schau Dir einfach Deine Matrix an und identifiziere das oder die Geräte wo sich die Werte durch Positionsänderung nicht verbessern lassen. - dann schaust Du ob Du den oder die per LAN versorgen kannst. 

Achte aber möglichst darauf, dass alle SONOS-Geräte mit ein und dem selben Switch (also am besten direkt mit der Fritte) verbunden werden. Es geht auch anders, aber dann muss man einiges beachten was zu erklären hier aktuell zu weit führen würde.

 

Zu deinen Antworten hab ich eine Frage. Ich habe die Fritzbox auf Kanal 6 eingestellt.

Somit sind doch die Repeater auch auf Kanal 6. Zumindest gehe ich davon aus.

Ja, da kannst Du von ausgehen, da Du sie ja im Mesh betreibst. - also übernehmen sie die Einstellungen vom Mesh-Master, also der Fritte.

Wie Du aber Deiner Grafik entnehmen kannst tummeln sich neben Deiner Fritte noch 8 weitere Geräte auf Kanal 6. Das können zum Einen Deine Repeater sein, zum Anderen aber auch Dein SONOS, und auch die “freundlichen Nachbarn”. Erkennen kannst Du das im Bereich darunter  “Andere WLAN-Funknetze in Ihrer Umgebung”. Da werden alle Netze die die Fritte sieht mit ihrem Namen (SSID), Kanal, MAC-Adresse und der Intensität (Mouse-Over auf das Symbol in der ersten Spalte) angezeigt. - SONOS würde ohne Namen (da hidden) auftauchen.

Auf Deine Nachbarn hast Du keinen Einfluss.

Aber Dein SONOS-WLAN (also das SONOS-Net) kannst Du im Controller umstellen. Und das meinte ich oben mit der Verteilung 1 und 11. - das würde ich an Deiner Stelle auf jeden Fall mal umstellen.

Btw., die selbe Ansicht solltest Du auch haben wenn Du Dich auf Deinen Repeatern einloggst. - da kann das dann ganz anders aussehen. - da muss man dann den besten Kompromiss suchen.

 

An der Fritzbox hängt noch ein Switch für den Fernseher und TV Box.

Wichtig wäre dass dieser Switch IGMPv3 bzw. IGMP-Sooping-fähig ist !
Wenn nicht solltest Du den austauschen, bzw. ansonsten zumindest darüber KEIN SONOS-Gerät anschließen.

 

… ich hoffe das hilft ein wenig weiter.

berichte mal über die Ergebnisse.

@redbac, ich nehme an, es handelt sich um ein mehrgeschossiges Haus. Wäre es möglich, in jedem Stockwerk eine Sonoskomponente zu verkabeln?

Abzeichen

Hallo Peter,

wo muss ich das in der Matrix suchen? Beim Boost steht hier nur:

Vertikal:

Horizontal:

 

Das Thema Kanal hab ich jetzt verstanden. In der Fritzbox habe ich Kanal 6 in Sonos war 11. Den habe ich nun auf 1 gesetzt.

Mein Wlan-Nachbar wird natürlich in meiner Fritzbox auch angezeigt und hat auch Sonos. Ich frag mal auf welchen Kanälen (Fritzbox und Sonos) er ist. Er hat kein Problem und keinen Boost.

Switch:

Wie finde ich heraus ob dieser Switch IGMPv3 bzw. IGMP-Sooping fähig ist? Im Datenblatt habe ich hierzu nichts gefunden, muss aber auch gestehen, ich weiß nicht wo ich suchen müsste.

Danke

SG René

@Hedy L. 

Ja, das Haus 2 Geschosse + Dachgeschoss und eine weitere NW Verkabelung wäre möglich, aber nicht wünschenswert.

Danke fürs helfen.

SG René

 

@Hedy L.

Ja, das Haus 2 Geschosse + Dachgeschoss und eine weitere NW Verkabelung wäre möglich, aber nicht wünschenswert.

Danke fürs helfen.

SG René

 

Es wird bei mehrgeschossigen Häusern empfohlen, auf diese Weise braucht man sich wegen der Deckenbeschaffenheit keine Gedanken zu machen.

 

Nennen Sie uns das Modell des Switches?

Hi Rene, 

in der ersten Spalte stehen die Eigenschaften des Gerätes (im Verbund als Node bezeichnet). Bei STP handelt es sich um eine hierarchische Baumstruktur (an oberster Stelle steht die Root-Bridge, gefolgt von Secondary [2. Ebene] und Tertiary [3. Ebene] Node) nach dem Highlander-Prinzip. - es kann nur Einen (Root-Bridge) geben.

Wenn die Root-Bridge nicht bei SONOS auftaucht, dann kann diese Rolle nur beim Switch vor der BOOST, also dem in der Fritte eingebauten, liegen. - möglich und durchaus denkbar, wäre mir aber neu. 

In Spalte 2 bis n stehen dann die Werte und der Status der Verbindung zwischen den jeweiligen Knoten (Nodes).

Der Signal-Fluss ist immer von Oben (Root) nach unten. - also "forward".

Andere Verbindungen sind geblocked und werden nur genutzt wenn die primäre Verbindung wegbricht.

 

Switch: wenn keine Angaben zu IGMP vorhanden, dann kann er das vermutlich nicht !

Dann solltest Du daran tunlichst kein SONOS (oder auch Telekom MediaReceiver) betreiben, da die aktiv Multicast nutzen. - oder halt austauschen.

Abzeichen

Hallo Peter,

mal eine Frage zur Boost. Ich habe diese nun ca. 50 cm von der Wand in die Mitte des Treppenhauses gelegt. Wie kann es sein, das hier nun der Boost - Orange ist! Da dieser ja an der Fritzbox angeschlossen ist, müsste der doch eigentlich immer grün sein. Oder?

Ist auf alle fälle sehr spannend, was hier cm ausmachen. Ein Testgerät für den besten Ort gibt es hier wohl leider nicht. Oder?

Bzgl. Switch, wenn ich diesen nun vorübergehend abstecke, könnte ich ja zumindest mal testen, ob der Fehler noch da wäre, oder ist da meine Denke falsch?

Würde es funktionieren, den Boost an einen Repeater zu hängen um zu sehen, ob die Verbindung hier nochbesser wäre? Oder geht das nur, wenn der Repaeter per Kabel an der Fritzbox wäre?

 

Abzeichen

Hallo Peter,

Hallo Hedy,

ich habe nun den Boost horizontal gedreht und er ist ca. 30 CM von der Fritzbox weg.

Nun ist zumindest hier nix mehr orange.

Ist ja schon mal besser wie vorher.

 

mal eine Frage zur Boost. Ich habe diese nun ca. 50 cm von der Wand in die Mitte des Treppenhauses gelegt. Wie kann es sein, das hier nun der Boost - Orange ist! Da dieser ja an der Fritzbox angeschlossen ist, müsste der doch eigentlich immer grün sein. Oder?

Nein, die erste Spalte wertet die (WLAN-)Umgebung des Gerätes. Dadurch das die BOOST jetzt besser steht "sieht / hört" sie auch mehr von ihrem Umfeld. Die hinterlegte Farbe ergibt sich aus der Bewertung vieler Metriken. Das sind u. a. der Noise Floor der Antennen (der ist bei Dir gut bis sehr gut) und der ANI Level (siehe meine Beschreibung der Matrix). Letzterer ist recht schlecht, da die BOOST jetzt vermutlich Nachbarnetze mit zu geringem Kanal-Abstand sieht (Stichwort Interferenzen).

Solange zunächst aber alles funktioniert ist diese Farbe (1. Spalte) eher zweitrangig und kann erst mal ignoriert werden. - die kann sich in 10 Min. oder der nächsten Std. auch wieder ändern.

 

Ist auf alle fälle sehr spannend, was hier cm ausmachen. Ein Testgerät für den besten Ort gibt es hier wohl leider nicht. Oder?

Naja, Du kannst einfach ein Mobile-Device mit einem WLAN-Scanner (z. Bsp. "Fritz!App WLAN") nehmen. Damit kannst Du dann das ganze Funkspektrum am Ort des jeweiligen Gerätes detailliert analysieren.

 

Bzgl. Switch, wenn ich diesen nun vorübergehend abstecke, könnte ich ja zumindest mal testen, ob der Fehler noch da wäre, oder ist da meine Denke falsch?

Ne, gute Idee. - einfach Ausschlussprinzip anwenden.

 

Würde es funktionieren, den Boost an einen Repeater zu hängen um zu sehen, ob die Verbindung hier noch besser wäre? 

Ganz schlechte / böse Idee !!!

Niemals ein SONOS-Gerät über eine WLAN-Brücke eines fremden Herstellers per LAN betreiben ! - zumindest nicht mit "Plug 'n Play" Repeatern. Anders sieht es mit (semi-) professionellen APs aus, welche man entsprechend konfigurieren kann.

Wenn Du das testen wills nimm ein langes LAN-Kabel. Das braucht nichts teures sein. Cat 5 reicht vollkommen. SONOS arbeitet eh nur mit FastETH (also 100 Mbps).

Wenn Du "gutes" PowerLAN hast, ja dann könnte man das testweise verwenden. - oft funzt es gut, manchmal macht aber auch das Probleme. Ich würd es nicht machen.

Abzeichen

Hallo Peter,

wie lange wird es ungefähr dauern, bis das im Sonos Netz ankommt, wenn ich den Switch ausschalte oder den Boost woanders hinstelle?

Minuten, Stunden, App neu starten?

Kannst Du das ungefähr sagen?

 

Abzeichen

Hallo Peter, 

mal ne ganz blöde Frage. Ich gehe immer davon aus, dass das Problem nur in Sonos liegt. Wenn ich in Tuneln einen Radiosender einschalte, dann läuft es ja überall. Das Problem besteht nur, wenn ich in Spotify unterschiedliche Titel abspiele. Kann es vielleicht eine ganz andere Ursache haben?

wie lange wird es ungefähr dauern, bis das im Sonos Netz ankommt, wenn ich den Switch ausschalte oder den Boost woanders hinstelle?

...

Kannst Du das ungefähr sagen?

Man sollte dem ganzen System ca. 10 Min. Ruhe gönnen.

STP benötigt protokoll- und definitionsbedingt bis zu 5 Min. für einen kompletten Neuaufbau.

Abzeichen

Hab gerde versucht Musik mit Amazon abzuspielen. War genau das gleiche Problem. Also liegt es weiterhin am Sonos System. 

Switch abschalten hatte auch keinen Erfolg. 

 

@redbac, Spotify ist das Problemkind unter den Musikdiensten, die auf Sonos verfügbar sind. Kann sein, dass das an der Cloudanbindung liegt, die für Spotify Connect essenziell ist.

 

Wann kommt es denn hauptsächlich zu Aussetzern/Ausfällen: Wenn Sie die Sonos-App verwenden oder nutzen Sie auch Direct Control (Spotify Connect)?

 

Die Matrix stellt lediglich eine Momentaufnahme dar, außerdem sind seit Einführung der Beam alle neuen Produkte mit der Matrix nicht mehr kompatibel (siehe weiße Komponentenfelder in der linken Spalte, die keine Werte enthalten).

 

 

Der Support kann selbstverständlich alle Werte sehen, hat dadurch einen umfassenden Überblick. Falls trotz der Unterstützung von @Peter_13 Spotify weiterhin herumzickt, telefonieren Sie bitte mit dem Support. Der kann sich bei Bedarf auch per Fernwartung aufschalten.

https://support.sonos.com/s/contact?language=de

mal ne ganz blöde Frage.

… gibt keine blöden Fragen, nur blöde Antworten ;-)

Ich gehe immer davon aus, dass das Problem nur in Sonos liegt. Wenn ich in Tuneln einen Radiosender einschalte, dann läuft es ja überall. Das Problem besteht nur, wenn ich in Spotify unterschiedliche Titel abspiele. Kann es vielleicht eine ganz andere Ursache haben?

Möglich ist alles.

Der größte Unterschied ist vermutlich die Bandbreite des Streams.

Radio läuft i. d. R. mit 128 bis max. 256 Kbps, ggf mit VBR

Bei Spotify hängt es m. W. vom Abo ab (hab kein Spotify). Aber da können durchaus 320 Kbps CBR oder gar bei FLAC 500 Kbps und mehr bei rauskommen.

Und wenn Du reines WAV in CD-Qualität streamst, dann liegst Du gleich mal bei 1,4 Mbps.

Und alles braucht diese Bandbreite kontinuierlich und ohne Unterbrechung. - mal die Buffer-Zeit ausgeklammert.

Das sind zwar alles noch keine Größen im Vergleich zu 100 Mbps DSL oder 500 bis 1Gbit GF oder Kabel-Anschlüssen. Aber in Summe sind das meist alles Shared Medien, und wenn da einfach mal für ein paar Sec. was klemmt, dann ist Dein Aussetzer perfekt.

Nachgedanke:

Ist VPN, Werbeblocker, Pi-Hole, Sicherheitssoftware oder Ähnliches installiert? Falls ja, scrollen sie runter zu "Firewall-Ports, die Sonos verwendet".

Benutzerebene 7
Abzeichen +4

@redbac 

Hallo, habe mal still mitgelesen und stelle mir auch die Frage, ob Spotify und Amazon jeweils aus der Sonos App oder aus der App des Musikdienstes genutzt werden? Ich würde erstmal ausschließlich über die Sonos App testen. 
Wenn für Amazon ein Unlimited Abo besteht, kann es durchaus ein Problem mit der Bandbreite sein, da hier HD und UHD Inhalte vorliegen. Spotify hingegen ist (immer noch nicht) nicht einmal bei CD Qualität/ HD/ HiFi angekommen und kann max. HQ mit 320 kbs. Wenn die Bandbreite auch hier das Problem wäre, dann stimmt da in deinem Netzwerk arg etwas nicht, wenn das Problem sogar bei einer Gruppe aus nur zwei Räumen auftritt. 
Ich empfehle auf jeden Fall auch mal eine tiefergehende Diagnose mit einem Support Mitarbeiter. 
https://support.sonos.com/de-de/contact?language=de