Beantwortet

Sonos Arc plays 7.1 dts-hd as 5.1 pcm and not 7.1 pcm


Abzeichen

Setup: sonos arc, 2x era 300 as rear speaker, 1x sub gen.3, LG C3, NVIDIA Shield pro 2019. (Media playback through Plex Media Server on a NAS)

When I play a 7.1 DTS-HD file (or a DTS:X file) it plays as 5.1 LPCM (sonos app shows multichannel 5.1 pcm) but since I have a 7.1.4 system with the 2 era 300s as rear speaker It should be playing as 7.1 LPCM. I cannot get that to work with any setting on both the TV or the shield. When I toggle DTS support on at the shield, the 7.1 DTS-HD file will play as the 5.1 DTS core, but still no 7.1. The TV audio is set to passthrough.

Edit: TrueHD Atmos plays fine btw.

Nochmal auf Deutsch nachdem ich gemerkt habe dass das hier ein deutsches Forum ist:

Wenn ich eine 7.1 DTS-HD Tonspur abspiele dann wird diese (bei deaktiviertem DTS & deaktiviertem DTS-HD Support in den Einstellung auf der NVIDIA Shield) als 5.1 LPCM abgespielt. Es sollte aber als 7.1 LPCM abgespielt werden nachdem mein Setup 7.1.4 Kanäle hat. Wenn ich jetzt den normalen DTS Support auf der Shield aktiviere dann wird immer nur der komprimierte DTS Kern aus der DTS-HD Tonspur abgespielt (auch nur 5.1 Kanäle). Also egal welche Einstellung ich nehme, es gibt nicht 7.1 LPCM, was aber eigentlich unterstützt wird mit diesem Setup. Der TV ist auf pass through eingestellt. Andere Formate wie Dolby Atmos TrueHD funktionieren einwandfrei.

icon

Beste Antwort von DieterPete 23 November 2023, 14:41

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

26 Antworten

Ich schupfe den Thread mal hoch, bevor er untergeht.

Benutzerebene 7
Abzeichen +4

@abcdefg 

Puh… könnte imho mit der Audiokodierung der Files zusammenhängen. Du spielst ja anscheinend per Plex ab, richtig? Was sind das für Files bzw. womit wurden die erstellt/ kodiert? 
Sonos kann ja nur „normales“ DTS, weswegen bei aktiver DTS X/ HD Funktion an der Shield kein Ton aus Sonos kommen würde (nicht unterstütztes Format). 
Deswegen bietet sich ja logischerweise an, das Signal als PCM Multichannel abzuspielen. Da bin ich nun aber nicht sicher, ob ein DTS 7.1 Signal dann tatsächlich auch in der LPCM Form immer 7.1 Kanäle hat. Bei Atmos ist das definitiv so, aber bei DTS weiß ich es nicht. Falls es dort auch so ist, dann kann ich mir nur vorstellen, dass beim Decodieren zu LPCM die Shield nur 5.1 ausgibt oder es an den Dateien liegt. 
Am TV ist „Durchlaufen“ bzw. pass through ja korrekt eingestellt. 
Sorry, andere Idee habe ich aktuell grad auch nicht. 

Benutzerebene 7
Abzeichen +4

@abcdefg 

PS: Du scheinst nicht alleine zu sein, oder ist der folgende Beitrag vor 9 Mon. auf Reddit auch von dir? 😉

https://www.reddit.com/r/PleX/comments/1137j1p/dts_71_becomes_lpcm_51/

Es könnte evtl. auch an Plex liegen, falls von dort bereits LPCM an die Shield ausgegeben wird. 

Benutzerebene 6
Abzeichen +4

sorry für die blöde Frage, is die Shild eARC fähig?

kanns daran liegen?

https://support.sonos.com/de-at/article/supported-home-theater-audio-formats

 

Benutzerebene 7
Abzeichen +4

sorry für die blöde Frage, is die Shild eARC fähig?

kanns daran liegen?

https://support.sonos.com/de-at/article/supported-home-theater-audio-formats

 

Das notwendige eARC bezieht sich nur auf die Verbindung der Soundbar zum TV. 😉

Die am TV angeschlossenen Abspielgeräte werden über normale HDMI Verbindungen angeschlossen. 

Abzeichen

sorry für die blöde Frage, is die Shild eARC fähig?

kanns daran liegen?

https://support.sonos.com/de-at/article/supported-home-theater-audio-formats

 

Der Media Player muss nicht eARC unterstützen da er ja nur das Audio am HDMI ausgibt (und keinen Ton empfangen muss wie mit dem Audio Return Channel). Ob eARC funktioniert oder nicht ist in dem Fall vom TV abhängig und der LG C3 unterstützt eARC. Wenn es an der eARC Verbindung liegen würde dann könnte ich ja auch kein TrueHD Atmos abspielen, was aber funktioniert wie schon im Post erwähnt.

Benutzerebene 4
Abzeichen +2

Ich kenne mich mit Plex nicht aus, würde es aber auch verdächtigen. Ich habe zwar nur einen LG C2, aber mit meiner Shield + Emby (oder auch Kodi), kann ich 7.1 problemlos abspielen, sofern benötigt. Wird im Plex Server Dashboard vielleicht angezeigt, ob transkodiert wird? 

Abzeichen

@abcdefg

Puh… könnte imho mit der Audiokodierung der Files zusammenhängen. Du spielst ja anscheinend per Plex ab, richtig? Was sind das für Files bzw. womit wurden die erstellt/ kodiert? 
Sonos kann ja nur „normales“ DTS, weswegen bei aktiver DTS X/ HD Funktion an der Shield kein Ton aus Sonos kommen würde (nicht unterstütztes Format). 
Deswegen bietet sich ja logischerweise an, das Signal als PCM Multichannel abzuspielen. Da bin ich nun aber nicht sicher, ob ein DTS 7.1 Signal dann tatsächlich auch in der LPCM Form immer 7.1 Kanäle hat. Bei Atmos ist das definitiv so, aber bei DTS weiß ich es nicht. Falls es dort auch so ist, dann kann ich mir nur vorstellen, dass beim Decodieren zu LPCM die Shield nur 5.1 ausgibt oder es an den Dateien liegt. 
Am TV ist „Durchlaufen“ bzw. pass through ja korrekt eingestellt. 
Sorry, andere Idee habe ich aktuell grad auch nicht. 

Ich spiele hauptsächlich (uhd) blu ray dateien ab und diese werden mit MakeMKV erstellt. Ich bin mir sehr sicher dass meine Dateien nicht das Problem sind (Ich habe das schon mit mehreren Filmen mit einer DTS-HD oder DTS:X Spur getestet und das Ergebnis bleibt gleich). Soweit ich weiß sollte die ARC an den TV mit der EDID die unterstützten Kanäle reporten und der TV gibt das dann an die Shield weiter wo dann eben das passende PCM ausgegeben wird. Ich weiß nicht ob es vielleicht am TV (LG C3) liegt nachdem ich diesen Post gesehen habe wo mehrere Leute mit LG Geräten ähnliche Probleme hatten: https://en.community.sonos.com/home-theater-228993/sonos-arc-and-7-1-downmix-to-5-1-6863804?sort=dateline.desc#comments

Abzeichen

Ich kenne mich mit Plex nicht aus, würde es aber auch verdächtigen. Ich habe zwar nur einen LG C2, aber mit meiner Shield + Emby (oder auch Kodi), kann ich 7.1 problemlos abspielen, sofern benötigt. Wird im Plex Server Dashboard vielleicht angezeigt, ob transkodiert wird? 

Ich habe zusätzlich zu Plex noch Tautulli laufen was genaue Wiedergabeinfos liefert und dort wird angezeigt dass die Dateien per Direct Play (also ohne transcoding) abgespielt werden und beim Audio: Direct Play (DTS, 8 Kanäle)

Benutzerebene 4
Abzeichen +2

Ok interessant, dann ist es evtl. der C3, was mich zwar verwundern würde, aber ausschließen kann man das natürlich nicht. Um Plex 100% auszuschließen, würde ich es mal mit Kodi versuchen. Dort einfach Passthrough ausschalten und dann Ausgabe auf 7.1 stellen, das sollte, sofern mich meine Erinnerung nicht trügt, dann PCM 7.1 ergeben. Ich kann da aber später nochmal genauer nachschauen. 

Abzeichen

Ok interessant, dann ist es evtl. der C3, was mich zwar verwundern würde, aber ausschließen kann man das natürlich nicht. Um Plex 100% auszuschließen, würde ich es mal mit Kodi versuchen. Dort einfach Passthrough ausschalten und dann Ausgabe auf 7.1 stellen, das sollte, sofern mich meine Erinnerung nicht trügt, dann PCM 7.1 ergeben. Ich kann da aber später nochmal genauer nachschauen. 

Ich werde das testen und dann Rückmeldung geben

Benutzerebene 7
Abzeichen +4

@abcdefg

Hast du evtl. auch einen BD Player am Start und kannst den auf LPCM Ausgabe einstellen während eine DTS 7.1 Tonspur abgespielt wird? Dann könnte man Plex und Shield ggf. als Ursache ausschließen und der TV würde sich als Verdächtiger bestätigen. Ich fände aber komisch, dass er das Problem dann aber nur mit 7.1 PCM aus einer DTS Spur hat und nicht auch mit Atmos. Aber wer weiß…

Benutzerebene 7
Abzeichen +4

@abcdefg 

Schade.. ich wollte eben auch mal per BD Player testen, aber habe hier keine Disk mit einer DTS 7.1 Spur. Alles nur 5.1. 🙈

Abzeichen

@abcdefg

Hast du evtl. auch einen BD Player am

Start und kannst den auf LPCM Ausgabe einstellen während eine DTS 7.1 Tonspur abgespielt wird? Dann könnte man Plex und Shield ggf. als Ursache ausschließen und der TV würde sich als Verdächtiger bestätigen. Ich fände aber komisch, dass er das Problem dann aber nur mit 7.1 PCM aus einer DTS Spur hat und nicht auch mit Atmos. Aber wer weiß…

Da muss ich gleich enttäuschen, ich habe keinen BD Player .. spiele nur Dateien über Plex ab

Abzeichen

Ok interessant, dann ist es evtl. der C3, was mich zwar verwundern würde, aber ausschließen kann man das natürlich nicht. Um Plex 100% auszuschließen, würde ich es mal mit Kodi versuchen. Dort einfach Passthrough ausschalten und dann Ausgabe auf 7.1 stellen, das sollte, sofern mich meine Erinnerung nicht trügt, dann PCM 7.1 ergeben. Ich kann da aber später nochmal genauer nachschauen. 

Ich werde das testen und dann Rückmeldung geben

also wenn ich eine DTS:X Datei, die in Plex mit Multi-Channel PCM 5.1 abgespielt wurde jetzt in Kodi abspiele und in den Kodi Einstellungen manuell die Anzahl der Kanäle auf 7.1 einstelle, dann wird tatsächlich in der Sonos App Multi-Channel PCM 7.1 angezeigt. scheint also irgendwie an Plex zu liegen obwohl es ja angeblich per Direct Play spielt…

Abzeichen

Ich habe diesen Beitrag gefunden:

„The problem being that LG OLED Tv's do not send the EDID from the device that is on the eARC channel downstream, and it's a fact, and it's verified, and no one wants to fix it or acknowledge it.“

aus einem Kommentar von hier:

https://www.reddit.com/r/LGOLED/comments/11tr7fi/lg_oled_c9_cx_series_earc_and_edid_not_passed/

 

also ich kann mir deshalb gut vorstellen dass die HDMI EDID Informationen (die ja auch die Anzahl der Kanäle beinhalten) nicht korrekt/gar nicht an die Shield weitergegeben werden vom LG C3 und deshalb es nur in 7.1 abspielt wenn ich das manuell festlegen kann (wie in Kodi).. das funktioniert mit Plex leider nicht soweit ich weiß.

Benutzerebene 4
Abzeichen +2

Da muss ich später mal schauen, ich habe z.B. mit Emby keine Probleme, aber ich weiß nicht mehr genau, ob ich da irgendwas bezüglich Ton eingestellt habe. Ich weiß auch nicht, ob das Thema beim C3 noch aktuell ist, der C9 ist immerhin von 2019, da könnte sich schon was getan haben. 

Abzeichen

Ich habe jetzt mal einen PC an den HDMI vom LG C3 (statt der NVIDIA Shield) angeschlossen und mit einem Tool die HDMI EDID Informationen ausgelesen (das Tool: Monitor Asset Manager). Dasselbe habe ich dann auf meinem alten LG NANO86 gemacht (und natürlich die Sonos Arc vorher daran angeschlossen). Hier die Ergebnisse:

PC -> LG C3 + Sonos ARC (connected with eARC, passthrough enabled)

CE audio data (formats supported)
  LPCM    2-channel, 16/20/24 bit depths at 32/44/48/96/192 kHz
  AC-3    6-channel,  640k max. bit rate at 32/44/48 kHz
  DD+     8-channel, 16-bit              at 32/44/48 kHz
  DTS     6-channel, 1536k max. bit rate at 44/48/88/96 kHz
  DTS-HD  8-channel, 16/20/24 bit depths at 44/48/88/96/176/192 kHz
  DVD-A   8-channel, 16/20 bit depths    at 48 kHz

PC -> LG NANO86 + Sonos ARC (connected with eARC, passthrough enabled)

CE audio data (formats supported)
  LPCM    8-channel, 16/20/24 bit depths at 32/44/48 kHz
  DD+     8-channel, 16/20 bit depths    at 32/44/48 kHz
  AC-3    6-channel,  640k max. bit rate at 32/44/48 kHz
  DVD-A   8-channel, 16/20 bit depths    at 44/48/88/96/176/192 kHz

also ich schließe aus den Ergebnissen dass der LG C3 nicht korrekt die EDID weitergibt, nachdem die Anzahl der LPCM Channel bei 2 ist und zudem DTS-HD Unterstützung angezeigt wird, was aber bei der Sonos Arc nicht der Fall ist.

Edit: zusätzlich zu “CE audio data (formats supported)” wird beim LG NANO86 noch folgendes übertragen (beim LG C3 gibt es diese Daten gar nicht):

CE speaker allocation data
  Channel configuration.... 7.1
  Front left/right......... Yes
  Front LFE................ Yes
  Front center............. Yes
  Rear left/right.......... Yes
  Rear center.............. No
  Front left/right center.. No
  Rear left/right center... Yes
  Rear LFE................. No

 

Benutzerebene 4
Abzeichen +2

LPCM 2-Channel ist definitiv komisch, kann ja aber nicht wirklich stimmen, denn du hast ja zumindest LPCM 5.1 also 6 Channels. Ich bin mir daher nicht wirklich sicher, inwiefern diese Infos hilfreich/korrekt sind. 

Ich habs jetzt mal bei mir gecheckt und in der Emby hab ich die Audioausgabe einfach auf Auto stehen, genauso wie in den Shield Einstellungen auch. Wenn ich einen Film mit DTS 7.1 starte, bekomme ich damit automatisch Multichannel PCM 7.1 in der Sonos App angezeigt. So wirklich erklären kann ich mir das bei dir also nicht, habe aber irgendwie immer noch die Plex App in Verdacht. 

Abzeichen

habe auch nochmal die Shield an den LG NANO86 angeschlossen und über die Plex App bekomme ich auch nur LPCM 5.1. Also liegt es wohl doch eher nicht an der EDID. Habe jetzt keine Ahnung was das Problem ist; wenn es tatsächlich nur die Plex App ist dann frage ich mich warum ich der einzige bin mit dem Problem.

Benutzerebene 4
Abzeichen +2

Superschlumpf hat ja dieses Thema verlinkt: https://www.reddit.com/r/PleX/comments/1137j1p/dts_71_becomes_lpcm_51/

Ich habe auch noch das hier gefunden: https://www.reddit.com/r/ShieldAndroidTV/comments/lp7j72/trying_to_get_shield_pro_to_decode_dtshd_ma_71_to/

Du scheinst also nicht der einzige zu sein und es scheint in der Tat wohl eher ein Plex Problem zu sein. 

Habe jetzt keine Ahnung was das Problem ist; wenn es tatsächlich nur die Plex App ist dann frage ich mich warum ich der einzige bin mit dem Problem.

 

Im Sonos-Forum sind Sie der Einzige mit dem Problem, es ist für Probleme mit Plex allerdings auch nicht die richtige Anlaufstelle.

 

https://forums.plex.tv/

Benutzerebene 7
Abzeichen +4

@abcdefg 

Ich finde, du bist u. a. natürlich auch hier im Forum richtig mit dem Thema. Ist aber eben kein gängiges Setup und Usecase. Daher kann man da schonmal einer von wenigen betroffenen Nutzern sein.

Der Blick in verschiedene Foren ist hier wohl am erfolgversprechendsten. 

Es könnte sich ja um einen Programmfehler in der Plex-App handeln, wovon ich momentan auch ausgehe. Die Stammnutzer des Plex-Forums wissen eventuell Bescheid.

 

Es gibt auch eine deutsche Community.

https://forums.plex.tv/c/the-world-is-flat/deutsch/82

 

Ich würde deswegen außerdem den Support anschreiben und nachfragen.

https://www.plex.tv/contact/

Abzeichen

Superschlumpf hat ja dieses Thema verlinkt: https://www.reddit.com/r/PleX/comments/1137j1p/dts_71_becomes_lpcm_51/

Ich habe auch noch das hier gefunden: https://www.reddit.com/r/ShieldAndroidTV/comments/lp7j72/trying_to_get_shield_pro_to_decode_dtshd_ma_71_to/

Du scheinst also nicht der einzige zu sein und es scheint in der Tat wohl eher ein Plex Problem zu sein. 

den zweiten Link habe ich auch schon gefunden und mal nachgefragt ob der eine Lösung hat inzwischen aber gab keine Rückmeldung bisher