Beantwortet

SMB Fehlermeldungen - Anmeldung des Benutzers [guest] am FRITZ!Box SMB-Dienst von IP gescheitert (Benutzer existiert nicht)


Abzeichen +1

Moin,

ich habe meine Musik auf diverse NAS-Laufwerke verteilt. Der Zugriff über’s Tablett oder PC funktioniert problemlos. Entsprechende Zugriffsrechte sowie User sind eingerichtet. Wenn ich über’s Tablett (IOS) oder PC Musik abspiele, versucht die Playbar mit dem Usernamen “Guest” auf die NAS-Inhalte zu zugreifen und der Router haut mir das Logfile mit Fehlermeldungen zu.

Anmeldung des Benutzers [guest] am FRITZ!Box SMB-Dienst von IP-Adresse XXX gescheitert (Benutzer existiert nicht)

 

Ich habe schon alles mögliche durch, Apps zurück gesetzt, User und Zugriffrechte gelöscht und neu erstellt. Hilft aber alles nix. hat jemand von euch eine Idee woran es liegen kann?

 

Gruß, Torsten

icon

Beste Antwort von hein-daddel 7 May 2021, 06:52

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

32 Antworten

Abzeichen +1

@hein-daddel

Moin Torsten,

falls du tatsächlich noch was herausfinden solltest, sag mal hier Bescheid. Fände ich interessant. 
Grüße,

Ralf

Moin Ralf,

gestern habe ich von unterwegs aus das Update 7.27 für die Fritzbox angeschubst und mir dann ca. alle 2-3 Stunden die Logfiles angesehen. Resultat ist immer dasselbe: der eingerichtete User Sonos greift korrekt auf das NAS der Fritzbox zu und keinerlei Versuche mehr von der Playbar als „guest“….  ich habe heute morgen noch einmal nachgesehen, immer noch alles völlig korrekt.
 

Also hat AVM da irgend etwas versaubeutelt…. 
 

Gruß, Torsten

Benutzerebene 7
Abzeichen +3

@hein-daddel 

Danke für die Info, Torsten. 
Grüße,

Ralf

Benutzerebene 7
Abzeichen +3

@hein-daddel 

Moin Torsten,

falls du tatsächlich noch was herausfinden solltest, sag mal hier Bescheid. Fände ich interessant. 
Grüße,

Ralf

@hein-daddel

Lade hier doch mal einen Screenshot der Einstellungen für die Musikbibliothek aus der Sonos App hoch. 


Moin, da gibt es doch keine besonderen Einstellungen, UNC Pfad reingehauen, Usernamen und Passwort rein, feddich…

\\FRITZ.BOX\FRITZ.NAS\SanDisk-Ultra-01\Music

 

nimm mal testweise statt dem Host-Namen die IP der Fritte

Abzeichen +1

Moin, 

 

habe gestern die Sonos komplett neu konfiguriert (vorher alles Geräte für eine Stunde komplett stromlos), Musikindex neu erstellt und Zing wieder dieselbe Fehlermeldung. Die Playbar versucht Zugriff als „Guest“ auf SMB obwohl der Index als User „Sonos“ samt Passwort konfiguriert wurde… 🙄

Benutzerebene 6
Abzeichen +3

@hein-daddel 

Bist du schon weitergekommen?

 

Wenn nicht, können wir uns das mal gemeinsam anschauen: Telefon (Mo - Fr, 10:00 - 18:00) oder Chat (Mo - So, 10:00 - 18:00)

Erstelle am besten schon mal kurz nach dem der Fehler aufgetreten ist eine Diagnose.

Es ist gut möglich, dass wir eine Beschreibung deines Heimnetzes brauchen werden.

 

Liebe Grüße

Nils

Abzeichen +1

@hein-daddel

Jau, Hauptsache es läuft… manche Dinge bleiben ein Mysterium.

Und nur um das ggf. noch herauszufinden und die Switches auszuschließen, würde ich jetzt auch kein 50m Lankabel durchs Haus ziehen oder die Playbar fürn Test zum Router schleppen.

;-)

 

das wohl wahr, ich behalte das aber mal so nebenher im Auge, vielleicht komme ich doch noch dahinter...


Ich hab im Keller noch ca. 300m Cat6 Kabel auf Rolle rumliegen, Stecker aufcrimpen und los geht’s :-)

Vielen Dank für Deine (eure) Bemühungen.

 

Gruß, Torsten

 

Abzeichen +1

@hein-daddel

>Bist du schon weitergekommen?

nö, noch nicht

>Wenn nicht, können wir uns das mal gemeinsam anschauen: Telefon (Mo - Fr, 10:00 - 18:00) oder >Chat (Mo - So, 10:00 - 18:00)

das wird leider nicht klappen, bin Berufskraftfahrer und europaweit unterwegs. Wenn alle Stricke reissen, machen wir’s wenn ich mal in der Woche frei habe. So dringend ist es ja nicht, Musikwiedergabe klappt problemlos, mich nerven nur die Einträge im Router Log leicht ein wenig :-)

>Erstelle am besten schon mal kurz nach dem der Fehler aufgetreten ist eine Diagnose.

yup, das mache ich

>Es ist gut möglich, dass wir eine Beschreibung deines Heimnetzes brauchen werden.

was bräuchtest Du genau?

Gruß, Torsten

 

 

Abzeichen +1

@hein-daddel

>Bist du schon weitergekommen?

kannst ja mal gucken….

290120756

 

Gruß, Torsten

 

 

 

Abzeichen +1

nochmal ein wenig rumprobiert…

07:38:23 Musikindex neu erstellt mit User Sonos und Passwort, der Zugriff funktioniert.

07:38:38 Zugriff über Sonos Controller für PC 13.0  von dem der Index erstellt wurde, die App kurz neu gestartet und die Playbar haut als User guest zurück.

Anmeldung des Benutzers guest am FRITZ!Box SMB-Dienst von IP-Adresse 192.168.220.39 gescheitert (Benutzer existiert nicht). [2 Meldungen seit 25.04.21 07:38:38]
Anmeldung des Benutzers Sonos am FRITZ!Box SMB-Dienst von IP-Adresse 192.168.220.39. [2 Meldungen seit 25.04.21 07:38:23]  
Benutzerebene 7
Abzeichen +3

@hein-daddel 

Moin…

Mit der Diagnosenummer kannst du dich leider nur per Chat oder Telefon beim Support melden. Übers Forum werden die nicht mehr ausgewertet. :-(

Hast du eigentlich nur die Playbar oder auch noch andere Sonosgeräte zum Testen des Zugriffs? Dann hätte man mal einen Anhalt, ob es am Gerät liegt. 
Du hast oben geschrieben, dass du die Geräte vom Strom genommen und alles neu eingerichtet hast. Hast du die Playbar dabei komplett auf Werkseinstellungen zurückgesetzt?

Das wäre ggf. sonst noch einen Versuch wert. 
 

Wobei die Tatsache, dass der Sonos-Zugriff auf das andere NAS ohne Probleme funktioniert imo eher auf eine Ursache im Zusammenspiel zwischen Playbar oder Sonossystem allgemein mit der Fritzbox hindeutet. 
 

Sorry falls ich die Info überlesen haben sollte, aber ist die Playbar per Lan oder Wlan angebunden? 
Und das andere NAS hängt auch an der Fritzbox?

Hi @hein-daddel ,

kannst Du von dem PC aus über den Explorer ohne Einschränkung auf die Share in der Fritte zugreifen?
Zu welchem Gerät gehört die o. in der FM gezeigte IP-Adresse ?

Hintergrund der Frage:
Beim Indizieren erfolgt der Zugriff vom SONOS-System aus direkt auf die Fritte (bzw. deren SMBv1-NAS-Dienst).

Bei der Auswahl von Tracks bzw. Titeln / Alben in der MB über den Controller greift nicht nur das SONOS-System alleine auf das NAS zu.
Um die Covers zu jedem Track im Controller zu zeigen erfolgt ein Zugriff auf diese Share direkt von dem Device auf dem der Controller läuft.
Der Controller erhält vom SONOS-System lediglich aus dem Index den Pfad zum originalen File. Das anzuzeigende Cover läd der Controller (vs das Device auf dem dieser läuft) dann realtime aus dem File selbst bzw. als FOLDERJPG aus dem Alben-Directory nach.

Heist im Klartext. Wenn Du sehr stringente Berechtigungen eingestellt hast kann der Zugriff als guest auch von Deinem PC her rühren.

Benutzerebene 7
Abzeichen +3

@Peter_13 

Dann wären mindestens für ein iPad auch Beschränkungen eingerichtet, den laut Eingangspost klappt auch der Zugriff per iOS Controller Nutzung vom Tablett nicht. :-(

 

@hein-daddel 

Ich weiß, wahrscheinlich hast du das schon geprüft, aber zur Sicherheit nochmal… Sind die folgenden Optionen der Fritzbox für die SMB Freigabe korrekt gesetzt?

 

 

@Peter_13

Dann wären mindestens für ein iPad auch Beschränkungen eingerichtet, den laut Eingangspost klappt auch der Zugriff per iOS Controller Nutzung vom Tablett nicht. :-(

… ob exclusive “Beschränkungen” oder einfach nur recht zurückhaltende und stringente “Berechtigungen” bleibt ohne die AW des TE zunächst offen.

Benutzerebene 7
Abzeichen +3

@hein-daddel 

Hast du meinen Beitrag oben als Antwort markiert? Wenn ja, dann klär uns doch noch auf, was die Ursache /Lösung war… ;-) Zurücksetzen der Playbar?

Gruß,

Ralf

Abzeichen +1

@hein-daddel

 

>Mit der Diagnosenummer kannst du dich leider nur per Chat oder Telefon beim Support melden. >Übers Forum werden die nicht mehr ausgewertet. :-(

schade...

>Hast du eigentlich nur die Playbar oder auch noch andere Sonosgeräte zum Testen des Zugriffs?

Playbar, Sub, 2 X Sonos one, 2 x Boost, 2 x Play 3

>Du hast oben geschrieben, dass du die Geräte vom Strom genommen und alles neu eingerichtet >hast. Hast du die Playbar dabei komplett auf Werkseinstellungen zurückgesetzt?

yup, das habe ich. Die Fehlermeldungen im Router Log kommen nur von der Playbar. Mir sind diese Fehlermeldungen vorher nie aufgefallen, imho treten die erst seit dem letzten Firmware Update von Sonos auf….

>Wobei die Tatsache, dass der Sonos-Zugriff auf das andere NAS ohne Probleme funktioniert imo >eher auf eine Ursache im Zusammenspiel zwischen Playbar oder Sonossystem allgemein mit der >Fritzbox hindeutet. 

Auf dem anderen NAS greift sie nur auf den Public Bereich zu (\\NAS\Music), ohne als User eingerichtet zu sein...

>Sorry falls ich die Info überlesen haben sollte, aber ist die Playbar per Lan oder Wlan angebunden? 

die Playbar hängt über Lan dran, alles andere über die beiden Boost….

>Und das andere NAS hängt auch an der Fritzbox?

yep, exakt.

Gruß, Torsten

 

Abzeichen +1

@Peter_13

>Dann wären mindestens für ein iPad auch Beschränkungen eingerichtet, den laut Eingangspost >klappt auch der Zugriff per iOS Controller Nutzung vom Tablett nicht. :-(

doch das klappt alles völlig problemlos, nur versucht die Playbar dann als User “guest”  den SMB Zugriff. Albencover werden auf allen IOS Geräten ebenfalls korrekt angezeigt….

@hein-daddel

>Ich weiß, wahrscheinlich hast du das schon geprüft, aber zur Sicherheit nochmal… Sind die >folgenden Optionen der Fritzbox für die SMB Freigabe korrekt gesetzt?

yep, ist exakt so incl smbv1

Gruß, Torsten

 

 

Abzeichen +1

Hi @hein-daddel ,

kannst Du von dem PC aus über den Explorer ohne Einschränkung auf die Share in der Fritte zugreifen?
Zu welchem Gerät gehört die o. in der FM gezeigte IP-Adresse ?

Hintergrund der Frage:
Beim Indizieren erfolgt der Zugriff vom SONOS-System aus direkt auf die Fritte (bzw. deren SMBv1-NAS-Dienst).

Bei der Auswahl von Tracks bzw. Titeln / Alben in der MB über den Controller greift nicht nur das SONOS-System alleine auf das NAS zu.
Um die Covers zu jedem Track im Controller zu zeigen erfolgt ein Zugriff auf diese Share direkt von dem Device auf dem der Controller läuft.
Der Controller erhält vom SONOS-System lediglich aus dem Index den Pfad zum originalen File. Das anzuzeigende Cover läd der Controller (vs das Device auf dem dieser läuft) dann realtime aus dem File selbst bzw. als FOLDERJPG aus dem Alben-Directory nach.

Heist im Klartext. Wenn Du sehr stringente Berechtigungen eingestellt hast kann der Zugriff als guest auch von Deinem PC her rühren.

@Peter_13 

Moin, hier laufen 3 PC’s und 3 Laptops, die sich automatisch über die NAS Laufwerke synchronisieren, 5 IOS Geräte, Fernseher, div Player und noch jede Menge AVM-Gedöns.

die angezeigte IP (220.39) ist die Playbar

Alben Cover usw werden völlig korrekt angezeigt, Abspielen von Musik, egal ob über beide NAS oder Streaming Dienste funktionieren völlig ohne Probleme, kein Ruckeln, kein Zucken, einfach nix 

Ich habe nur auf dem Fritz.NAS ein Passwort und User eingerichtet, weil es nicht anders geht… Auf dem anderen NAS (Zyxel NSA325v2) kann Sonos nur auf den Public Bereich (\\NAS\Music) ohne User und Passwort zugreifen. Alle anderen PC’s und Laptops laufen über eigens eingerichtete Bereiche mit entsprechenden Zugriffsrechten….

die Fehlermeldungen treten immer dann auf wenn mit einer Sonos App auf das AVM Gedöns zugegriffen wird (egal ob über IOS Gerät, PC oder Laptop). Imho treten diese Meldungen erst nach dem letzten Sonos Firmware Update auf.

Vom Prinzip her kann ich das so weiter laufen lassen, funktioniert ja alles ohne Probleme, nur diese Fehlermeldungen gehen mir auf den Senkel ;-)

Hmm, bleibt wohl nix anderes über als die von der Playbar gesendeten Pakete abzufangen und mal zu gucken was genau das Teil da versucht….

 

Gruß, Torsten

Benutzerebene 7
Abzeichen +3

@hein-daddel 

Moin Torsten,

Danke für deine detaillierten Infos. Jetzt wird einiges klarer… ich bin bisher davon ausgegangen, dass der Zugriff von der Playbar aus dann auch Probleme in der Anwendung macht. 
Es nervt dich ja aber anscheinend nur die Meldung der Fritzbox. ;-)

Die könnte imo in der Tat durch ein Update, ob eines der Fritzbox selber oder auf Sonos Seite sei dahingestellt, verursacht sein, sofern sie früher nicht da war. 
Imo ist sie aber nicht tragisch, denn sie sagt ja nur aus, dass ein Gerät nicht mit dem Admin Account der Fritzbox aufs NAS zugreift, sondern mit einem anderen angelegten Benutzer. Fraglich bleibt halt nur, warum die Meldung nur beim Zugriff über die Playbar kommt. 
Hast du mal das Abspielen vom Fritz NAS auf einem anderen Sonosgerät versucht? Wäre interessant, ob die Meldung dann auch kommt. Ggf. hat es auch mit der Art der Lanverbindung der Playbar zu tun. Hängt die direkt an der Fritzbox oder an nem Switch o. ä.?

Hallo @hein-daddel ,

zunächst musst Du auf der Fritte für SONOS SMBv1 aktivieren. - das ist ggf. mit dem letzten Update deaktiviert worden.

Dann muss auf der Fritte auch ein User (incl. PW) für den Zugriff auf dieses Share eingerichtet sein.

Mit diesen Voraussetzungen sollte dann auch der Zugriff von SONOS aus funktionieren.

Benutzerebene 7
Abzeichen +3

@hein-daddel

Lade hier doch mal einen Screenshot der Einstellungen für die Musikbibliothek aus der Sonos App hoch. 

Abzeichen +1

Hallo @hein-daddel ,

zunächst musst Du auf der Fritte für SONOS SMBv1 aktivieren. - das ist ggf. mit dem letzten Update deaktiviert worden.

Dann muss auf der Fritte auch ein User (incl. PW) für den Zugriff auf dieses Share eingerichtet sein.

Mit diesen Voraussetzungen sollte dann auch der Zugriff von SONOS aus funktionieren.


smbv1 ist aktiviert, sowie User und Zugriffrechte auch...

Abzeichen +1

@hein-daddel

Lade hier doch mal einen Screenshot der Einstellungen für die Musikbibliothek aus der Sonos App hoch. 


Moin, da gibt es doch keine besonderen Einstellungen, UNC Pfad reingehauen, Usernamen und Passwort rein, feddich…

\\FRITZ.BOX\FRITZ.NAS\SanDisk-Ultra-01\Music

 

Benutzerebene 7
Abzeichen +3

@hein-daddel 

Nein, viel kann man da nicht falsch machen, sofern man weiß, was da korrekt eingegeben werden muss. ;-)

So ist der Bereich aber als Fehlerquelle schonmal ausgeschlossen. 
 

Da die Fritzbox halt einen nicht existierenden Usernamen als Fehler ausspuckt, liegt imo nahe, dass bei der Einrichtung des Users oder der Freigebe ein Fehler unterlaufen ist. Da müsste man jetzt mal genau in die Konfiguration der Fritzbox schauen. 

Benutzerebene 7
Abzeichen +3

@hein-daddel 

PS:

Auf jeden Fall muss in der Fritzbox unter System… Benutzer… bei „guest“ der NAS Zugriff erlaubt und der entsprechende Speicherort freigegeben werden.