Sonos ohne Router?

  • 2 September 2009
  • 16 Antworten
  • 10580 Ansichten

Hallo allerseits,

habe ein kleines Problem mit meinem Sonos.

Hier ist es im mom ein wenig kompliziert: Seit Montag verfüge ich über keinen eigenen DSL-Anschluss mehr, da ich in 3 Wochen umziehen werde. Das Internet bekommen wir per WLAN über den Vater meiner Frau, welcher im Nebenhaus wohnt. Das klappt recht gut. Nur mussten wir dort auch meine Fritzbox anschließen, da der Router dort zu schwach war. Kurz: Ich bin ohne Router. Ins Netz gehe ich dann über meinen WLan-Stick.

Nur würde ich jetzt gerne mein Sonos System weiterbenutzen. Habe im Rechner auch noch eine Lan-Karte frei. Oder ich könnte das ganze evt direkt ans NAS anschließen.

Da ich heute morgen auch noch meinen Rechner neu einrichten musste, musste ich mir die Sonos-Desktop-Software auch neu installieren. Nach der installation wollte das Programm dann eine neue Verbindung zur Bridge oder Player suchen - obwohl diese ja vorher schon bestand. Nur findet er diese nicht, und daher läuft das Programm auch nicht weiter.

Hat jemand eine Idee, was ich machen könnte?

Besten dank

Lapje

Dieser Beitrag ist geschlossen für weitere Beiträge

16 Antworten

Ich gehe mal von windows aus: wenn du Internet Connection Sharing aktivierst, wird dein Laptop zum Router.
http://de.wikipedia.org/wiki/Internetverbindungsfreigabe

Zum betreiben von Sonos mit nur eine NAS:
http://forums.sonos.com/showthread.php?t=13916
Müsste ich dann den Player direkt ans NAS (Synology) anschließen oder würde das auch über die Bridge gehen?

Also die GEräte waren schon am I-Net, es dürfte also auch bei allen die neuste Firmware drauf sein...

Und zu dem I-Net-Sharing: Ich habe bei meinen XP-Einstellungen eingestellt, dass andere Rechner die Internetverbindung benutzen dürfen...habe es aber gerade an meinem zweiten Rechner ausprobiert...und das funzt irgendwie nicht...

Muss ich evt irgendwo einstellen, über welche Karte oder welches Netz das I-Net weitergegeben wird?
Nur mussten wir dort auch meine Fritzbox anschließen, da der Router dort zu schwach war. Kurz: Ich bin ohne Router.
Der Router vom Vater Deiner Frau ist doch jetzt frei.
Kannst Du den als WLAN-Repeater konfigurieren und bei Dir aufstellen?
Dann kann das Sonos per Ethernet-Kabel da dran.

Gruss
Jochen
ichhätte hier unseren alten Speedport W500V...weiß aber nicht ob der schon WPA2 kann...

Drüben wäre ein Speedport 700 irgendwas....
Im Detail kenne ich mich mit ICS nicht aus. Die NAS kann man an jede Sonos-Komponente anschließen.

Wie wäre es eigentlich, die Zonebridge bei den Schwiegereltern aufzustellen?
dann müsste ich ja auch das NAS rüberbringen...und das wäre ein wenig viel verlangt..;-)
habe ich dass denn soweit richtig verstanden? Das SONOS braucht die I-Net-Verbindung nur am Anfang um die Software abzugleichen? (von I-Net-Radio mal abgesehen). Und wenn ich das richtig verstanden habe brauche ich - nur damit sich die Komponenten finden - nicht einmal eine Lan-Verbindung, oder?

Ich habe die Bridge auch mal direkt an die Lan-Karte angeschlossen...aber das geht irgendwie auch nicht...menno...kann doch nicht sein dass ich keine Musik mehr hören kann nur weil ich kein DSL mehr habe...in der hinsicht ist jeder popelige WLan-Player besser...
Die NAS kannst du an jeden beliebigen Player anschließen. Die Zonebridge muß man nur rübertragen und anschließen. Anschließend alle andere ZPs noch mal neu starten, danach die NAS noch mal neu starten. Dann sollte alles wieder beim Alten sein, vorausgesetzt die Zonebridge kann einer der Zoneplayer erreichen.

Sonos braucht Internet für Updates, Internetradio, Last.fm und Napster. Um von der NAS zu spielen braucht es kein Internet.

Um Sonos ohne LAN einzusetzen, braucht es eine händische Konfiguration der NAS. Auch müssen alle Komponenten mittels Update auf den selben Software-Stand gebracht worden sein.
Also auf den neusten Stand sind sie, da sie bis vorgestern noch normal am Router liefen.

Ich probier das nacher mal so aus...das PRoblem wäre nur, das meine NAS (Synology DS 209) nur einen LAn-Anschluss hat, aber ich denke, ich kann die Bridge "zwischen" die Verbindung des NAS zum Rechner setzen, oder? Dafür sind die 2 Lan-Anschlüsse sichelrich da...denke ich..;-)

besten dank bis dahin

Lapje
Du kannst die NAS an irgendeine Sonos komponente anschließen. Muß nicht unbedingt an die Bridge sein. Wenn dein rechner im Wlan eingebunden ist, kann er darüber auf die NAS zugreifen. Alles vorausgesetzt, die Zonebridge kann von den Nachbarn aus dein restliches Sonos-System erreichen. Du benutzt dann weiterhin die Fritzbox als router.
Ne, wie gesagt, das wäre zu aufwendig...daher Bridge direkt am NAS...wäre ja nur für nen Monat...
mmhhh...also:

Hab die Bridge ans NAS angeschlossen und jene und Player neu gestartet, dann noch mal das NAS. Nur jetzt steht auf dem Controler die ganze Zeit das nach Playern und Bridges gesucht wird...aber dabei bleibts auch.

in der Übericht am Controler hat das Systen die IP-Adresse 192.168.1.27, die NAS hat aber die 192.168.2.60, also ein anderes Netz. Kann das Probleme geben? Umstellen kann ich sie aber nicht, weil ich der Lan-Karte dieses Netzt geben musste, da der WLan-Stick schon das 1er-Netz hat (192.168.1.35). Sonst könnte ich das NAS gar nicht ansteuern weil die Verbindung sonst übers WLan gehen würde...

Muss ich jetzt noch irgendwo an den Geräten Knöpfchen drücken???

Nachtrag: Player und Bridge wurden jetzt gefunden, aber ich bekomme das NAs einfach nicht rein...habe es ein paar mal neu gestartet, wie mir oben gesagt wurde, aber nichts...

Oder muss ich noch irgendwas auf der Synology freigeben? Einen Benutzer einrichten oder so? Kenne mich mit der noch nich so aus...

Nachtrag vomn Nachtrag..;-) Es lebt, es lebt..;-) Hab einfach mal in den Einstellungen, in denen ich den Ort der Bibliothek selber eingeben konnte rumprobiert...und PENG! - es funzt...

Besten Dank euch allen, die mich in die richtige Richtung gedrückt haben..;-)

Lapje
Ola Muchachos...

Habe seit ein vorhin das Problem, dass mein NAS nicht mehr gefunden wird.

Vor ner Stunde hat es noch funktioniert, habe Musik gehört und plötzlich, mitten im Lied bricht die Verbindung ab und Bridge und Player waren raus. Controler neu gestartet, und Player war wieder drinn, Bridge kurz vom Strom genommen, und in die Zone eingebunden. Aber das NAS bekomme ich nicht mehr rein.

Gebe - wie gestern - unte r "Neue Freigabe hinzufügen" den Pfad des NAS (\\NAS\Musik) ein, aber diesmal wird es nicht gefunden (Computer 'nas' nicht gefunden). Gesten hat es genau so noch funktioniert. Per Rechner komme ich ans NAs drann, da ist alles in Ordnung. Habe es auch noch mal neu gestartet, nichts...

Ach ja, die Bridge hängt bei mir direkt am NAS drann...

Wäre toll wenn jemand schnell helfen könnte...

Besten dank

Lapje
Hallo Lapje,

Zum Betrieb von Sonos ohne Router, mußt du die NAS genau so einstellen wie hier beschrieben:
http://forums.sonos.com/showthread.php?t=13916

Damit die Sonos-Geräte sich auf Auto-IP umstellen, kannst du sie am Besten neu starten und ein paar Minuten abwarten.

Das es bisher funktioniert hat, lag wahrscheinlich daran, daß Sonos noch nicht versucht hatte, seine IP vom Router zu erneuern.
Ich hab jetzt mal einen alten Router (ohne I-Net)dazwischen geschaltet, jetzt scheint es wieder zu funzen...aber seltsam ist das ganze schon.

Hat jemand von euch auch schon mal diese Probleme gehabt?