Probleme


Benutzerebene 1
Hallo zusammen,

auf die vielen positiven Berichte aus allen Ecken habe ich mich für einen ZP 90 mit Ipod Touch entschieden.

Zuerst meine Installation:

Arcor DSL
direkt am w-Lan-Router hängt
QNAP TS 409 mit 3x 1 TB
davon etwa 600 GB voll mit Musik
iMac 20 mit Windows XP
Sonos ZP 90 mit iPod touch zur Steuerung.

Es funktioniert fast alles einwandfrei.
MP3s jeder Auflösung, Internetradio und Napster spielen weinwandfrei und bis hierhin macht es auch viel Spass.

Nun zum Problem:
Ich habe alle Musik aus Unwissenheit zuerst in WAV auf damals noch USB-Platten gespielt und mit dem WMP 11 wiedergegeben. Das hat immer einwandfrei funktioniert. Aus angst irgendwann die Database des WMP 11 zu verlieren oder dass sie mal beschädigt sein könnte habe ich alles mit dbPoweramp in WMA Lossles konvertiert und ordentlich getaggt. Das war, wie man sich vorstellen kann, eine Heidenarbeit. Jetzt erst wurde ich auf das Sonos aufmerksam, und ausgerechnet WMA Lossless spielt das System nicht. Also habe ich mir einen Zweiten Musikordner angelegt und dort alle WMAs in FLAC konvertiert.
Obwohl WMP 11 eigentlich nicht mit FLAC kompatibel ist, konnte er diese Dateien einwandfrei und unterbrechungsfrei abspielen. Nicht so das Sonos. Spätestens nach zwei Minuten kommt der ZP 90 ins stocken. Einige Male kam dann uf dem iPod die Meldung die Datei sei beschädigt. Danach die gleiche Datei im WMP 11 gespielt - alles einwandfrei.

Also habe ich alle FLAC wieder gelöscht und zu Testzwecken ein par Stücke in Apple losless konvertiert mit dem gleichen Erfolg das Sonos verschlcukt sich.

Ich habe auch das Gefühl, dass es sich durch andere Netzwerkeingriffe stören lässt. Einige Male war der Verschlucker just als ich das sytem bedienen wollte (der iPod Touch also über W-Lan ins Netzwerk geht) oder wenn ich am rechner etwas mache (Surfen oder am QNAP Dateien bearbeiten).

Da meine Musik bis Sie beim Sonos ist mindestens zwei Konvertierungen hinter sich hat (WAV > WMA losless > FLAC oder Apple lossless) ist es zwar tatsächlich denkbar dass einzelne Dateien vielleicht einen Schuss haben - ich konnte aber noch keine einzige Datei in FLAC oder Apple losless fehlerfrei durchspielen obwohl, auch auf die Gefahr hin, dass ich mich vielleicht wiederhole, sie auf dem Rechner einwandfrei laufen.

Auf Eure Hilfe freut sich

Markus

Dieser Beitrag ist geschlossen für weitere Beiträge

17 Antworten

Hallo,

Vielleicht wird tatsächlich etwas durch den Router gebremst, versuche doch mal die NAS direkt am ZP90 anzuschließen. Wenn es da besser funktioniert, liegt es am Router.

Die Umwandlung zwischen Lossless Formate sollte an sich kein Problem darstellen, wobei Apple Lossless evt. schon kritisch sein kann, weil es keinen öffentlichen Codec dafür gibt. Also Dateien die aus Alac heraus in was anderes gewandelt wurden, könnte es sein daß was nicht 100% ist.

Sonos ist nur mit 16-bit Musik bis zu 48 kHz kompatibel. Bedenke auch, daß wenn mehrere Dateien mit denselben Tags vorliegen, es nicht beinflußbar ist, welches Format Sonos spielt. Da muß man darauf achten, daß Sonos jeweils nur zugriff auf ein Share mit nur eine Variante hat.
Benutzerebene 1
Abzeichen
Hallo,

das Ganze hört sich danach an, dass Dein WLAN ein paar Probleme hat.

Das kann viele Ursachen haben.

Ein Nachbar, der auf dem gleichen Kanal sendet, ein DECT-Telefon, welches den Empfang stört, zuviel Eisen im Beton Deines Hauses.

Ich würde Dir raten, Dein WLAN zu überprüfen und auf Vordermann zu bringen ...

Liebe Grüße
W.
Benutzerebene 1
Hi,

wenn ich Dich richtig verstehe, hängt der ZP90 per Kabel am Router, genau wie das NAS. In der Konfiguration würde ich Netzprobleme erstmal ausschließen.

Ich habe bei meinem NAS die Erfahrung gemacht, dass starke Last auf der Platte Sonos zum Stottern bringt, insbesondere wenn man den Index gerade aktualisiert - also: Indes aktualisieren, Backup fahren und Abspielen führt immer zum Stottern, aber nur bei Flac. Ist ja auch klar, weil hier viel mehr Durchsatz gebraucht wird.

Die Konvertiererei würde ich auch ausschließen, dbpoweramp macht das einwandfrei, auch nach Apple lossless.
Benutzerebene 1
Hallo zusammen,

vielen Dank für die vielen Antworten.

ja, alles hängt mit Kabeln am Router (außer dem iPod natürlich).

Auf Euren Rat hin habe ich noch ein wenig gespielt. Am W-Lan liegts wohl nicht. Der Router ist maximal 4 Meter (im gleichen Raum) vom iPod entfernt, mein Rechner sieht nur zwei Netze, meins und ein zweites, was aber 3 Kanäle entfernt liegt.
Ich habe mir heute einen anderen Router besorgt, konnte Ihn aber noch nicht installieren, da noch ziemlich wichtige Prozesse auf dem NAS laufen, die ich nicht unterbrechen will. Somit kann ich auch noch keine Auskunft geben ob der Direktanschluss des NAS am Sonos was bringt.

Heute hat er sich sogar mit MP3s verschluckt. Obwohl es noch viele Möglichkeiten gibt um anzusetzen, steigt der Frustpegel nun doch langsam über meine persönliche Schmerzgrenze.

Wie oben zu lesen ist meine Installation (zumindest Netzwerktechnisch) ja eher von der einfachen Sorte. Ich will auch keine HD Videos schauen oder Online-Spiele spielen. Wieso läuft es bei anderen einwandfrei? Haben die alle so eine Odysée hinter sich?

:DIm Werbevideo wurde mir was anderes versprochen - oder sind die alle taub und hören nur 160er MP3s?:D

Eigentlich wollte ich das mal meinen Freunden und Bekannten empfehlen...

Grüße

Markus

ein kleiner Nachtrag noch:

es heißt ja ganz offiziell: Das WMA Lossless-Format wird derzeit nicht unterstützt.
was heißt derzeit - weiß das jemand.
Ich wäre natürlich überglücklich meine Musik nicht 2 Mal auf der Platte haben zu müssen. Die WMAs lasse ich drauf - auch gegen gut gemeinte Ratschläge.
Benutzerebene 1
Abzeichen
Hiho,

nicht verzagen. Ein Netzwerk ist immer noch ein technisches Gebilde, welches ziemlich anfällig ist.

Neben den Problemen der einzelnen Geräte kommen ja auch noch Inkompatibilitäten der Hardware und insbesondere der Software der verschiedenen Geräte dazu.

Mein Router - ein ziemlich billiges Ding - "verschluckt" sich ab und zu, sodass der Durchsatz insbesondere aus dem Internet sich drastisch reduziert.

Ein Software-Neustart wirkt da Wunder.

Also ... mal Router neustarten und hoffen, dass es besser wird. Evtl. Update der Firmware des Routers durchführen. Falls das nicht funktioniert, das Netzwerk vollständig in der folgenden Reihenfolge neustarten:

Modem, Router, QNAP, PC, Sonos

Zum Anderen mal ALLE Einstellungen durchschauen. Evtl. blockieren sich die Einstellungen der verschiedenen Geräte gegenseitig.

Und zum Letzten: Eine Festplatte kann nur einen begrenzten Durchsatz bedienen. Insbesondere wenn Schreib- und Lesezugriffe parallel durchgeführt werden, können die normalen Consumer-Festplatten ganz schnell an ihre Grenzen kommen.

Wenn Dein QNAP mehr macht, als nur als Musik-Server zu dienen, dann kann es auch schnell an seine Grenze kommen, da normalerweise die CPU in so einem Ding doch sehr begrenzt ist.

In diesem Falle würde ich tatsächlich zu einem zweiten NAS raten ... oder du kaufst Dir ein Profi-Teil, das dann aber schnell >1000 Euro kosten kann.

Liebe Grüße
W.
Hallo, Ich mache das was du machst drahtlos, und geht ohne Probleme. Früher hatte ich eine Linkstation NAS, jetzt läuft es von eine Mac Mini. Es ist keinesfalls eine Designschwäche oder so, es sollte bei dir einwandfrei funktionieren!

Wie Weepee korrekt bemerkt, es könnte am router liegen, oder eine überbelastete NAS. Den Router kann man ausschließen indem man die NAS mal direkt am ZP90 anstöpselt. Die NAS kann man ausschließen indem man mal Dateien vom PC aus shared, und testet ob es damit immer noch die Probleme gibt. Das würde ich dir also raten auszuprobieren, um auf die Engstelle zu schließen.

Sonos sagt hierüber nichts, aber es wird gemutmaßt, daß WMA Lossless deshalb nicht unterstützt wird, weil es sehr ineffizient bei der dekodierung ist. Flac wurde darauf optimiert, von einfache Hardware dekodiert zu werden (ohne Fließkommaoperationen), WMA Lossless nicht. Also es ist ein wahrscheinlicher Grund, daß die Zoneplayer gar nicht genug Rechenkraft haben um jemals WMA Lossless zu spielen. Dies sieht man auch bei andere Hardware-Geräte, die WMA lossless höchstens mit der Hilfe eines PC abspielen können.
Benutzerebene 1
Hallo an Alle,

das QNAP ist während des Musikhörens eigentlich völlig gelangweilt. Es ist kein FTP-Server, da liegen nur meine Daten. Im Moment ist es sehr beschäftigt, weil ich gerade 600GB kopiere und dann noch konvertiere - wohl wieder in FLAC. Keine Sorge, die Löschaktion von vorgestern war nicht sinnlos, weil ich bei den WMAs noch ziemlich viele Tag-Änderungen vorgenommen habe und es mich mehr Zeit kostet, die in FLAC nochmal zu machen.

Das mit der Dekodierung verstehe ich nicht ganz. Die FLAC-Datei ist größer als die WMA-Datei und WAV wird ja auch gespielt- was nochmals etwa doppelt so groß ist. Oder meinst Du damit, die WMA sei komplizierter zu spielen?

Mit dem ganzen Einstellungskram kenne ich mich nicht so ganz aus, habe aber einen Bekannten der Netzwerke installiert, vielleicht kann der mir nächste Woche mal helfen.

Ich bin jetzt jedenfalls soweit in einen Gigabit-Router zu investieren und auch die ganze Verkabelung auf diesen Level zu hieven. Dann kann in Zukunft kommen was will. Den Router vom Samstag (D-Link 100 MBit-Teil) kann ich noch zurückgeben. Das Ding ist mir zu unübersichtlich.

Wie ich schon erwähnte schließe ich mein WLAN eigentlich aus, da der Nachbar 3 Kanäle entfernt ist und mein Telefon nur funkt, wenn der Hörer nicht auf der Basis steht. Da ich persönlich telefonieren hasse, tut es das fast immer (Mindestens 23.58 pro Tag).

Grüße und Dank für die Tatkräftige Hilfe

Markus
WMA dekodierung ist komplizierter als flac. Du kannst es so sehen: bei Wav ist gar keine Rechnerei notwendig, dafür werden die Daten auch nicht komprimiert. Flac kann mann mit mathematik die auch einfache Prozessoren verstehen bewältigen, WMA LL braucht am meisten Rechnerei, ergibt dafür noch mal etwas kleinere Dateien.

Bei ein Gigabit-Router keine sog. "Jumbo Frames" aktivieren, dies ist nicht mit Sonos kompatibel.

Wenn der Nachar 3 Kanäle entfernt ist, überlappt er eigentlich. Denn 54Mbps Wlan braucht eine Bandbreite von 5 Kanäle. Das ist auch der Grund, daß Sonos nur 1,6 und 11 anbietet.Wenn ein Wlan weniger als 5 Kanäle entfernt ist, stört er einige Sonos-Kanäle, was die Bandbreite reduziert. Bei mir zuhause gibt es auch mehrere Wlans, und ich habe es so hingelegt, daß Sonos überlappungsfrei ist, mein PC-Wlan aber sich mit den anderen überlappt. Beim PC merkt man dies weniger als bei Sonos.

Störungen vom Telefon machen sich nur bemerkbar wenn telefoniert wird. Aber es muß nicht unbedingt das eigene Telefon sein, wenn man in ein Mehrfamilienhaus wohnt.
Benutzerebene 1
Was mir noch einfällt: Es könnte wirklich an der direkten Verkabelung mit dem Switch des Routers liegen (wie ich Dich verstanden habe, hast Du keinen gesonderten Switch). Aus leidvoller Erfahrung kann ich sagen, dass die nicht immer wirklich sauber sind...

Wenn mit einem gesonderten Switch immer noch Probleme auftauchen und sichergestellt ist, dass das NAS sich langweilt, kann es eigentlich nur noch ein Hardwaredefekt am Sonos sein.
Benutzerebene 1
Hallo,

@ esc

soll das heißen, das es mit einem extra Switch besser laufen sollte? Ich habe so ein Ding rumliegen, hatte es zu Beginn auch in der Installation, da gab es auch Aussetzer.

Ich habe meinem arcor-Router Unrecht getan. Da gibt es mehr Einstellungsoptionen als gedacht. Durch ewiges rumsurfen und machen und tun bin ich auf den Begriff qos gestoßen. Ich habe von UBR auf VBR-rt umgestellt - siehe da das QNAP verschluckt sich nicht mehr. (Das tat es seit Integration des Sonos ins Netz).

Ob sich das Sonos immer noch verschluckt, kann ich im Moment noch nicht sagen, da ich noch am kopieren und konvertieren bin. Solange das Netz damit wirklich komplett ausgelastet ist, macht es keinen Sinn belastungsfähige Test zu fahren. Dass das Sonos einen Defekt hat halte ich nicht für unwahrscheinlich, wenngleich es ja alle anderen Medien einigermaßen sauber spielt.

Na dann

Grüße

Markus
Benutzerebene 1
Hallo,

nach längerem mal wieder ein Zwischenbericht:

Mein Problem besteht immer noch.

Ich konnte bisher noch kein einziges Stück in FLAC von QNAP komplett durchhören. Der Tip mit dem PC war gut. Davon läuft es einwandfrei.

Also scheint das streamen mit dem Router und das Sonos OK zu sein.

Beim QNAP habe ich gerade ein FirmWare-Update gemacht. In der Beschreibung steht ausrücklich, dass Probleme mit Aufhängen damit behoben werden sollen. Ohne Erfolg. Wieso kann ich aber schon seit einem Vierteljahr Alle Musik vom QNAP über den Windows Media Player 11 einwandfrei abspielen?

Mir geht die Lust so langsam aus.
Offensichtlich ist jedes Hardware-Teil in Ordnung. QNAP spielt am PC. Sonos spielt am PC. Nur Sonos spielt nicht am QNAP. Kabel kann ich auch ausschließen. Jede relevante Verbindung wurde mittlerwile gegen eine andere gestestet.

Lustigerweise läuft die Zeit im Desktop-Controller weiter. Und irgendwann spielt das Sonos manchmal auch weiter, aber zum Teil an ganz anderen Stellen.
Die erste Minute eines Albums läuft meistens durch. Danach kommen, wenn es gut geht 10 Sekunden-Stücke.

Was soll ich noch machen.

Grüße

Markus
Eigentlich sind die QNap Geräte nicht für Probleme bekannt. Ich habe auch keine Ahnung was genau die Ursache sein könnte.

Vielleicht kannst du mal Sonos Support anrufen, die können über die Diagnostik-Informationen der Zoneplayer vielleicht detaillierter sehen wo es hakt.
Also der Tip mit dem Support finde ich schonmal gut.

Wenn Du schreibst du hast mal alle Leitungen untereinander getauscht, hast Du auch die Kabel getauscht?

Das problem was Du beschreibst würde zu ein solchen Fehler passen.
Der Sonos puffert ein bestimmten Teil an Musik vor und zieht im hintergrund die folgenden Teile eines Liedes. Wenn diese aber nicht sauber ankommen läuft der Puffer irgendwann leer und dann stockt das abspielen.

Kann der QNAP dhcp? Wenn ja dann schließe doch mal den router aus und das Sonos direkt an den QNAP an. Das wurde ja schon vorgeschlagen ich habe aber nicht erkennen können, ob Du das schon getestet hast. Damit kann man dann wenigstens den Router als Problem erkennen bzw. ausschließen.

Der WMP zieht die Lieder meines Wissens nach anders. Der Streamt nicht sondern kopiert sich das lied temporär in den Speicher somit würde ein solches Streaming Problem nicht wirklich bestehen.
Benutzerebene 1
Hallo,

@Ta Lun

da liest aber einer aufmerksam mit - Respekt.
Der Direktanschluss des QNAP am Sonos hat überhaupt nicht funktioniert.
Ich schalte die ganzen Komponenten beim Kabeltauschen immer aus und danach wieder an, nachdem mir das QNAP schon mal eine Error E-mail geschickt hat. Ich habe keinen Bock, dass mir meine Daten versehentlich abschmieren. Jedenfalls nach ankabeln QNAP an Sonos hat die weiße LED am Sonos ewig geblinkt bis ich das Kabel zum QNAP wieder abgezogen habe (3 Versuche, auch mit anderen Kabeln - immer das gleiche). Das System kann ich ohne Router nicht fahren, weil ich das W-Lan zur Steuerung brauche. Wenn ich mit dem Desktop-Controller arbeite ist der Test nicht realistisch, weil ich das Sytem ja letzten Endes mit ausgeschaltetem PC fahren will, eine Einmischung einer vierten Netzwerkkomponente (den PC) könnte also zu Schwierigkeiten führen, die mir hinterher egal sein könnten.

Ich war heute im örtliche angesagten Computerladen, und wollte mir zum Test eine einzelne NAS ausleihen. Mit dem ganzen Raid5-Ballast wäre es ja denkbar, dass der Datendurchsatz tatsächlich schwächelt. Nachdem ich mein Problem geschildert habe, hat er mir einen Gigabit-Switch mitgegeben.
Das soll helfen.

Was ich bisher noch nicht erwähnte, den Computerfritzen aber nicht weiter gestört hat:
In meinem QNAP werkeln HDDs, die nicht auf der Positiv-Liste von QNAP stehen. Deshalb wollte ich mal mit einem aufeinander abgestimmten System (einer fertigen NAS-HDD) experimentieren. Das ist das dann der nächste Schritt. Ob das mit dem neuen Switch geht, kann ich noch nicht sagen, da das Zimmer gerade belegt ist. Erfahrungsbericht dann in ca. 3 Stunden.

Alle Kabel konnte ich nicht auf einmal tauschen, aber die Verbindung zum QNAP und zum Sonos habe ich gegen 2 andere getauscht (nacheinander) ohne Erfolg.

Support anrufen ist gut, aber für mich nahezu unmöglich, tagesüber muß ich arbeiten, abends "stören" die Kinder. Meine ganzen Tests kann ich erst nach 22.30 Uhr fahren. Irgendwann werde ich da schon mal anrufen.

Für Euer Mitfühlen bedankt sich

Markus
Benutzerebene 1
Hallo

Der Gigabit Switch hat nichts gebracht. Gleiche Symptome wie bisher.

Gleichzeitig habe ich noch etwas probiert. Bei dBPoweramp kann man in 9 Stufen nach FLAC konvertieren (0-8). Alle Formate sind lossless aber Stufe 8 hat die dichteste Packung, Stufe 0 die geringste. Dort heißt es die Konvertiererei würde für 0 schneller gehen, aber etwas mehr Speicherplatz benötigen, was mir ja erst mal egal ist. Hinter Stufe 5 steht in Klammern noch (default), wohl die Standardeinstellung. Also habe ich mir mal ein Album aus WMA lossless in FLAC (5) konvertiert. Zum ersten Mal konnte ich damit 3 Stücke am Stück hören. Ich wollte schon den Schampus entkorken - Zack - Aussetzer. Danach konnte ich wieder kein ganzes Stück hören, weder in FLAC 0, 5 oder mittlerweile sogar MP 3.

Nächster und letzter Schritt: NAS mit einzelner Platte ausprobieren (direkt am Sonos). So ganz böse über die zusätzliche Investition wäre ich nicht einmal, da ich dann nochmal eine Sicherung anlegen könnte, wer weiß schon, was mit dem QNAP wirklich los ist; und zweitens verbraucht eine NAS mit einer Festplatte sicher weniger Strom als das ganze Raid5-Gedöns.
Wenn das nicht geht, lasse ich das Sonos zurückgehen. Das wird wohl gehen, ich kenne den Vertreter. Für diesen Fall hätte ich einen 2 Wochen alten (ja so lange geht die Odysée schon) iPod touch 8 GB günstig abzugeben (Sonos Software schon drauf, na so was...). Ich habe mir extra den Kleinsten gekauft, weil ich damit ausschließlich das Sonos bedienen will. Unterwegs brauche ich nicht auch noch das Gedröne...

Wünscht mir Glück.

Markus
Benutzerebene 1
Hallo

Kann man den Thread umbennen? Zum Beispiel "keine Probleme mehr"

Es lag wohl am QNAP. Ich habe mein ganzes Netzwerk wieder auf den Ursprungszustand zurückgebaut. Also Arcor Modem - Arcor W-Lan-Router daran iMac Sonos QNAP und über W-Lan den iPod touch. Dann habe ich mir heute eine LaCie 1TB Netzwerkplatte gekauft und habe jetzt mal Testweise 20 Alben drauf gespielt. Zwei davon habe ich schon komplett durchgehört das Dritte läuft gerade. Netzwerkverkehr kann das Problem nicht sein. Ich kopiere gerade alles von QNAP nach LaCie, surfe hier im Internet und habe gerade parallel dazu noch einen F16-Flug durch NewYork inkl. Gebäudeanzeige in Google-Earth laufen gehabt. Keine Aussetzer.

Die letzten 14 Tage habe ich viel übers Netzwerk gelernt, versucht die Sache sportlich zu nehmen, ich werde es schon schaffen - andere haben es auch geschafft. Aber ich war kurz davor das Projekt zu begraben.

Jetzt werde ich mir noch mal irgendwoher 1 TB ausleihen um den Rest vom QNAP noch zu sichern und dieses dann noch mal komplett neu installieren.

Für Euren Support möchte ich mich herzlich bedanken. Gerne werde ich auch mal helfen, aber die meisten hier haben ja mehr drauf als ich.

Grüße

Markus