Frage

Beamer und sonos one


Hi.
Ich würde gern den Sound von Filmen auf den Sonos One wiedergeben. die Filme werden vom iPhone via AirPlay auf dem Beamer gestreamt.
Hab jetzt die Meinung der Techniker zu Bluetooth verstanden. Allerdings sehe ich andere Anbieter die das schaffen und ich will auch keinen Glaubenskrieg oder Meinungen über Sinn und Unsinn bitte. Jeder darf seine Meinung haben. Ich suche einen Weg unter den bestehenden Rahmenbedingungen. Wer hat Ideen? Welche Wege gibt es?
Bestehendes Equipment:
- Apple TV
- smarter Beamer mit AirPlay & Klinke
- iPhone
- wlan

Lösungen für unter 100,- EUR zum nachrüsten der Funktionslücke der Sonos One (meine Sicht im Vergleich zum Markt 2018) wären auch nich akzeptabel.

Danke für jeden konstruktiven Vorschlag vorab!

Herzlichst
Torsten

15 Antworten

Hallo Torsten,

wenn mich nicht alles täuscht, kann man in den Einstellungen des Apple TVs die Tonausgabe auf ein anderes AirPlay fähiges Gerät einstellen, wie unter https://www.sonos.com/de-de/airplay beschrieben ist. Wenn du den Apple TV an den Beamer anschließt und die Tonausgabe auf den one änderst, müsste das Setup eigentlich klappen, oder irre ich mich da?

Lg Daniel
Hallo,
ich hab einen (sauteuren) Beamer und sowohl das alte als auch ein aktuelles Apple TV angeschlossen. Das Apple TV findet die Sonos problemlos...aber es schaltet immer wieder um. Sprich Audio und Video kommen beide beim Beamer an. (Anschluss per HDMI)
Wir sind etwas am verzweifeln...es ist alles richtig eingerichtet...Sonos sind zu finden...aber starte ich ein Video vom iPhone kommt alles nur beim Beamer an. Lustigerweise klappt das ganze aus Youtube problemlos und wie gewünscht. nur die Foto App von iOS macht Stress.

Vielleicht hat noch einer eine Idee..

Gruß Dirk
Benutzerebene 3
Abzeichen +3
100mark schrieb:

Hallo,
ich hab einen (sauteuren) Beamer und sowohl das alte als auch ein aktuelles Apple TV angeschlossen. Das Apple TV findet die Sonos problemlos...aber es schaltet immer wieder um. Sprich Audio und Video kommen beide beim Beamer an. (Anschluss per HDMI)
Wir sind etwas am verzweifeln...es ist alles richtig eingerichtet...Sonos sind zu finden...aber starte ich ein Video vom iPhone kommt alles nur beim Beamer an. Lustigerweise klappt das ganze aus Youtube problemlos und wie gewünscht. nur die Foto App von iOS macht Stress.

Vielleicht hat noch einer eine Idee..

Gruß Dirk



Das Video von YouTube kommt am Beamer an und der Ton bei Sonos? Wie gehst du denn da praktisch vor? Meiner Meinung nach kann man nicht von einem Video getrennt gleichzeitig Airplay-Videosignal und Airplay-Audiosignal an verschiedene Ziele senden. Wenn ich aus der YouTube App im Airplay Auwahlmenü am iPhone das Apple TV wähle, spielt dort Bild und Ton. Hake ich zusätzlich noch meine Sonos One an, dann spielt auf beiden Geräten nur der Ton. Das Videosignal stoppt dann am Apple TV und wird wieder am iPhone gezeigt(natürlich dann dort ohne Ton)
Gruß,
Ralf

EDIT:
Sorry... habe eben nochmal gelesen... du wählst die Sonos ja nicht am iPhone, sondern am ATV aus. Das ändert aber (leider) nichts an der von mir beschriebenen Funktionsweise von Airplay. Denn du musst immer vom Gerät ausgehen, das das Video ursprünglich abspielt. Und das bleibt ja das iPhone, wenn von dort per Airplay zum ATV gestreamt wird.
Am ATV kannst du die Sonos nur als Audioziel wählen, wenn das ATV das Ursprungsgerät des Videos ist. Also wenn dort über eine App direkt ein Video abgespielt wird. Heißt... Foto App vom iPhone klappt der Ton NICHT zu Sonos, wenn das Bild zum ATV soll. Foto App direkt vom ATV klappt der Ton zu Sonos und das Bild spielt am ATV.
Ebenso halt mit YouTube... YouTube direkt auf ATV funktioniert mit Ton zu Sonos, YouTube am iPhone(siehe oben beschrieben) funktioniert nicht, dass Ton auf Sonos und Bild auf ATV spielt.
und genau DAS ist das Phänomen. Nutze ich am iPhone die Youtube app und hab am AppleTV eingegeben, dass Sound über die Sonos gespielt werden soll...dann klappt das. iPhone Youtube App: Bild macht der Beamer...Sound kommt über die Sonos-Boxen.

Sobald ich aber die Foto-App nutze deaktiviert er die Option im AppleTV, dass er Sound an Sonos ausgibt.

Die Youtube App kann es aber!
100mark schrieb:

und genau DAS ist das Phänomen. Nutze ich am iPhone die Youtube app und hab am AppleTV eingegeben, dass Sound über die Sonos gespielt werden soll...dann klappt das. iPhone Youtube App: Bild macht der Beamer...Sound kommt über die Sonos-Boxen.

Sobald ich aber die Foto-App nutze deaktiviert er die Option im AppleTV, dass er Sound an Sonos ausgibt.

Die Youtube App kann es aber!


Und? Die YouTube-App wurde von Google entwickelt und die Foto-App von Apple. Es obliegt den Eigentümern zu entscheiden, welche Funktionen für welches Medium verfügbar sind.
Benutzerebene 4
Abzeichen +3
Perpugilliam schrieb:

100mark schrieb:

und genau DAS ist das Phänomen. Nutze ich am iPhone die Youtube app und hab am AppleTV eingegeben, dass Sound über die Sonos gespielt werden soll...dann klappt das. iPhone Youtube App: Bild macht der Beamer...Sound kommt über die Sonos-Boxen.

Sobald ich aber die Foto-App nutze deaktiviert er die Option im AppleTV, dass er Sound an Sonos ausgibt.

Die Youtube App kann es aber!


Und? Die YouTube-App wurde von Google entwickelt und die Foto-App von Apple. Es obliegt den Eigentümern zu entscheiden, welche Funktionen für welches Medium verfügbar sind.



Ja, leider ist das so.
Benutzerebene 3
Abzeichen +3
Ja, irgendwas hat Apple da aus meiner Sicht vermurkst... Apple selbst nennt es wahrscheinlich „Feature“. 🙄 Aus der Apple Foto App scheint nur noch Video-Airplay möglich zu sein. 😬 Auf iOS war mir das bekannt, aber mit TV OS auf Apple TV war ich davon ausgegangen, dass der Ton von Videos der Foto App an Airplayempfänger gesendet werden kann. Ich hatte ja oben geschrieben, dass es funktionieren würde... stimmt aber leider nicht(mehr). 😕
Habe es eben nochmal getestet. Während man per ATV ein Video aus der Foto App abspielt, erscheinen im Auswahlmenü für Airplay zwar im Gegensatz zu iOS auch Audioempfänger wie z. B. meine Sonos One, ABER... der Ton wird weiter über HDMI ausgegeben, obwohl die One sich als Ziel für den Ton auswählen lässt. Unter iOS erscheint sie wenigstens erst garnicht.
Einzige Chance ist also, Apple zu nerven, dass das Murks ist.
Gruß,
Ralf
Superschlumpf schrieb:

Ja, irgendwas hat Apple da aus meiner Sicht vermurkst... Apple selbst nennt es wahrscheinlich „Feature“. 🙄 Aus der Apple Foto App scheint nur noch Video-Airplay möglich zu sein. 😬 Auf iOS war mir das bekannt, aber mit TV OS auf Apple TV war ich davon ausgegangen, dass der Ton von Videos der Foto App an Airplayempfänger gesendet werden kann. Ich hatte ja oben geschrieben, dass es funktionieren würde... stimmt aber leider nicht(mehr). 😕


Anderes Beispiel: Ich kann auf dem iPad den Ton eines von mir gekauften Films per Airplay zu Sonos schicken, während ich den Film in der Video-App gucke. Versuche ich jedoch das gleiche über die YouTube-App (wohlgemerkt: mit einem Kaufvideo), sieht das Ergebnis wie folgt aus.
Benutzerebene 3
Abzeichen +3
@Peri
Konnte den Fehler bei YouTube mit einem Kauffilm reproduzieren. Das passierte, wenn zuvor Airplay bereits aktiv war. YouTube App beenden, Airplay deaktivieren, App neu starten, Film starten und dann Ton per Airplay zu Sonos hat dann funktioniert. Ob da der Fehler nun auch bei Apple oder in der YouTube App zu suchen ist, weiß ich auch nicht genau. Würde aber auch eher auf die App tippen.
Auf jeden Fall unbefriedigend, dass Airplay manchmal immer wieder hakelt...
Danke Ralf. Werde ich versuchen. Es ist übrigens die YouTube-App.

https://de.community.sonos.com/controller-und-software-223391/youtube-ipad-app-ton-ueber-airplay2-an-beam-augeben-6744530
Nochmals danke, Ralf. Es klappt, wenn das Video vorher gestartet wird. Jedenfalls ist es eine Frechheit, dass Google diese 'Airplay-Sperre' ausgerechnet bei Kauffilmen aufrechterhält.
Benutzerebene 3
Abzeichen +3
@Peri
Gern geschehen... habe es aber auch nur durch Zufall bemerkt, weil beim ersten Versuch Airplay bereits aktiv war und beim zweiten nicht.
Schon komisch, dass davon anscheinend nur Kauffilme betroffen sind... Kann mir kaum vorstellen, dass das beabsichtigt ist. 😳
Benutzerebene 3
Abzeichen +3
Etwas off topic, aber in dem Zusammenhang doch interessant: selbst Kauffilme von Google, die ja über die Google Play App in 5.1 Ton gestreamt werden, werden über die YouTube App auf Apple Geräten nur in Stereo gestreamt. 😒
Superschlumpf schrieb:

@Peri
Gern geschehen... habe es aber auch nur durch Zufall bemerkt, weil beim ersten Versuch Airplay bereits aktiv war und beim zweiten nicht.
Schon komisch, dass davon anscheinend nur Kauffilme betroffen sind... Kann mir kaum vorstellen, dass das beabsichtigt ist. 😳


Vor ein paar Monaten hatte Google Airplay generell sabotiert, dann nach Wochen für YouTube-Premiumabonnenten freigeschaltet. Was YT-Free anlangt, widersprechen sich die Berichte, bei manchen funktionierts, bei manchen nicht. Bei YT-Premium ist der große Vorteil, dass man das Display ausschalten kann, was bei Kauffilmen übrigens ebenfalls nicht möglich ist (auch auf Androidgeräten nicht).
Benutzerebene 4
Abzeichen +3
Superschlumpf schrieb:

Etwas off topic, aber in dem Zusammenhang doch interessant: selbst Kauffilme von Google, die ja über die Google Play App in 5.1 Ton gestreamt werden, werden über die YouTube App auf Apple Geräten nur in Stereo gestreamt. 😒



Interessant. :)

Cookie-Richtlinen

Wir machen Gebrauch von Cookies um Ihr Erlebnis zu personalisieren und zu optimisieren. Wenn Sie zustimmen, stimmen Sie unseren Bestimmungen bzgl. Cookies zu. Klicken Sie hier um mehr über unsere Cookies zu erfahren.

Akzeptieren Cookie-Einstellungen