Beantwortet

Sonos Arc verhindert Betrieb (HDMI) der Fernseher Lautsprecher


Abzeichen

Hi, ich kann seit die ARC mit meinem Sony AG9 verbunden ist nicht mehr auf die Fernseher Lautsprecher (TV-System) umschalten. Also die Ausgabe über das Audiosystem deaktivieren und TV-System aktivieren. Sobald ich das im Fernseher Menü umschalte wechselt das kurzfristig 2-3x zwischen TV-System und Audiosystem hin und her und am ende ist das Audiosystem aktiv.

Hat jemand eine Idee? Danke für Eure Hilfe 

icon

Beste Antwort von Peter_13 13 August 2021, 10:14

Original anzeigen

12 Antworten

Ja, das liegt an der Priorität des HDMI-ARC des TVs und ließe sich nur durch ein FW-Update seitens Sony ändern. Dir bleibt nur der Weg des Ziehens der HDMI-Verbindung bei Nichtnutzung der Arc.

Abzeichen

Danke für die schnelle Antwort.
Das mit dem Ziehen der HDMI Verbindung ist natürlich keine Lösung. Ich habe mich jetzt auch an den Sony Support gewendet und das Problem geschildert.

Leider habe ich nicht wirklich Hoffnung auf eine zufriedenstellen Lösung. Wahrscheinlich wird hier der Schwarze Peter zwischen Sony und Sonos hin und her geschoben und ich bleibe auf dem Problem sitzen. Den Sonos Support hatte ich ja auch schon vorab kontaktiert, da gab es auch nur den Hinweis auf diese Forum.

Ich bin sehr enttäuscht das so hochpreisige Komponenten von namhaften Herstellern nicht zusammen funktionieren.

 

Benutzerebene 2
Abzeichen +2

@Herzrasen

 

Wie @Peter_13 schon erläutert hat, hängt dies an der Priorisierung des HDMI-ARC Anschlusses. Wenn du nicht immer das Kabel ziehen möchtest, kannst du auch prüfen, ob die Deaktivierung von der ARC-Funktion (auch CEC) über die Einstellungen am TV den gewünschten Effekt beschwert. 

Dies bedeutet allerdings auch, dass du jedes Mal die Einstellungen am TV vornehmen musst, wenn du die Tonausgabe verändern möchtest.

 

Liebe Grüße

Claudia S.

Abzeichen

So heute war der Sony-Support vor Ort und hat sich das Problem angeschaut.

Mit der mitgebrachten Soundbar (keine Sonos) und dem vorhandenen HDMI-Kabel tritt das Problem nicht auf. Die Ausgabe kann über den Fernseher einwandfrei gesteuert bzw. gewechselt werden. Alles funktioniert wie gewünscht und wie es sein soll.

Wenn die Sonos ARC wieder angeschlossen wird, tritt das Problem sofort wieder auf und die Audiosteuerung funktioniert nicht mehr.

Ich vermute das Problem doch auf Seiten von Sonos :-(

 

Liebe Grüße 

Benutzerebene 3
Abzeichen +3

@Herzrasen 

 

Das Problem hierbei ist die CEC Steuerung. Wenn der Arc angeschlossen ist, wird dem Fernseher mitgeteilt das eine Soundbar vorhanden ist und der Fernseher nutzt diese dann automatisch als Ausgabegerät.

Das kann man nur verhindern in dem man CEC ausschaltet (BRAVIA Sync bei Sony), ein HDMI Kabel ohne CEC (Pin 13) oder einen CEC Blocker verwednet. Dann kommunizieren Arc und TV nicht mehr miteinander.

Nachteil ist dann aber auch das die TV Fernbedienung angelernt werden muss, da diese Kommunikation auch über CEC läuft.

 

Viele Grüße

Sven

Abzeichen

Ich habe mir nun so einen CEC Blocker besorgt, damit ist die Steuerung in soweit hergestellt das die Ausgabe zwischen Fernseher und ARC gewechselt werden kann.

Zufriedenstellend ist das natürlich nicht, da ich auch die Gelegenheit hatte andere Soundbars auszuprobieren. Ergebnis, bis auf die ARC haben alle anderen nicht das Problem produziert.

Benutzerebene 3
Abzeichen +1

Wenn die TV Autoplay Funktion funktionieren würde dann dann müsste man CEC am TV  nicht manuell ausschalten.

Eigentlich sollte man an der beam TV autoplay ausschalten und die Beam sollte sich dann wenn sie nicht auf dem TV Eingang eingestellt ist vom TV quasi abmelden und sobald TV angewählt ist wieder die CEC Befehle annehmen !

 

Benutzerebene 3
Abzeichen +1

@Herzrasen 

Ich gehe davon aus, das der CEC Blocker aber auch verhindert das die FB Befehle vom.TV an die ARC weiter gegeben werden ?

Abzeichen

@Herzrasen

Ich gehe davon aus, das der CEC Blocker aber auch verhindert das die FB Befehle vom.TV an die ARC weiter gegeben werden ?

Genau nur noch Steuerung über die App, in der App wird dann aber auch noch ein Fehler (Fehlerhafte Kommunikation) angezeigt. Der kann aber ignoriert werden.

Ist wirklich nicht die Lösung ….

Sehr ärgerlich 😡 

Abzeichen

Ich habe genau das gleiche Problem, besitze allerdings erst seit kurzem einen Sonos AMP mit einem Samsung UE65MU8009. Der TV war vorher über HDMI-ARC an einen Denon AVR angeschlossen. Dieser lies sich perfekt per HDMI-CEC steuern. Er schaltet sich ein, wenn ich “HDMI-Audio” auswähle und wenn ich “TV-Lautsprecher” wähle wird die Tonausgabe am AVR gestoppt und läuft dann wieder über die internen TV-Lautsprecher.

Mit dem Sonos AMP (auch über HDMI-ARC angeschlossen) wähle ich “TV-Lautsprecher” aus und solange der Sonos Amp per HDMI verbunden ist, springt die Audio-Ausgabe nach 3 Sekunden zurück auf “HDMI-Audio”. Ich kann zwar HDIM-CEC am TV auschalten aber dann kann ich keinen Ton über den Amp ausgeben und ich benötige es außerdem zur Steuerung meines nVidia Shield TV.

Im Moment habe ich mir mit dem Sonos Optical Adapter beholfen und gebe den Ton über SPDIF wieder, das hat aber steuerungstechnisch andere Nachteile, ist also ein Rückschritt zu meinem alten Setup mit Denon AVR.

Ich sehe hier ganz klar Sonos in der Pflicht, das Problem besteht anscheinend schon länger und betrifft ja auch verschiedene TV-Hersteller.

Da ich den Amp direkt bei Sonos bestellt habe, befinde ich mich noch in dem 100 Tage-Test-Zeitraum, vielleicht wird das ja doch noch gefixt!? Ansonsten denke ich darüber nach, den Amp zurückzuschicken, obwohl mich das Gerät ansonsten echt überzeugt hat, super Stereosound und perfekte Integration in meine restliche Sonos-Welt. Schade!

Abzeichen

Ich habe genau das gleiche Problem, besitze allerdings erst seit kurzem einen Sonos AMP mit einem Samsung UE65MU8009. Der TV war vorher über HDMI-ARC an einen Denon AVR angeschlossen. Dieser lies sich perfekt per HDMI-CEC steuern. Er schaltet sich ein, wenn ich “HDMI-Audio” auswähle und wenn ich “TV-Lautsprecher” wähle wird die Tonausgabe am AVR gestoppt und läuft dann wieder über die internen TV-Lautsprecher.

Mit dem Sonos AMP (auch über HDMI-ARC angeschlossen) wähle ich “TV-Lautsprecher” aus und solange der Sonos Amp per HDMI verbunden ist, springt die Audio-Ausgabe nach 3 Sekunden zurück auf “HDMI-Audio”. Ich kann zwar HDIM-CEC am TV auschalten aber dann kann ich keinen Ton über den Amp ausgeben und ich benötige es außerdem zur Steuerung meines nVidia Shield TV.

Im Moment habe ich mir mit dem Sonos Optical Adapter beholfen und gebe den Ton über SPDIF wieder, das hat aber steuerungstechnisch andere Nachteile, ist also ein Rückschritt zu meinem alten Setup mit Denon AVR.

Ich sehe hier ganz klar Sonos in der Pflicht, das Problem besteht anscheinend schon länger und betrifft ja auch verschiedene TV-Hersteller.

Da ich den Amp direkt bei Sonos bestellt habe, befinde ich mich noch in dem 100 Tage-Test-Zeitraum, vielleicht wird das ja doch noch gefixt!? Ansonsten denke ich darüber nach, den Amp zurückzuschicken, obwohl mich das Gerät ansonsten echt überzeugt hat, super Stereosound und perfekte Integration in meine restliche Sonos-Welt. Schade!

Das sehe ich genauso, leider habe ich von Sonos noch keine Rückmeldung bekommen. Eine tolle Soundbar leider ist die HDMI Anbindung stark verbesserungswürdig.

 

Abzeichen

Ich habe mit dem deutschen Sonos-Support gesprochen. Die haben keine Lösung für das Problem, ich solle bitte im amerikanischen Sonos-Forum einen Beitrag erstellen und das Problem schildern, da würden dann auch die Entwickler mitlesen. Auch da finden sich einige Posts über das HDMI-ARC-Problem, die Lösung ist dann entweder das HDMI-Kabel abzuziehen oder HDMI-CEC im TV abzuschalten… super! Ich bin mir sicher, das es nur einer kleinen Softwareanpassung auf Seiten von Sonos bedarf, um das Problem zu lösen.

Ich habe den TV neulich nochmal mit meinem alten Onkyo TX-NR616 mit HDMI-ARC getestet, auch hier trat das Problem nicht auf, ich konnte ohne Probleme zwischen der Tonausgabe mit den internen TV-Lautsprechern und dem Receiver wechseln.

Antworten