Beantwortet

Wieder verbinden der App nach einiger Zeit


Abzeichen

Hallo Communitiy,

seit dem letzten Update habe ich folgendes Problem. 
 

Ich starte Radio über die Sonos App. Nach einiger Zeit, wenn ich z. B. die Lautstärke ändern möchte, findet die App das Sonos System nicht mehr. 
 

Andere Handys finden das System aber. Alle haben die gleiche App installiert. 
 

Das nervt langsam echt. Kennt jemand Abhilfe?

 

Komponenten:

1 x Play One

2 x Symfonisk

IPhone 7s, Galaxy S10 

FritzBox 7590
 

Vielen Dank! 

icon

Beste Antwort von Greta A. 22 Februar 2021, 09:02

@Amplexus, es könnte am FritzMesh liegen, doch da ich nicht weiß, ob es hier einen Unterschied gibt, wenn eine Fritzbox als Repeater fungiert, ist es das Beste, du sprichst mit dem Support.

https://www.sonos.com/de-de/support (auf der Seite nach unten scrollen)

Original anzeigen

13 Antworten

@Amplexus, welches Handy findet das System nicht, das iPhone oder das Android?

Benutzerebene 1
Abzeichen +2

Hallo @Amplexus

herzlich willkommen in der Community.

 

Wie @Greta A. schon fragte, verrate uns bitte einmal was für ein Smartphone du benutzt.

Und kann es sein, dass du neben der Fritzbox noch Repeater oder ähnliche Geräte nutzt um dein Wlan zu erweitern?

Must du etwas bestimmtes machen, damit du deine Lautsprecher wieder finden kannst?

 

Liebe Grüße

Claudia S.

 

Abzeichen

Hallo Ihr Lieben,

 

ich benutze das IPhone 7S. Habe aber nochmal ein IPhone, dass nur dazu dient, Smarthome und Sonos zu steuern. Alle sind systemtechnisch auf dem neuesten Stand. 
 

Das zweite IPhone findest zumeist das System etwas schneller wieder als meins. 
 

Weiter habe ich ein Mesh mit einer Fritzbox 7560. Auch diese Geräte sind alle auf dem aktuellen Stand. 
 

Und das Auffinden des Systems klappt nur dann nicht, wenn ich erst nach einiger Zeit des „einfach Laufen lassens“ wieder in die App gehe. 
 

Erst nach zigmaligem Neustart der App, wird das System wieder erkannt. 
 

Gibt es schon Vermutungen?

Wie schauts mit Folgendem auf den betroffenen iPhones aus?

 

iOS 14 führt eine neue Zugriffsberechtigung bei Anwendungen ein, die aktiviert werden muss, um die Sonos App mit deinem System verbinden zu können. Falls du ein Update auf iOS 14 durchgeführt hast, öffne in der App deines iOS Geräts Einstellungen und dann Datenschutz > Lokales Netzwerk. Aktiviere in dieser Liste den Zugriff für Sonos, um eine Verbindung mit der Sonos App herstellen zu können.

https://support.sonos.com/s/article/290?language=de

 

 

Wenn das nichts bringt, schalte auf den iPhones Die Nutzung privater WLAN-Adressen in einem Netzwerk (nach unten scrollen) aus.

Abzeichen

Hallo Greta,

 

vielen Dank für den Tipp. 
Zugriff ist auf beiden Geräten gewährt. 
 

Der Fehler kommt ja auch nur bei bereits laufendem System. Also ich starte irgendeinen Player / Streaming-Dienst, lege das Handy bei Seite und möchte nach einer Stunde z. B. leider machen, weil vllt. das Telefon klingelt. Dann erst baut die App keine Verbindung mehr auf. 
 

Pausiere ich in der App das Abspielen und aktiviere später wieder neu, ist die Funktion gegeben. 
 

Das Ganze kam mit dem letzten Update der App. 
 

Den zweiten Hinweis werde ich probieren. 
 

Danke!

Abzeichen

Hallo nochmal,

 

nach ein Paar Tagen kann ich nun sagen, es hat sich nichts geändert. 
 

Heute wieder mit meinem Handy keinen erneuten Verbindungsaufbau, dass zweite iPhone aber schon. 
 

Wlan an / aus, Flugmodus, Neustart der Fritzbox, nichts hilft. 
 

Wäre echt super, der Bug würde wieder behoben werden. 
 

Besten Dank!

@Amplexus, unter welcher Version des FritzOS laufen Fritzbox sowie Repeater(?) / PowerLAN-Adapter(?) “Befinden sich auf aktuellem Stand” lässt nicht auf die installierte Version schließen.

Abzeichen

Guten Morgen,

 

FritzBox 7590 = 7.21 

FritzBox 7560 UI = 7.12 (Mesh)

 

Beide Geräte sind auf dem aktuellen Stand, keine Updates verfügbar  

 

@Amplexus, es könnte am FritzMesh liegen, doch da ich nicht weiß, ob es hier einen Unterschied gibt, wenn eine Fritzbox als Repeater fungiert, ist es das Beste, du sprichst mit dem Support.

https://www.sonos.com/de-de/support (auf der Seite nach unten scrollen)

Benutzerebene 3
Abzeichen +3

@Greta A. @Amplexus 

Hallo zusammen,

grundsätzlich sollten die Geräte auf der neusten Version laufen. Das ist laut AVM FritzBox 7560 https://avm.de/service/downloads/?product=fritzbox-7560 7.12. Datum:    06.08.2019

 

Wir schauen uns das gerne noch mal an, jedoch sei gesagt: AVM hat seine Geräte (Router / Repeater) erst ab Version 7.20 auf Sonos optimiert. Damit wird es also als kabelloser Repeater mit gleichem WLAN-Namen und Sonos nicht klappen und wir müssen schauen, was hier im Einzelfall die beste Lösung ist.

 

Liebe Grüße

Nils

Abzeichen

Hallo Nils,

 

vielen Dank für die Antwort. 
 

Ich verstehe Ihre Ausführung. Zum Umfeld vllt. noch. Die Box 7590 befindet sich im 1 OG, unweit der Sonos Speaker. Alle im Umkreis von max. 7m. 
 

Der Mesh-Router 7560 befindet sind im EG, um dort ebenfalls, bis nach draußen, vollen WLAN Empfang zu haben. 
 

Meinen Sie also das die 7560 für die Störungen sorgt? 
 

Das ganze System sollte schon laufen. Wenn ein Anruf kommt und man nicht leiser machen kann ist das echt stressig, zumal in Zeiten von Homeoffice auch dienstliche Anrufe an der Tagesordnung sind  

 

Ich möchte jetzt aber auch keine neuere FritzBox kaufen als Mesh Repeater wegen dem FritzOS, um dann womöglich festzustellen, dass der Fehler danach immer noch besteht. 
 

Soll ich nun wie Greta schrieb den Support kontaktieren, oder sind Sie bereits aus dem Support? 
 

Vielen Dank und lieben Gruß

Timo

@Amplexus, die Repeaterkonfiguration blockiert bestimmte Datenpakete, die für Sonos essenziell sind. Anbei eine Zusammenstellung diverser Lösungsansätze.

 

Repeater ausstecken, 10 Min. warten und danach die Wiedergabe starten. Wenn es läuft wie es laufen soll, kann der Repeater (die 2. Fritzbox) wieder eingesteckt werden.


Wenn das hilft, hast du folgende Optionen:

Wenn der Repeater einen eigenen Mac-Filter haben, dann kann man dort die Mac-Adressen der Sonos-Player eintragen, sodass sich diese nicht mehr damit verbinden oder du änderst die SSID des Repeaters, wenn der Mesh-Master dies zulässt. Ansonsten musst du immer darauf achten, dass sich kein Player mit dem Repeater verbindet. Also wenn ein Update ansteht, vorher den Repeater ausschalten, das gleiche gilt auch, wenn ein Update für den Router ansteht oder dieser aus einem anderen Grund neu gestartet werden muss.

FRITZBOX Anleitungen für FritzRepeater


Oder: EINEN Player dauerhaft mit dem Router verkabeln, wie folgt vorgehen, dadurch wechselt das System in die Betriebsart SonosNet:

1) Repeater ausschalten
2) Einen Player (bei einem Stereopaar den linken ; Sub & Surrounds kommen dafür nicht infrage!) dauerhaft mit dem Router verkabeln
3) Anschließend die WLAN-Zugangsdaten wie folgt aus dem System entfernen. Tippe in der Sonosapp unter Einstellungen auf System > Netzwerk > Netzwerke. Wähle das WLAN-Netzwerk aus, das du entfernen möchtest und tippe auf Entfernen.

4) Mindestens 10 Min. warten. Erst wenn unter 'Einstellungen --> Über mein Sonos-System' neben jedem Player WM:0 steht, darf der Repeater wieder ans Netz.

[Der Move ist eine Ausnahme, der verbleibt auf WM:1]


Für Fälle, wo kein Player mit dem Router verkabelt werden kann, wurde der Boost konzipiert.

https://www.sonos.com/de-de/shop/boost.html

Benutzerebene 3
Abzeichen +3

Meinen Sie also das die 7560 für die Störungen sorgt? 

Hey Timo das ist möglich. Wie läuft es denn, wenn man das Gerät testweise vom Strom nimmt?

 

Soll ich nun wie Greta schrieb den Support kontaktieren, oder sind Sie bereits aus dem Support? 

Beides trifft zu :) 

Zu Diensten und ein Anruf wäre hier zielführend meiner Meinung nach. Wir können mit Diagnosen sehen, wie sich die Geräte verbinden. Diese werden hier im Forum nicht bearbeitet. Uns erkannt man immer an “Sonos Staff”.

Antworten