Warum verliert mein Sonos-System immer wieder die Räume?



Ersten Beitrag anzeigen
Dieser Beitrag ist geschlossen für weitere Beiträge

128 Antworten

Der Connect ist an einem Switch angeschlossen, welcher seinerseits am Router hängt. Die Luftstrecke zum WLAN-Router und zu vier meiner fünf weiteren Playern ist kurz (alles Nachbarzimmer) und die Wände des Fachwerkhauses sehr unproblematisch. Nur ein Gerät steht etwas weiter weg, hat aber erfahrungsgemäß auch keine Probleme, sich zu verbinden. Wenn du schreibst, sechs Sonos-Geräte, zählst du den Connect selbst offenbar mit?! Sonst habe ich einen unsichbaren Trittbrettfahrer oder irgendein Sonos-Gerät meldet sich doppelt an. Das sehe ich in der Geräteauflistung allerdings nicht.
Benutzerebene 7
Abzeichen +3
Der CONNECT ist ja auch ein Sonos Gerät. Wird also mitgezählt.
Benutzerebene 4
Abzeichen +3
Könntest du uns vielleicht noch eine Diagnose von dem Gerät senden, von welchem du das Update gestartet hast? Mit dem jetzigen Logs lässt sich leider, bis auf die Funkstörungen, nicht viel sagen.
Hallo,
Ich habe auch ein ähnliches Problem.
Seit ein paar Tagen kommt es immer wieder vor, dass die Wiedergabe plötzlich aufhört. Gucke ich dann in die App wird für den Betroffenen Raum aber immer noch eine Wiedergabe angezeigt, diese lässt sich aber werde pausieren noch anderweitig verändern. Nach einem Neustart der App werden dann in der Raumliste nicht mehr alle Räume angezeigt. Komisch ist aber, dass in der Liste Leerstellen sind, wo vorher noch die fehlenden Räume waren.
Nach kurzer Zeit (10-15min) und mehrfachem Neustart der App werden die fehlenden Räume wieder angezeigt und lassen sich wie gewohnt steuern.

Mein Diagnosebericht:
Deine Bestätigungsnummer lautet: 1532110779.

Viele Grüße
Sebastian
Hallo Sebasian,

betreibst Du Sonos über WLAN und setzt Du Repeater oder PowerLAN-Adapter ein? Falls ja, lies Dir bitte diesen Thread durch.


Gruß,
Peri
Benutzerebene 6
Abzeichen +3
Hallo,
Ich habe auch ein ähnliches Problem.
Seit ein paar Tagen kommt es immer wieder vor, dass die Wiedergabe plötzlich aufhört. Gucke ich dann in die App wird für den Betroffenen Raum aber immer noch eine Wiedergabe angezeigt, diese lässt sich aber werde pausieren noch anderweitig verändern. Nach einem Neustart der App werden dann in der Raumliste nicht mehr alle Räume angezeigt. Komisch ist aber, dass in der Liste Leerstellen sind, wo vorher noch die fehlenden Räume waren.
Nach kurzer Zeit (10-15min) und mehrfachem Neustart der App werden die fehlenden Räume wieder angezeigt und lassen sich wie gewohnt steuern.

Mein Diagnosebericht:
Deine Bestätigungsnummer lautet: 1532110779.

Viele Grüße
Sebastian


Hi Sebastian,

in der Diagnose sehe Ich, dass sich einige Player über einen Repeater anmelden.
Du kannst gerne versuchen deinen Wlan-Funkkanal am Router zu ändern, um eine Besserung zu erzielen.
Ich würde dir aber empfehlen einen Boost zu installieren, da sich die Sonos-Geräte dann untereinander verbinden.
Wenn einer deiner Player sowieso beim Router stehen sollte, dann kannst du auch diesen Player via LAN verbinden.
Der Player würde dann die Aufgabe vom Boost übernehmen.

Gruß,
Daniel
Vielen Dank für die Rückmeldung.
Ich werde mal versuchen eine Sonos per LAN anzubinden.

Dennoch finde ich es komisch das plötzlich Räume aussteigen, denn bis vor ca 2 Wochen lief das System in gleicher Konstellation stabil.

Sebastian
Benutzerebene 7
Abzeichen +3
Hi Sebastian,
das kann viele Gründe haben.
Schon ein neuer Nachbar mit WLAN oder ein anderer Nachbar mit neuer Hardware usw. kann das verursachen, dass dein Netzwerk sich anders verhält. Dann kommen auf einmal Verbindungen zu Stande, die es vorher nicht gab.
Deshalb ist der Vorschlag von Daniel am besten, da sich dann diese Repeater Verbindungen nicht mehr ergeben können.
Gruß
Armin
Benutzerebene 6
Abzeichen +3
Vielen Dank für die Rückmeldung.
Ich werde mal versuchen eine Sonos per LAN anzubinden.

Dennoch finde ich es komisch das plötzlich Räume aussteigen, denn bis vor ca 2 Wochen lief das System in gleicher Konstellation stabil.

Sebastian


Hi,

gib uns gerne eine Rückmeldung, was die Performance von deinem System betrifft.
In den meisten Fällen läuft das System deutlich stabiler als vorher.

Gruß,
Daniel
Abzeichen
Hallo,

ich habe das gleiche Problem. Sobald ich meine Balkontüre öffne, verschwinden die Boxen im Bad und Schlafzimmer. Schließe ich die Balkontüre wieder, funktioniert alles einwandfrei. Ich habe bereits einen Boost gekauft, um diesen als Repeater zu nutzen und das SonosNet zu verstärken. Den Boost habe ich an den verschiedensten Orten in der Wohnung aufgebaut, aber leider hat das nichts gebracht. Außerdem habe ich den SonosNet Wireless-Kanal von 6 auf 1 und 11 gewechselt. Das hat leider auch nichts gebracht. Es ist immer das gleiche Spiel. Balkontüre auf, SonosNet bricht zusammen - Balkontüre zu, alles funktioniert wunderbar.

Kann mir jemand helfen?

Hier meine Diagnosedatei bei geöffneter Balkontüre: 1000225031

Viele Grüße
Uta
Hallo Uta,

da Du "Den Boost habe ich an den verschiedensten Orten in der Wohnung aufgebaut" schreibst, frage ich vorsichtshalber nach, ob der Boost mit dem Router verkabelt ist(?)


Außerdem sollte, falls nicht geschehen, die Wireless-Einrichtung wie folgt rückgängig gemacht werden, um einem Mischbetrieb entgegenzuwirken:


Sobald dein System erfolgreich in der BOOST-Einrichtung konfiguriert ist, empfiehlt es sich, das WLAN-Kennwort anhand der folgenden Schritte aus dem Sonos-System zu entfernen:

Sonos Controller-App für iOS oder Android: Tippe im Sonos-Musikmenü auf „Einstellungen“ > „Erweiterte Einstellungen“ > „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.
Sonos Controller-App für Mac: Klicke auf „Sonos“ > „Einstellungen“ > „Erweitert“ > „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.
Sonos Controller-App für PC: Klicke auf „Verwalten“ > „Einstellungen“ > „Erweitert“ > „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.


Warte danach bitte mindestens fünf Minuten.


Gruß,
Peri
Benutzerebene 4
Abzeichen +3
Hallo,
einen Boost sehe in der Diagnose nicht. Die Playbar ist per Kabel angeschlossen, die beiden Play:3 sind jedoch mit dem WLAN des Routers verbunden. Das ist schon nicht optimal und lässt auf ein Problem schließen. Die Frage ist natürlich, was die Balkontür damit zu tun hat. Kannst du uns vielleicht noch eine Diagnose senden, wenn die Tür geschlossen ist?
Hallo Christopher,
wenn man so das Forum durchgeht, dann ist es eigentlich sehr auffällig, wie viele solche "Fehl-Konfigurationen" (sprich doppelte Netzanbindung - einerseits per SONOS-Net / also LAN und andererseits per priv. WLAN) hier immer wieder vorkommen!?
Ggf. solltet Ihr (sprich also vielmehr die Entwicklung) einmal darüber nachdenken, hier eine SW-technische Lösung bereit zu stellen.
- nur so als Anregung und im Sinne einer besseren Useability des Systems für die Kundenzufriedenheit und zur Reduzierung der Supportfälle.
Aus meiner Sicht ließe sich das recht einfach erreichen, indem man ganz simpel per SW unterbindet, dass sich eine Komponente in einen WLAN-Access außer dem der SONOS-BSSID einloggen kann, wenn auch nur an einem der Geräte ein LAN-Port in Benutzung ist.
- die wenigsten Nutzer verstehen nämlich anscheinend die Zusammenhänge der unterschiedlichen Netzkonfigurationen und der sich daraus ergebenen Probleme / Folgen. :?
- und ein Großteil (zumindest derer, die hier von ihren solchen Problemen berichten) ignoriert (bewusst oder unbewusst) oder vergisst die wenn auch sehr gute Beschreibung für den Wechsel in den Boost-Mode - sprich ins SONOS-Net - auszuführen und entfernt somit die SSID für das priv. WLAN nicht.
... ein kleiner Schritt für einen Menschen (den Programmierer), aber ein großer Schritt für die Menschheit (also die User) 🆒:8
Abzeichen
Hallo Peri,

vielen Dank für deine schnelle Antwort. Die Wireless-Einrichtung habe ich zurückgesetzt. Leider hat das zu keiner Veränderung geführt.

Hallo Christopher,

um ein stabiles Netz zu bekommen, habe ich Vieles versucht. Boosteinrichtung, Standardeinrichtung, Standardeinrichtung mit Boost als Repeater etc. Deshalb waren am Schluss die Play:3 Speaker sowohl über die Playbar / Sonos Net als auch über das WLAN eingerichtet.
Ich habe alles wieder rückgängig gemacht, die Wireless-Einrichtung zurückgesetzt, den Boost an den Router angeschlossen, die Playbar und Play:3 Speaker mit dem Boost neu eingerichtet. Alles läuft jetzt über die Boosteinrichtung (@ Peter: wie im Lehrbuch!). Das Problem bleibt allerdings bestehen: Balkontüre zu, alles läuft super - Balkontüre auf, Playbar setzt aus.

Ich habe neue Diagnosedateien erstellt: 164584393 bei geschlossener Balkontüre (alles läuft), 983579540 bei offener Balkontüre (Playbar läuft nicht).

Besten Dank im Voraus für die Hilfe!

Viele Grüße
Uta
Benutzerebene 7
Abzeichen +3
Hallo Christopher,
wenn man so das Forum durchgeht, dann ist es eigentlich sehr auffällig, wie viele solche "Fehl-Konfigurationen" (sprich doppelte Netzanbindung - einerseits per SONOS-Net / also LAN und andererseits per priv. WLAN) hier immer wieder vorkommen!?
Ggf. solltet Ihr (sprich also vielmehr die Entwicklung) einmal darüber nachdenken, hier eine SW-technische Lösung bereit zu stellen.
- nur so als Anregung und im Sinne einer besseren Useability des Systems für die Kundenzufriedenheit und zur Reduzierung der Supportfälle.
Aus meiner Sicht ließe sich das recht einfach erreichen, indem man ganz simpel per SW unterbindet, dass sich eine Komponente in einen WLAN-Access außer dem der SONOS-BSSID einloggen kann, wenn auch nur an einem der Geräte ein LAN-Port in Benutzung ist.
- die wenigsten Nutzer verstehen nämlich anscheinend die Zusammenhänge der unterschiedlichen Netzkonfigurationen und der sich daraus ergebenen Probleme / Folgen. :?
- und ein Großteil (zumindest derer, die hier von ihren solchen Problemen berichten) ignoriert (bewusst oder unbewusst) oder vergisst die wenn auch sehr gute Beschreibung für den Wechsel in den Boost-Mode - sprich ins SONOS-Net - auszuführen und entfernt somit die SSID für das priv. WLAN nicht.
... ein kleiner Schritt für einen Menschen (den Programmierer), aber ein großer Schritt für die Menschheit (also die User) 🆒:8

100% Zustimmung!
Hallo Uta,

[...] Alles läuft jetzt über die Boosteinrichtung (@ Peter: wie im Lehrbuch!). Das Problem bleibt allerdings bestehen: Balkontüre zu, alles läuft super - Balkontüre auf, Playbar setzt aus.[...]
setzt jetzt nur die Playbar aus? Vielleicht funkt ein 5 GHz-Signal aus der unmittelbaren Nachbarschaft dazwischen, sobald die Balkontür geöffnet ist(?) Ist momentan nur der Boost mit dem Router verkabelt?


Gruß,
Peri
Abzeichen
Hallo Peri,

genau, nur der Boost ist mit dem Router verkabelt und nur die Playbar setzt aus. Die beiden Speaker im Bad und Schlafzimmer laufen weiter.

Viele Grüße
Uta
Und bei welcher Betriebsart kommt es dann zu den Aussetzern bei der PB ?
- nur bei Musikwiedergabe oder auch bei TV-Betrieb ?!
Und wenn bei Musikwiedergabe, läuft die PB dann in einer Gruppe mit den anderen PLAYern, und wenn ja, von welchem PLAYer / Raum wurde dann die Gruppe aufgebaut ???
Betreibst Du die PB eigentlich solo oder mit angeschlossenen Satelliten, und wenn mit Rears, setzen nur die dann aus oder die PB selbst auch ?

Hintergrund:
Es ist tatsächlich denkbar, dass die Funkversorgung der PB sehr grenzwertig ist und bei geöffneter Tür Dir ein "Nachbar-WLAN" oder z.Bsp. auch eine benachbarte Funk-Überwachungskamera (oder auch andere Sender) reinstrahlt und die Verbindung total zusammen brechen lässt.
Wie gut / schlecht die Versorgung der PB ist, das kannst Du nur in der Netzwerk-Matrix oder SONOS in der Diagnose sehen.
Die restlichen Fragen dienen nur der weiteren Eingrenzung in welchem Bereich die Ursache denn überhaupt erst einmal einzuordnen ist.
Benutzerebene 6
Abzeichen +3
Hallo Peri,

genau, nur der Boost ist mit dem Router verkabelt und nur die Playbar setzt aus. Die beiden Speaker im Bad und Schlafzimmer laufen weiter.

Viele Grüße
Uta


Hallo Uta,

In der Diagnose ist zu sehen, dass der Boost ebenfalls unter enormen Funkstörungen leidet.
Wie weit von der Blakotür sind die Playbar, bzw. der Boost positioniert?
Hier muss irgendwas in der Umgebung dafür sorgen, dass die Kommunikation direkt zusammenbricht.

Gruß,
Daniel
Abzeichen
Hallo zusammen,

vielen Dank für die schnellen Rückmeldungen.

Boost und Playbar sind nebeneinander positioniert, ca. 2-3 Meter von der Balkontüre entfernt. Seltsam ist, dass bei geöffneter Balkontüre die beiden Speaker im Bad und Schlafzimmer weiterlaufen, die vom Boost sehr viel weiter entfernt sind als die Playbar.

Zu den Aussetzern kommt es nur im Musikbetrieb, nicht im TV-Betrieb. Im TV-Betrieb läuft die Wiedergabe über das optische Kabel problemlos. Die Playbar läuft in einer Gruppe mit zwei Play:3 Speakern, einer im Bad und einer im Schlafzimmer. Ich habe zuerst den Boot eingerichtet, dann die Playbar im Wohnzimmer und anschließend die zwei Play:3 Speaker. Mir stehen nun drei Räume zur Verfügung, die ich unterschiedlich ansteuern und aufbauen kann. Ich habe keine Satelliten für die Playbar, betriebe sie also solo.

Ich hoffe, das hilft.

Besten Dank und schöne Grüße
Uta
Die genauen Ursachen der Funkstörungen bei der PB und dem BOOST kann nur Daniel wirklich sehen / beurteilen, es sei denn die kennst Dich mit der SONOS-Hidden-GUI und der darin erreichbaren Network-Matrix aus bzw. willst dort einsteigen.

Zum jetzigen Zeitpkt. und aus der Ferne würde ich sagen, da hilft nur testweise mal Umstellen des BOOSTs und ggf. zusätzliches anschließen der PB per LAN an den Router (oder alternativ auch an den 2. LAN-Port des BOOSTs).
Abzeichen
Danke Peter.

Mit der Sonos-Hidden-GUI kenne ich mich leider nicht aus.

Das Umstellen des Boosts sowie das zusätzliche Anschließen der Playbar direkt an den Router oder an den Boost per LAN habe ich auch schon gemacht. Das hat leider nicht geholfen. Es scheint so, als ob die Playbar trotz LAN-Verbindung an erster Stelle immer das SonosNet des Boosts benutzt. Beim Öffnen der Balkontüre, setzt die Playbar wieder aus. Wenn ich den Boost abschalte, dann funktioniert die LAN-Verbindung. Bei offener Türe funktioniert die Playbar, allerdings dann die beiden Speaker im Bad und Schlafzimmer nicht.

Kann ich irgendwo definieren, dass die Playbar an erster Stelle die LAN-Verbindung nutzen soll und nicht das SonosNet?

Beste Grüße,
Uta
Benutzerebene 6
Abzeichen +3
Danke Peter.

Mit der Sonos-Hidden-GUI kenne ich mich leider nicht aus.

Das Umstellen des Boosts sowie das zusätzliche Anschließen der Playbar direkt an den Router oder an den Boost per LAN habe ich auch schon gemacht. Das hat leider nicht geholfen. Es scheint so, als ob die Playbar trotz LAN-Verbindung an erster Stelle immer das SonosNet des Boosts benutzt. Beim Öffnen der Balkontüre, setzt die Playbar wieder aus. Wenn ich den Boost abschalte, dann funktioniert die LAN-Verbindung. Bei offener Türe funktioniert die Playbar, allerdings dann die beiden Speaker im Bad und Schlafzimmer nicht.

Kann ich irgendwo definieren, dass die Playbar an erster Stelle die LAN-Verbindung nutzen soll und nicht das SonosNet?

Beste Grüße,
Uta


Hallo Uta,

Ich habe beide Screenshots der Matrix hier angehängt.
Wenn die Tür zu ist, dann ist der Boost nicht so sehr gestört (Gelb) aber bei offener Tür sehr stark gestört (Rot).
Auch wenn du es schon gemacht hats, wechsel bitte den Sonosnet-Kanal, warte ca. 20 Minuten und sende uns wieder zwei Diagnosen.
So haben wir alle 3 Kanäle mal als Diagnose und können uns die Matrix ansehen.
In der Diagnose sehen wir leider nicht, ob eine Wetterstation oder ein anderes Wlan-Netz die Probleme auslöst.

Gruß,
Daniel
[...] Kann ich irgendwo definieren, dass die Playbar an erster Stelle die LAN-Verbindung nutzen soll und nicht das SonosNet?
Zum besseren Verständnis: Das SonosNet wird initiiert, sobald eine oder mehrere/alle Sonos-Komponenten (Player oder Boost) mit dem Router verkabelt werden.
Abzeichen
Hallo Daniel,

ich habe den Sonosnet-Kanal von 6 auf 11 gewechselt und mehr als 20 Minuten gewartet. Die beiden Diagnosedateien lauten wie folgt:

1021619546 bei geschlossenem Fenster (alles funktioniert)
1115864866 bei geöffnetem Fenster (Playbar geht nicht)

Ich bin sehr gespannt. Besten Dank im Voraus für die Hilfe und viele Grüße
Uta