Beantwortet

Sonos One und AirPlay - kein Ton


Abzeichen
Hallo zusammen

ich habe immer wieder mal das Problem, dass ich beim Abspielen über AirPlay keinen Ton bekomme. Egal welchen One ich auswähle, es kommt kein Ton 😏 über Spotify Connect funktioniert jedoch.

Diagnose läuft unter 1665924227

meistens funktioniert es nach nem Router, One und iPhone Neustart - das kann ja aber nicht die Lösung sein 🙈

vg
slurpee
icon

Beste Antwort von Perpugilliam 16 May 2019, 09:05

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

47 Antworten

Benutzerebene 7
Abzeichen +3
@arming
Wenn die Fritzbox auf „Autokanal“ steht, dann scannt sie regelmäßig die Wlan-Umgebung und wechselt bei sich ändernden Bedingungen automatisch auf einen anderen Kanal. Das kann selten, aber auch sehr oft der Fall sein. Je nach Rahmenbedingungen...
Du kannst bei Fritzboxen definitiv einen festen Kanal vergeben. Die FB zeigt dir auch an, was in deiner Umgebung so wlan mäßig los ist. Ich würde erstmal Kanal 1 oder 11 fest einstellen.
Für Sonos sollte jedenfalls definitiv ein fester Kanal eingestellt sein.
Du findest das im Menü der FB unter Wlan... Funkkanal...

Und bei der Gelegenheit setze doch gleich auch (falls noch nicht vorhanden) den Haken bei Wlan... Sicherheit... für „die angezeigten Geräte dürfen untereinander kommunizieren“

siehe Screenshots...

Feste IP Adressen vergibst du unter Heimnetz... Netzwerk..., indem du bei den betroffenen Geräten auf das Stiftsymbol zum Bearbeiten gehst und dann den Haken für die feste IP-Vergabe setzt.


Merkwürdig ist bei dir jedoch, dass das Airplay-Problem NUR mit Spotify auf deinem iPhone auftritt. 🤔
Teste mal die Vorschläge und berichte dann mal...
Viel Erfolg,
Ralf
Abzeichen
Hey @Superschlumpf vielen Dank für die tollen Hinweise inkl. Anleitung. Ich bin schon sehr gespannt ob es klappt! Melde mich dazu am Montag.

Komisch ist auch dass es bei meiner Frau bisher immer problemlos geklappt hat, das spricht ja nicht unbedingt dafür dass es an der FB liegt.
Benutzerebene 7
Abzeichen +3
Hey @Superschlumpf vielen Dank für die tollen Hinweise inkl. Anleitung. Ich bin schon sehr gespannt ob es klappt! Melde mich dazu am Montag.

Komisch ist auch dass es bei meiner Frau bisher immer problemlos geklappt hat, das spricht ja nicht unbedingt dafür dass es an der FB liegt.

Da hast du (leider) Recht, wobei die genannten Einstellungen definitiv grundsätzlich sinnvoll sind.
Bei zwei iPhone Geräten im gleichen Netzwerk kann es eigentlich fast nur an den gerätebezogenen Einstellungen am Gerät selber und am Router für dieses Gerät liegen, wenn nur eines der Geräte Probleme macht.
Irgendetwas wird sich im Detail evtl. bei deinen Einstellungen von denen deiner Frau unterscheiden. 🤔 Oder es liegt an einer instabilen Verbindung aufgrund schlechtem Empfang bei deinem Gerät. Das könntest du ausschließen, indem ihr mal gleichzeitig mit beiden Geräten am gleichen Standort testet.

Ansonsten fielen mir eben noch zwei Dinge ein...
Du könntest mal die Wlan Verbindung deines iPhone zur Fritzbox trennen und dann in der Fritzbox dein iPhone komplett aus der Liste der bekannten Geräte löschen. Dann das iPhone neu am Wlan der FB anmelden und eine feste IP Vergeben.
Der zweite Versuch könnte noch sein, das 5 Ghz Wlan der FB (sofern es aktiviert ist) testweise mal auszuschalten. Normal vermittelt die FB bei Airplay zwischen 2,4 und 5 Ghz, falls Sender und Empfänger auf verschiedenen Bändern sind, aber evtl. hakelt es ja dabei.

So, jetzt hast du glaube ich bis Montag erstmal genug zu tun... 😂😉
Viel Erfolg!
Abzeichen
@Superschlumpf In der Tat! 🙂 Vielen Dank!
Abzeichen
@Superschlumpf So, jetzt bin ich endlich dazu gekommen deine vielen Vorschläge auszuprobieren. Ich habe wirklich alle hier genannten Einstellungen vorgenommen und auch die Deinstallation der Spotify App versucht, aber leider hat nichts davon geholfen 😞

Das einzige was Spotify dazu bewegt auf dem Sonos über Airplay einen Ton auszugeben, ist weiterhin der Neustart des iPhones und sonst nichts! Bei dem iPhone meiner Frau funktioniert es weiterhin einwandfrei und ich habe es auch gleichzeitig am selben Standort versucht.
Benutzerebene 7
Abzeichen +3
@arming
Ziemlich strange... mein Ansatzpunkt wäre nun, herauszufinden, worin sich dein iPhone und das deiner Frau unterscheiden.
Welche Geräte habt ihr denn genau? Und welche Version von iOS ist jeweils installiert?
Abzeichen
@Superschlumpf Wie haben beide ein iPhone X unter ios 12.4, also im Grunde kein Unterschied.

Mittlerweile stellt sich die Situation aber etwas anders da. Auch bei meiner Frau finden nun ähnliche Aussetzer statt (kein Ton in Spotify bei Verbindung über Airplay). Und bei uns beiden besteht dasselbe Problem nun auch in der Audible App.

Und auch bei der zweiten Box, die ich mir mittlerweile zugelegt habe, besteht dasselbe Problem. Darum habe ich es noch mal mit der festen IP-Adresse für die iPhones und die Sonos Boxen probiert. Aber anschließend war dann überhaupt keine Verbindung mehr über AirPlay möglich, denn die Boxen wurden gar nicht mehr angezeigt auf den Telefonen. Nur ein komplettes Zurücksetzen beider Boxen hat sie dann wieder zum Leben erweckt.
Benutzerebene 7
Abzeichen +3
@arming
Ok, das hört sich nun imo schwer nach einem Netzwerkproblem an, wobei eben immer noch merkwürdig ist, dass NUR Spotify betroffen sein soll. Kannst du zur Sicherheit nochmals andere Streaming-Quellen per Airplay vom iPhone testen?

Und erstelle bitte unbedingt eine aktuelle Diagnose, nachdem Probleme aufgetreten sind.
Die Nummer dann bitte hier mitteilen...
Benutzerebene 7
Abzeichen +3
PS:
Welcher Kanal ist denn aktuell an der Fritzbox für das 2,4 Ghz Wlan eingestellt?
5 Ghz Wlan ist aktiv oder ausgeschaltet?
Abzeichen
HI @Superschlumpf Mittlerweile betrifft es ja auch Audible, hier kann ich auch nicht mehr per AirPlay auf die Sonos Boxen streamen. Das einzige was immer sofort über Airplay funktioniert ist die Youtube App. Bei beiden Sonos Boxen ist es dasselbe Bild.

Eine Diagnose habe ich erstellt, die Bestätigungsnummer ist 1642930886
Abzeichen
und was mir noch auffällt ist, dass immer wenn ich alle Geräte auf feste IPs einstelle (Sonos und iPhone), dann kann ich neben dem fehlenden Ton über Airplay auch über Spotify Connect keine Geräte mehr auswählen, es werden einfach keine angezeigt. Stelle ich dann aber wieder alles
auf dynamische IPs sehe ich alle Geräte sofort wieder in Spotify Connect.

Ich habe jetzt mit dynamischen IPs nochmal eine Diagnose erstellt 1628383499
Benutzerebene 7
Abzeichen +3
@arming
Da du mir zur Frage nach dem aktuellen Wlan Kanal und 5Ghz Netz nichts geantwortet hast, bleibt von meiner Seite nur, das Ergebnis der Diagnose abzuwarten.
Abzeichen
@Superschlumpf Sorry, hatte ich überlesen. Es sind beide aktiv, 5 Ghz ist auf Kanal 100 und 2,5 Ghz auf 8.

Was genau ist denn das jetzt mit der Diagnose? Bekomme ich dann eine Email von Sonos?
Benutzerebene 7
Abzeichen +3
@Superschlumpf Sorry, hatte ich überlesen. Es sind beide aktiv, 5 Ghz ist auf Kanal 100 und 2,5 Ghz auf 8.

Was genau ist denn das jetzt mit der Diagnose? Bekomme ich dann eine Email von Sonos?

Teste für 2,4 Ghz bitte mal Kanal 1 oder 11 und schalte 5 Ghz solange aus. Wie gesagt... nur testweise, um Fehler einzugrenzen.

Zur Diagnose solltest du hier morgen wohl im Laufe des Tages von @Daniel K oder einem anderen Sonos Mitarbeiter ein Feedback bekommen.
Benutzerebene 6
Abzeichen +3
und was mir noch auffällt ist, dass immer wenn ich alle Geräte auf feste IPs einstelle (Sonos und iPhone), dann kann ich neben dem fehlenden Ton über Airplay auch über Spotify Connect keine Geräte mehr auswählen, es werden einfach keine angezeigt. Stelle ich dann aber wieder alles
auf dynamische IPs sehe ich alle Geräte sofort wieder in Spotify Connect.

Ich habe jetzt mit dynamischen IPs nochmal eine Diagnose erstellt 1628383499


Hi,

kannst du mal testweise einen Sonos-Player via LAN mit dem Router verbinden und uns noch eine Diagnose erstellen?
Ein Anruf würde auch Sinn machen, da der Fehler in der Diagnose nicht ersichtlich ist.

Gruß,
Daniel
Abzeichen
@Superschlumpf Es ist echt zum Mäuse melken. Jetzt wo ich 5Ghz ausgeschaltet und den Kanal von 2,4Ghz auf 1 geändert habe, funktioniert AirPlay einwandfrei aber das Verbinden über Spotify Connect mit einer der Boxen geht dann nicht mehr (ich sehe das Gerät über Spotify Connect gar nicht mehr). Das ging vorher durchgängig ohne Probleme.

@Daniel K Danke für deine Hilfe. Ich habe jetzt die eine Sonos Box mal per LAN verbunden (mit o.g. Einstellungen) und eine weitere Analyse gemacht. Die Nummer lautet: 1005208285
Benutzerebene 7
Abzeichen +3
@arming
Du hast jetzt leider gleich mehrere Dinge auf einmal geändert, was es schwierig macht, zu beurteilen, WAS nun WELCHE Änderung bewirkt hat.
Meine Vermutungen...
  • das Airplay Problem könnte damit zusammenhängen, dass es am Router Probleme beim Handshake zwischen 2,4 und 5 Ghz gibt, wenn das iPhone mit 5 Ghz verbunden ist (Sonos ist immer per 2,4 Ghz mit dem Router verbunden; das iPhone wechselt je nach Verbindungsqualität hin und her, wenn der Router beides anbietet). Hier kann ein Kanalwechsel auf 5 Ghz oder das Deaktivieren helfen.
  • dass eine Box per Spotify Connect nun nicht mehr sichtbar ist, kann am Kanalwechsel im 2,4 Ghz Band liegen. Router und Sonosgeräte einfach mal neu starten.
  • Ob der Wechsel ins SonosNet sich nun positiv ausgewirkt hat, ist schwierig zu beurteilen, da du wie gesagt mehrere Dinge geändert hast.
Abzeichen
  • Ob der Wechsel ins SonosNet sich nun positiv ausgewirkt hat, ist schwierig zu beurteilen, da du wie gesagt mehrere Dinge geändert hast.


@Superschlumpf Ist damit der Anschluss über das LAN Kabel gemeint? Das hatte ich nur für die Diagnose gemacht. Aktuell laufen beide Boxen über WLAN und in der FB ist der 5Ghz Kanal weiter ausgeschaltet und der 2,4 GHz Kanal auf “1” eingestellt. Und die Situation ist, dass ich über Airplay nur auf einer Box Ton bekomme und keine der Boxen über Spotify Connect ansprechen kann. Also schlechter als mit aktiviertem 5Ghz 😞
Benutzerebene 7
Abzeichen +3
  • Ob der Wechsel ins SonosNet sich nun positiv ausgewirkt hat, ist schwierig zu beurteilen, da du wie gesagt mehrere Dinge geändert hast.
@Superschlumpf Ist damit der Anschluss über das LAN Kabel gemeint? Das hatte ich nur für die Diagnose gemacht. Aktuell laufen beide Boxen über WLAN und in der FB ist der 5Ghz Kanal weiter ausgeschaltet und der 2,4 GHz Kanal auf “1” eingestellt. Und die Situation ist, dass ich über Airplay nur auf einer Box Ton bekomme und keine der Boxen über Spotify Connect ansprechen kann. Also schlechter als mit aktiviertem 5Ghz :-(

@arming
Ja, im SonosNet sind die Geräte, sobald mindestens eines per Lankabel direkt am Router hängt. Die Wlan Zugangsdaten für das Router Wlan sollten dann aber ebenfalls nach dem Verkabeln über die Einstellungen der Sonos App zurückgesetzt werden, damit sich die Player nicht teilweise doch noch mit dem Wlan des Routers verbinden. Sonst hätte man einen Mischbetrieb. In „über mein Sonossystem“ in den Einstellungen der App kannst du sehen, ob alle Geräte auf WM0 (steht für SonosNet) stehen. WM1 wäre Wlan des Routers...
Eigentlich solltest du mal im SonosNet Airplay testen und dabei eine Diagnose absetzen. Natürlich würde es dann Sinn machen, mal weiter zu testen, ob die Probleme dann verschwinden.
Mit deinem Wlan des Routers scheint imo irgendwas nicht ganz rund zu laufen... evtl. zu schwache Verbindungen... Wenn 5 Ghz ausgeschaltet ist, sollte eigentlich alles per 2,4 Ghz kommunizieren und rund laufen, da du ja keine Repeater, sondern nur den Router einsetzt. Ich kann mir nur vorstellen, dass die Sonosgeräte evtl. am Randbereich des Router Wlans positioniert sind.
Wie auch immer, teste doch mal längere Zeit den Betrieb im SonosNet.
Benutzerebene 7
Abzeichen +3
PS:
Und nur nochmal zur Sicherheit, da es vor einigen Tagen ja mehrere Ratschläge auf einmal waren... 😉
Hast du an der Option „Die unten aufgeführten Geräte dürfen untereinander kommunizieren“ den Haken gesetzt?
https://de.community.sonos.com/installation-und-nutzung-223378/sonos-one-und-airplay-kein-ton-6746605/index2.html#post16067702
(...dritter Screenshot)
Abzeichen
Hast du an der Option „Die unten aufgeführten Geräte dürfen untereinander kommunizieren“ den Haken gesetzt?

Ja das war schon die ganze Zeit aktiv. Ich teste die Tage nochmal alles durch und melde mich dann wieder. Vielen dank für deine unermüdliche Hilfe @Superschlumpf
Benutzerebene 7
Abzeichen +3
@arming
Alles gut... wird schon werden. 😎