Frage

Sonos One mit Apple Music sehr träge


Abzeichen

Hallo ihr,

ich habe seit einiger Zeit das Problem (möglicherweise nach dem letzten großen Update), dass es sehr lange dauert, wenn ich ein Lied über Alexa von Apple Music abspielen möchte. Alexa bestätigt, dass das Lied nun abgespielt wird, aber dann dauert es bis zu fünf Sekunden bis zur Wiedergabe. 
Früher ging das Lied teilweise sogar schon während Alexas Bestätigung an. 
 Was habe ich bereits versucht:

-Sonos per Kabel angeschlossen und eingerichtet

-Netzwerk gecheckt

- Bei Alexa und Apple Music neu eingeloggt

- Serverstatus von Apple und Amazon überprüft

  • Apple Music auf anderen Geräten benutzt (Wiedergabe startet direkt)

 Was kann ich noch tun????

 

 Viele dank!


Sonos One mit 11.0


36 Antworten

@HerrBert, gibt es nur Probleme bei der Steuerung von Apple Music über Alexa? 

Wie betreibst du Sonos jetzt, über WLAN oder ist immer noch eine Komponente mit dem Router verkabelt? Gibt es WLAN-Verstärker (Repeater oder PowerLAN-Adapter)?

Abzeichen

Danke für die Antwort, @Greta A. 
Wählen ich einen Track von Apple Music in der Sonos App aus, dauert es auch recht lang, gefühlt aber etwas kürzer. 
Der Sonos One ist mit dem WLAN des Amplifi HD verbunden, der als Accesspoint einer Fritzbox 6591 dient. Auf der Fritzbox läuft der DHCP Server.
 

Mir kommt gerade in den Sinn, dass circa zeitgleich mit dem Update ein Echo Dot ins Netzwerk gewandert ist, der aber in einem anderen Stockwerk steht. Dürfte eigentlich kein Problem sein, oder? Auf dem läuft es übrigens einwandfrei mit Apple Music. 
Danke für weitere Ideen und Anregungen!     

Gibt es nur den Sonos ONE oder noch weitere Komponenten? Ist das WLAN der Fritzbox ausgeschaltet? Steht der Funkkanal des des Amplifi HD auf Autokanal? Wenn ja, bitte einen festen Kanal zuweisen, indem du die Kanäle 1, 6, 11 durchtestest.

Benutzerebene 6
Abzeichen +3

Hallo ihr,

ich habe seit einiger Zeit das Problem (möglicherweise nach dem letzten großen Update), dass es sehr lange dauert, wenn ich ein Lied über Alexa von Apple Music abspielen möchte. Alexa bestätigt, dass das Lied nun abgespielt wird, aber dann dauert es bis zu fünf Sekunden bis zur Wiedergabe. 
Früher ging das Lied teilweise sogar schon während Alexas Bestätigung an. 
 Was habe ich bereits versucht:

-Sonos per Kabel angeschlossen und eingerichtet

-Netzwerk gecheckt

- Bei Alexa und Apple Music neu eingeloggt

- Serverstatus von Apple und Amazon überprüft

  • Apple Music auf anderen Geräten benutzt (Wiedergabe startet direkt)

 Was kann ich noch tun????

 

 Viele dank!


Sonos One mit 11.0

 

Hallo,

sende uns bitte eine Diagnose (https://support.sonos.com/s/article/141?language=de) kurz nachdem das Problem aufgetreten ist und antworte uns mit der Bestätigungsnummer.

Wir schauen uns das gerne an.

 

Gruß,

Daniel

Abzeichen

Hallo @Daniel K ,

 

 ich habe die Diagnose gesendet: 1425906589

 Vielen Dank! 

Benutzerebene 6
Abzeichen +3

Hallo @Daniel K ,

 

 ich habe die Diagnose gesendet: 1425906589

 Vielen Dank! 

 

Hi,

 

ich sehe so erst einmal nichts, was auffällig ist.

Einige Datenpakete vom AP kommen erst nach mehrmaligen Versuchen an.

Kannst du den Player testweise mal via LAN anschließen und noch einmal testen.

Wie gesagt, das ist nur ein Test.

 

Gruß,

Daniel

Abzeichen

Hallo @Daniel K ,

 

hier der neue Code: 567681430

Gab auch Aussetzer bei der Wiedergabe. Sonos One war nun per Kabel verbunden. 
Vielen Dank für deine Hilfe!

Abzeichen

Sehe gerade, das auch bei der Nutzung von Alexa und Amazon Music diese Denkpausen auftreten.... das war wirklich vorher nicht so 😞 

Benutzerebene 6
Abzeichen +3

Sehe gerade, das auch bei der Nutzung von Alexa und Amazon Music diese Denkpausen auftreten.... das war wirklich vorher nicht so 😞 

 

Bist du dieser Anleitung schon einmal gefolgt?

In den meisten Fällen hilft es, wenn man alles “rausschmeißt” und wieder hinzufügt in der Alexa-App.

Abzeichen

Hallo Daniel,

ja, ich habe alles aus Alexa entfernt und neu eingerichtet. Keine Verbesserung.

Noch einmal kurz zur Einordnung:

Wenn ich Apple Music über die Sonos App starte, dann wird die Verknüpfung von Sonos zu Apple Music genutzt, oder?

Wenn ich Apple Music über einen Alexabefehl starte, wird die Verknüpfung von Amazon Alexa zu Apple Music genutzt, oder?

Ich frage mich das deshalb, da ja der Echo Dot mit dem selben Amazonkonto läuft und blitzschnell reagiert, wenn Apple Music per Sprachbefehl abgerufen wird. Dabei steht er noch viel ungünstiger, was den WLAN Empfang anbelangt.

Irgendwie scheint es mir, als würde der Sonos One zwar die Abfrage über Alexa an Apple schnell verarbeiten, aber die Antwort wird gebremst. 

Der Echo Dot zeigt ja, dass die eigentliche Schnittstelle zwischen meinem Alexakonto und Apple Music nicht gestört ist.

Vielen Dank für weitere Hilfen!

Abzeichen

Hab noch eine Diagnose erstellt. Seit der Firmware 11.0 ist echt der Wurm drin. 

 Habe den One jetzt direkt mit dem WLAN der Fritzbox verbunden und den AmpliFi ausgeschaltet. 
Viele Abbrüche und das Problem mit Apple Music bleibt. 

Hier der neue Code: 2039768502

Guckst du noch einmal rein? 
Vielen Dank!

Abzeichen

Sooooo, ich habe das Problem gelöst:

Für alle, die auch so Probleme mit Firmware 11 haben:

Alle Dienste abmelden und Sonos Gerät zurücksetzen (das alleine hatte ich ja bereits mehrfach ausprobiert). 
Jetzt aber auch die iOS App komplett vom iPhone löschen und neu installieren und den Einrichtungsprozess der Sonos Geräte durchführe (da wird dann auch wieder das Airport Konfigurationsprogramm genutzt. War vorher nicht der Fall). 
 

Jetzt wird nichts mehr verzögert und die Wiedergabe startet direkt!!!
 

Rauscht aber jetzt im Standby 😫

Edit: Kommando zurück. Ein Neustart des Sonos One und alles ist so lahm und buggy wie vorher....

@HerrBert, was hat das Airport-Konfigurationsprogramm mit Sonos zu tun? Ich dachte, du hast eine Fritzbox plus Amplifi HD? Wenn es wieder zu Problemen kommt, ist es wohl das Beste, du wendest dich telefonisch an den Support, der kann sich das mittels Fernwartung ansehen.

 

Deutschland: 0800 627 9990

Österreich: 0800 88 08 58

Schweiz: 0800 45 46 46

 

Montag bis Freitag von 10 bis 18 Uhr erreichbar.

Abzeichen

@HerrBert, was hat das Airport-Konfigurationsprogramm mit Sonos zu tun? Ich dachte, du hast eine Fritzbox plus Amplifi HD? Wenn es wieder zu Problemen kommt, ist es wohl das Beste, du wendest dich telefonisch an den Support, der kann sich das mittels Fernwartung ansehen.

 

Deutschland: 0800 627 9990

Österreich: 0800 88 08 58

Schweiz: 0800 45 46 46

 

Montag bis Freitag von 10 bis 18 Uhr erreichbar.

Ja, ich werde wohl mal anrufen müssen. 
Das Airport Dienstprogramm poppt bei der Einrichtung der Sonos App auf dem iPhone auf und übermittelt das WLAN Passwort an das Sonos One. Vermutlich wird ein Handshake über Bluetooth initiiert. 

Das lese ich zum ersten Mal. Hast du auch einen Airport Express? Der DHCP-Server ist wirklich nur auf der Fritzbox aktiv? Mit welchem WLAN-Router/Access Point soll sich der ONE nun verbinden? Das WLAN der Fritzbox ist ausgeschaltet? Wenn nicht, kann es bei der Netzwerkkonfiguration zu Problemen kommen.

Abzeichen

Das lese ich zum ersten Mal. Hast du auch einen Airport Express? Der DHCP-Server ist wirklich nur auf der Fritzbox aktiv? Mit welchem WLAN-Router/Access Point soll sich der ONE nun verbinden? Das WLAN der Fritzbox ist ausgeschaltet? Wenn nicht, kann es bei der Netzwerkkonfiguration zu Problemen kommen.

 

Ich versuche mich klarer auszudrücken:

Also ich habe eine Fritzbox 6591, deren WLAN deaktiviert ist. An einem LAN Port der Fritzbox hängt der Amplifi HD Router im Bridgemode. Die Fritzbox hat einen aktiven DHCP Server, der Amplifi arbeitet als AP und spannt das WLAN Netz auf.
 

Als ich nun die SONOS App neu installiert habe und der SONOS One gefunden wurde, poppte das AirPort Konfigurationstool auf (oder so ähnlich, auf jeden Fall was mit AirPort). Dieses Tool hat dann das WLAN Passwort an den SONOS One übertragen. Somit ist dieser Schritt, in dem der One kurzzeitig ein eigenes Netz aufbaut, übersprungen worden.

Mittlerweile wird es aber deutlicher, dass der Amplifi im Bridgemode die Probleme verursacht. 

Lese da gerade viele Posts, in denen der Amplifi Probleme macht:

https://en.community.sonos.com/troubleshooting-228999/amplifi-hd-bridge-compatibility-with-sonos-6787075

https://en.community.sonos.com/troubleshooting-228999/ubiquiti-amplifi-hd-6820103

 

https://community.amplifi.com/topic/1379/sonos-and-amplifi-in-bridge-mode

 

 

Ich habe einen ähnlichen Aufbau, allerdings befindet sich bei mir der Provider-Router im Bridgemodus. Eine Fritzbox 4040 dient jetzt als WLAN-Router, wodurch sich die IP-Adressen von 192.168.0.x auf 192.168.178.x geändert haben und sämtliche netzwerkfähigen Geräte (einschl. Sonos) befinden sich im Subnetz der Fritzbox. Dafür musste ich alle Geräte vom Strom nehmen (Mobilgeräte ausschalten), nachdem ich die Fritzbox aufgestellt und eingerichtet hatte.

 

Ich schlage vor, du nimmst alles vom Netz und vergewisserst dich, dass der Amplifi HD richtig mit der Fritzbox konfiguriert ist.

Abzeichen

Leider kann ich die FritzBox 6591 nicht in den Bridge Mode versetzen. Beim Vorgängermodell 6490 konnte man durch eine Trick den BridgeMode aktivieren, und den Amplifi DHCP SERVER nutzen. Bei der neueren geht das leider nicht mehr. Da wir Gigabit Cable haben und ich weitere AVM Produkte besitze muss die 6591 im Setup bleiben. Nur das WLAN ist halt beim Amplifi HD eigentlich besser.

Bekloppt alles. Dachte, wenn ich den Router als AP betreibe, dürfte es keinerlei Probleme geben.

 

Eigentlich habe ich beim Provider-Router nur das WLAN (2.4 GHz & 5 GHz) ausgeschaltet und ihn mit dem WAN-Port der Fritzbox verbunden (wäre bei deiner Fritzbox "Internetzugang über 'LAN 1'", sofern die Option vorhanden ist). Als DHCP-Server agiert immer noch der Provider-Router, das habe ich dadurch festgestellt, dass ich keinen Internetzugang mehr hatte, als ich den Server ausschaltete. Ich musste den Provider anrufen, der aus der Ferne den Router zurückgesetzt hat, da ich selbst keinen Zugriff mehr auf die Einstellungen hatte.

 

FRITZ!Box für Betrieb mit anderem Router einrichten

Abzeichen

Eigentlich habe ich beim Provider-Router nur das WLAN (2.4 GHz & 5 GHz) ausgeschaltet und ihn mit dem WAN-Port der Fritzbox verbunden (wäre bei deiner Fritzbox "Internetzugang über 'LAN 1'", sofern die Option vorhanden ist). Als DHCP-Server agiert immer noch der Provider-Router, das habe ich dadurch festgestellt, dass ich keinen Internetzugang mehr hatte, als ich den Server ausschaltete. Ich musste den Provider anrufen, der aus der Ferne den Router zurückgesetzt hat, da ich selbst keinen Zugriff mehr auf die Einstellungen hatte.

 

FRITZ!Box für Betrieb mit anderem Router einrichten

Dann hast du möglicherweise ein doppeltes NAT. Das kann auch zu Problemen führen.

 

Ich verstehe gerade einfach nicht, warum kein Gerät bei meiner Netzwerkkonfiguration ein Problem hat, bis auf die Sonos Geräte.

Was kann denn ein Router, der nur als AP fungiert, also kein Routing vornimmt, so falsch machen, dass der Sonos One damit so ein Problem hat?

Muss jetzt überlegen, ob ich den One rausschmeiße, oder den Amplifi…..dann brauche ich aber einen AVM Repeater (3000 als Meshpoint).

@HerrBert, bitte nicht. Mit einem Repeater kommst du vom Regen in die Traufe. Nur der Support wird dir sicher sagen können, warum es mit dem Amplifi HD nicht klappt. Ubiquiti Unifi APs machen dagegen weniger Ärger, obwohl WLAN-Meshs im Zusammenhang mit Sonos auch ein mehr oder weniger schwieriges Thema sind. Ein Multiroomsystem ist eben ‘ne Diva.

Nachtrag: Habe gerade nachgeschaut, Im Gegensatz zu dem Technicolor-Router meines Kabelproviders steht der Amplifi HD nicht auf der Liste der Inkompatiblen Hardware.

Abzeichen

So, ich habe zwei sehr nette Gespräche mit dem Sonos Support gehabt und auch den Support von AVM genutzt:

Mittlerweile ist es nämlich noch skurriler:
Ich habe alle Störquellen aus dem Netzwerk entfernt, sprich, nur noch Fritzbox und Sonos One angeschlossen.
Nun ist es aber so, dass ich die oben genannten Probleme nur habe, wenn ich den Sonos One kabelgebunden betreibe. Betreibe ich den Sonos im WLAN Modus habe ich keinerlei Probleme und keine Pausen oder Aussetzer.

Ich habe folgendes gemacht:

  • Kabel getauscht
  • Lan Buchse an der Fritzbox gewechselt
  • Sonos einmal aktiv kabelgebunden eingerichtet, und einmal über WLAN eingerichtet.
  • Alle Geräte neugestartet
  • (sogar Wlan Channel gewechselt, obwohl in dem Setup die Verbindung ja nicht aktiv genutzt wird → Fritzbox Channel 11, Sonos auf 1)

Das Problem ist reproduzierbar. Ich vermute nun, dass mein Ursprungsproblem daher kommt, dass ja auch der Amplifi per LAN an der Fritzbox angeschlossen ist.

Beide Supportteams, Sonos und AVM, wissen nicht weiter. An AVM werde ich ein erweitertes Protokoll schicken, in dem beide Szenarien einmal vorkommen.

Es ist echt verrückt. Vielleicht hat ja noch jemand eine Idee!? Es wäre toll. Danke.

Mittlerweile ist es nämlich noch skurriler:
Ich habe alle Störquellen aus dem Netzwerk entfernt, sprich, nur noch Fritzbox und Sonos One angeschlossen.
Nun ist es aber so, dass ich die oben genannten Probleme nur habe, wenn ich den Sonos One kabelgebunden betreibe. Betreibe ich den Sonos im WLAN Modus habe ich keinerlei Probleme und keine Pausen oder Aussetzer.

 

Wenn ich es richtig verstanden habe, gibt es nur den ONE und keine weiteren Sonoskomponenten. Da ist es kein Problem, ihn über WLAN zu betreiben. Sollten später weitere Komponenten dazu kommen, sehen wir weiter.

 

Die verkabelte Komponente dient als LAN/WLAN-Brücke (als Systemchef ; wie das System dies löst, wenn es nur einen Player gibt, weiß ich nicht), die Fritzbox hat eigentlich kein Problem damit, wenn der ONE mit ihr verkabelt ist und soweit ich verstanden habe, wurde der ONE nicht mit dem Amplifi HD per Ethernet verbunden. Es gibt nämlich Router, die mit einer Netzwerkbrücke nicht zurechtkommen.

 

Sobald man eine Komponente verkabelt, sollte man auch die WLAN-Zugangsdaten aus dem System entfernen. Sonos Controller-App für iOS oder Android: Tippe in der Sonosapp unter Einstellungen auf System > Netzwerk > Netzwerke. Wähle das WLAN-Netzwerk aus, das du entfernen möchtest und tippe auf Entfernen. Mindestens 10 Min. warten, danach überprüfen, ob in der Sonosapp unter 'Einstellungen --> System --> Über mein Sonos-System' neben jedem Player WM:0 steht; dann befindet sich das System im SonosNet.

Abzeichen

Danke für deine Antwort. 
Ich möchte natürlich langfristig wieder mein Amplifi System nutzen. Der Test mit dem Fritzbox-Wlan war nur zur Eingrenzung der Fehlerquelle gedacht. Ich hab auch noch ein IKEA Lautsprecher, aber den habe ich testweise auch aus dem Sonos System entfernt → Fehler eingrenzen.
Es wird auch in “Über mein System” jeweils die richtige Verbindungsart angezeigt.

Ich habe also weiterhin das Problem, dass ich einen per LAN Kabel angeschlossenen AP nicht richtig mit Sonos nutzen kann und auch eine direkte Verbindung per LAN Kabel mit der Fritzbox zu denselben Problemen führt. Ich verstehe es einfach nicht. Es gibt keinerlei Fehlermeldungen. 

 

Antworten