Frage

Sonos + Fritz NAS Zugriff (USB)



Ersten Beitrag anzeigen
Dieser Beitrag ist geschlossen für weitere Beiträge

62 Antworten

Abzeichen
So, leider bin ich nicht weitergekommen. Unter Netzwerk sieht das ganze bei mir so aus. Da sind allerhand Fritzbox-Links eingetragen, diese verweisen allesamt auf fritz.box - aber nicht auf die NAS direkt.

Die Fritzbox ist als fritz.nas in der Arbeitsgruppe "workgroup" konfiguriert....

Habt ihr eine Idee, wo der Konfigurationsfehler liegen könnte - wenn es denn einen gibt?
Versuch mal den folgenden für WIN 10 genannten Verbindungsweg:

Speicher (NAS) am Computer als Netzlaufwerk einrichten Ist zwar für eine 7390 beschrieben, funktioniert aber wohl für all FB Varianten!
Abzeichen
Ja, klar das tut - wie oben schon beschrieben komm ich da sauber drauf und kann ein Laufwerk z.B. Z:\ verknüpfen. Im Explorer sehe ich das dann auch und kann voll mit Lese-/Schreibzugriff drauf zugreifen.

Das nützt mir aber für die Einrichtung der Musikbibliothek leider nichts, selbst wenn ich hier auf das LW und den Ordner Music gehe kommt es zur Fehlermeldung, s. Screenshot.

So langsam bin ich mit meinem Latein am Ende, woran es hängt....
Wenn Du im Dateibrowser links in der Menüleiste auf Netzwerk klickst, ist denn dort fritz.box aufgeführt?
Abzeichen +1
Was bekommst du denn als Fehlermeldung angezeigt, wenn du die FritzNas als NAS zu Sonos hinzufügen willst? Ich meine, es ist ja jetzt keine große Kunst, die NAS hinzuzufügen, da muss doch irgendwas grundlegend falsch sein.

Ob Windows die FritzNas sieht, ist übrigens nicht wichtig.
Die Fehlermeldung hat er über meinem letzten Post als Anhang geliefert. Da er das NAS mit dem Desktop Controller hinzufügen möchte muss er sie dort schon sehen, aber aus welchem Grund auch immer kann er das im Moment nicht!
Abzeichen
Wenn Du im Dateibrowser links in der Menüleiste auf Netzwerk klickst, ist denn dort fritz.box aufgeführt?

Nein, da fehlt sie auch...Hab jetzt an anderen Rechnern im Netzwerk (u.a. noch mit Win7) probiert, die kommt nirgends im Browser :-(

Vielleicht muss ich dochmal einen Werksreset machen an der Box und alles neu initialisieren lassen...
Benutzerebene 6
Abzeichen +3
Hallo,

eventuell wäre es am einfachsten uns einmal telefonisch zu kontaktieren, die Kollegen können durch eine Remoteverbindung einmal auf die Fritz.Box schauen.

Wenn Windows die NAS nicht sieht, wird Sonos sie auch nicht sehen, Grund hierfür ist dass das Windows Freigabeprotokoll SMB(CIFS) verwendet wird, es sei denn im Windows OS wurden alle Freigabe/Sharingeinstellungen abgeschaltet.

Befindet sich etwas zwischen der Fritz.Box und den restlichen Klienten wie PC und Sonos, es scheint als ob die Daten unterwegs verloren oder herausgefiltert werden, wenn wir annehmen das es nicht an der Fritz.Box selber liegt.

Gruss,
Moritz
Abzeichen
Die Annahme ist korrekt, das Sonos Play 1 hängt per WLAN an einem Buffalo Access Point, die Klienten hängen an einer zweiten Fritzbox 7170, die als Router konfiguriert ist. Innerhalb der Arbeitsgruppe kann ich von einem Rechner auf die anderen zugreifen - das funktioniert alles.

Für die blosse EINRICHTUNG des Pfades der Musikbibliothek sollte doch aber eigentlich vollkommen egal sein, wo das Sonos im Netzwerk eingehängt ist, oder? Theoretisch müsste das doch sogar funktionieren, wenn gar keine Sonos-Hardware im Netzwerk ist, oder?

Die Freigabe/Sharingeinstellungen sind systemseitig nicht abgeschaltet, das sollte passen.

Werde mich telefonisch an den Support wenden, danke einstweilen.
Abzeichen
So wirklich weiter bin ich nicht gekommen. Habe jetzt in einem anderen Forum noch den Tipp bekommen, dass die NAS dann angezeigt wird wie unten im Screenshot, wenn ich einfach vorher \\fritz.box in der Eingabeaufforderung eingebe - und tatsächlich, danach wird sie angezeigt und ich kann auch aus dem Explorer direkt darauf zugreifen - ganz ohne Eingabe von Benutzer/Passwort... Beim nächsten Rechner-Neustart fehlt sie aber wieder - irgendwie reichlich komisch das ganze...

Das ändert aber nichts daran, dass SONOS immer noch nix findet...

Gibt's noch Ideen?
Benutzerebene 7
Abzeichen +3
Hast du sie denn nun mal hinzugefügt, nachdem du sie im Browser findest?
Abzeichen
Hast du sie denn nun mal hinzugefügt, nachdem du sie im Browser findest?

...wie oben schon erwähnt - die Oberfläche der SONOS findet sie nachwievon nicht über "Suchen...". Sie wird wirklich nur im Browser angezeigt wenn ich in der Liste links das NETZWERK aufklappe über ">" - ich habe keine Ahnung, woran es hängt...
Benutzerebene 6
Abzeichen +3
Ich empfehle uns einmal telefonisch zu kontaktieren, sonos.com/contact.
Abzeichen
So, Update zu meinem Problem:

Ich hab jetzt die Fritzbox, an der die NAS hängt, nochmal 10 Minuten stromlos gemacht. Danach lief jetzt alles! NAS wird sauber über die SONOS-Oberfläche erkannt und verbunden!

Danke allen für die tatkräftige Unterstützung!

Gruß, Thomas
Benutzerebene 7
Abzeichen +3
Dann veil Spass damit!
Im Anhang mal meine Konfigs in der Fritzbox, sollte so bei dir etwa auch aussehen!





Vielen Dank Savalas! Damit bin ich super klar gekommen.
Bitte, gerne doch!

Weiterhin viel Spaß mit Deinem Sonos!

Grüße,

Gernot
Abzeichen +1
Hallo auch,
bin auch gerade dabei meine Fritzbox als Sonos-NAS einzurichten.
Leider habe ich auch den Fehler gemacht den Ordnerpfad in der Sonoskonfig über den Explorer mit "durchsuchen" zu finden/übernehmen.
Habe zwar über den Explorer Verbindung auf den Ordner Musik bekommen aber nicht im Sonos.
Eigentlich ist es gans einfach aber doch etwas seltsam.
OK, die Einrichtung in der Fritzbox haben wir ja schon oben gelesen.
Ich habe mir extra einen Benutzer Sonos mit Passwort erstellt und diesen nur auf dem Ordner Musik Rechte erteilt.
Dann im Totalcommander den Netztwerkpfad gesucht und in die Zwischenablage kopiert (man kann es auch manuell eintragen).
Diesen Pfad dann in die Zeile in der Sonoskonfig übertragen.
Dann dauert es kurz und es steht dann der Pfad nicht mit "\" sondern "/" klingt komisch ist aber so.
Jetzt klappts auch im Sonos mit dem Ordnerpfad und Freigabe:
Abzeichen
Hallo auch,
bin auch gerade dabei meine Fritzbox als Sonos-NAS einzurichten.

Diesen Pfad dann in die Zeile in der Sonoskonfig übertragen.
Dann dauert es kurz und es steht dann der Pfad nicht mit "\" sondern "/" klingt komisch ist aber so.
Jetzt klappts auch im Sonos mit dem Ordnerpfad und Freigabe:


Leider habe ich trotzdem das Problem mit fritz.nas geht es nichts. Meine Box ist auf Firmware 6.50 also kein telnetd zum ändern der Freigabe.
Hat unser lieber SONOS support da nicht eine idee wie wir normalen Fritz!Box user diese als Musik Laufwerk verbinden können.
Abzeichen +1
Hi,
was geht denn nicht.
Schon mal oben alles gelesen? Müßte auch mit 6.50 gehen.
Kommst du mit dem Win-Explorer auf deine Freigabe auf Fritzbox?
Abzeichen
Connection vom PC auf die Fritz Box geht.
Copy Paste von \\Fritz.box\Fritz.nas\Musik in die Sonos APP bringt
Keine Ordnerfreigabe Fritz.nas

Mediaserver aktiv ist gesetz obwohl ich das nicht so verstehe was das mit einem SMB Share zu tun hat.

Danke
Abzeichen +1
Genau das mit dem Mediaserver habe ich auch nicht begriffen, muß aber aktiviert sein.
Muss gehen
Hallo,

hilft diese Anleitung weiter?

Einrichtung des NAS:
Die Einrichtung bzw. Integration des Fritz-NAS in die Songs war problematischer, da ich Probleme hatte das NAS mit der Songs zu koppeln.
Die Funktion hier heißt "Musikbibliothek".
Das Hinzufügen machte ständig Probleme und wollte nicht klappen.

Für mich nun folgender Lösungsansatz, der bei mir funktionierte.
Unter den Einstellungen-Heimnet-NAS habe ich den Netzwerkfreigabenamen von FRITZ.NAS in FRITZNAS (also ohne Punkt) geändert. Da gibt es wohl ein bekanntes Problem zwischen beiden Herstellern.
Um in der Sonos App Musikbibliothek hinzuzufügen benötigt man nun eine Adresse zu dem NAS-Speicher. Diese wäre nun //fritz.box/FRITZNAS

Die Sonos App wird jetzt noch einen Benutzer und ein Passwort verlangen.
Dabei handelt es sich um einen Fritzbox Benutzer.
Ein solcher Benutzer ist in der Fritzbox unter dem Reiter "System- Fritzbox-Benutzer" zu finden / einzurichten.
In den Benutzereinstellungen ist entsprechend auch der Zugang zu NAS-Inhalten sowie der Ordner anzugeben.
Ist das geschehen, können die Nutzerdaten in der Songs-App eingegeben werden und das NAS-Laufwerk verbindet sich mit der Songs-App.


Gruß,
Peri
Abzeichen +1
Hast du vielleicht irgendwelche sonderzeichen in den Netzwerknamen, Usernamen, Passwörtern o.ä. - habe schon die dollsten sachen erlebt.