Frage

Sonos Audiowiedergabe stockt


Abzeichen
Hallo,

folgendes Problem:
Ich habe ein Play:5 gen2 Stereopaar und einen Play:1.

Auf beiden Geräten stockt häufig die Radiowiedergabe. Im Falle des Stereopaars synchron auf beiden Boxen.
Außerdem gibt's fast immer Stocken, wenn ich am Play:1 Radio und auf den Play:5 Musik über Airplay 2 streame.
Alles hängt per WLAN an einer FritzBox. Die WLAN Verbindung ist eigentlich super.

Die Diagnosenummer lautet 1637846921.

Wäre super, wenn mir da jemand einen Tip geben könnte!

Viele Grüße
Peter

24 Antworten

Gibt es zur Fritzbox auch einen Fritzrepeater?
Abzeichen
Nein, das WLAN wird direkt von der FritzBox im nächsten Raum aufgespannt.. Laut Fritz-App ist das WLAN am Ort der Sonos Boxen recht gut (100Mbit/s).
Die Geschwindigkeit des WLANs ist irrelevant. Ein Multiroomsystem stellt andere Anforderungen als ein Einzelgerät, das sich z.B. nicht mit sich selbst gruppieren kann und auch nicht mit sich selbst synchron spielen muss.Befrage die Fritz-App lieber, welcher der Kanäle 1,6,11 am Ort der Sonos Boxen gerade nicht übervölkert ist und stelle den Funkkanal entsprechend ein.
Abzeichen
Danke für deine Antwort!
Aber bedeutet das, dass ich immer wenn die Wiedergabe stockt schauen muss, welchen Kanal die Nachbarn gerade nicht verwenden um dann meine Fritzbox manuell auf diesen Kanal zu stellen?

Viele Grüße
Peter
Danke für deine Antwort!
Aber bedeutet das, dass ich immer wenn die Wiedergabe stockt schauen muss, welchen Kanal die Nachbarn gerade nicht verwenden um dann meine Fritzbox manuell auf diesen Kanal zu stellen?

Womöglich. Oder Du verkabelst einen Player dauerhaft mit dem Router und betreibst das System im sog. SonosNet. In dem Fall bitte anschließend das WLAN-Kennwort wie folgt zurücksetzen:

Sonos Controller-App für iOS oder Android: „Einstellungen“ --> „Erweiterte Einstellungen“ --> „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.


Gruß,
Peri
Abzeichen
Danke für deinen Tip, aber gibt es da nicht noch eine andere Möglichkeit?
Es muss doch möglich sein, ein WLAN-Lautsprechersystem über WLAN zu betreiben, ohne permanent manuell die Kanäle nachzujustieren?!
Benutzerebene 6
Abzeichen +3
Hallo,

folgendes Problem:
Ich habe ein Play:5 gen2 Stereopaar und einen Play:1.

Auf beiden Geräten stockt häufig die Radiowiedergabe. Im Falle des Stereopaars synchron auf beiden Boxen.
Außerdem gibt's fast immer Stocken, wenn ich am Play:1 Radio und auf den Play:5 Musik über Airplay 2 streame.
Alles hängt per WLAN an einer FritzBox. Die WLAN Verbindung ist eigentlich super.

Die Diagnosenummer lautet 1637846921.

Wäre super, wenn mir da jemand einen Tip geben könnte!

Viele Grüße
Peter


Hallo Peter,

bitte schließe testweise einen Lautsprecher via LAN an und starte die Wiedergabe.
Beschreibe uns dann auch, ob das Problem dann auch auftritt.
Das hilft, um die Ursache eingrenzen zu können.

Gruß,
Daniel
Abzeichen
Wenn ich den Lautsprecher über LAN betreibe scheint es das Problem nicht zu geben.

Viele Grüße
Felix
Wenn ich den Lautsprecher über LAN betreibe scheint es das Problem nicht zu geben.

Viele Grüße
Felix

Hast Du die Möglichkeit, den linken Play:5 dauerhaft mit der Fritzbox zu verkabeln? In dem Fall bitte anschließend das WLAN-Kennwort wie folgt zurücksetzen:

Sonos Controller-App für iOS oder Android: „Einstellungen“ --> „Erweiterte Einstellungen“ --> „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.


Gruß,
Peri

P.S. Für Fälle, wo kein Player mit dem Router verkabelt werden kann, wurde der Boost konzipiert.

https://www.sonos.com/de-de/shop/boost.html
Benutzerebene 6
Abzeichen +3
Wenn ich den Lautsprecher über LAN betreibe scheint es das Problem nicht zu geben.

Viele Grüße
Felix


Kannst du von diesem Versuch noch eine Diagnosenummer erstellen und hier posten?
Abzeichen
Hallo!

Also herzlichen Dank erstmal an alle für eure Tips! Ich habe mir jetzt auf euer Anraten einen Sonos BOOST zugelegt, ihn per LAN mit meiner Fritzbox verbunden und die Wifi-Einstellung in der SONOS-App zurückgesetzt. Und siehe da, das Streamen von Inhalten über die SONOS-App funktioniert seit zwei Woche ohne Probleme!

Leider ist ein anderes, gravierendes Problem aufgetreten: AirPlay funktioniert nicht mehr. Verbinde ich ein Gerät über Airplay, bricht nach etwa 1-2 Minuten die Wiedergabe ab. (Es kommt kein Ton mehr, mein iPhone zeigt aber zunächst noch an, dass die Musik weiter abgespielt wird). Nach Trennen und neuem Verbinden von Airplay funktioniert die Wiedergabe manchmal wieder für ein paar Sekunden. Nach ein paar Minuten erstreckt sich der ausgelöste Fehler auf das Gesamte Netzwerk, das heißt ich kann dann von keinem über Wifi verbundenen Gerät mehr ins Internet bis ich die Airplay-Wiedergabe beendet und einige Minuten gewertet habe. Das geht so weit, dass selbst die Fritzbox Benutzeroberfläche nicht mehr aufrufbar ist.

Das ist eigentlich fast nerviger als der ursprüngliche Fehler, weil die Benutzung von Apple Music über die SONOS-App deutlich umständlicher ist als die Musik direkt aus der Music App zu streamen.

Wäre nett, wenn mir da jemand einen Hinweis geben könnte. Ich hab heute schon überlegt ob ich einfach mal alle Komponenten auf Werkseinstellungen zurücksetzen und von vorne neu konfigurieren sollte, aber der SONOS-Support rät davon ab..

Viele Grüße
Peter
Das iPhone einmal neu zu starten, ist ein Hinweis.
Abzeichen
danke für den Tip, hat aber nichts gebracht. Der Fehler ist auch mit mehreren Geräten reproduzierbar..
danke für den Tip, hat aber nichts gebracht. Der Fehler ist auch mit mehreren Geräten reproduzierbar..
Die Sonos-Player sind reine Ausgabegeräte, Airplay spielt sich vollständig auf iOS-/macOS-Ebene ab.
Du kannst zwar das nächste Mal innerhalb von 15 Min. eine Diagnose (Link) absetzen und hier mit der Bestätigungsnummer antworten, ob Dir ein Techniker jedoch weiterhelfen kann, muss sich erst herausstellen.


Das Einzige, was mir von Sonos' Seite noch einfällt: Ändere bitte unter Auf iOS oder Android: „Mehr“ --> „Erweiterte Einstellungen“ --> „SonosNet-Kanal“ auf 1,6,11 und entsprechend dazu den WLAN-Kanal des Routers. Heißt, teste folgende Kanalkombinationen durch: 1/6 bzw. 6/1, 6/11 bzw. 11/6, 11/1 bzw. 1/11. Verstehst Du, was ich meine?
Benutzerebene 6
Abzeichen +3
@Peter
Wie ist denn dein Apple-Gerät, von dem aus du den Airplay Stream sendest, mit dem Router verbunden? 2,4 Ghz Wlan oder 5 Ghz Wlan?
Gruß,
Ralf
Abzeichen
Hallo,

ich noch nicht dazu gekommen alle Kombinationen ausprobieren, aber ich hab schon vorher versucht das Sonos System auf den am wenigsten belegten Kanal und die Fritizbox auf einen weit entfernten Kanal zu legen, und auch das hat keine Besserung gebracht.

Die Diagnosenummer lautet 975081112.

Viele Grüße
Peter
Abzeichen
@Peter
Wie ist denn dein Apple-Gerät, von dem aus du den Airplay Stream sendest, mit dem Router verbunden? 2,4 Ghz Wlan oder 5 Ghz Wlan?
Gruß,
Ralf


Meine Fritzbox kann leider nur 2,4 GHz Wlan..
Benutzerebene 6
Abzeichen +3
@Peter
Wie ist denn dein Apple-Gerät, von dem aus du den Airplay Stream sendest, mit dem Router verbunden? 2,4 Ghz Wlan oder 5 Ghz Wlan?
Gruß,
Ralf


Meine Fritzbox kann leider nur 2,4 GHz Wlan..

Ist ja nicht tragisch... und in deinem Fall eine Fehlerquelle weniger. ;)
Dann bleibt dir nur, die genannten Kanalkombinationen durchzutesten.
Ich vermute, dass der Airplaystream bereits auf dem Weg zum Router gestört wird.
Hi Peter_H,
ich kenne mich zwar nicht mit iOS und AirPlay aus, aber Deinen Schilderungen zu Folge tippe ich mal darauf, dass Dein gesamtes Netz mit Muticast-Paketen geflutet wir.
- zumindest liegt diese Vermutung Deinem Einsatzszenario nach recht nahe.

Hast Du ggf. neben der Fritte noch einen (oder auch mehrere) kleine Desktop-Switches im Einsatz, welche NICHT IGMPv3 und IGMP-Snooping-fähig sind ?
- wenn ja, dann nimm den (oder die) mal testweise außer Betrieb und versuch es danach nochmals mit einem Airplay-Stream.
Benutzerebene 6
Abzeichen +3
Also die Diagnose zeigt, dass auch einige Sonos-Geräte die IP-Adresse verlieren.
Irgendetwas stimmt da nicht.
Liebes Sonos-Team,

ich habe ein ähnliches Problem - Sonos stottert im Spotifybetrieb. Der Betrieb über TuneIn zum Radiohörern funktioniert. Das System läuft seit über einem Jahr. Es gab keine Veränderung außer den Updates von Sonos. Das Stottern haben wir seit ca. einer Woche. Eine Play 3 läuft über LAN, alle Anderen über WLAN.

Die Diagnosenummer lautet: 390170914

Vielen Dank im voraus
Dominik
Benutzerebene 6
Abzeichen +3
Liebes Sonos-Team,

ich habe ein ähnliches Problem - Sonos stottert im Spotifybetrieb. Der Betrieb über TuneIn zum Radiohörern funktioniert. Das System läuft seit über einem Jahr. Es gab keine Veränderung außer den Updates von Sonos. Das Stottern haben wir seit ca. einer Woche. Eine Play 3 läuft über LAN, alle Anderen über WLAN.

Die Diagnosenummer lautet: 390170914

Vielen Dank im voraus
Dominik


Hallo Dominik,

ich sehe, dass du eine Fritzbox nutzt und Devolo.
Kannst du uns deinen Netzwerkaufbau beschreiben?

Gruß,
Daniel
Hallo Daniel,

danke für Deine Antwort. Die Fritzbox speist über LAN auf Devolo Pro 1200 DIN Rail (3-phasige Aufteilung im Hauptverteiler), WLAN bei der Fritzbox ist a.B. Ich benutze 7 (verschiedene) Devolo DLAN-Adapter im gesamten Haus. Diese Arbeiten auf unterschiedlichen Kanälen, hier habe ich lange dran getüftelt. Hintergrund ist WLAN Rooming und Interferenzvermeidung. Sonos lief damit seit ca. einem Jahr mehr oder weniger reibungslos, habe 8 Boxen (Play1 u. 3) im Haus verteilt.

Lösung:
Ich habe gestern zunächst die Fritzbox neu gestartet und anschließend die Devolo Einspeisung zurückgesetzt. Sonos ruckelte mit Spotify nach wie vor. Dann habe ich alle DLAN-Devoloadapter gezogen und eingesteckt - seit dem ist Ruhe. Ich gehe davon aus, das sich ein Adapter aufgehängt hat (es war bei einem Adapter keine LED-Rückmeldung aktiv) und dadurch wurde mein Netzwerk warum auch immer für Sonos gestört.

Vielen Dank und viele Grüße
Dominik
Benutzerebene 6
Abzeichen +3
Hallo Daniel,

danke für Deine Antwort. Die Fritzbox speist über LAN auf Devolo Pro 1200 DIN Rail (3-phasige Aufteilung im Hauptverteiler), WLAN bei der Fritzbox ist a.B. Ich benutze 7 (verschiedene) Devolo DLAN-Adapter im gesamten Haus. Diese Arbeiten auf unterschiedlichen Kanälen, hier habe ich lange dran getüftelt. Hintergrund ist WLAN Rooming und Interferenzvermeidung. Sonos lief damit seit ca. einem Jahr mehr oder weniger reibungslos, habe 8 Boxen (Play1 u. 3) im Haus verteilt.

Lösung:
Ich habe gestern zunächst die Fritzbox neu gestartet und anschließend die Devolo Einspeisung zurückgesetzt. Sonos ruckelte mit Spotify nach wie vor. Dann habe ich alle DLAN-Devoloadapter gezogen und eingesteckt - seit dem ist Ruhe. Ich gehe davon aus, das sich ein Adapter aufgehängt hat (es war bei einem Adapter keine LED-Rückmeldung aktiv) und dadurch wurde mein Netzwerk warum auch immer für Sonos gestört.

Vielen Dank und viele Grüße
Dominik


Danke für deine Rückmeldung.

Antworten