Frage

Probleme mit Sonos und der Horizont Box


Abzeichen
Hallo,
Ich habe gestern mein Sonos system ( Boost ,Play 1&3) auf Werkseinstellung zurückgesetzt da mein System nicht mehr gefunden wurde. Boost ist direkt an der Horizon Box per Kabel angeschlossen. Es hat alles gut funktioniert und alles Controller haben das System gefunden.
Heute habe ich wieder das gleiche Problem, dass das System nicht gefunden wird.

Woran kann das liegen? Wer hat ähnliche Probleme?

Ich bin etwas ratlos und würde mich über Lösungsvorschläge sehr freuen.

Herzliche Grüße

24 Antworten

Servus Ghotmog,

...gleich mal als Erstes, das zurücksetzen des Systems auf Werkseinstellung bringt nur selten etwas, außer den Verlust ALLER Einstellungen Playlisten usw.! Dies sollte man eigentlich nur tun, wenn man vom Support dazu aufgefordert wird.

Nun zu Deinem Problem, schau Dir mal Deine WLAN Umgebung an (Ich nutze unter Android die WiFi Analyzer App dazu). Vielleicht hat Dein Nachbar den selben WLAN Kanal wie Dein SONOS, oder vielleicht auch Dein eigener Router!? Trenne die Kanäle von einander. Die besten Kanäle sind 1,6 und 11. Diese werden auch von SONOS zur Verfügung gestellt.

Auch ein IP Adressenkonflikt könnte die Ursache für Dein Problem sein und ließe sich durch einen Netzwerkneustart beheben.
Abzeichen
Wie kann ich denn Kanäle zuordnen? Damit kenne ich mich leider gar nicht aus
In der Android App unter Einstellungen - Erweiterte Einstellungen - SnosNet-Kanal.
Abzeichen
Ok der Neustart hat des Routers hat geholfen. Allerdings hat er nur die Boots gefunden. Die Player musste ich vm Strom nehmen. Dann waren auch sie wieder zu sehen. Trotzdem seltsam, dass es so instabil geworden ist.
Benutzerebene 6
Abzeichen +3
Das kann schon an einer Änderung am Netzwerk in deiner Nachbarschaft liegen.
Ist halt Funk.
Also, auch wenn es lästig ist, bei einem Netzwerkneustart solltest Du ALLE Geräte, die eine IP von Deinem Router erhalten anständig ausschalten oder herunterfahren, einschließlich Deinem Router. Danach startest Du in folgender Reihenfolge neu:

Router
Kabelgebundenes SONOS
Schnurlose SONOS
Danach den Rest

Immer warten bis das jeweilige Gerät fertig gebootet hat. Wenn dann alles rund läuft, kannst Du schauen, ob man in Deinem Router diese nun frisch und neu vergebenen IPs reservieren kann. Dann kann es nicht erneut zu solch einem IP Konflikt kommen.
Warum kommt es zu solch einem Konflikt? Durch Updates des Routers oder von SONOS kann es zu doppelt vergebenen IP Adressen kommen.
Abzeichen +1
Guten Abend in die Runde. Ich muss leider diesen Horizon-Fred wieder hochschieben :-)
Seit einiger Zeit kommt es bei mir vor, dass sich meine Gruppe auflöst. Und ich vermute, dass dies an meinem Horizon-Router liegt. Nun kann ich nicht erkennen ob das Problem eine Sache der Einstellung ist oder dies "adhoc" passiert. Mein Setup ist wie folgt:

Play 3 mit Netzwerkkabel am Modem/Router
Play 1 in selbem Raum
Play 1 in anderem Raum

Ist es eigentlich normal, dass nicht die Box, die per Netzwerkkabel angeschlossen ist, als verknüpfter ZP fungiert?

Vielen Dank für Eure Hilfe
Abzeichen +1
Niemand?
Benutzerebene 6
Abzeichen +3
Hi,
verknüpfter ZP ist die PLAY, die zuerst eingerichtet wurde.
Egal ob Kabel oder nicht.
Schaltet sich dein Netzwerk Nachts aus?
Gruß
Armin
Hallo,

hier ist damit der mit dem Controller verknüfte Player gemeint.

@Armin, Der FirstZP scheint meines Wissens in der Standardeinrichtung nicht auf, weil es da keine Root Bridge gibt; und welcher Player im Boost-Modus der FirstZP ist, kann man nur über das Web-Interface eruieren.


Gruß,
Peri
Abzeichen +1
Bassmann1968 schrieb:

Hi,
verknüpfter ZP ist die PLAY, die zuerst eingerichtet wurde.
Egal ob Kabel oder nicht.
Schaltet sich dein Netzwerk Nachts aus?
Gruß
Armin



Ich denke, das wird es sein. Eine andere Erklärung habe ich dafür nicht. Ich werde mich mal auf die Suche nach einer Einstellung machen.

Danke
Benutzerebene 6
Abzeichen +3
Gutes Gelingen.
Über Feedback freuen wir uns immer ;)
Gruß
Arminm
Abzeichen +1
So richtig bin ich noch nicht dahinter gekommen. Kann es was mit der DHCP-Leasedauer von 24 Stunden bzw. 86400 Sekunden zu tun haben? Habe die Leasedauer mal erhöht. Ich probiere es weiter.
Benutzerebene 6
Abzeichen +3
Hi,
lass die Lease Time so wie sie ist.
Das Lease wird nach der Hälfte der eingestellten Zeit erneuert. Das führt aber nicht zu einem Vetbindungsabbruch.
Ist ganz normal. Nur wenn es bei der Leaseerneuerung ein Problem gäbe und 2 Renew Versuche schief gehen, dann würde abgebrochen werden.

Kannst du eine Regelmäßigkeit bei den Unterbrechungen erkennen? Passiert das einmal am Tag, bei Nacht oder mehrmals?
Gruß
Armin
Benutzerebene 3
Hi lopez83,
das Problem mit "sich auflösender Gruppe(n)" habe ich auch :(
- kannst Du unter ""Gruppe-löst-sich-von-Zeit-zu-Zeit-immer-wieder-von-selbst-auf"" ausgiebig nachlesen.
- über den dort abgebildeten Thread hinaus steh ich in Fortsetzung dessen mit dem SONOS-Support bis dato in direktem eMail-Kontakt dazu.
- die gesamte Kommunikation würde hier im Forum ca. 20 Seiten füllen :(

Fakt ist, das Objekt Gruppe ist das instabilste und flüchtigste Objekt im ganzen SONOS-System überhaupt. Und SONOS, bzw. der Support konnte bis jetzt noch nicht identifizieren welches Event denn (zumindest bei mir) zum Brake der Gruppe führt. Sollte da mal eine verlässlich und belastbare Aussage zu treffen sein, dann werde ich den o. g. Thread mit den Ergebnissen aktualisieren.
- aktuell ist das aber alles nur im Bereich der Vermutungen und vom Gefühl hat IMO der Support auch noch nicht so den richtigen Ansatzpunkt benennen können.
- alles andere hier zu thematisieren würde den Rahmen sprengen
Bei mir zumindest tauchen dies Instabilitäten (GroupBrake) seit ca. Anfang des Jahres auf, was zeitlich mit einem Update (ich meine der 7.2, - oder war es die 7.1 :? ) und bei mir der Anschaffung von 2 P1ern zusammenfällt.

Zu Deiner Frage ...
lopez83 schrieb:

... Ist es eigentlich normal, dass nicht die Box, die per Netzwerkkabel angeschlossen ist, als verknüpfter ZP fungiert?

... diese Auswahl trifft das System / bzw. der Controller über eine ganz einfache techn. Logik.
Die Suche nach den SONOS-Komponenten im lokalen (Sub-)Netz erfolgt via Broadcast- bzw. UPnP-Requests.
Der erste PLAYer, der hier dann im Netz mit einem Replay antwortet ist immer der mit dem Controller "verknüpfte ZP".

Bzgl. "ZP first" ist das so eine Sache mit der Definition ...
Eigentlich ist der Begriff falsch und meint im SONOS-Net (das ist der so genannte "BOOST-Mode) die "Root-Bridge".
Root-Bridge ist ein Begriff aus dem STP (Spanning Tree Protokoll), welches SONOS in im BOOST-Mode zwingend einsetzt.
Diese Root-Bridge ist die oberste Spitze des gesamten Rooting-Baums, welche durch Aufbau eines MESH-Net's im SONOS-Net entsteht, und somit der Master über alle nachgeordneten Hop's.
Wie das Ganze sich dann life darstellt kann man in der Network Matrix der Hidden-GUI sehen.

Eine weitere, aber eher zu vernachlässigende Rolle ist genau die erste, bei SONOS registrierte Komponente, welche manchmal auch als "ZP fist" bezeichnet wird. Diese Komponente, bzw. deren UUID taucht immer bei Verwendung von WEB-Services auf. Zum Bsp. wird diese ID bei Verwendung von Internetradio via TuneIn an den Streaming-Endpoint übergeben, um das individuelle SONOS-System bei TuneIn zu erkennen, und um damit z.B. auf "meine Radiosender" überhaupt zugreifen zu können.

Eine letzte, hier dann aber sehr wohl relevante Rolle, ist die des "Group-Coordinators".
Das ist der, der als erster in der App ausgewählt wird, und zu dem die weiteren Member hinzu gruppiert werden.
Dieser Coordinator ist auch der, über den der gesamte Traffic z.B. beim Streaming läuft.
- heißt, ist das ein WLAN-Player mit schlechter Netzanbindung, laufen alle Bits und Bytes aus dem Internet oder vom NAS erst per WLAN zu dem hin, müssen dort koordiniert (ggf. gepudffert) werden, und werden dann an die Member der Gruppe, ggf wieder über inperformantes WLAN weiter gegeben.
- heißt auch, ist der also ungünstig und unwissend ausgewählt, kommen die hier beschriebenen Probleme meist aus dieser Systematik. - meist, nicht immer :)
Eine Besonderheit ist bei einem Stereo-Paar zu beachten.
Der Coordinator einer Stereo-Paarung ist immer der linke Payer!
- das ist hard so von SONOS gecodet.
- dabei ist es egal, auch wenn der Rechte per LAN angeschlossen ist, der Linke ist und bleibt der Coordinator !!!

... damit sollen Deine Fragen ausgiebig beantwortet sein :?

PS: der DHCP-Lease-Timer spielt bei diesem Problem hier überhaupt keine Rolle, es sei denn Du hättest den so kurz eingestellt. dass er sich jede Sec. erneuern müsste ...

v.G. // Peter
Abzeichen +1
Bassmann1968 schrieb:

Hi,
lass die Lease Time so wie sie ist.
Das Lease wird nach der Hälfte der eingestellten Zeit erneuert. Das führt aber nicht zu einem Vetbindungsabbruch.
Ist ganz normal. Nur wenn es bei der Leaseerneuerung ein Problem gäbe und 2 Renew Versuche schief gehen, dann würde abgebrochen werden.

Kannst du eine Regelmäßigkeit bei den Unterbrechungen erkennen? Passiert das einmal am Tag, bei Nacht oder mehrmals?
Gruß
Armin



Eine Regelmäßigkeit kann ich nicht erkennen, nein. Ich hatte jetzt tatsächlich mal zwei Tage Glück :-) Sonst gefühlt jeden Tag. Heute früh war die Gruppenenteilung noch da, jetzt gerade war sie wieder weg.
Abzeichen +1
Peter_13 schrieb:

Hi lopez83,
das Problem mit "sich auflösender Gruppe(n)" habe ich auch :(
- kannst Du unter ""Gruppe-löst-sich-von-Zeit-zu-Zeit-immer-wieder-von-selbst-auf"" ausgiebig nachlesen.
- über den dort abgebildeten Thread hinaus steh ich in Fortsetzung dessen mit dem SONOS-Support bis dato in direktem eMail-Kontakt dazu.
- die gesamte Kommunikation würde hier im Forum ca. 20 Seiten füllen :(

Fakt ist, das Objekt Gruppe ist das instabilste und flüchtigste Objekt im ganzen SONOS-System überhaupt. Und SONOS, bzw. der Support konnte bis jetzt noch nicht identifizieren welches Event denn (zumindest bei mir) zum Brake der Gruppe führt. Sollte da mal eine verlässlich und belastbare Aussage zu treffen sein, dann werde ich den o. g. Thread mit den Ergebnissen aktualisieren.
- aktuell ist das aber alles nur im Bereich der Vermutungen und vom Gefühl hat IMO der Support auch noch nicht so den richtigen Ansatzpunkt benennen können.
- alles andere hier zu thematisieren würde den Rahmen sprengen
Bei mir zumindest tauchen dies Instabilitäten (GroupBrake) seit ca. Anfang des Jahres auf, was zeitlich mit einem Update (ich meine der 7.2, - oder war es die 7.1 :? ) und bei mir der Anschaffung von 2 P1ern zusammenfällt.

Zu Deiner Frage ...

lopez83 schrieb:

... Ist es eigentlich normal, dass nicht die Box, die per Netzwerkkabel angeschlossen ist, als verknüpfter ZP fungiert?

... diese Auswahl trifft das System / bzw. der Controller über eine ganz einfache techn. Logik.
Die Suche nach den SONOS-Komponenten im lokalen (Sub-)Netz erfolgt via Broadcast- bzw. UPnP-Requests.
Der erste PLAYer, der hier dann im Netz mit einem Replay antwortet ist immer der mit dem Controller "verknüpfte ZP".

Bzgl. "ZP first" ist das so eine Sache mit der Definition ...
Eigentlich ist der Begriff falsch und meint im SONOS-Net (das ist der so genannte "BOOST-Mode) die "Root-Bridge".
Root-Bridge ist ein Begriff aus dem STP (Spanning Tree Protokoll), welches SONOS in im BOOST-Mode zwingend einsetzt.
Diese Root-Bridge ist die oberste Spitze des gesamten Rooting-Baums, welche durch Aufbau eines MESH-Net's im SONOS-Net entsteht, und somit der Master über alle nachgeordneten Hop's.
Wie das Ganze sich dann life darstellt kann man in der Network Matrix der Hidden-GUI sehen.

Eine weitere, aber eher zu vernachlässigende Rolle ist genau die erste, bei SONOS registrierte Komponente, welche manchmal auch als "ZP fist" bezeichnet wird. Diese Komponente, bzw. deren UUID taucht immer bei Verwendung von WEB-Services auf. Zum Bsp. wird diese ID bei Verwendung von Internetradio via TuneIn an den Streaming-Endpoint übergeben, um das individuelle SONOS-System bei TuneIn zu erkennen, und um damit z.B. auf "meine Radiosender" überhaupt zugreifen zu können.

Eine letzte, hier dann aber sehr wohl relevante Rolle, ist die des "Group-Coordinators".
Das ist der, der als erster in der App ausgewählt wird, und zu dem die weiteren Member hinzu gruppiert werden.
Dieser Coordinator ist auch der, über den der gesamte Traffic z.B. beim Streaming läuft.
- heißt, ist das ein WLAN-Player mit schlechter Netzanbindung, laufen alle Bits und Bytes aus dem Internet oder vom NAS erst per WLAN zu dem hin, müssen dort koordiniert (ggf. gepudffert) werden, und werden dann an die Member der Gruppe, ggf wieder über inperformantes WLAN weiter gegeben.
- heißt auch, ist der also ungünstig und unwissend ausgewählt, kommen die hier beschriebenen Probleme meist aus dieser Systematik. - meist, nicht immer :)
Eine Besonderheit ist bei einem Stereo-Paar zu beachten.
Der Coordinator einer Stereo-Paarung ist immer der linke Payer!
- das ist hard so von SONOS gecodet.
- dabei ist es egal, auch wenn der Rechte per LAN angeschlossen ist, der Linke ist und bleibt der Coordinator !!!

... damit sollen Deine Fragen ausgiebig beantwortet sein :?

PS: der DHCP-Lease-Timer spielt bei diesem Problem hier überhaupt keine Rolle, es sei denn Du hättest den so kurz eingestellt. dass er sich jede Sec. erneuern müsste ...

v.G. // Peter



Hey Peter,

Danke vielmals für deine ausführlich Antwort. Ich werde mich mal durch den von dir verlinkten Thread lesen.

Ich habe das Gefühl, dass bei mir auch nach der Anschaffung zweier P1 zu Beginn des Jahres, das Verhalten eingetreten ist. Gut, davor hatte ich nur einen P3, aber der letzt gespielte Sender war nie weg. Nun ist es mit Verlust der Gruppeneinteilung so, dass auch der letzt gespielte Sender weg ist.
Hallo lopez,

vielleicht ist eine doppelt vergebene IP-Adresse die Ursache. Hast Du mal den Horizon-Router und die Sonos-Komponenten in der richtigen Reihenfolge neu gestartet? Zuerst den Router, warten bis er vollständig hochgefahren ist, danach die Player, einen nach dem anderen.

Wenn Du Glück hast, sollte sich danach alles wieder in Wohlgefallen auflösen. Wenn Du Pech hast, musst Du die Prozedur auf alle netzwerkfähigen Geräte, einschl. Smartphones & Tablets, ausweiten.


Gruß,
Peri
Abzeichen +1
Doppelt vergebene IP's habe ich schon per Analyzer gecheckt. Negativ.
Bei Problemen sollte man als ersten Lösungsansatz stets Router und Komponenten neu starten. Wenn Du dazu nicht bereit bist, wird Dir hier niemand helfen können.
Benutzerebene 3
Wenn es das selbe Problem wie bei mir ist, dann kannst'e alle Netzkomponenten bis zur Vergasung neu starten .... das ändert dann überhaupt nichts !!!
- außerdem ist es unprofessionell Problemen mit einem Reboot zu begegnen!
- das ist max. ein Workarround um kurzfristig wieder einen definierten (und ggf. funktionsfähigen) Zustand zu erzielen, beseitigt oder identifiziert aber nicht den Fehler!
- das hilft und befriedigt ggf. den Laien (und das Incident, weil man es schließen kann), ... das Problem wird man damit aber nicht los, und mit Wiederkehr wird auch der Laie immer unzufriedener :(

Wie gesagt, wenn wir hier die selben Symptome und ggf. die selbe Problematik haben, dann liegt die Ursache IMHO irgendwo im Code von SONOS, wobei dafür erst einmal der genaue Auslöser zu finden wäre. - und da tappen aktuell noch alle im Dunkeln, da diese Situation anscheinend nur unter ganz bestimmten (und vermutlich sehr speziellen oder vereinzelten) Bedingungen auftritt und selbst diese noch nicht einmal genau abgesteckt ist :(
Um so wichtiger ist es IMO hier am Ball zu bleiben und ggf. noch mehr betroffene zu identifizieren.
Peter_13 schrieb:

Wenn es das selbe Problem wie bei mir ist, dann kannst'e alle Netzkomponenten bis zur Vergasung neu starten .... das ändert dann überhaupt nichts !!!
- außerdem ist es unprofessionell Problemen mit einem Reboot zu begegnen! [...]




Fehlerbehebung


Wenn du Schwierigkeiten mit deinem System nach dem Update hast, wende dich bitte an unsere Techniker. Du kannst auch einen neuen Thread in der Community aufmachen oder einen finden, der deinem Ärger ähnlich ist und wir helfen. Im Allgemeinen werden alle Probleme unmittelbar nach einem Update durch Interferenzen oder doppelte IP-Adressen verursacht, ein Router Neustart, gefolgt von den Lautsprechern ist der beste erste Schritt.

Abzeichen +1
Auch wenn es auf der Sonos webseite so steht, ändert das nichts an der Tatsache das es unprofessionell ist. Da gebe ich peter_13voll und ganz Recht. Und davon mal abgesehen ist die Aussage mit doppelten IP Adressen absoluter Blödsinn. Die kämen bei DHCP nämlich nur dann vor wenn 2 eigenständige DHCP-Server (kein HA cluster) parallel betrieben würden. Selbst Billig CPEs sind schlau genug keine Adresse doppelt zu vergeben...
alex1977 schrieb:

[…] Und davon mal abgesehen ist die Aussage mit doppelten IP Adressen absoluter Blödsinn. Die kämen bei DHCP nämlich nur dann vor wenn 2 eigenständige DHCP-Server (kein HA cluster) parallel betrieben würden. Selbst Billig CPEs sind schlau genug keine Adresse doppelt zu vergeben...




ratty schrieb:

Any network traffic failure after an upgrade is almost always caused by a duplicated IP address. The Sonos units reboot during the update process and, if the router's lost lease info, can be assigned an IP that's already in use.

Reboot all the devices on your network. This will ensure that all request fresh, unique IP addresses.

Assuming that resolves the problem, I suggest you get your router to reserve IP addresses for important network devices. Most will let you do so.


https://en.community.sonos.com/ask-a-question-228987/connection-speed-insufficient-immediately-after-7-3-upgrade-6788284/index1.html#post16129511


ratty schrieb:

windbag schrieb:

How can there be dupe IPs anyway?


Typically it's because a router has restarted, and forgotten about all the IP addresses it handed out beforehand. Along comes a new device -- such as a Sonos unit as it reboots -- which requests an IP, and the router unknowingly hands out one that's already in use.


https://en.community.sonos.com/ask-a-question-228987/connection-speed-insufficient-immediately-after-7-3-upgrade-6788284/index1.html#post16129523


ratty schrieb:

[…] Oh, and you won't spot any IP duplication from the DHCP table in the router. If there were any dupes it wouldn't know about it, otherwise it would have taken appropriate action.


https://en.community.sonos.com/ask-a-question-228987/connection-speed-insufficient-immediately-after-7-3-upgrade-6788284/index1.html#post16130062

Antworten

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)