Probleme bei mehreren WLAN AP`s mit gleicher SSID/PW


Abzeichen

Hallo zusammen

Seit ein paar Wochen (ev schon länger) habe ich massive Probleme mich mit der Sonos App mit den Playern (2x Play1, 1x Symfonisk) zu verbinden, resp in der App sehe ich plötzlich einzelne Geräte nicht mehr. Manchmal sehe ich das Gerät auch, kann es aber nicht steuern, und dessen Status wird nicht aktualisiert. In diesem Zustand funktionieren die anderen Geräte in der App aber einwandfrei.

 

Ich habe 3 AP’S (Ubiquiti Unifi) welche alle die gleiche SSID und das gleiche PW haben. Meine Vermutung ist, dass sobald das Mobile mit der App nicht am gleichen AP wie der Sonos angemeldet ist, ich die Probleme habe. Aber das sollte doch einwandfrei funktionieren? 

 

Hat jemand eine Idee woran das liegen kann? 

Was brauchts noch an Informationen zur eingrenzung?

Vielen Dank

Markus


18 Antworten

@mmarkus33, setze bitte alle APs auf den gleichen Funkkanal, indem du die Kanäle 1,6,11 durchtestest. Das erleichtert den Komponenten die Kommunikation untereinander.

Abzeichen

Hallo Greta

werde ich mal testen. 

Bekomme ich dann keine Probleme mit Interferenzen wenn sich die WLAN Abdeckung überschneidet?

@mmarkus33, die Frequenzen der Kanäle 1,6,11 überschneiden sich nicht. Teste bitte einmal und berichte, dann sehen wir weiter.

Abzeichen

hmm, jetzt bin ich nicht sicher ob ich dich richtig verstanden habe. 

@mmarkus33, setze bitte alle APs auf den gleichen Funkkanal, ...

Ich hätte jetzt alle 3 AP auf den gleichen Kanal zB. 6 eingestellt

hmm, jetzt bin ich nicht sicher ob ich dich richtig verstanden habe. 

@mmarkus33, setze bitte alle APs auf den gleichen Funkkanal, ...

Ich hätte jetzt alle 3 AP auf den gleichen Kanal zB. 6 eingestellt

 

Ja richtig verstanden. Wenn es bei Kanal 6 weiterhin zu Aussetzern kommt, probier es mit 1 und danach mit 11.

Benutzerebene 7
Abzeichen +3

@mmarkus33 

Meiner Meinung nach sollte es eigentlich keine Rolle spielen, ob die Access Points alle den gleichen Kanal oder verschiedene Kanäle aus der Auswahl 1,6 und 11 nutzen.
Aber Probieren geht über studieren…

Hast du für den Router bzw. dein Unifi System die Option „Auto Optimize Network“ aktiv?

Die muss deaktiviert werden, da Sonos sonst Zicken macht. 
Gruß,

Ralf

Anforderungen an die WLAN-Einrichtung

Die folgenden Anforderungen und Einschränkungen gelten für ein Sonos System, das über WLAN läuft. Wenn dein Netzwerk diese Anforderungen nicht erfüllt, empfehlen wir, dein System kabelgebunden zu konfigurieren. 

 

  • [...] Bei Verwendung mehrerer Zugangspunkte vergewissere dich, dass alle auf den gleichen 2,4-GHz-Funkkanal eingestellt sind.

https://support.sonos.com/s/article/126?language=de

Benutzerebene 7
Abzeichen +3

Keine Ahnung, WARUM Sonos bei Verwendung von mehreren Access Points die Verwendung des gleichen Kanals empfiehlt… die Begründung würde mich interessieren. 
Im gleichen Supportdokument wird ja aber auch die Verwendung von Mesh Systemen empfohlen… was ja nach diversen Feldversuchen meistens auch nicht funktioniert. 
Von daher, meine Meinung… Support Infos sind gut und wichtig, aber auch nicht unfehlbar. ;-) Praxistests helfen meist am besten. :sunglasses:

With mesh networks (Google WiFi, Velop, etc) becoming more and more common in the household, this changes "default network layout" of most homes. That being said, some basic Sonos features like grouping, function with the help of something called direct routing. This means that any wireless extenders or nodes need to be broadcasting on the same wireless channel in order to send audio content to the entire group. Most mesh networks set their satellites on different channels to give each node a clean channel to communicate with and have the largest wireless footprint. As you can imagine, having a wireless network that tries to dominate the wireless spectrum in your house will certainly cause problems with a wireless home sound system.

 

https://en.community.sonos.com/components-228996/will-sonos-work-plugging-the-sonos-bridge-into-a-google-wifi-designated-router-and-mesh-6805645#post16227067

Abzeichen

Ich habe jetzt mal alle 3 AP`s  auf Kanal 6 eingestellt. Erster kurzer Test war erfolgreich. Allerdings hat vorhin soeben mein Mobil von einem AP zum anderen gewechselt, was zur wirkung hatte, dass ich die ZP  in der App nicht mehr Gruppieren konnte. Nach einer Minute gings wieder. Ist das Normal? 

 

Das einstellen aller AP`s auf den gleichen Kanal hat nun aber zur folge das der W-Lan empfang aller anderen Geräte gesunken ist :-(

Abzeichen

„Auto Optimize Network“ aktiv?

 

Ja ist aus.

Kann die eingeschaltete Mesh- Option eine Rolle Spielen? oder kann IGMP Snooping etwas verbessern? (ist ausgeschaltet)

 

Danke für eure Hilfe

Ich habe jetzt mal alle 3 AP`s  auf Kanal 6 eingestellt. Erster kurzer Test war erfolgreich. Allerdings hat vorhin soeben mein Mobil von einem AP zum anderen gewechselt, was zur wirkung hatte, dass ich die ZP  in der App nicht mehr Gruppieren konnte. Nach einer Minute gings wieder. Ist das Normal? 

 

Ob das normal ist, kann nur ein Sonos-Mitarbeiter beantworten. Verbindet sich das Mobilgerät über 5 GHz mit den APs? Das kann im WLAN-Betrieb problematisch sein, wenn die APs zwischen den Bändern nicht brücken.

Wie sieht es mit potenziellen Störquellen wie Philips HUE, Schnurlostelefon, Babyphon, Mikrowelle, WLAN-Drucker, Bluetoothgeräte, Überwachungskameras oder Hausautomation aus? Die Sonos-Komponenten und andere WLAN-fähige Geräte (einschließlich Router) sollten in einem Respektabstand zueinander stehen.

 

 

 

Das einstellen aller AP`s auf den gleichen Kanal hat nun aber zur folge das der W-Lan empfang aller anderen Geräte gesunken ist :-(

 

Wenn eine der Komponenten in der Nähe des Routers steht, könntest du sie auch mit dem Router verkabeln (bei einem Stereopaar den linken Player), dann wechselt das System in die Betriebsart SonosNet. Anschließend die WLAN-Zugangsdaten wie folgt aus dem System entfernen.

Sonos Controller-App für iOS oder Android: Tippe in der Sonosapp unter Einstellungen auf System > Netzwerk > Netzwerke. Wähle das WLAN-Netzwerk aus, das du entfernen möchtest und tippe auf Entfernen. Mindestens 10 Min. warten, danach überprüfen, ob in der Sonosapp unter 'Einstellungen --> System --> Über mein Sonos-System' neben jedem Player WM:0 steht; dann befindet sich das System im SonosNet.

 

Setze bitte eine Diagnose ab und antworte hier mit der Bestätigungsnummer, dann kümmert sich ein Techniker darum. Eine Diagnose senden (Klick mich!)

@mmarkus33, “Auto Optimize Network” bitte ausschalten. IGMP Snooping wird in der Regel im WLAN-Betrieb nicht gebraucht, wenn du es einschaltest, werden wir sehen, ob es etwas bewirkt.

Das einstellen aller AP`s auf den gleichen Kanal hat nun aber zur folge das der W-Lan empfang aller anderen Geräte gesunken ist :-(

Das ist in dieser Konstellation ganz normal und verständlich. Durch die Verwendung des selben Kanals bei allen APs müssen diese sich jetzt die verfügbare AirTime teilen.
Heist, es kann und darf immer nur einer senden. - egal ob AP oder Client.
Damit reduziert sich natürlich bei Parallelbetrieb von Clients der mögliche Durchsatz.

Wenn Du jeden AP auf einem eigenen Kanal konfigurierst, dann musst Du bei 3 (und mehr), vorausgesetzt die APs können sich gegenseitig sehen, die Bandbreite (im UniFi-Controller heißt das “Kanalbreite”) auf “HT20” einstellen. - nur dann kannst Du interferenzfrei Kanal 1, 6 und 11 auf den APs nutzen.

Sehen sich die APs nicht gegenseitig, oder jeder AP sieht immer nur einen, dann darfst Du mit “HT40" arbeiten, wobei dann eigentlich nur noch Kanal 1 und 11 sauber und interferenzfrei nutzbar ist.

Das Ganze gilt aber nur wenn Du keine “freundlichen Nachbarn” hast, ansonsten musst Du die und deren Funknetze auch berücksichtigen.

 

Abzeichen

Danke für eure Hilfe.

Also wenn alles auf einem Kanal ist, sind die Sonos Produkte viel stabiler im W-Lan, das ist schon mal positiv. Allerdings lässt der restliche WLAN Empfang dieses Szenarium nicht zu. 

 

Alternative daher ein SonosNet aufzubauen. Problem dabei nur den Play im mittleren Stockwerk würde alle anderen erreichen. aber dieser steht selten am gleichen Ort, oder ist auch plötzlich mal ausgesteckt (Kinder). Ich könnte dies ja nun mit einem Boost lösen, oder?  Würde auch ein Tradfri-gateway funktionieren? dieses hat auch LAN und funktioniert ja mit Symfonisk. Was denkt ihr? Hat das schon jemand so gemacht?

@mmarkus33, ein Boost wäre wahrscheinlich die beste Lösung. Das SonosNet ist zwar vom heimischen WLAN unabhängig, doch Ikea TRÅDFRI und Philips HUE arbeiten mit ZigBee, ob der LAN des Gateway hier einen gleichwertigen Ersatz für eine Verkabelung mit dem Router darstellt, müsste getestet werden. Gutes Gefühl habe ich dabei keines.

Würde auch ein Tradfri-gateway funktionieren? dieses hat auch LAN und funktioniert ja mit Symfonisk. 

Tut mir leid, aber in der Produktbeschreibung steht doch eindeutig “Kann nur in Verbindung mit IKEA Home Smart Beleuchtungsprodukten benutzt werden.”
Von Symfonisk ist da nirgends die Rede !?

Kann ich mir btw. bei dem Preis auch nicht vorstellen, selbst wenn bei SONOS z.T. auch das Logo auf den Geräten den Preis treibt.
Und in einem BOOST (und auch den anderen SONOS-Geräten) steckt schon eine Menge individueller Technik drin, welche man nicht für läppische 30 € bekommt. - auch nicht beim Schweden.

Bei IKEA stehen sowohl Symfonisk Regallautsprecher wie Lampe in der Beleuchtungsabteilung, was es sicherlich manchmal erschwert, zwischen Ikea-Produkt und Sonos-Produkt zu unterscheiden. Ich hatte es so verstanden, dass ein Boost oder eine Sonoskomponente mit dem TRÅDFRI Gateway verkabelt werden soll.

Antworten