Frage

Problem mit Sonos und Repeater im WLAN


Abzeichen +1
Hallo Gemeinde,
ich habe diverse Probleme beim Betrieb meiner Sonos-Anlage, und hier keine Lösung gefunden. Zunächst mein Setup: Einfamilienhaus, Gasbeton / Trockenbau. Eine Fritzbox 6490 im Wirtschaftsraum am Ende des Hauses, einen Repeater 1750E in der Mitte. Eine Play 1 jeweils in Küche und Bad, zwei Play 3 im Wohnzimmer als Stereopaar. Sonos-App auf iPhone.
SSID usw. auf Fritzbox und Repeater identisch. Küche und Wohnzimmer liegen näher an der Fritzbox, Bad näher am Repeater.
Nun kommt es zu seltsamen Effekten: wenn die Box vom Bad auf dem Repeater "hängt" und das Smartphone ebenso, "sieht" es die restlichen Boxen nicht mehr. "Hängen" die Wohnzimmerboxen auf dem Repeater, funktioniert nur der rechte Kanal. Da die Lösung jedes mal ist, den Repeater kurz stromlos zu machen, dürfte der Zusammenhang hier zu suchen sein. Nur: wo? Was könnte ich falsch konfiguriert haben?
Ich habe zwei Screenshots beigefügt, vielleicht helfen die weiter: einmal ist der Repeater in Betrieb (dort, wo Wohnzimmer und Bad rot sind), dann unmittelbar nach dessen Entfernung.
Wäre eine Sonos Boost die Lösung?

Herzlichen Dank für eure Hilfe
Axel

Dieser Beitrag ist geschlossen für weitere Beiträge

20 Antworten

... Ich hatte mich in Venezuela gewundert, dass ich meine Sonos im Zimmer steuern konnte, obwohl ich unten am Pool gesessen habe und ganz andere Login Daten dort hatte, als im Zimmer. solange Du in diesem Hotel in ein und der selben Broadcast-Domain unterwegs warst, ist das SONOS vollkommen egal.
- der Voucher (also der Hotspot-Login) und die SSID/PW ist ja nur ein Thema der Autorisierung und des Zugangs in das Netz.
- das Netz selbst kann dabei ein und das Selbe sein.
Die angesprochene Problematik muss nicht zwingend bei Dir mit dem AVM FRITZ!WLAN Repeater 310 auftreten.
- dass Du dies Gerät benutzt war ja vorher nicht klar.
Das Thema ist halt, dass SONOS mit der Nutzung des UPnP-Frameworks auf die Durchleitung von Broad- und Multicast-Paketen angewiesen ist.
Die Eigenheit dieser Pakete ist, dass diese nicht in einer synchronen Kommunikation, sondern asynchron (im Grunde Fire and forget) erfolgen.
- werden sie also geblocked, oder wenn nicht geblocked aber "verlustig gehen", dann kommt es genau zu den immer wieder beschriebenen Fehlerbildern.
- das kann mit Repeatern funktionieren, muss aber nicht.

Eine reine / "echte" Repaeter-Strecke ist halt per se weitaus inperformanter als ein dedizierter Uplink, da bei dieser Funkstrecke sich alle dahinter liegenden Clients die verfügbare Bandbreite teilen müssen.
Das ist bei einem 5G-Uplink zwar auch der Fall, aber dieser ist von Haus aus und aufgrund der in .11n/ac verwendeten Technik viel breitbandiger (und aufgrund der Auslastung und Reichweite der höheren Trägerfrequenz weit weniger störbelastet).
Demnach kannst Du z.B. hinter einem 1.300 MBps-5G-Uplink mit 3-fach-MIMO und 80 MHz BB rein theoretisch um die 24 .11g-Clients mit 54 MBps ohne nennenswerte Einschränkung betreiben.
Würdest Du diese Clientanzahl auf eine 2,4G-Repeaterstrecke legen, bricht Dir rein rechnerisch und theoretisch die Brutto-Rate bei .11g auf 2,25 Mbps/Client (54 / 24), und bei .11n auf 25 MBps/Client (600 / 24) zusammen.
Betrachtest Du jetzt den Netto-Datendurchsatz, redurzieren sich o.g. Werte per se nochmal auf die Hälfte, weil Funk halt nicht Duplex-fähig ist.
- außerdem kommt ja noch IP-Overhaed usw. dazu.
Genau aus diesen Zusammenhängen (und auch noch weiteren) sind bei vielen (ins besondere älteren) Repeatern Broad- und Multicast-Pakete in der plug'n play - Konfiguration vom Hersteller bereits deaktiviert.
- man braucht sie für Internetsurfen halt nicht.
Das sind dann aber genau die Teile, bei denen SONOS nämlich seine Arbeit verweigert und es zu den hier immer wieder zu lesenden Fehlerbildern kommt :(

Ansonsten gibt es xxx weitere verschiedene Möglichkeiten, warum es bei Dir funzt und bei anderen nicht.
- das jetzt hier aber genau zu analysieren und ggf. zu erklären sprengt IMHO eindeutig den Rahmen.

v.G. // Peter
Benutzerebene 7
Abzeichen +3
Eigentlich hast du recht, bei den Bediengeraeten ist es egal.
Wahrscheinlich ist dann sogar SSID und PW egal.
Ich hatte mich in Venezuela gewundert, dass ich meine Sonos im Zimmer steuern konnte, obwohl ich unten am Pool gesessen habe und ganz andere Login Daten dort hatte, als im Zimmer.
Benutzerebene 1
Abzeichen
Hallo,

Was du mit dem Controllern meinst kann ich nicht so ganz nachvollziehen. Ich kann das Sonos System mit meinem Handy bedienen auch wenn dieses im Wlan des Repeaters eingeloggt ist. Wichtig ist nur, dass die sonos player alle in einem Wlan Netz hängen. Das kann auch das des Repeaters sein. Wahrscheinlich hab ich dich aber auch falsch verstanden ?!
Funktioniert bei mir ohne Probleme mit den AVM FRITZ!WLAN Repeater 310 - und das obwohl ich sicherlich kein Experte bin.
Aber wofuer braucht man dann noch den Repeater?... prinzipiell im Grunde heute überhaupt nicht mehr, weil mittlerweile nahezu alle Anbieter die Geräte auch mit LAN/5G-WLAN-Uplink und dann im 2,4G-AP-Mode anbieten.
Repeater ist halt Technik von "gestern" und nur noch wegen der "Einfachheit (plug'n play)" für die "breite Masse" von Interesse.
Liegt vielleicht auch daran, das LAN und WLAN eigentlich ein "Experten-Thema" ist ...
... leider meint halt Jeder, der die Begriffe auch nur ausschreiben kann, dass er da dann bereits Experte ist 😞
Benutzerebene 7
Abzeichen +3
Klar,
man muesste alle Sonos bezogenen Geraete dort ausschliessen.
Aber wofuer braucht man dann noch den Repeater? :D
Deshalb habe ich bei mir Antennen verbaut. Decken alles ab und brauchen keinen Strom.
Hallo,

Ich hatte für mich das Problem gelöst. Ich habe meine Repeater so eingestellt, dass sich neue IPs nicht anmelden dürfen. Somit nutzen die sonos Geräte das Wlan der Fritzbox. Die Einstellung dazu findet man in der Konfiguration des Repeaters unter Wlan\Sicherheit.

Das ist aber keine Lösung (@Armin, und ein Kauftipp sollte das erst recht nicht werden !), da Du dann definitiv Probleme mit einem Controller bekommst, der über ein Mobil-Device via diesen Repeatern zugreift !
Die einzige Variante im Repeater-Betrieb ist, wenn man die Teile so konfiguriert, dass sie Broad- und Multicast-Pakete über die Uplink-Verbindung durchreichen, was aber ja bewusst aus Performance-Gründen beim Repeater-Betrieb deaktiviert ist!
Benutzerebene 7
Abzeichen +3
Hi beisl,
danke fuer dein Feedback.
Verrate uns auch noch, was du fuer einen Repeater hast.
Dient eventuell als Kauftipp.
Gruss
Armin
Benutzerebene 1
Abzeichen
Hallo,

Ich hatte für mich das Problem gelöst. Ich habe meine Repeater so eingestellt, dass sich neue IPs nicht anmelden dürfen. Somit nutzen die sonos Geräte das Wlan der Fritzbox. Die Einstellung dazu findet man in der Konfiguration des Repeaters unter Wlan\Sicherheit.
Abzeichen
Hallo Peter_13
Vielen Dank für diese fundierte und hilfreiche Antwort.
Ich habe mir schon soetwas gedacht.
hi Lolleck,
das Problem liegt nicht bei SONOS, sonder bei dem was die Repeater (und da ist es egal von wem der ist) im Repeater-Modus im Netz durchreichen.
Sonos benötigt UPnP- mit Multi-/Broadcast-Kommunikation für die einwandfreie Funktion!
- blockt der Repeater dies in seiner Konfiguration kommt es zu Problemen.

Das Ganze kannst Du grundsätzlich umgehen, wenn Du den Repeater via LAN-Kabel versorgst und in den AP-Mode konfigurierst.
Oder der Repeater lässt es zu die erforderlichen Protokolle durchzureichen, dann funzt es auch im Repeater-Mode.
Die ganzen Router- und Repeater-Hersteller (u. a. auch AVM) haben die Problematik mittlerweile auch geschnallt und springen derzeit gerade alle auf die MESH-Net-Thematik auf.
- vor allem auch wegen der systembedingten Restriktion der Netto-Bandbreiten-Halbierung im Repeater-Mode
- ist auch nichts neues, wird aber so vermarktet.
- wobei mit echtem MESH-Netzen haben diese "neuen Lösungen" oft nicht wirklich was gemeinsam.

Ein Netz kann immer nur so gut funktionieren wie seine Konfiguration.
- und eine Repeater war und ist schon immer ein Kompromiss / eine Krücke.
- geht man dann bei und blockt in diesem Mode auch noch Multi-/Broadcasts, dann funktionieren halt gewisse andere Teile des Netzes nicht mehr, die darauf angewiesen sind.

Ein richtiges IP-Netz besteht nun mal aus Router, Switches und (möglichst) LAN-versorgten APs. Und darin sollten alle notwendigen Protokolle und Ports transparent durchgereicht werden.
- alles Andere ist mit mehr oder weniger Einschränkungen verbunden.
Ich habe auch noch das selbe problem mit einem fritzbox repeater und einer sonos 1 box
Was sollen wir denn mit dem mageren Satz anfangen? Ein paar Hintergrundinfos über Dein Heimnetz und ob Du außer diesem einen Player noch andere hast, wären nicht zu verachten.
Abzeichen
Gibt es eigendlich nun eine lösung ?
Ich habe auch noch das selbe problem mit einem fritzbox repeater und einer sonos 1 box
Benutzerebene 7
Abzeichen +3
Ist so richtig.
Abzeichen +1
Dazu eine Frage: BOOST ist neu, BRIDGE älter - BOOST hat mehr Sendeleistung, BRIDGE weniger. Ist das so richtig? In meinem Fall, nur um ein separates Netz zu schaffen, wäre es doch egal, was ich verwende?

Axel
Benutzerebene 7
Abzeichen +3
Ist sowieso nicht nötig auf 5 GHz zu gehen in diesem Fall.
Setze eine BRIDGE oder BOOST ein und wähle die WLAN Kanäle geschickt.
Sowohl am Sonos als auch am Router.
Ich habe einfach alle probiert und die besten Kanäle beibehalten.
Abzeichen +1
Hallo,
danke für die umfassenden Ausführungen. Ich bin daraufhin mein System nochmals durchgegangen, die Einstellungen sind alle okay, beide Frequenzbereiche sind aktiv, ebenso flexibles Cross Band Repeating (automatisch).

Ich habe nun meinen Bad-Player per Kabel mit dem Repeater verbunden (Ergebnis siehe Screenshot), und werde das Verhalten eine Weile beobachten. Wenn das ohne die im Eingangsposting genannten Effekte funktioniert, werde ich wohl den BOOST testen; nicht wegen der Leistungserhöhung, sondern damit er der "Zugang" für die anderen Player wird. (Kabel und Repeater im Bad sind keine Dauerlösung).

Das Umhängen aller Gerät auf 5GHz wird leider nicht funktionieren, da einige das nicht beherrschen. Aber das wäre mit dem BOOST wohl auch nicht erforderlich?

Viele Grüße, Axel
Abzeichen +2
Hallo zusammen,
ich habe ein ähnliches Setup, mit einer Fritzbox und einem 1750e Repeater und insgesamt 5 Sonos Boxen und einem Connect.

Zunächst würde ich nicht unbedingt viel auf die roten Einträge in Deiner Matrix geben, die können durch äußere Einflüsse stark schwanken, also fremde WLAN's und den übrigen Datenverkehr im Haus, und trotzdem kann Sonos stabil laufen. Die Werte für sonstige Störsignale (sog. noise floor) sind ok.
Deine Signalstärken sind allerdings deutlich niedriger als bei mir, die sind mit oder ohne Repeater gleich, dieser scheint überhaupt keinen positiven Effekt für die SONOS Komponenten zu haben.

Du hast kein SONOSnet, also reines WLAN ohne Kabel. Ich habe eine Player am Repeater verkabelt. Das ist nach meiner Erfahrung immer besser.

Der Boost könnte helfen, bei mir gehts auch ohne, deshalb keine Erfahrung. Wenn man den mit Rückgabe- oder Widerrufsrecht kauft, kann man ihn getrost ausprobieren.
Vor dem Kauf würde ich folgendes probieren:

Ist der Repeater richtig eingestellt? Funkt er auf beiden Frequenzen(2,4 und 5 GHz)? Wieviel Bandbreite liefert er?
Wenn sowohl 2,4 als auch 5 GHz aktiv sind, kann man den Repeater noch optimieren, (Stichwort Cross Band Repeating)

Wenn es irgendmöglich ist, würde ich einen Player per Kabel mit dem Repeater verbinden, vorausgesetzt dieser hat ausreichend Signalstärke von der Fritzbox, das sieht man schon an den LED Streifen oder auch auf der Webseite des Repeaters.

Ferner würde ich die Nicht-Sonos-Geräte mit 5GHz WLAN versorgen, falls die Geräte das können (wie z.B. das iphone), der Repeater und die FritzBox können sowohl 2,4 als auch 5 Ghz simultan betreiben.

Gruß Frank
Abzeichen +1
Hallo Armin,
ja, der Repeater ist erforderlich: am anderen Ende des Hauses ist das WLAN sonst zu schwach, und das gibt Ärger mit meiner Frau und meinem Sohn, die ihre Zimmer dort haben. Eine Umsetzung der Fritzbox ist aus baulichen Gründen nicht ohne weiteres möglich, leider.
Viele Grüße, Axel
Benutzerebene 7
Abzeichen +3
Hi Axel,
Brauchst du den Repeater überhaupt?
BOOST bringt etwas, wenn Distanz dein Problem ist.
Ich würde zuerst mal den Repeater raus werfen.
Gruß Armin