Beantwortet

Playlisten werden teilweise doppelt angezeigt


Benutzerebene 2
Abzeichen +1
  • Aufsteigendes Talent
  • 237 Antworten
Habe einmal meine Musikfestplatte, die direkt an meinem Router hängt, neu formatiert und auch die gesamte dort befindliche Musiksammlung "bereinigt". In den importierten Playlisten finden sich nun ab und an - nicht bei allen- manche Playlisten doppelt. Diese sind weder auf der Ausgangsfestplatte noch auf der Routerfestplatte vorhanden.
Wie kann ich diese Fehlanzeige korrigieren?
Viellen Dank für jede Hilfe
icon

Beste Antwort von horsti 7 March 2019, 17:43

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

47 Antworten

Benutzerebene 2
Abzeichen +1
Habe ich kurz quergelesen, kann für mich aber wahrscheinlich nicht zutreffen, denn die Playlisten befinden sich im Ordner der Files und wurden auch dort erstellt.
Bei AVM steht -und das wird bei mir so sein:
-------
Relative Pfadnamen:
Bei relativen Pfadnamen werden Teile des Dateipfads weggelassen, z.B. die Laufwerksangabe. Die Pfadangabe wird stattdessen erst von einem bestimmten Punkt aus interpretiert, meist dem Speicherort der Datei.
Relative Pfadnamen sind für Playlisten geeignet, da eine Anpassung der Playlist nur erforderlich ist, wenn sich die relative Zuordnung von Dateien und Playlist zueinander ändert. Liegen Dateien und Playlist im gleichen Ordner, kann dieser z.B. beliebig verschoben werden, ohne dass die Playlist angepasst werden müsste.
--------
Natürlich habe ich keine Pfade abgespeichert, die ich dann durch Veränderung der Struktur hätte mitändern müssen. Wenn ich "zu Fuß" die Playliste in SONOS öffne, wird die Playliste abgespielt. Etwas anderes wäre es, wenn ich nicht im Ordner selbst, sondern auf dem root die Listen speichern würde. Im Grunde müsste ich dann aber aich Probleme beim Abspielen haben.
Mein eigentliches Problem ist aber die willkürlich -eben nicht alle, sondern einige- auftretenden doppelten Listen. Beide funktionieren übrigens gleichermaßen, nur sie doppelte Anzeige nervt. Ebenso habe ich dann das Problem, dass neue Orden mit Playlisten nicht mehr in den "importierten Playlisten" unter SONOS auftauchen. Das macht keinen Sinn, denn die 50.000 Musiktitel sind noch nicht erreicht. Die Software verweigert aber ihren Dienst. So kann man nicht arbeiten. Um per Wecker Playlisten abspielen zu können, müssen diese auch auswählbar, also vorhanden sein. So wird meine Musiksammlung nicht handle-bar, ich kann nur abspielen, was angezeigt wird, alles andere nur "zu Fuß".
Benutzerebene 2
Abzeichen +1
Hallo Perpugilliam,
das macht nichts! :8:D Ich bin ja froh, dass ich mich mit jemandem austauschen kann! Irgendwo mache ich doch einen Fehler und mir fällt er einfach nicht auf, weil man so etwas auch immer wiederholt ...
Benutzerebene 2
Abzeichen +1
So sieht das dann aus:

Ganz blöde Frage, wieso erstellst Du Playlisten von Alben, die kann man doch auch durch Antippen abspielen.
Benutzerebene 2
Abzeichen +1
Umgekehrt: ich muss sie raussuchen, weil ich die Playlisten nicht verwenden kann! Oder kann ich beim Wecker das Abspielen von Ordnern speichern?
Benutzerebene 2
Abzeichen +1
Übrigens: SONOS erhöht die Anzahl der gleichen Playlisten auf 3, siehe Screenshot!
Umgekehrt: ich muss sie raussuchen, weil ich die Playlisten nicht verwenden kann! Oder kann ich beim Wecker das Abspielen von Ordnern speichern?
Brauchst Du nicht, man kann ein Album als Weckmusik vorgeben. Gehe einfach mal die Weckereinstellungen durch.
Brauchst Du nicht, man kann ein Album als Weckmusik vorgeben.Das ist aber nicht die Lösung zu dem von Horsti hier platzierten Problem !

@Horsti,
warum folgst Du nicht einfach mal dem, was ich vor etlichen Posts hier bereits formuliert hatte :?:?:?
Für Dich die wichtigen Schritte hier nochmal als Zitat:Hi horti,
vermutlich ist beim aktualisieren des Index in SONOS ein Fehler aufgetreten !?
Starte zunächst einfach mal eine neue Indexierung der Musikbibliothek in SONOS.
- damit müssten eigentlich alle Veränderungen korrigiert werden.

Wenn das nicht hilft, dann entferne mal den Pfad zu MB in der Konfiguration von SONOS.
- damit sollte SONOS den kompletten Index eigentlich löschen und es dürfte über die Navigation in SONOS unter Musikbibliothek kein einziger Eintrag mehr auftauchen.
- ist das nicht der Fall, dann ALLE SONOS-Geräte für ca 5 bis 10 Min. einmal vom Netz (230V) nehmen und danach neu starten.

Jetzt trägst Du den Pfad zu MB in der Konfiguration von SONOS erneut wieder ein und wartest die Indexierung ab.
- jetzt sollt eigentlich alles wieder "sauber" sein.

Wenn das nicht der Fall ist, dann setz eine Diagnose ab und poste die ID hier damit sich die Techniker das anschauen können.
Benutzerebene 2
Abzeichen +1
Hallo Perpugilliam,
Teil 1 hatte ich ja schon mehrmals gemacht. Was meinst Du genau (!) mit Pfad entfernen? Einfach entfernen und dann den Pfad wieder hinzufügen? So einfach, wie es sich anhört 😳?
Was meinst Du genau (!) mit Pfad entfernen? Einfach entfernen und dann den Pfad wieder hinzufügen? So einfach, wie es sich anhört 😳?Genau, eins zu eins wie es da beschrieben steht.

..., dann entferne mal den Pfad zu MB in der Konfiguration von SONOS.
- damit sollte SONOS den kompletten Index eigentlich löschen und es dürfte über die Navigation in SONOS unter Musikbibliothek kein einziger Eintrag mehr auftauchen.
- ist das nicht der Fall, dann ALLE SONOS-Geräte für ca 5 bis 10 Min. einmal vom Netz (230V) nehmen und danach neu starten.

Jetzt trägst Du den Pfad zu MB in der Konfiguration von SONOS erneut wieder ein und wartest die Indexierung ab.
- jetzt sollt eigentlich alles wieder "sauber" sein.

Wenn das nicht der Fall ist, dann setz eine Diagnose ab und poste die ID hier damit sich die Techniker das anschauen können.
Benutzerebene 2
Abzeichen +1
Nochmal an Perpugilliam mit meinem Nebenproblem,
diese Anzeige finde ich bei mir nicht! Scheine etwas zu übersehen!
@Peter_13: das werde ich am Wochenende versuchen, da habe ich etwas mehr Zeit!
Nochmal an Perpugilliam mit meinem Nebenproblem,
diese Anzeige finde ich bei mir nicht! Scheine etwas zu übersehen!
@Peter_13: das werde ich am Wochenende versuchen, da habe ich etwas mehr Zeit!

Du meinst die Musikquelle für den Wecker heraussuchen? Was verwendest Du denn für einen Controller - PC/Mac, Android oder iOS?
Benutzerebene 2
Abzeichen +1
PC!
PC!
Ist unter 'Wecker --> Bearbeiten --> Musik auswählen --> Weckmusik' die Sonos Musikbibliothek aufgeführt? Ich habe meine Musiksammlung über Subsonic eingebunden, das kann ich auswählen.
Benutzerebene 2
Abzeichen +1
Nein, Subsonic kenne ich nicht!:$
Nein, Subsonic kenne ich nicht!:$
Du sollst auch nicht nach Subsonic suchen, sondern nach "Musikbibliothek". Mache bitte mal im PC-Controller einen Screenshot von "Musikquelle auswählen".
Benutzerebene 2
Abzeichen +1
So wie ich das verstehe, wird über Subsonic die Musikbibliothek eingebunden, ohne Subsonic eben nicht!
So wie ich das verstehe, wird über Subsonic die Musikbibliothek eingebunden, ohne Subsonic eben nicht!
Klicke doch einfach unter "Weckmusik suchen" auf 'Musikbibliothek'.
Benutzerebene 2
Abzeichen +1
Dort befinden sich bei mir nur die installierten Dienste. Die Musikbib taucht dort nur auf, wenn man den Subsonic-Dienst installiert. Bei mir gibt es an der Stelle keine Musikbibliothek.
Dort befinden sich bei mir nur die installierten Dienste. Die Musikbib taucht dort nur auf, wenn man den Subsonic-Dienst installiert. Bei mir gibt es an der Stelle keine Musikbibliothek.
Ich habe seit Jahren keine Sonos-Musikbibliothek mehr eingerichtet, weshalb ich mich nicht mehr an die genaue Bezeichnung erinnere, unter der sie im Sonos-Controller aufscheint. Da Du Dich weigerst, mir zu helfen, Dir zu helfen, habe ich mich jetzt zwar im Internet schlau gemacht, bin aber trotzdem raus. Suche nach dem Folgenden unter "Weckmusik", sollte zur Auswahl stehen.
Benutzerebene 2
Abzeichen +1
So, das eigentliche Problem der Geisterlisten ist gelöst. Ich habe einen neuen User angelegt, den alten Pfad gelöscht und dann einen neuen Pfad gelegt. Daraufhin wurde die Datenbank aktualisiert und der Spuk ist vorbei.
Vielen Dank an alle! Et löpp!
Benutzerebene 6
Abzeichen +3
So, das eigentliche Problem der Geisterlisten ist gelöst. Ich habe einen neuen User angelegt, den alten Pfad gelöscht und dann einen neuen Pfad gelegt. Daraufhin wurde die Datenbank aktualisiert und der Spuk ist vorbei.
Vielen Dank an alle! Et löpp!


Danke für dein Feedback.
Das hilft anderen Usern sicherlich auch weiter.