Frage

Nur noch Geräteverluste oder Ausfälle


Abzeichen
Hallo liebes Forum,

dem Wahnsinn langsam völlig nahe, starte ich nochmal einen letzten Versuch über das Forum, bevor ich mich nach fast 10 Jahren von Sonos trenne.

Bis vor zwei, drei Jahren lief alles recht stabil. Mittlerweile vergeht fast kein Abend, an dem nicht ein oder mehrere Räume „verloren“ gehen. Smartphone neu starten, Fritzbox vom Strom nehmen, Boost und/ oder die Connects vom Strom nehmen, damit es mal wieder für einen Moment geht. Das zehrt momentan schon sehr an den Nerven.

Zu meiner Config:
1 Boost ( vor 4 Wo vergeblich als Problemlöser gekauft > mit LAN verbunden)
3 Connects
1 Play 5.1

Das Problem: wie oben geschrieben verliert er gerne mal den Play 5, der die weiteste Strecke zurücklegen muss (daher der Boost). Gern sind nach dessen Verlust auch mal Küche, Wohnzimmer und Büro weg, trotz räumlicher Nähe.

Der Support hatte mir mal den Tipp mit dem browserbasierten Analysetool gegeben. Der Play5 hatte dabei Werte von 25 - 30. Nicht super, sollte aber eigentlich reichen.

Wenig hilfreich finde ich Aussagen des Supports, dass nach Analyse Störeinflüsse da sind. Ja, aber die meisten von uns haben ein Smart TV, diverse andere ans WLan angebundene Geräte sowie mindestens (wie in meinem Fall) einen Nachbarn im Haus links und rechts. Damit muss Sonos heute klarkommen, sonst wäre es nicht zeitgemäß.

Die Kanäle habe ich auch so gelegt, dass sie sich nicht in die Quere kommen (aber auch da habe ich schon viel experimentiert).

Vielleicht habt ihr noch eine Idee? Das würde mich freuen.

So jedenfalls kostet Sonos einfach nur unglaublich viel Zeit, ohne Musik genießen zu können.

LG
Steve

Dieser Beitrag ist geschlossen für weitere Beiträge

65 Antworten

Wenn Du die Hidden-GUI bereits kennst, dann lad doch mal die Matrix als ScreenShot hoch, damit man etwas mehr sieht.
Und erzähle mal wie Dein weiteres Netz aussieht ...
- Router ?
- Switche(s)
- AP(s) oder etwa Repeater
- WLAN und Kanaleinstellung / 802.11-Betriebsart / Bandbreite
- WLAN-Umgebung (ggf. ScreenShot eines Scanners vom Bandspektrum)
- ...
Dann lässt sich ggf. auch etwas mehr und genaueres sagen / vorschlagen
Abzeichen
Hi Peter,

nachvollziehbar. Stell ich die nächsten Tage mal rein.

LG
Steve
Abzeichen
... und danke für dein Feedback!
Abzeichen
Und nochmal Hallo.

Hier jetzt mal eine Grafik, hoffe man kann sie als Bildformat vernünftig lesen (ging im PDF prima).
Ich lade auch gleich nochmal die Matrixdaten hoch ...
Abzeichen
und hier noch die Matrixdaten.

Schon mal herzlichen Dank für eure Unterstützung! 🙂
Abzeichen
... noch eine Ergänzung. Die Matrixdaten des ersten Standortes sind die des "normalen" Auftstellortes.

Beim "verbesserten" Standort habe ich den Play5 vor die offene Terrassentür gestellt. Spannend, ist die geschlossen, sinken die Werte um bis zu 12. Geschlossene Zimmertüren hatten keine Auswirkung. Da hab ich doch wieder was gelernt. 😉
Hi Steve,
was heißt in Deiner Skitze eigentlich "SONOS, Kanal 6 (WLAN deaktiviert)"
- meinst Du damit, dass es Dein priv. WLAN nicht kennt oder soll das was anderes bedeuten ?!

... und dann in der Reihenfolge wie mir was aufgefallen ist.

1.) die BOOST da im Büro ist eigentlich überflüssig, da in unmittelbarer Nähe ja die CONNECT (und die ebenfalls am LAN) steht.
Die BOOST würde ich an anderer Stelle, viel weiter zum Wohnzimmer platzieren.
- evtl. auf dem Flur.
Du kannst die auch ohne LAN betreiben, dann arbeitet Sie wie jeder andere Wireless-PLAYer auch.
- das ist ja der Vorteil des SONOS-Net, das jeder Empfänger gleichzeitig auch Sender für andere ist.
Super wäre natürlich wenn Du sie per LAN im Flur versorgen könntest, aber es geht wie gesagt auch rein drahtlos.

2.) die BOOST hängt an der Fritte, und die CONNECT (Büro) an einem Switch, der dann an der Fritte hängt.
Das ist eher suboptimal, um nicht zu sagen schlecht !
Entweder hängst Du BOOST und CONNECT beide an den Switch, oder Du hängst sie beide an die Fritte !
- das kann übrigens auch schon ein Grund Deiner Probleme sein.

3.) das Deine P5 so mies arbeitet hängt IMO mit dem von Dir gewählten Standort zusammen.
Die Antennen der P5 sind extrem verrauscht, sprich der Signal-Rauschabstand (NoiseFloor) ist eigentlich unterirdisch.
Dieser Wert sollte möglichst über 100 dB liegen.
- optimal sind 105 bis 110
- unter 90 wird es kritisch.
Ich halte jede Wette, dass die P5 in den Details der Hidden-GUI unter dem Eintrag PhyErr erhebliche Werte im Bereich >= 5.000 zeigt.
Wenn ich das richtig sehe ist das eine P5g1.
Probier mal bitte aus die im Büro max. 1 - 2 m von der CONNECT und / oder dem BOOST zu betreiben, und möglichst alle anderen Funk-Sender aus dem Raum entfernen.
Im freien Raum muss der NoiseFloor auf über 105 ansteigen.
Tut er das nicht, dann ist es auch möglich, dass hier ein Defekt vorliegt.

4.) grundsätzlich ist der NoiseFloor bei fast allen PLAYern nicht überagend.
- hast Die Geräte evtl. zu gut in / unter / hinter den Schränken / anderen Geräten verstaut ?!?
- da solltest Du mal sehen, dass durch Positionsänderung (manchmal auch nur geringfügig) Werte min. über 100 erreicht werden.

5.) das mit der geschlossenen Balkon-Tür hängt ab von den dort verbauten Scheiben.
Modernes Iso-Glas ist im LZR zwecks besserer Wärmedämmung oft mit einer ganz dünnen Alu-Schicht bedampft.
- das würde erklären warum die Verbindungswerte dann bei geschlossener Tür noch weiter in die Knie gehen.

viel Erfolg und berichte mal ...
... ggf. setzt Du ja auch noch eine aktuelle Diagnose ab damit ein Techniker nochmal drüber schaut.
- die haben weit mehr Daten vorliegen und auch noch andere Tools ...

v.G. // Peter
Hi Steve, noch eine kleine Ergänzung.

6.) was mich ein wenig wundert bzw. irritiert sind die rech schlechten Weak- und ANI-Werte der SONOS-Geräte.
- das ist eigentlich ein Zeichen dafür, dass die Geräte Interferenzen von anderen WLAN-Kanälen ausgesetzt sind.
Du schreibst, dass deine Fritte und die 1750Es auf Kanal 11 und SONOS auf 6 eingestellt sind.
Dieser Kanalabstand reicht nur, wenn die Fritte und die 1750er mit 20 MHz BandBreite arbeiten !
- bei 40 MHz stören die AVM-Geräte den Kanal 6 gehörig.
- da bleibt als ungestörter Kanal für SONOS dann nur Kanal 1, oder die strikte Reglementierung auf 20 MHz BandBreite.

7.) ein weiterer Punkt, auf den Du nicht eingegangen bist, ist Deine Somfy Tahoma Box.
Das ist, wenn ich mich recht entsinne, ein echtes "Universalgenie" was die SMART-Home-Funkprotokoll-Unterstützung angeht.
Das kann aber auch das Universalgenie für WLAN-Störungen bedeuten !?
- all die dort unterstützten Protokolle wie IO Homecontrol, RTS, ZigBee, usw laufen auch im 2,4G-ISM-Band.
- das kann auch die Quelle der Interferenzen sein!?
Was nutzt Du da alles über diese Box ???
Hast Du diese mal testweise ausgeschaltet und Dir dann die SONOS-Matrix angeschaut ?
- irgend woher müssen die Störungen ja kommen?!

Auch die DECT-Telefone sind immer wieder gerne genannt als pot. Störquellen für WLAN.
Die lassen wir hier aber (zunächst) mal ausgeklammert, es sei denn Du hättest sie direkt auf einem SONOS-Gerät platziert, was aus Deiner Skitze aber anders hervor geht.

... in diesem Sinne.
Abzeichen
Hallo Peter,

was soll ich sagen, TAUSEND DANK! :D

Unglaublich, was du dir hier für eine Mühe gemacht hast. Absolut super.

Leider bin ich heute nur kurz zu Hause und hatte keine echte Möglichkeit, etwas zu testen. Deshalb vorab nur ein kurzes Feedback.

Habe mal mit den Aufstellorten schnell mal getestet, macht gravierende Unterschiede! Zum anderen habe ich jetzt auf Kanal 1 gewechselt. Connect und Boost hängen jetzt auch beide an der FB. DANKE für die wertvollen Tipps. Zu den anderen Punkten gehe ich Dienstag ein. Da bin ich dann abends auch wieder zu Hause. Ich lade dann auch nochmal neuere Daten rauf.

Sorry, dass ich jetzt so kurz bin.

Ach ja, die Tür, ist ne spezielle Schallschutztür (52 dB) ... das dürfte der Grund sein.

Dir/ euch einen schönen Sonntag Abend!

LG
Steve

P.S. Tolles Forum!
[...] 2.) die BOOST hängt an der Fritte, und die CONNECT (Büro) an einem Switch, der dann an der Fritte hängt.
Das ist eher suboptimal, um nicht zu sagen schlecht ! [...]

Warum ist das keine gute Idee? Ich frage aus persönlichen Gründen, wegen einer möglichen Umstrukturierung meines Heimnetzes.
Naja, ein Switch heißt deshalb Switch weil er halt switched, also die Verbindungen der einzelnen Ports durchschaltet.
Muss er das über den Uplink-Port zu einem anderen Switch tun, dann "schaltet" er zwar auch, aber der Uplink ist ein shared-Medium, auf dem sich dann auch noch der Traffic der anderer Ports tummelt.
Jetzt könnte man kommen mit ... ja, das ist nur relevant bei größeren Netzen und ...
Das stimmt schon, aber in größeren Netzen werden auch (genau deshalb) weit höherwertige Switche mit FC-Uplink und der x-fachen Switchleistung eingesetzt.
Und gerade SONOS ist bekannt für sein "recht kommunikatives Verhalten" im Netz, und zudem recht anfällig auf Verzögerungen (Latenzen).
Des weiteren kommt bei einer Verbindung über einen Uplink über einem (oder auch mehrerer) anderen Switch immer ein weiterer Hop hinzu, was STP als höhere Preis (Cost) für die Route ermittelt.
- diese Kosten gilt es aber möglichst gering zu halten.
- genau deshalb setzt man ja eine LAN-Verbindung ein, weil hier die Cost per se auf Grund der höheren Übertragungsrate schon geringer ist.
- warum also diesen Gewinn durch eine höhere Hop-Zahl wieder zu nichte machen.
Es gibt noch x weitere Faktoren, u.a. auch abhängig von der eingesetzten HW, die alle hier aufzuführen würde IMO aber den Rahmen sprengen.
Kurz und einfach zusammengefasst heißt die Devise im Grunde "so einfach und kurz wie möglich", wobei sich "einfach" auf die Menge der HW und "kurz" auf die Anzahl der Knoten bezieht.
- genau deshalb sollte man auch möglichst keine Kaskaden von Switches aufbauen.
Hier ist wie so oft weniger mehr.
Einfach überlegen wie die einzelnen Kommunikationswege sind, und die jeweiligen Partner auf den einzelnen Ebenen zusammenfügen. - oder gleich einen 24 oder 48-Port-Web-Smart-Switch verwenden und alles darauf abstützen.
Danke, Peter, für die ausführliche Erläuterung.
Abzeichen
@Peter_13:

Hier jetzt nochmal die vollständigen Antworten auf deine sehr hilfreidhen Anmerkungen:

WLAN deaktiviert - damit meinte ich, in SONOS kann ich ja die "Wireless Einrichtung" vornehmen und das vorhanden WLan zusätzlich zum SONOS-Netz nutzen, wenn ich das richtig verstehe. Diese zusätzliche WLan Nutzung via SONOS habe ich nicht aktiviert.

zu 1: den Boost habe ich zunächst im Büro umpositioniert und festgestellt, dass der Aufstellort einen enormen Unterschied macht (Stichwort "Sichtverbindung"). Ich habe ihn auch mal ins Wohnzimmer gestellt, ohne LAN-Anbindung. Das brachte die besten Ergebnisse. Nach dem Post lade ich nochmal ein paar Daten hoch. Da kann man das prima sehen. Was mir in dem Zusammenhang auch auffiel, wie instabil die Verbindung ist. Hier habe ich enorme Schwankungen (bei unveränderten Aufstellbedingungen).

zu 2: wie geschrieben - jetzt beides an FB

zu 3: Ist eine P5g1 - war mir nicht bewusst, da die empfangsseitig so schwach auf der Brust ist. Am Ende lade ich PhyErr Werte hoch. Aber so schlecht sahen die gar nicht aus. Zumindest nicht bei der P5. Im Wohnzimmer, bei späteren Messungen (ggf. durch Somfy/Tahoma Box, Denon AVR X4200W oder den Sky Receiver - der fehlt nämlich in meiner Skizze vom Anfang).

zu 4: was bedeutet der NoiseFloor Wert? Ansonsten stehen die Geräte eigentlich gut. D.h. keine Schränke. Der TV hängt an einem Spectrum Ständer, der unten zwei Glasplatten hat, dahinter steht im Wohnzimmer der Connect. Ich nehm ihn mal auf die Glasplatte (ich sag nur Terrassenscheibe ...). Im Büro steht er frei. In der Küche im Rahmen der Möglichkeiten ganz OK (also weitestgehend frei). Allerdings hatte bisher nur der Boost Werte > 100. Aber ich experimentier mal.

zu 5: Schallschutz-Tür, 52 dB ...

zu 6: was sagt der Weak-Level denn aus und was ist der ANI-Wert (diese Rookies ... :?). SONOS steht jetzt auf Kanal 1 - FB auf 11. So weit so gut.

zu 7: ein ziemlich spannender und vielleicht sogar entscheidender Punkt. Habe heute Abend mal Tahoma, sky Receiver und Denon AVR nacheinander vom Strom genommen. Danach wurde es immer etwas besser. Besonders der sky Receiver stänkert glaube ich ordentlich rum. Mit Somfy läufen die Rolläden und die Markise. DECT Telefone ... hm. Habe gerade ein zweites C4 in Betrieb genommen.

Mal die große Bitte an dich. Es gibt ja das eine oder andere Tool, mit dem man via Smartphone mal die Umgebung scannen kann. Hatte die AVM mal drauf, ist aber irgendwie recht kryptisch (für mich). Hast du da noch nen anderen Tipp?

Ansonsten was wäre dein weiterer Tipp? Trial and Error und immer mal für kurze oder längere Zeit das eine oder andere Gerät vom Strom?

Ich hatte vor eingen Wochen mit dem SONOS Support Kontakt, die hatten nämlich auch mal einen kurzen "Ausschlag" feststellen können. Ist eben die Frage, ob es EIN Gerät ist, oder die Summe aller Geräte (so wenige sind es ja nicht), die sich ggf. auch überlagern.

Nochmal VIELEN DANK. Du hast mir schon ne Menge guter Tipps an die Hand gegeben. Alleine der Empfang des P5 ist schon mit den vorgenommenen Maßnahmen spürbar besser! Bin gespannt, ob die Abbrüche (auch anderer Räume) jetzt besser werden oder sogar aufhören. 😃
Abzeichen
Hier nochmal einige Messungen ...
Abzeichen
... und noch ein paar Daten
Abzeichen
noch ne Ergänzung ...

Ich hatte mit den sehr hohen PhyErr Werten Somfy (Tahoma Box) in Verdacht. Das kann auch aber der sky Receiver gewesen sein. Der läuft ja mehrfach am Tag an.

Deswegen, wenn es irgendein schlaues Tool gibt, mit dem ich mein Netzwerk auf solche Aktivitäten überwachen kann, wäre ich für einen Tipp von euch dankbar.
Also, Netzwerk so überwachen, wie Du es Dir evtl. vorstellst ... ja, das geht sogar mit Windows-Boardmitteln. Erfordert aber einiges an Kenntnis, um nicht zu sagen Profi-Wissen. Ebenso der Einsatz von Wireshark.
Als WLAN- Scanner nutze ich auch am liebsten die "Fritz!-WLAN App", zumal die in Verbindung mit einer Fritte eine echte Durchsatz-Messung mit Hilfe von JPerf gestattet. - in der Fritte muss natürlich der JPerf-Deamon aktiviert sein, was über das Support-Menü ja aber überhaupt kein Problem ist.

"Eins" noch zu Deinen Matrixen (wie ist eigentlich der Plural von den Dingern ?! - hm, egal).

1. musst Du nach dem Umstellen von solchen Geräten wie der BOOST grundsätzlich ALLE Player einmal durchstarten (erst die LAN-verbunden und dann den Rest), danach auf jeden Fall mindestens 10 Min. warten und auch Last auf die Büchsen geben (also am besten alle gruppieren und irgendwas streamen), denn das SONOS-Net mit seinem STP brauch ein wenig um sich neu zu organisieren.
- der WZ war nämlich noch mit der CONNECT im Büro verbunden, obwohl die Verbindung zur BOOST fasst doppelt so gut war.

2. so wie ich Deine Versuche interpretiere wäre der optimalste Platz für den BOOST irgendwo im Flur, also genau zwischen Deinen beiden Versuchs-Aufbauten (Büro / WZ).
Und am allerbesten natürlich mit LAN-Anschluss, wobei er dann auch im WZ stehen kann.
- die strecke vom Büro zum WZ ist für eine reine Funkverbindung einfach zu schlecht.
- wer weiß was da als Bausubstanz für die Wände Verwendung gefunden hat !?
- auf jeden Fall schirmen die recht gut ab.

Die Farben der Matrix und wie man die Werte interpretiert sind in nachfolgendem Thread erklärt.
https://de.community.sonos.com/installation-und-nutzung-223378/frage-zur-farbe-der-network-matrix-6739481/index1.html#post16000420
Da steht auch was der NoiseFloor bedeutet. - also wass es mit dem Signal-Rauschabstand auf sich hat.
Ansonsten ist dazu Tante Gockel oder die Wiki Dein Freund.

Und zu guter Letzt ...
... mich irritiert z.Bsp., warum das Ausschalten des Denon zwar im WZ nichts ändert, dafür aber den NoiseFloor der CONNECT im Büro dahin gehend beeinflusst, dass dieser bei in Richtung >= 100 wandert und damit von gelb nach grün wechselt.
Du hast meiner Meinung nach reichliche Quellen für Elektro-Smog und solltest überlegen welche Du davon zwingend benötigst. Das was auf dieser Liste dann nicht steht würde ich zunächst mal deaktivieren. - zumindest die entsprechenden Funk-Bestandteile wenn es möglich ist. - oder halt wo anders platzieren.
Ich weiß das wird Dir nicht gefallen, und es ist Sissifusarbeit, aber ohne dem bekommst Du IMHO keine vernünftige Umgebung zu stande.
Nach dem Motto "so wenig wie möglich, so viel wie nötig".

Ggf. setzt Du zu zwei / drei Setups auch mal jeweils eine Diagnose ab !?
Die SONOS-Jungs schauen sich die garantiert gerne mal an und liefern Ihre Kommentare dazu, denn Die haben noch weit mehr Möglichkeiten.

schönen Abend noch // Peter
Abzeichen
Guten Morgen Peter,

Wireshark kenne ich, müsste mich da aber ehrlich gesagt erst mal reinarbeiten. Würde ich, wenn möglich, gerne vermeiden.

zu 1: na, da hab ich ja so ziemlich alles falsch gemacht ... Danke für den wertvollen Tipp! Also Boost + Connect Büro mind. 10 min vom LAN nehmen ... aber was meinst du mit "Reset"?

zu 2: Flur ist schwierig. LAN erst Recht. Es gäbe da die aufwändige Möglichkeit mit Wand durchbohren und Boost im Flur an die Wand hängen. Ich würde im ersten Step mal die Wohnzimmer Variante ohne LAN wählen. Falls das hakt, dann wirklich per LAN im Flur positionieren.

Den Link zu Farben und Noisefloor schaue ich mir die Tage mal in Ruhe an.

Zum Thema Elektrosmog. Eigentlich bin (war) ich gerade bei diesem Thema immer sehr sensibel. Aber irgendwann "überholen" dich die Devices. Von daher, Trial & Error und vor allem mich wirklich intensiver mit den Störquellen und vor allem generell den Quellen zu beschäftigen. Da werde ich nicht drum herum kommen. Als erstes muss ich dazu mich mal in die Fritz!-WLAN-App einarbeiten. Denn so ganz selbsterklärend läuft die nicht.

Wobei mich im Büro wundert, eigentlich gibt es dort nur WLAN und das DECT-Telefon. Ach so und ein JABRA Pro 9470 Headset (läuft elenderweise auch auf DECT ...). Puh ... ich muss da mal ran. Zumal ich offen gesagt auch gerne dem einen oder anderen das "Strahlen" abgewöhnen oder verbieten würde. Falls das bei einigen Geräten (AV-Receiver) überhaupt geht.

Übrigens, mit den bisherigen Änderungen: Kanal 1, LAN beide an FB, Boost im Wozi hatte ich gestern kein einziges Problem am Abend. Die Verbindung, sprich Reaktionszeiten waren deutlich schneller als bisher. Also erste Erfolge. Den Rest muss ich mir erarbeiten.

Danke nochmal an dich und das Forum. Wirklich großes Kino. 🆒
zu 1: na, da hab ich ja so ziemlich alles falsch gemacht ... Danke für den wertvollen Tipp! Also Boost + Connect Büro mind. 10 min vom LAN nehmen ... aber was meinst du mit "Reset"?Ich hab nichts geschrieben von "mind. 10 min vom LAN nehmen", und auch nichts von "Reset".
Da steht ... ... grundsätzlich ALLE Player einmal durchstarten (erst die LAN-verbunden und dann den Rest), danach auf jeden Fall mindestens 10 Min. warten... - da war vermutlich noch ein wenig Schlaf in den Augen :?;)
Abzeichen
Tja, da denkst du, komm geht bei großer Schrift auch mal ohne Lesebrille ... 😉
Abzeichen
Sorry, aber ich muss trotzdem nochmal fragen. Mit "durchstarten" meinst du alle für ein paar Minuten stromlos machen (LAN zuerst), richtig?
Das ist im Alter nun mal so ... viel schlimmer ist dann eigentlich nur, wenn aus Rot auf einmal Grün wird. Das ist dann letztlich nur noch total blau zu ertragen ... 😛
Sorry, aber ich muss trotzdem nochmal fragen. Mit "durchstarten" meinst du alle für ein paar Minuten stromlos machen (LAN zuerst), richtig?Die "paar Minuten stromlos machen" ist noch nicht mal erforderlich. - Stecker raus und wieder rein reicht.
Oder remote mit "ip-adresse:1400/reboot"
- da braucht man noch nicht mal aufzustehen 😳
Abzeichen
...
Oder remote mit "ip-adresse:1400/reboot"
- da braucht man noch nicht mal aufzustehen :$

Wird ja immer besser ... 🆒
Abzeichen
Jetzt bin ich doch mal erst happy, dass die Werte schon mal besser aussehen. Auch wenn nach Reboot (vom Schreibtisch aus ;-)), 10 min warten und ansteuern aller Geräte als Gruppe, dann nach zehn Minuten mal wieder ein weiteres (altes) Problem auftaucht:

"Fehler beim Hinzufügen von Titeln (1001)"

Wollte mit dem Android Smartphone das Abspielen beenden. Rien ne va plus ...

Irgendeine Idee, was das ausgelöst haben kann?