Beantwortet

Netzwerk & Repeater...?!


Abzeichen
Hallo,
zur Situation:
Vor einem halben Jahr habe ich mir einen Sonos Play 1 gekauft. Die Instllation lief nicht reibungslos, was aber mein Fehler war (im Router war nicht eingestellt, dass die Geräte untereinander kommunizieren dürfen).
Das Gerät ist per WLan-Angeschlossen und steht praktisch 1,5 Meter neben der FritzBox entfernt im Wohnzimmer und läuft tadellos.
Am Wochenende habe ich dann einen zweiten Play 1 gekauft, der in der Küche stehen soll. Die Einrichtung war wieder etwas tricky. Ich wollte ihn direkt in der Küche ans Laufen bringen, was aber nicht ging. Also habe ich ihn in der Nähe des Routers per WLan eingebunden. Kurz liefen gar keine Sonos mehr, aber dann gingen beide, so wie sie laufen sollen.
Nun habe ich den zweiten in die Küche gestellt und andauern Aussetzer gehabt. In der FritzBox habe ich gesehen, dass das Signal nur Mittelmäßig ist. Wenn ich Songs vom NAS abspielen wollte, gab es immer wieder Fehlermeldungen.
Dann habe ich einen FritzRepeater gekauft und ihn zwischen FritzBox und 2. Sonos im Flur platziert. Dann habe ich das 2. Sonos vom Strom genommen, kurz gewartet und wieder eingeschaltet. Das 2. Sonos hat sich dann über den Repeater mit dem WLan verbunden die Signalstärke war besser, aber es gab noch ein paar wenige Aussetzer. Dann habe ich den Repeater auch in der Küche installiert (nur 3m näher zum Router) und nun Top Siganlstärke. Nun habe ich bisher keinerlei Verbindungsabbrüche mehr. Also alles top.

Dazu habe ich aber ein paar Fragen:
- Ich habe hier im Forum bei der Suche nach Lösungen immer wieder gelesen, dass man keinen Repeater nehmen soll. Warum nicht?
- Auch habe ich gelesen, dass man keine Updates über den Repeater installieren soll und diesen dafür ausschalten soll. Warum soll man das?
Eigentlich weiss das Sonos doch gar nicht, ob ein Repeater dazwischen ist, oder? Es ist ja "nur normal im WLan"...
- Und ich habe gelesen, dass (speziell Fritz-) Repeater bestimmte Daten in der Standard-Konfiguration nicht "weiterleiten" (o. ä.) - ich kann da aber nichts einstellen. Was ist damit gemeint?

Grüße, MarcoCol
icon

Beste Antwort von Perpugilliam 28 January 2019, 22:35

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

48 Antworten

[...] Dazu habe ich aber ein paar Fragen:
- Ich habe hier im Forum bei der Suche nach Lösungen immer wieder gelesen, dass man keinen Repeater nehmen soll. Warum nicht?
- Auch habe ich gelesen, dass man keine Updates über den Repeater installieren soll und diesen dafür ausschalten soll. Warum soll man das?
Eigentlich weiss das Sonos doch gar nicht, ob ein Repeater dazwischen ist, oder? Es ist ja "nur normal im WLan"...
- Und ich habe gelesen, dass (speziell Fritz-) Repeater bestimmte Daten in der Standard-Konfiguration nicht "weiterleiten" (o. ä.) - ich kann da aber nichts einstellen. Was ist damit gemeint?

Okay, dann wiederhole ich noch mal, was Du schon gelesen hast:

Repeater neigen dazu, Datenpakete zu blockieren, die für Sonos essenziell sind. Schalte den/die Repeater bitte vorübergehend aus und starte zuerst die Fritzbox und anschließend alle Sonos-Komponenten neu, damit sich diese mit dem Router, statt mit dem Repeater, verbinden können.


Wenn die Repeater einen eigenen Mac-Filter haben, dann kann man dort die Mac-Adressen der Sonos-Player eintragen, sodass sich diese nicht mehr damit verbinden. Das Beste wäre eine Sonos-Komponente dauerhaft mit dem Router zu verkabeln, wenn dies nicht möglich ist, musst Du immer darauf achten, dass sich kein Player mit dem/den Repeatern verbindet. Also, wenn ein Update ansteht, vorher die Repeater ausschalten, das gleiche gilt auch, wenn ein Update für den Router ansteht oder dieser aus einem anderen Grund neu gestartet werden muss.

https://support.sonos.com/s/article/3209?language=de
Benutzerebene 6
Abzeichen +3
[...]Dazu habe ich aber ein paar Fragen:
- Ich habe hier im Forum bei der Suche nach Lösungen immer wieder gelesen, dass man keinen Repeater nehmen soll. Warum nicht?
- Auch habe ich gelesen, dass man keine Updates über den Repeater installieren soll und diesen dafür ausschalten soll. Warum soll man das?
Eigentlich weiss das Sonos doch gar nicht, ob ein Repeater dazwischen ist, oder? Es ist ja "nur normal im WLan"...
- Und ich habe gelesen, dass (speziell Fritz-) Repeater bestimmte Daten in der Standard-Konfiguration nicht "weiterleiten" (o. ä.) - ich kann da aber nichts einstellen. Was ist damit gemeint?

Okay, dann wiederhole ich noch mal, was Du schon gelesen hast:

Repeater neigen dazu, Datenpakete zu blockieren, die für Sonos essenziell sind. Schalte den/die Repeater bitte vorübergehend aus und starte zuerst die Fritzbox und anschließend alle Sonos-Komponenten neu, damit sich diese mit dem Router, statt mit dem Repeater, verbinden können.


Wenn die Repeater einen eigenen Mac-Filter haben, dann kann man dort die Mac-Adressen der Sonos-Player eintragen, sodass sich diese nicht mehr damit verbinden. Das Beste wäre eine Sonos-Komponente dauerhaft mit dem Router zu verkabeln, wenn dies nicht möglich ist, musst Du immer darauf achten, dass sich kein Player mit dem/den Repeatern verbindet. Also, wenn ein Update ansteht, vorher die Repeater ausschalten, das gleiche gilt auch, wenn ein Update für den Router ansteht oder dieser aus einem anderen Grund neu gestartet werden muss.

https://support.sonos.com/s/article/3209?language=de


Danke dir.
Wenn einem die Performance wichtig ist, dann verzichtet man auf Repeater. Zumindest, um Sonos zu nutzen.
Hier ist die Boost-Einrichtung besser. Man kann aber auch einen Player direkt mit dem Router verkabeln.

Gruß,
Daniel
Abzeichen
Um ehrlich zu sein, verstehe ich das mit dem Repeater nicht, aber wenn es da tatsächlich zu Problemen kommt, suche ich eine andere Möglichkeit.
Also wenn ich so auf den Repeater verzichte, dann habe ich andauernd Abbrüche und Aussetzer. Wenn das die Lösung wäre, würde ich das ganze Sonos-System nicht mehr erweitern und langfristig rausschmeißen, um ehrlich zu sein.

Das mit dem SonosNet habe ich nun erst gelesen und das werde ich später probieren. Ich kann glücklicherweise einen Play 1 direkt per Kabel an den Router anschließen, wobei dann ein Effekt vom Sonos (mal eben den Raum wechseln) nicht mehr so leicht geht - aber es geht in meinem Fall und ist ok. Danach werde ich die IP-Config-Daten im anderen Gerät löschen und das Gerät neu starten. Eigentlich müsste sich das Gerät dann automatisch am anderen Sonos per SonosNet anmelden und alles prima laufen.
Eine Frage nur dazu: Die Apps auf iPad, Android und dem PC, muss da auch was eingestellt werden? Und was ist mit den PlayLists usw. müssen (können) die gespeichert werden oder sind die weg?
[...] Das mit dem SonosNet habe ich nun erst gelesen und das werde ich später probieren. Ich kann glücklicherweise einen Play 1 direkt per Kabel an den Router anschließen, wobei dann ein Effekt vom Sonos (mal eben den Raum wechseln) nicht mehr so leicht geht - aber es geht in meinem Fall und ist ok. Danach werde ich die IP-Config-Daten im anderen Gerät löschen und das Gerät neu starten. Eigentlich müsste sich das Gerät dann automatisch am anderen Sonos per SonosNet anmelden und alles prima laufen.
Natürlich geht das.

Wechsle erstmal ins SonosNet (vorher alle Repeater vorübergehend ausschalten): Einen Player mit dem Router verkabeln und anschließend das WLAN-Kennwort wie folgt zurücksetzen:

Sonos Controller-App für iOS oder Android: Tippe im Sonos-Musikmenü auf „Einstellungen“ > „Erweiterte Einstellungen“ > „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.


Mindestens 10 Minuten warten. Danach in der Sonos App 'Einstellungen --> Über mein Sonos-System' aufrufen. Wenn neben jedem Player WM:0 steht, dürfen die Repeater wieder ans Netz.


Eine Frage nur dazu: Die Apps auf iPad, Android und dem PC, muss da auch was eingestellt werden? Und was ist mit den PlayLists usw. müssen (können) die gespeichert werden oder sind die weg?
Nein, muss eigentlich nichts eingestellt werden, Du kannst aber in den 'Erweiterten Einstellungen' die App zurücksetzen, sollte die Anzeige nicht stimmen. Playlisten und Einstellungen werden beim Wechsel übernommen.


Sollte es danach noch Fragen geben, frag einfach.
Abzeichen
Ok, das werde ich mal versuchen.
Also Repeater ausschalten und dann beide Sonos ausschalten???
Dann einen Sonos per Kabel an den Router, dann erst den 2. einschalten
Also alles einstellen, dann auf der Seite "Wireless-Einrichtung" auf "Zurücksetzen" und dann auf "Fertig". Dann 10 Minuten warten und in den Einstellungen schauen.
Den Repeater habe ich ja nur für das Sonos gekauft, den würde ich danach nicht mehr nutzen, wenn alles wie erhofft klappt.
Danke
Ok, das werde ich mal versuchen.
Also Repeater ausschalten und dann beide Sonos ausschalten???

1) Nur Repeater ausschalten.
2) einen Player mit dem Router verkabeln
3) das WLAN-Kennwort wie folgt zurücksetzen:

Sonos Controller-App für iOS oder Android: Tippe im Sonos-Musikmenü auf „Einstellungen“ > „Erweiterte Einstellungen“ > „Wireless-Einrichtung“. Klicke im Bildschirm „Wireless-Einrichtung“ auf die Schaltfläche „Zurücksetzen“. Klicke im nächsten Bildschirm auf „Fertig“.

4) Mindestens 10 Minuten warten
5) Danach in der Sonos App 'Einstellungen --> Über mein Sonos-System' aufrufen. Wenn neben jedem Player WM:0 steht, dürfen die Repeater wieder ans Netz
Abzeichen
Wie geschrieben: Den Repeater schalte ich aus und er wird auch gar nicht mehr eingeschaltet, wenn es über das SonosNet klappt. Aber muss ich nach 2. oder 3. einen oder beide Sonos ausschalten, oder werden sie gar nicht ausgeschaltet und den Sprung vom WLan zum SonosNet handelt die Software?
Wie geschrieben: Den Repeater schalte ich aus und er wird auch gar nicht mehr eingeschaltet, wenn es über das SonosNet klappt. Aber muss ich nach 2. oder 3. einen oder beide Sonos ausschalten, oder werden sie gar nicht ausgeschaltet und den Sprung vom WLan zum SonosNet handelt die Software?
Ja. Der verkabelte Player wird zum Systemkoordinator.
Abzeichen
Ok. Dann schalte ich die beiden Sonos gar nicht aus und befolge später die Punkte 1-5 und bin gespannt... :)
Ich werde dann berichten.
Benutzerebene 6
Abzeichen +3
Um ehrlich zu sein, verstehe ich das mit dem Repeater nicht, aber wenn es da tatsächlich zu Problemen kommt, suche ich eine andere Möglichkeit.
Also wenn ich so auf den Repeater verzichte, dann habe ich andauernd Abbrüche und Aussetzer. Wenn das die Lösung wäre, würde ich das ganze Sonos-System nicht mehr erweitern und langfristig rausschmeißen, um ehrlich zu sein.

Das mit dem SonosNet habe ich nun erst gelesen und das werde ich später probieren. Ich kann glücklicherweise einen Play 1 direkt per Kabel an den Router anschließen, wobei dann ein Effekt vom Sonos (mal eben den Raum wechseln) nicht mehr so leicht geht - aber es geht in meinem Fall und ist ok. Danach werde ich die IP-Config-Daten im anderen Gerät löschen und das Gerät neu starten. Eigentlich müsste sich das Gerät dann automatisch am anderen Sonos per SonosNet anmelden und alles prima laufen.
Eine Frage nur dazu: Die Apps auf iPad, Android und dem PC, muss da auch was eingestellt werden? Und was ist mit den PlayLists usw. müssen (können) die gespeichert werden oder sind die weg?


Ich meinte mit meiner Antwort auch, dass du das Sonosnet für Sonos nutzen solltest und deine Controller dann über die Repeaeter verbinden kannst.
Es hat nur seine Gründe, warum wir schreiben, dass wir die Nutzung von Repeatern nicht empfehlen:
https://support.sonos.com/s/article/126?language=de

Gruß,
Daniel
Ich meinte mit meiner Antwort auch, dass du das Sonosnet für Sonos nutzen solltest und deine Controller dann über die Repeaeter verbinden kannst.
Es hat nur seine Gründe, warum wir schreiben, dass wir die Nutzung von Repeatern nicht empfehlen:
https://support.sonos.com/s/article/126?language=de

Gruß,
Daniel

Das geht problemlos? Muss ich mir merken.
Abzeichen
Aber ich dachte, dass Sonos sein eigenes Netz - neben dem WLan aufbaut und in meinem Fall der Repeater dann nicht mehr verwendet wird?!
Aber ich dachte, dass Sonos sein eigenes Netz - neben dem WLan aufbaut und in meinem Fall der Repeater dann nicht mehr verwendet wird?!
So ist es auch. Wenn Du den Repeater nicht zur Verstärkung des Router-WLANs braucht, kannst Du ihn entsorgen.
Benutzerebene 6
Abzeichen +3
Aber ich dachte, dass Sonos sein eigenes Netz - neben dem WLan aufbaut und in meinem Fall der Repeater dann nicht mehr verwendet wird?!

Ich glaube, ich habe mich blöd ausgedrückt.
Verkabelst du eine Sonos-Komponente, dann baut sich das SonosNet auf die die Sonos-Geräte nutzen das.
Deine Mobiltelefone verbinden sich dann mit dem Heim-Wlan.
Solange du nicht die Musik vom Mobiltelefon streamst, sondern die Musik von TuneIn oder einem Musikdienst startest, kann sich das Mobiltelefon ruhig mit dem Repeater verbinden.
Solange du nicht die Musik vom Mobiltelefon streamst, sondern die Musik von TuneIn oder einem Musikdienst startest, kann sich das Mobiltelefon ruhig mit dem Repeater verbinden.Das sollte man in

ganz großen Lettern

dann aber nochmal hervorheben. 😉
Abzeichen
Ok. Ich starte Radio nur von TuneIn und Spiele Songs vom NAS. Da bleiben die Playlists aber ja erhalten.
Ich teste alles nachher 🙂
Abzeichen
So.
Ich habe die Punkte befolgt und von der Einrichtungsseite hat alles geklappt:
Unter "Über mein Sonos-System" steht neben den beiden Playern WM:0 und auch die Playlists usw. sind noch da. Soweit so gut.
Den Repeater habe ich nicht angeschlossen und in der Fritzbox sind beide Player nicht mehr im WLan aufgelistet.

Dann kam der erste Start am System, was mit dem Router verbunden ist: Alles prima, so wie vorher.
Und dann der erste Start mit dem anderen System in der Küche: Da kamen direkt Aussetzer - genau so wie es vorher ohne Repeater war. Wenn ich in der Küche einen (TuneIn-) Radio-Sender starte, dann kann es schnell klappen, aber auch mal 20 Sekunden dauern, Abbrüche danach kommen auch immer wieder.
Songs vom NAS abspielen ist ein Glücksspiel, mal klappt es (auch mit Aussetzern), mal werden sie mit dem Hinweis "1002" gar nicht gestartet, oder er spielt den Song an und dann kommt eine Meldung nach 10-20 Sekunden, dass der Song eine falsche Codierung hätte (mit dem Repeater lief der Song problemlos und auch wenn es ich es später nochmal probiere klappt es!).

Das ist leider alles andere als zufriedenstellend und das gleiche Ergebnis wie vorher ohne Repeater 😞
So.
Ich habe die Punkte befolgt und von der Einrichtungsseite hat alles geklappt:
Unter "Über mein Sonos-System" steht neben den beiden Playern WM:0 und auch die Playlists usw. sind noch da. Soweit so gut.
Den Repeater habe ich nicht angeschlossen und in der Fritzbox sind beide Player nicht mehr im WLan aufgelistet.

Dann kam der erste Start am System, was mit dem Router verbunden ist: Alles prima, so wie vorher.
Und dann der erste Start mit dem anderen System in der Küche: Da kamen direkt Aussetzer - genau so wie es vorher ohne Repeater war. Wenn ich in der Küche einen (TuneIn-) Radio-Sender starte, dann kann es schnell klappen, aber auch mal 20 Sekunden dauern, Abbrüche danach kommen auch immer wieder.
Songs vom NAS abspielen ist ein Glücksspiel, mal klappt es (auch mit Aussetzern), mal werden sie mit dem Hinweis "1002" gar nicht gestartet, oder er spielt den Song an und dann kommt eine Meldung nach 10-20 Sekunden, dass der Song eine falsche Codierung hätte (mit dem Repeater lief der Song problemlos und auch wenn es ich es später nochmal probiere klappt es!).

Das ist leider alles andere als zufriedenstellend und das gleiche Ergebnis wie vorher ohne Repeater :(


Was für ein anderes System ?!
Abzeichen
Sorry, schlecht ausgedrückt: Anderes System in dem Fall: Der andere Sonos Play 1 in der Küche, der nicht direkt am Router angeschlossen ist und bisher am Repeater "hing" und der jetzt auch unter WM:0 angezeigt wird.
ruf mal bitte im Browser die Seite " IP-ADRESSE:1400/support/review " auf.
- den Platzhalter IP-ADRESSE tauscht Du gegen die IP der P1 (am besten NICHT der der Küche) aus
Auf der erscheinenden Seite klickst Du auf den untersten Link "Network Matrix" und postets diese als ScreenShot hier.
Abzeichen
Here you go.
Ändere bitte unter Auf iOS oder Android: „Mehr“ --> „Erweiterte Einstellungen“ --> „SonosNet-Kanal“ auf 1,6,11 und entsprechend dazu den WLAN-Kanal des Routers. Heißt, teste folgende Kanalkombinationen durch: 1/6 bzw. 6/1, 6/11 bzw. 11/6, 11/1 bzw. 1/11. Verstehst Du, was ich meine?
Abzeichen
Ja. Ich teste die Kombinationen...
Provoziere bitte das Fehlerbild mit den Aussetzern bei der P1-Küche und setze dazu eine Diagnose ab.
Danach gruppiere die Beiden P1er und lass das ganze 10 weitere Minuten (auch wenn es grässlich ist) mit den Fehlern spielen und setze eine weitere Diagnose ab.
- die ID's bitte beite (mit Beschreibung was was ist) hier dann posten.
Das muss sich Daniel / SONOS in den Logs genauer anschauen.

Hintergrund:
Mit den Verbindungswerten, selbst wenn sie gelb sind, müsste das System eigentlich (nahezu) einwandfrei laufen !
- 29 / 33 ist zwar nicht gerade der "Brüller", aber noch lange kein Wert wo solche Aussetzer / Fehler kommen.
Da muss die Ursache ggf. noch wo anders liegen ?!

PS zu: Ändere bitte ... „SonosNet-Kanal“ ...IMHO besteht lt. der Matrix kein Grund / Anlass dafür !
Es sind keine Interferenzen vorhanden !
Der ANI-Level steht mit 0 (bzw. 1) auf dem Bestwert (0) !

Und die schwachen Verbindungswerte der PLAYer begründet sich auf die Entfernung und die baulichen Gegebenheiten zwischen den beiden P1ern.
Abzeichen
Soll ich also nun die Kanalkombinationen ausprobieren oder das Fehlerbild provozieren und die Diagnosen absetzen oder beides?
Noch zur Info: Im Router steht der Kanal auf "Automatisch"...
10 Minuten wären schön. Zumeist bricht das ja irgendwann ganz ab.