Musik spielt nicht weiter wenn länger als 2-3 Minuten Pause war - Airplay


Abzeichen

Hallo, 

wenn ich von meinem Macbook Air auf den One SL streame über Airplay, reichen oft schon weniger als 2-3 Minuten Pause und es kommt kein Sound nach erneutem Play anklicken. 

Airplay zeigt mir noch an dass das Gerät ausgewählt ist aber es kommt kein Sound.

Wenn ich dann kurz auf “Interner Lautsprecher” umstelle und danach wieder auf den Sonos, dann kommt auch wieder Sound.

Hab auch schon länger gewartet ob ich vielleicht zu ungeduldig bin. Aber es passiert einfach nichts. 

Gibt es da Abhilfe?

Gruß


43 Antworten

@spankmaster79, die Sonoskomponenten gehen nach 3 Minuten in den Ruhemodus, wenn sie kein Signal mehr empfangen. Und da sich Airplay von der Sonos-Methode der Wiedergabe unterscheidet, werden die Player durch Airplay womöglich nicht wieder geweckt. Aber ganz genau weiß das nur ein Sonos-Mitarbeiter.

Airplay1 ist nicht multiroomfähig, also fällt es wahrscheinlich nicht allzusehr ins Gewicht, wenn man nur einen ONE/ONE SL hat und hauptsächlich Musik streamt. Kritischer wird es bei Übertragung von Videos und Filmen sein, denn die Bitrate ist hier um ein Vielfaches höher.

 

Ich würde davon ausgehen, dass sich Apple bei der Weiterentwicklung von Airplay2 nur auf iOS konzentrieren wird (vielleicht gibt es technische Gründe dafür).

 

ok, das natürlich schlecht. Lässt sich dieser Intervall irgendwo konfigurieren? In der App hab ich dazu nichts gefunden. 

 

Nein, ist fix vorgegeben.

Habe das selbe Problem. Aber erst seit kurzem.

 

Dann bitte das nächste Mal eine Diagnose absetzen, die Bestätigungsnummer aufschreiben und mit dem Support in Verbindung setzen, damit der sich das anschauen kann.

System-Diagnosen senden

https://support.sonos.com/

Benutzerebene 3
Abzeichen +3

@mheller 

Hey willkommen in der Community,

ich bin mir nicht sicher, ob ihr ein gemeinsames Problem habt.

Eine One sollte natürlich unabhängig von der Farbe gleich gut funktionieren. Am besten wendet ihr euch noch mal an uns telefonisch, wenn es noch nicht läuft.

Telefon (Mo - Fr, 10:00 - 18:00) oder Chat (Mo - So, 10:00 - 18:00)

Meldet euch danach gerne weiterhin hier und haltet uns auf dem Laufenden.

 

Gruß

Nils

Abzeichen +1

2.4 GHz. WLAN und der Router sind glaube ich nicht die Ursache, zB. mein iPhone 12 Pro iOS 14.2.1 benutzt das selbe Netzwerk da funktioniert alles mit der Sonos One, sogar nach Stunden wenn ich nach der Pause Play drücke kommt nach 1-2 Sekunden der Ton. Beim iMac ob LAN oder WLAN gibt es das gleiche Problem. Also der Fehler liegt iwo beim OSX, AirPlay und dem One,

Hallo @ mheller

Richtig, soweit ich das bisher feststellen konnte und auch in diversen Diagnosen bestätigt wurde, nutzt iMac noch Airplay 1, was nicht so stabil ist wie Airplay 2. Ausnahme: die Musik App auf dem iMac/Macbook nutzt Airplay 2.
Beim iPad/iPhone wird Airplay 2 immer genutzt. 

 

@mheller, da wäre der Apple Support die richtige Anlaufstelle, schließlich ist Airplay deren Baby. Sonos ist bloß Empfänger, Apple der Sender.

Abzeichen +1

Habe ein Workaround für mich gefunden, funktioniert aber nur mit Logic Pro X.

Man wählt bei Ton im Control Center seine Sonos One (bei mir das Musikzimmer) aus, dann öffnet man Logic Pro X und wählt in Einstellungen AirPlay also Ausgangsgerät aus, Core Audio muss   auch ausgewählt sein. Logic muss nur weiterhin im Hintergrund geöffnet bleiben. Mit dem Setup funktioniert alles wie es soll ohne nervige Aussetzer/Pausen bei YouTube etc., Laut und Leiser Tasten auf der Tastatur funktionieren natürlich auch.

Nach dem Bildschirmschoner bleibt die Verbindung auch,

Nach Ruhemodus muss man lediglich die Sonos One im Control Center wieder kurz anklicken, Logic erkennt das Ausgabegerät dann von selbst wieder.

falls jemand mit dem AirPlay Problem Logic Pro X drauf hat ist das auf jeden Fall eine gute Notlösung.

LG

 

Abzeichen

@spankmaster79, die Sonoskomponenten gehen nach 3 Minuten in den Ruhemodus, wenn sie kein Signal mehr empfangen. Und da sich Airplay von der Sonos-Methode der Wiedergabe unterscheidet, werden die Player durch Airplay womöglich nicht wieder geweckt. Aber ganz genau weiß das nur ein Sonos-Mitarbeiter.

ok, das natürlich schlecht. Lässt sich dieser Intervall irgendwo konfigurieren? In der App hab ich dazu nichts gefunden. 

Abzeichen +1

Habe das selbe Problem. Aber erst seit kurzem.

Abzeichen +1

Seitens Sonos wurde wohl nichts an Airplay geändert. Das Wlan-Modul bleibt auch im Ruhemodus aktiv.

An meiner Konfiguration habe ich auch nichts geändert. Ich sollte den Speaker per LAN anschließen. Der Fehler war immer noch da. Nicht wirklich zufriedenstellend.

Apple soll mir nun weiterhelfen.

 

Vielleicht erreicht jemand der das Problem reproduzieren kann mehr bei Sonos.

Abzeichen +1

Selbe Problem hier, gab es eine Lösung?

ich hatte eine Sonos One hier in Schwarz, AirPlay über iMac , keine Probleme.

Den Sonos One in Schwarz habe ich zurückgeschickt da ich mich doch für weiß entschieden hatte. Nun mit der weißen One ständige Verbindungsprobleme, allein wenn ich paar Minuten keinen Ton habe über den iMac und dann etwas abspielen will gibt es bereits keine Verbindung mehr, dachte erst an einen Defekt am Gerät da dies mit der anderen One kein Problem war..

Keine Ahnung ist sehr nervig,

Abzeichen +1

Hallo, nochmal ja muss ich wohl morgen mal durchrufen. Ich habe zumindest hinbekommen das die Sonos One wieder erkannt wird, wenn mehr als ein paar Minuten Pause war.

Das Problem jetzt noch  , es braucht 2-3 Minuten bis der Ton über AirPlay 2 wieder kommt. Ist das echt Normal? 🙈

gibt es Einstellungen über den iMac die von Sonos Empfohlen sind um das zu ändern?

 

@mheller, welche macOS-Version läuft auf dem iMac? Wann hast du den iMac das letzte Mal neu gestartet?

Abzeichen +1

iMac Mid 2017 Big Sur das neuste Update.

bevor ich es heute Nachmittag nochmal ausprobiert habe. Also starte den öfters am Tag neu. 

@mheller, verbindet sich der ONE über 2.4 GHz oder 5 GHz? Die Reichweite von 5 GHz ist bescheiden. Verfügen beide Frequenzbänder über je eine eigene SSID oder ist Bandsteering aktiv? Bitte dem Router auch einen festen Kanal zuweisen, indem du die Kanäle 1,6,11 durchtestest.

Abzeichen +1

2.4 GHz. WLAN und der Router sind glaube ich nicht die Ursache, zB. mein iPhone 12 Pro iOS 14.2.1 benutzt das selbe Netzwerk da funktioniert alles mit der Sonos One, sogar nach Stunden wenn ich nach der Pause Play drücke kommt nach 1-2 Sekunden der Ton. Beim iMac ob LAN oder WLAN gibt es das gleiche Problem. Also der Fehler liegt iwo beim OSX, AirPlay und dem One,

Abzeichen +1

Komischerweise als es die Verbindung vom iMac und iPhone nach Pause garnichtmehr gefunden hatte war in den Sonos App-Einstellungen der Regler aktiviert für „ Standort bestätigen“ ( Wenn Sonos eine Weile lang nicht aktiv ist, bestätige, wo die Musik abgespielt werden soll) . Das habe ich deaktiviert so hat der One die Wiedergabegeräte wiedergefunden,

nur beim iMac braucht das halt viel zu lang.
 

Kann es sein das die Sonos App Einstellungen da Einwirkungen darauf haben das es am iPhone super funktioniert? 

Abzeichen +1

Ich hatte bis vorgestern mit Aussetzern und dem “Abschalten” nach längeren Pausen zu kämpfen. Mein Provider hat mir eine neue Fritz!Box zur Verfügung gestellt, was erstmal keine Abhilfe geschaffen hat.

 

Danach habe ich von WPA3 wieder auf WPA2 gewechselt. Zudem habe ich für 2,4 GHz den Funkkanal auf 11 gestellt und den Standart auf 802.11 g+b+n gewechselt. Irgendwas davon hat Abhilfe geschaffen. Es funktioniert wieder wie gewohnt.

Kann es sein das die Sonos App Einstellungen da Einwirkungen darauf haben das es am iPhone super funktioniert? 

 

Die Sonosapp kommt mit Airplay gar nicht in Berührung und die Komponenten sind rein Empfänger, nur Apple-Geräte können Sender sein. Airplay ist ressourcenhungrig, hast du die Energiespareinstellungen und außerdem die Datenschutzeinstellungen des iMac schon überprüft?

 

Normalerweise würde ich an dem Punkt raten mit dem Support zu telefonieren, ist nur die Frage inwieweit Sonos hier helfen kann und ob es nicht besser wäre sich gleich an Apple zu wenden.

Abzeichen +1

Schön zu hören dass es bei dir wieder funktioniert d28!:) Ja werde nochmal ein paar Änderungen in meinen Routereinstellungen ausprobieren.

 

Energiespar- und Datenschutzeinstellungen bin ich bereits durchgegangen, hab da auch nichts mehr gefunden was die Verbindung einschränken könnte. 
 

ich Probier ein paar Einstellungen später dann, mal sehen was der Sonos oder Apple Support sagen wenn’s nicht klappt.

danke euch auf jeden Fall,

LG

Angeblich beherrscht macOS seit Catalina Airplay2 umfassend. Was ist das, reines Marketinggeschwafel seitens Apple? :rolling_eyes:

Abzeichen +1

Also ich bekomme es hier nicht hin, habe alles mögliche probiert, bei 3 min Pause in einem YouTube Video braucht die One exakt 50 Sekunden / bei 15 min schon 5 min um wieder automatisch weiterzuspielen nach dem ich Play drücke.

 

die Jungs hier erörtern das Problem ganz gut falls es jemand lesen möchte, womöglich ein Problem seitens Sonos?..

 

https://www.reddit.com/r/sonos/comments/cz5n5j/airplay2_stops_working_after_long_pause/

Abzeichen +1

 

2.4 GHz. WLAN und der Router sind glaube ich nicht die Ursache, zB. mein iPhone 12 Pro iOS 14.2.1 benutzt das selbe Netzwerk da funktioniert alles mit der Sonos One, sogar nach Stunden wenn ich nach der Pause Play drücke kommt nach 1-2 Sekunden der Ton. Beim iMac ob LAN oder WLAN gibt es das gleiche Problem. Also der Fehler liegt iwo beim OSX, AirPlay und dem One,

Hallo @ mheller

Richtig, soweit ich das bisher feststellen konnte und auch in diversen Diagnosen bestätigt wurde, nutzt iMac noch Airplay 1, was nicht so stabil ist wie Airplay 2. Ausnahme: die Musik App auf dem iMac/Macbook nutzt Airplay 2.
Beim iPad/iPhone wird Airplay 2 immer genutzt. 

 

Okey Krass du hast recht, beim iMac AirPlay Lautstärke/Ausgabg den Sonos Raum ausgewählt in Apple Music sowie Apple TV funktioniert tadellos ohne Verzögerung nach einer Pause! Im neuen Safari in YouTube gibt es die AirPlay Auswahl mit dem Sonos Raum auch , nur leider geht dann bei mir garnichts mehr weder Video noch Ton. Übler Bug. 
Also verkauft Apple die Funktion bereits groß als AirPlay 2 Native in Big Sur, geht aber nur teilweise.. Ohmann hoffe die können das fixen mit einem Update irgendwann.

 

Abzeichen +1

Da kann man lang irgendwelche Router Einstellungen durchprobieren 😂 

Antworten