Musik spielt nicht weiter wenn länger als 2-3 Minuten Pause war - Airplay


Abzeichen

Hallo, 

wenn ich von meinem Macbook Air auf den One SL streame über Airplay, reichen oft schon weniger als 2-3 Minuten Pause und es kommt kein Sound nach erneutem Play anklicken. 

Airplay zeigt mir noch an dass das Gerät ausgewählt ist aber es kommt kein Sound.

Wenn ich dann kurz auf “Interner Lautsprecher” umstelle und danach wieder auf den Sonos, dann kommt auch wieder Sound.

Hab auch schon länger gewartet ob ich vielleicht zu ungeduldig bin. Aber es passiert einfach nichts. 

Gibt es da Abhilfe?

Gruß


43 Antworten

Abzeichen +1

Habe ein Workaround für mich gefunden, funktioniert aber nur mit Logic Pro X.

Man wählt bei Ton im Control Center seine Sonos One (bei mir das Musikzimmer) aus, dann öffnet man Logic Pro X und wählt in Einstellungen AirPlay also Ausgangsgerät aus, Core Audio muss   auch ausgewählt sein. Logic muss nur weiterhin im Hintergrund geöffnet bleiben. Mit dem Setup funktioniert alles wie es soll ohne nervige Aussetzer/Pausen bei YouTube etc., Laut und Leiser Tasten auf der Tastatur funktionieren natürlich auch.

Nach dem Bildschirmschoner bleibt die Verbindung auch,

Nach Ruhemodus muss man lediglich die Sonos One im Control Center wieder kurz anklicken, Logic erkennt das Ausgabegerät dann von selbst wieder.

falls jemand mit dem AirPlay Problem Logic Pro X drauf hat ist das auf jeden Fall eine gute Notlösung.

LG

 

Abzeichen +1

Ja habe ich heute, das Problem ist angeblich  seitens Apple Support nicht bekannt, 

Die Schritte die mir vorgeschlagen wurden muss ich erst noch ausprobieren,

Soll den Mac mal im abgesicherten Modus starten und dann nochmal ausprobieren ob das Besserung bringt. Wenn nicht, 

NVRam oder PRAM zurücksetzen.

Nächster Schritt wäre das System neu zu installieren.

ja mal sehen, alles auf eigene Gefahr wegen Datenverlust😅

 

 

Wollte nur noch sagen das hat alles nichts gebracht bei mir:(

Abzeichen +1

Ja habe ich heute, das Problem ist angeblich  seitens Apple Support nicht bekannt, 

Die Schritte die mir vorgeschlagen wurden muss ich erst noch ausprobieren,

Soll den Mac mal im abgesicherten Modus starten und dann nochmal ausprobieren ob das Besserung bringt. Wenn nicht, 

NVRam oder PRAM zurücksetzen.

Nächster Schritt wäre das System neu zu installieren.

ja mal sehen, alles auf eigene Gefahr wegen Datenverlust😅

 

 

Abzeichen +1

Welches OS X habt ihr aktuell drauf? @d28 @d4nkuba @spankmaster79 

Ich habe das aktuelle BigSur drauf. Hatte das Problem aber auch schon mit dem alten System. Zudem war mein Problem Chrome/Youtube und die Sonos Lautsprecher und nicht Safari.

Komisch das Airplay 1 bei manchen rumzickt und bei anderen nicht. Hat denn jemand bei Apple schon eine Antwort bekommen?

Abzeichen +1

Vllt.

@mheller, da wäre der Apple Support die richtige Anlaufstelle, schließlich ist Airplay deren Baby. Sonos ist bloß Empfänger, Apple der Sender.

Abzeichen +1

Naja Sry da geht es auch um OS Geräte MacBook, Mac wenn man den Thread liest nü.

also ist es ein bekannter Bug über AirPlay 1?

bei manchen hier funktioniert das Sonos Gerät wie es soll, also schätze ich gibt es irgendeine Einstellung im Apple Betriebssystem für den Lag verantwortlich ist, Okey kann Sonos egal sein da ja nur AirPlay 2 unterstützt wird und das funktioniert ja richtig. 

@mheller, ich dachte, es gäbe nur Probleme unter Big Sur wegen Airplay1, warum kommst du mit einem Thread aus dem US-Forum an, wo es hauptsächlich um iOS-Geräte geht, die Airplay2-kompatibel sind?

 

Apple wird wegen Sonos macOS nicht AP2-fähig machen, Sonos ist auch nur einer von vielen Herstellern, deren Systeme AP2 unterstützen.

Abzeichen +1

Ich mein selbst wenn es ein Apple Problem ist , warum kümmert man sich bei Sonos nicht darum im Austausch mit Apple das so ein Problem behoben wird oder welche Einstellung im OSX das verursacht?? das wäre jetzt meine Vermutung wenn es bei manchen Nutzern funktioniert.

 Kann ich nicht verstehen..

Abzeichen +1

An meiner WLAN Infrastruktur liegt es jedenfalls definitiv nicht.

 

https://en.community.sonos.com/troubleshooting-228999/airplay-cuts-out-on-pause-6828388

 

Eine schnelle Lösung kann man wohl vergessen,

deprimierend so einen alten Beitrag zu finden ohne Lösung des Problems, übrigens wenn man die Sonos App auf dem iPhone auf hat, Play drückt am YouTube Video (Beispiel) und dann Play in der App geht der Ton sofort weiter ohne ewige Pause, aber toll ist das nicht.

Benutzerebene 7
Abzeichen +3

Also es scheint imo nur ein Bug von Big Sur und/oder Safari zu sein, dass man aus Safari nicht direkt über das z. B. bei YouTube eingeblendete AirPlay Symbol die Sonos Lautsprecher ansteuern kann. Da dreht sich nur der Kreis… :-(

Über das Audiomenü oben rechts in der Leiste funktioniert es bei mir allerdings ohne Probleme mit YouTube. Auch keine Aussetzer… die kommen imo eher durch ne nicht so tolle Wlan Infrastruktur. Da ist AirPlay recht anspruchsvoll. 
 

Da mein iMac auch nur ein 2015er mit 1,6GHz ist, sollte die Hardware da eher keine Bremse sein. 
 

Abzeichen +1

Leider geht das über Apple Music auch nicht normal über die Tastatur. Nur über den Slider den man aber ja mit dem Cursor ziehen muss..

 

Ich hab genau das gleiche Problem. Auf meinem MacBook Pro spielt Youtube nach einer Pause gar nicht mehr über die Sonos ab. Wenn ich allerdings über die Spotify App die Sonos auswähle funktioniert das deutlich besser. Problem ist nur, dass man dann zb nicht mehr laut und leiser über die Tastatur regeln kann, sondern nur noch in der Spotify App. Auch super nervig… Die Erklärung mit Airplay 2 würde dann hier aber ja auch Sinn machen.

@mheller Kannst du über Apple Music laut und leiser ganz normal steuern?

Abzeichen +1

Okey, ja ich glaube das liegt an Big Sur und Safari/YouTube. Ja nervt übelst, vllt wird das in Zukunft verbessert. Ich habe einen 2017 iMac , ob das nun auf einen 2020er laufen würde über die soundausgabe hat ich mich auch schon gefragt.


Aber jetzt haben sie mich, Apple Music abonniert darüber funktioniert AirPlay und der Sonos One wie es soll, ist halt nun mein YouTube Ersatz iwie wenn’s um Music und Music Videos geht die ich gern im Hintergrund mal laufen lass😏
 

 

@mheller das aktuellste os x, also big sur.. habe aber ein 2013er macbook. kann das daran liegen? 

 

verstehe halt nicht, warum das über handy ohne laggs geht.

 

aktuell kann ich z.b. nicht mal über safari airplay auf dem macbook was streamen, sondern muss das über die soundausgabe machen und habe dadurch die laggs.

 

habt ihr am macbook keine laggs? falls nicht, würde ich vllt mal ein neues macbook / boxen besorgen.. finde die boxen 1a aber die laggs gehen halt nicht klar..

Abzeichen +1

Welches OS X habt ihr aktuell drauf? @d28 @d4nkuba @spankmaster79 

Ich habe genau das selbe Problem..

Via iphone läuft alles super, wenn ich jedoch auf dem macbook über sound ins airplay gehe, dauert es unglaublich lange bis musik abgespielt wird. über safari lassen sich die boxen nichtmal connecten.

Abzeichen +1

Ja, es geht sofort weiter. Ich hatte die Probleme damals allerdings auch mit einem IPhone 12, welches ja eigentlich AirPlay 2 kann.

Abzeichen +1

Ich verstehe nur nicht wieso es bei mir jetzt wieder (dann wahrscheinlich unabhängig der Routereinstellungen) funktioniert.

Sehr gute Frage,

 ich glaub das einzige was ich glaube verändert habe war dass ich Apple TV App Test Abbo abgeschlossen und bei iCloud Sync was Eingestellt hab..

@d28 Wie ist das bei dir wenn du auf YouTube ein Video anschaust und Pause drückst, geht das bei Play sofort weiter?

 

Airplay1 ist nicht multiroomfähig, also fällt es wahrscheinlich nicht allzusehr ins Gewicht, wenn man nur einen ONE/ONE SL hat und hauptsächlich Musik streamt. Kritischer wird es bei Übertragung von Videos und Filmen sein, denn die Bitrate ist hier um ein Vielfaches höher.

 

Ich würde davon ausgehen, dass sich Apple bei der Weiterentwicklung von Airplay2 nur auf iOS konzentrieren wird (vielleicht gibt es technische Gründe dafür).

Abzeichen +1

Ich verstehe nur nicht wieso es bei mir jetzt wieder (dann wahrscheinlich unabhängig der Routereinstellungen) funktioniert.

Abzeichen +1

Da kann man lang irgendwelche Router Einstellungen durchprobieren 😂 

Abzeichen +1

 

2.4 GHz. WLAN und der Router sind glaube ich nicht die Ursache, zB. mein iPhone 12 Pro iOS 14.2.1 benutzt das selbe Netzwerk da funktioniert alles mit der Sonos One, sogar nach Stunden wenn ich nach der Pause Play drücke kommt nach 1-2 Sekunden der Ton. Beim iMac ob LAN oder WLAN gibt es das gleiche Problem. Also der Fehler liegt iwo beim OSX, AirPlay und dem One,

Hallo @ mheller

Richtig, soweit ich das bisher feststellen konnte und auch in diversen Diagnosen bestätigt wurde, nutzt iMac noch Airplay 1, was nicht so stabil ist wie Airplay 2. Ausnahme: die Musik App auf dem iMac/Macbook nutzt Airplay 2.
Beim iPad/iPhone wird Airplay 2 immer genutzt. 

 

Okey Krass du hast recht, beim iMac AirPlay Lautstärke/Ausgabg den Sonos Raum ausgewählt in Apple Music sowie Apple TV funktioniert tadellos ohne Verzögerung nach einer Pause! Im neuen Safari in YouTube gibt es die AirPlay Auswahl mit dem Sonos Raum auch , nur leider geht dann bei mir garnichts mehr weder Video noch Ton. Übler Bug. 
Also verkauft Apple die Funktion bereits groß als AirPlay 2 Native in Big Sur, geht aber nur teilweise.. Ohmann hoffe die können das fixen mit einem Update irgendwann.

 

Abzeichen +1

Also ich bekomme es hier nicht hin, habe alles mögliche probiert, bei 3 min Pause in einem YouTube Video braucht die One exakt 50 Sekunden / bei 15 min schon 5 min um wieder automatisch weiterzuspielen nach dem ich Play drücke.

 

die Jungs hier erörtern das Problem ganz gut falls es jemand lesen möchte, womöglich ein Problem seitens Sonos?..

 

https://www.reddit.com/r/sonos/comments/cz5n5j/airplay2_stops_working_after_long_pause/

Angeblich beherrscht macOS seit Catalina Airplay2 umfassend. Was ist das, reines Marketinggeschwafel seitens Apple? :rolling_eyes:

Antworten