Frage

iTunes Musikbibliothek in Verbindung mit 2 Sonos Systemen


Abzeichen
Hallo,
ich habe 2 getrennte Sonos System in 2 unterschiedlichen WLANs. Auf meine "Musikbibliothek" (MacBook) kann ich leider nicht zugreifen, wenn ich die Musikbibliothek aktualisiert habe, als der Rechner mit dem anderen Sonos System verbunden war. Was dazu führt, dass ich immer wieder beim Wechsel des Sonos Systems, die Musikbibliothek aktualiseren muss. Die Fehlermeldung, beim Versuch, ein Lied abzuspielen lautet z.B.:

Wiedergabe von "Lied-XYZ" nicht möglich - Datei //Macintoshlocal-3/Musik/iTunes/iTunes Media/Music/XYZ.mp3 nicht gefunden.

Nachtrag: Versuche ich die Bibliothek einfach nur zu aktualisieren, bekomme ich erst überhaupt keine Rückmeldung und dann später ein Fenster mit der Fehlermeldung:

"//Macintoshlocal-3/Musik" ist nicht länger verfügbar. Das Gerät auf dem die Musikdateien gespeichert sind, ist eventuell nicht eingeschaltet, oder der Pfad hat sich vielleicht geändert. Wechsele zu "Verwalten" > "Einstellungen der Musikbibliothek", um den Pfadnamen zu prüfen"

Einzige Lösung, um das Problem zu beheben, die ich bis jetzt gefunden habe, ist die Bibliothek zu löschen und neu zu importieren.

In den "Einstellungen der Musikbibliothek" steht der korrekte Pfad: /Users/Benutzername/Music

Edit: Mit "Benutzername" meine ich "Benutzername" in eckigen Klammern, die euere Forumssoftware aber einfach verschluckt.

Dieser Beitrag ist geschlossen für weitere Beiträge

47 Antworten

Und wie sieht es mit dem Hinweis von Christopher, dass "die DNS-Namensauflösung nicht funktioniert und der Fehler "Macintoshlocal-3 lookup failed" angezeigt wird" aus ?!
Was bekommst Du denn als Ergebnis wenn Du in einer Console mal "nslookup Macintoshlocal-3" absetzt ?
Abzeichen
$ nslookup Macintoshlocal-3
Server: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9
Address: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9#53

Non-authoritative answer:
*** Can't find Macintoshlocal-3: No answer
Abzeichen
Das oben war der Fehlerfall, nach dem ich die Musikbibliothek wieder neu eingelesen habe, ergibt sich die selbe IP:

$ nslookup Macintoshlocal-3
Server: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9
Address: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9#53

Non-authoritative answer:
*** Can't find Macintoshlocal-3: No answer
*** Can't find Macintoshlocal-3: No answerfür mich heißt das, dass der Hostname "Macintoshlocal-3" nicht aufgelöst werden kann !?
Was liefert Dir denn ein "PING Macintoshlocal-3" als Ergebnis ?
Abzeichen
Im Fehlerfall liefert ping einen Fehler und im Fall, dass die Mediathek-Wiedergabe funktioniert (also, nach dem die Mediathek wieder neu eingelesen wurde), liefert ping den "üblichen" output.
Im Fehlerfall liefert ping einen Fehler und im Fall, dass die Mediathek-Wiedergabe funktioniert (also, nach dem die Mediathek wieder neu eingelesen wurde), liefert ping den "üblichen" output.Das ist möglich.
- es kann sein dass im Gutfall die Namensauflösung aus dem lokalen / clientseitigen Nameservice-Cache bedient wurde.
Generell stimmt da dann aber etwas nicht in dem Netz.
Was hast Du denn für einen NameServiceResolver / DNS-Server vs. Router mit DNS-...

Wenn ich es richtig verstanden habe, dann ist doch das "andere Netz" ein Firmen-Netz !?
- Enterprice- oder SmallBusiness mit SoHo-Infrastruktur ?!
Wie sieht es denn da mit der Namensauflösung aus ?

Btw., ich hab gerade festgestellt, dass bei mir meine Fritte (vermutlich seit dem letzten Update auf FRITZ!OS: 07.01) auch irgendwie Bockmist mit dem lokalen Nameservice macht !? :@
- einige meiner Geräte (die, die dynamische IPs bekommen und somit die sich häufiger mal ändert) werden von der Fritte mit 2 IPs aufgelöst.
- die erste zurückgelieferte IP ist dabei immer die veraltete ... :?:@
... ich weiß noch nicht woher die Ursache rührt und warum die Fritte die DNS-Einträge nicht aktualisiert :?:@
Abzeichen
Ich glaube eher nicht, dass es irgend etwas mit dem Router zu tun hat. Dagegen spricht, dass das Problem in beiden Netzwerken auftritt, die unterschiedliche Router haben. Mein Wunsch wäre: Bei Sonos versucht das mal einer kurz zu reproduzieren. Die haben sicher mehr als ein System zum Testen und die haben sicher auch ein MacBook zum testen. Der Test würde ca. 5 Minuten dauern.
Du kannst natürlich darüber denken wie Du willst, aber wenn die Namensauflösung bei Dir nicht funktioniert, dann kann man auch in einem anderen Netz nichts reproduzieren.

Btw., hab gerade gesehen, dass Dein Hostname 16 Zeichen lang ist !?
- eigentlich sollte das kein Problem sein, aber ich meine mich an Fälle (lang is her) zu erinnern, wo es Beschränkungen auf 15 Zeichen gab.
- ggf. probierst Du das mal mit "Macintoshlocal3" oder "Maclocal-3" aus.
Abzeichen
Mache ich alles gerne, wenn Du eine plausible Erklärung dafür hast, warum alles super funktioniert, nach dem ich unter "Verwaltung > Einstellungen der Musikblibliothek... > Ordner" den Order "Musik" (zeigt auf /Users//Music) gelöscht habe und sofort danach wieder hinzugefügt habe.

Das kann doch wohl kaum irgend etwas mit einer Fehlkonfiguration irgend welcher Netzwerke zu tun haben.
Mache ich alles gerne, wenn Du eine plausible Erklärung dafür hast, warum alles super funktioniert, nach dem ich unter "Verwaltung > Einstellungen der Musikblibliothek... > Ordner" den Order "Musik" (zeigt auf /Users//Music) gelöscht habe und sofort danach wieder hinzugefügt habe.

Das kann doch wohl kaum irgend etwas mit einer Fehlkonfiguration irgend welcher Netzwerke zu tun haben.

Nichts für ungut, aber warum setzt Du die Vorschläge nicht einfach um, statt darum zu kämpfen, Recht zu behalten? Das wird Dein zweifaches Problem bestimmt nicht lösen.

U. a. darf der Computername max. 15 Zeichen lang sein, Bindestriche, aber keine Leerzeichen enthalten.
Abzeichen

Nichts für ungut, aber warum setzt Du die Vorschläge nicht einfach um, statt darum zu kämpfen, Recht zu behalten? Das wird Dein zweifaches Problem bestimmt nicht lösen.


Ich kämpfe nicht, um Recht zu behalten. Ich bin aber berufstätig und habe Familie und damit halt nicht unendlich viel Zeit. Für mich sieht es halt aus wie ein Bug in der Controller-Software. Wenn Sonos versucht, dass zu reproduzieren und sagt, dass die das mit Ihren beiden Sonos-Systemen und Ihrem MacBook nicht hin bekommen, dann bin ich gerne bereit bei der Reproduktion zu helfen. Wenn Sonos sagt, dass sie nicht vorhaben, so ein Szenario zu unterstützen, dann muss ich damit halt leben. Ich sehe aber nicht, dass ich jetzt jeder Idee eines (wenn auch sehr hilfreichen) Forenbenutzers folgen muss, wenn die Idee nicht zu den von mir beobachteten Symptomen passen.

Ausserdem habe ich ansonsten alle eure Fragen beantwortet.

U. a. darf der Computername max. 15 Zeichen lang sein, Bindestriche, aber keine Leerzeichen enthalten.

Warum funktioniert es denn dann grundsätzlich, wenn ich nicht zwischen den beiden Sonos-Systemen wechsle? Diese Tatsache scheinst Du ständig aus den Augen zu verlieren.

Ich habe den Namen des Computer jetzt mal auf "Computer" geändert, habe das Netzwerk / Sonos-System wieder gewechselt und siehe da Fehlermeldung:



Nun lösche ich den Musikbibliotheks-Ordern wieder... Und füge den Ordner wieder hinzu (was wieder mal mindestens 5 Minuten dauert...).



Und siehe da, nun funktioniert es wieder (wie vorher, mit dem anderen Computer-Namen auch).

Jetzt wechsle ich wieder in das ursprüngliche Netzwerk / Sonos-System ...

Und sie da, funktioniert wieder nicht (genau so wie vorher; interessanter Weise, immer noch mit dem alten Computer-Namen):

DNS-Fehler kommen auf Netzwerkebene vor, die kann ein Außenstehender nur dann reproduzieren, wenn er Dich zu Hause oder in der Firma aufsucht.

https://praxistipps.chip.de/dns-server-antwortet-nicht-was-tun_23947
https://support.apple.com/kb/PH25346?locale=de_DE&viewlocale=de_DE


P.S. Hast Du außerdem, wie von Christopher vorgeschlagen, den Mac-Controller deinstalliert, den/die Mac(s) neu gestartet und den Controller wieder aufgespielt?

https://www.sonos.com/de-de/software/release/10-1
Abzeichen
DNS-Fehler kommen auf Netzwerkebene vor, die kann ein Außenstehender nur dann reproduzieren, wenn er Dich zu Hause oder in der Firma aufsucht.

Wie gesagt, ich würde mich freuen, wenn Sonos mal versucht, den Fehler zu reproduzieren. Ich vermute, dass sich das relativ einfach mit 2 Sonos-Systemen und einem MacBook reproduzieren läßt.


P.S. Hast Du außerdem, wie von Christopher vorgeschlagen, den Mac-Controller deinstalliert, den/die Mac(s) neu gestartet und den Controller wieder aufgespielt?

https://www.sonos.com/de-de/software/release/10-1



...
Nach Neuinstallation des Controllers und nach erneutem Einlesen der Mediathek, habe ich folgendes Diagnose gestartet: 2028629001
Wie gesagt, ich würde mich freuen, wenn Sonos mal versucht, den Fehler zu reproduzieren. Ich vermute, dass sich das relativ einfach mit 2 Sonos-Systemen und einem MacBook reproduzieren läßt.
Nur, wenn Sonos vorher Dein(e) Netzwerk(e) nachbaut.
Hallo Torsten,
wenn Du Dir helfen lassen willst, dann beantworte einfach nachstehende Fragen.
Wenn nicht, dann sag es ... und dann ist Funkstille meinereiner nach diesem Post.

Fragen:
1.) hat Dein Mac in beiden Netzen den selben Hostnamen ?
2.) ist der Hostname statisch in der Config im Mac eingetragen oder wird der dynamisch per DHCP-Server im jeweiligen Netz vergeben ?
3.) als Du den Hostnamen auf "Computer" geändert hattest, hast Du danach in beiden Netzen im jeweiligen SONOS-System den Pfad zur MB auch NEU mit "//Computer/Musik/..." eingetragen und den Index aktualisiert ???
- wenn nicht wäre dies allerdings zwingend notwendig gewesen, da der Hostname "Macintoshlocal-3" ja keine Gültigkeit mehr hatte und somit ein Abspielversuch von der Quelle "//Macintoshlocal-3/Musik/..." unweigerlich zu einer FM führen musste !
4.) falls Du doch in beiden SONOS-Systemen den Pfad zur MB auch NEU mit "//Computer/Musik/..." eingetragen hattest, hast Du danach dann nochmal einen Wechsel der Netz ausprobiert und überprüft ob jetzt der Zugriff auf die MB jeweils ohne Aktualisierung der Pfadangabe zur MB einwandfrei funktioniert ?!?
5.) hast Du mit geänderten Hostnamen "Computer" mal in beiden Netzen die Ausgabe von "PING Computer" und "NSLOOKUP Commputer" in der Console überprüft ?

... und jetzt Du.
mfg
Abzeichen

1.) hat Dein Mac in beiden Netzen den selben Hostnamen ?

Ja

2.) ist der Hostname statisch in der Config im Mac eingetragen oder wird der dynamisch per DHCP-Server im jeweiligen Netz vergeben ?

statisch

3.) als Du den Hostnamen auf "Computer" geändert hattest, hast Du danach in beiden Netzen im jeweiligen SONOS-System den Pfad zur MB auch NEU mit "//Computer/Musik/..." eingetragen und den Index aktualisiert ???
- wenn nicht wäre dies allerdings zwingend notwendig gewesen, da der Hostname "Macintoshlocal-3" ja keine Gültigkeit mehr hatte und somit ein Abspielversuch von der Quelle "//Macintoshlocal-3/Musik/..." unweigerlich zu einer FM führen musste !

Ja (siehe https://de.community.sonos.com/installation-und-nutzung-223378/itunes-musikbibliothek-in-verbindung-mit-2-sonos-systemen-6746465/index2.html#post16061573)

4.) falls Du doch in beiden SONOS-Systemen den Pfad zur MB auch NEU mit "//Computer/Musik/..." eingetragen hattest, hast Du danach dann nochmal einen Wechsel der Netz ausprobiert und überprüft ob jetzt der Zugriff auf die MB jeweils ohne Aktualisierung der Pfadangabe zur MB einwandfrei funktioniert ?!?

Funktioniert genau so wenig wie vorher. Interessanterweise, steht in der Fehlermeldung immer noch der alte Computer-Name.

5.) hast Du mit geänderten Hostnamen "Computer" mal in beiden Netzen die Ausgabe von "PING Computer" und "NSLOOKUP Commputer" in der Console überprüft ?


$ nslookup computer
Server: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9
Address: 2a02:810d:8940:544a:ae22:5ff:fe83:49e9#53

Non-authoritative answer:
*** Can't find computer: No answer

$ nslookup computer
Server: 192.168.178.1
Address: 192.168.178.1#53

Name: computer.fritz.box
Address: 192.168.178.21

$ ping computer
ping: cannot resolve computer: Unknown host

$ ping computer
PING computer.fritz.box (192.168.178.21): 56 data bytes
64 bytes from 192.168.178.21: icmp_seq=0 ttl=64 time=0.053 ms
64 bytes from 192.168.178.21: icmp_seq=1 ttl=64 time=0.085 ms
^C
--- computer.fritz.box ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.053/0.069/0.085/0.016 ms
Abzeichen
Und um es noch einmal auf den Punkt zu bringen:
a) Das Abspielen der Mediathek funktioniert grundsätzlich, sowohl in dem einen, als auch in dem anderen Netz.
b) Das Abspielen der Mediathek funktioniert aber immer nur in einem Netz (unabhängig davon, mit welchem Netz der Computer gerade verbunden ist). Beim Wechsel in das nicht funktionierende Netz, muss (als Workaround) die Mediathek gelöscht und wieder eingelesen werden. Danach funktioniert es in diesem Netz, ohne das irgend welche Änderungen an der Netzwerk-Konfiguration vorgenommen wurden!
c) Daran hat die Änderung des Computer-Namens auch nichts geändert.

Meine Vermutung (als jemand, der professionel sein Geld mit Software-Entwicklung verdient) ist, dass sich der Sonos-Controller / das Sonos-System, eine falsche IP Adresse (oder ähnliches) merkt. (Der falsche Computer-Name in der Fehlermeldung könnte ggf. sogar erst beim Erstellen der Fehlermeldung ins Spiel kommen.)
Meine Vermutung (als jemand, der professionel sein Geld mit Software-Entwicklung verdient) ist, dass sich der Sonos-Controller / das Sonos-System, eine falsche IP Adresse (oder ähnliches) merkt. (Der falsche Computer-Name in der Fehlermeldung könnte ggf. sogar erst beim Erstellen der Fehlermeldung ins Spiel kommen.)
Womöglich kommt Sonos nicht damit zurecht, dass von zwei verschiedenen Systemen aus auf dasselbe NAS zugegriffen wird. Sei wie es sei, ich kann Dir versichern, dass Sonos die Firmware nicht umschreiben wird. Du solltest Dich damit abfinden und Dir für das 2. System ein 2. NAS zulegen.
Hallo Torsten,
sorry, aber Du machst es einem (gerade als jemand, der professionel sein Geld mit Software-Entwicklung verdient !) nicht leicht !
Ich hatte angenommen Dir wäre klar, dass es bei der Analyse solcher Probleme einer sehr, sehr detaillierten, strukturierten und differenzierten Vorgehensweise und auch Darstellung Deinerseits erfordert, damit Andere, u.a. auch der Support hier, dies verständlich nachvollziehen können.

Ich kann leider noch nicht erkennen, in welchem Netz Du den nslookup / ping oben zu Antwort 5) abgesetzt hast.
Wie Du als "Mann vom Fach" ja selbst siehst, funktioniert die Namensauflösung ja einmal ...
---/ $ ping computer
---/ PING computer.fritz.box (192.168.178.21): 56 data bytes
und das andere Mal funktioniert sie augenscheinlich NICHT ...
---/ $ ping computer
---/ ping: cannot resolve computer: Unknown host

Ich kann daraus zwar erkennen, dass es sich im Gut-Fall beim Nameserver um ein Netz handelt, in dem eine Fritzbox den NameServiceResolver stellt und diese auf 192.168.178.1 konfiguriert ist.
- ich nehme mal an, das in diesem Netz auch die Wiedergabe aus der SONOS-MB einwandfrei funktioniert !?
Hier fehlt für den Support eigentlich nur die passende Diagnose-ID :?

Wenn ich es dann weiterhin korrekt erkenne, dann handelt es sich im Bad-Case (*** Can't find computer: No answer // mit // ping: cannot resolve computer: Unknown host) um ein Netz, in dem anscheinend IPv4 deaktiviert, und nur IPv6 aktiviert ist !?
- hier kann dann auch ein Zugriff von SONOS auf die Share der MB nicht funktionieren, da SONOS den Hostnamen auch nicht auflösen kann, es sei denn, SONOS hat die Auflösung (Hostname >> IP) zuvor aus einem anderen Prozess noch irgendwoher im Cache gespeichert.
- das kann natürlich der erneute Einrichtungs-Prozess der MB sein, was dann auch erklären würde weshalb Du das nach einem Netz-Wechsel jedesmal erst wieder mal machen musst.
- woher dieser Prozess die Namensauflösung (Hostname >> IP) bekommt wäre zwar interessant zu wissen, ist hier aber zunächst mal irrelevant, da diese ja auch ohne diesen Prozess über den "normalen NameServiceLookUp" funktionieren muss, was sie nicht tut !
Deshalb bleibe ich bei meiner derzeitigen Erkenntnis:
>> die Ursache liegt in Deiner Konfiguration und dem Problem der nicht funktionierenden Namensauflösung.
Btw., für diesen Bad-Case fehlt dann aber auch für den SONOS-Support die zugehörige Diagnose-ID !?

Für das weitere Vorgehen ...
... entweder schaffst Du es hier jetzt in Deiner Darstellung weit mehr Struktur und auch noch zusätzliche Infos (auch zum jeweiligen Netz) herein zu bringen und wir schaffen es (auch unter Mithilfe des SONOS-Supports) damit die Ursache zu beseitigen,
... oder Du musst weiterhin mit Deinem Workarround leben.
Als Fachmann und Programmierer solltest Du ja selber wissen welche Informationen und in welcher Struktur diese erforderlich sind, damit einem geholfen werden kann !
Abzeichen

...
Ich kann leider noch nicht erkennen, in welchem Netz Du den nslookup / ping oben zu Antwort 5) abgesetzt hast.
Wie Du als "Mann vom Fach" ja selbst siehst, funktioniert die Namensauflösung ja einmal ...
---/ $ ping computer
---/ PING computer.fritz.box (192.168.178.21): 56 data bytes
und das andere mal funktioniert sie augenscheinlich NICHT ...
---/ $ ping computer
---/ ping: cannot resolve computer: Unknown host



richtig! 🙂 Und da die SONOS-MB in beiden Netzwerken funktioniert, scheint es so, als DNS nichts mit dem Problem zu tun hat. Die SONOS-MB funktioniert sowohl in dem Netz, in dem die Fritzbox den Namen auslöst, als auch in dem Netz, in dem der andere Router des ISP den Namen nicht auflöst. Scheint also so, als bräuchte SONOS-MB kein DNS!


Ich kann daraus zwar erkennen, dass es sich im Gut-Fall beim Nameserver um ein Netz handelt, in dem eine Fritzbox den NameServiceResolver stellt und diese auf 192.168.178.1 konfiguriert ist.
- ich nehme mal an, das in diesem Netz auch die Wiedergabe aus der SONOS-MB einwandfrei funktioniert !?


Wie ich schon _mehrfach_ schrieb. Funktioniert die SONOS-MB in beiden Netzwerken einwandfrei. Was nicht funktioniert, ist der Wechsel von einem Netz in das andere.


Hier fehlt für den Support eigentlich nur die passende Diagnose-ID :?


Ich habe schon ca. 6 Diagnosen in diesem thread an SONOS geschickt. Was fehlt, ist jemand, der da mal drauf guckt.


Wenn ich es dann weiterhin korrekt erkenne, dann handelt es sich im Bad-Case (*** Can't find computer: No answer // mit // ping: cannot resolve computer: Unknown host) um ein Netz, in dem anscheinend IPv4 deaktiviert, und nur IPv6 aktiviert ist !?
- hier kann dann auch ein Zugriff von SONOS auf die Share der MB nicht funktionieren, da SONOS den Hostnamen auch nicht auflösen kann, es sei denn, SONOS hat die Auflösung (Hostname >> IP) zuvor aus einem anderen Prozess noch irgendwoher im Cache gespeichert.


Nein, der Computer bekommt von der Fritzbox halt eine IPv6 Adresse. Und auch damit kommt SONOS spätestens dann zurecht, wenn ich die Musikbibliothek lösche und wieder neu einspiele. In dem Fall, wird die Fritzbox dem Rechner sicher nicht neu eine IPv4 Adresse geben.


- das kann natürlich der erneute Einrichtungs-Prozess der MB sein, was dann auch erklären würde weshalb Du das nach einem Netz-Wechsel jedesmal erst wieder mal machen musst.


Dann funktioniert DNS plötzlich wieder, obwohl IPv4 anscheind deaktiviert ist?


Deshalb bleibe ich bei meiner derzeitigen Erkenntnis:
>> die Ursache liegt in Deiner Konfiguration und dem Problem der nicht funktionierenden Namensauflösung.


Und ich bei meiner Erkenntnis, dass es nichts mit DNS zu tun hat, da es ja grundsätzlich funktioniert und das neu-Einlesen der MB sich nicht zu einer geänderten DNS-Konfiguration führt. Eher wahrscheinlich ist, dass es zu einer erneuten Ermittlung der IP-Adresse führt.


Btw., für diesen Bad-Case fehlt dann aber auch für den SONOS-Support die zugehörige Diagnose-ID !?


Nein, im thread befinden sich die Diagnose-IDs von allen möglichen Zwischenständen.
Also nochmal in Kürze.

zu "Scheint also so, als bräuchte SONOS-MB kein DNS!".
- doch, SONOS benötigt zwingend ein funktionierendes DNS.

zu "Was nicht funktioniert, ist der Wechsel von einem Netz in das andere."
- weil nach diesem Wechsel augenscheinlich die Namensauflösung in die Binsen geht und SONOS somit nicht mehr weiß an welche IP die SMB-Anfrage zu senden ist.

Wenn Du dafür sorgen kannst, dass Dein Mac in beiden Netzen immer die selbe IP bekommt,
dann kann Du den UNC für die MB ja mal in beiden Netzen via IP (also mit "//192.168.178.21/Musik") konfigurieren.
- jede Wette, das dann auch der Netz-Wechsel einwandfrei funktioniert!

zu dem Thema "IPv4 vs. IPv6"
- das hab ich nur angemerkt um deutlich zu machen, dass das für mich der einzige Anhaltspunkt ist um die von Dir dargestellten 2 Netze zu unterscheiden !
- wie gesagt fehlen hier von Dir die erforderlichen Details.

zu Diagnose und SONOS
Du glaubst doch nicht im Ernst, dass die SONOS-Jungs hier die Zeit zum Rätselraten haben und sich aus mittlerweile 45 Posts alle Details zusammensuchen können / wollen.
- entweder stellst Du das nochmal in einem Post übersichtlich strukturiert und mit allen Details zusammen und bekommst dann eine AW, oder ...

[PS und Edit]
Das Einzige was mir gerade noch einfällt ...
Du verwendest ja den Mac als Freigabe für die Share zur MB.
Unter Windows zumindest verwendet SONOS beim DTC (DeskTopController) einen Hintergrund-Dienst, welcher einen eigenen, rudimentären Web-Server auf dem System zur Verfügung stellt, um das bekannte Problem mit dem SMBv1/v3-Stack zu umgehen und einen Zugriff via HTTP zu ermöglichen.
Ob das beim Mac-DTC genau so ist kann ich nicht sagen !?
- wenn ja, dann könnte das von Dir skizzierte Fehlverhalten und das Thema mit dem vermeintlich gecachten Hostnamen irgendwie daraus resultieren ?!?
- das kann aber wirklich nur SONOS beantworten.
Abzeichen
Hallo Christopher,

Zudem wird auch anscheinend über SMB und nicht über den im Sonos-Controller integrierten http Server gestreamt. Daher würde ich dich bitten, einmal den Sonos Controller auf dem Mac komplett neu zu installieren und die Bibliothek neu einzurichten. Danach sende uns bitte eine weitere Diagnose. Vielen Dank.

hast Du schon die Zeit gefunden, Dir die Diagnose 2028629001 anzugucken?

schöne Grüße,

Torsten