Frage

Fritzbox 6490 Internetaabrüche bei Sonos Nutzung


Abzeichen
Hallo,

ich habe seit ca. 3 Monaten folgendes Problem: Ich besitze drei Sonos One und einen Play1. Beim Streamen von Spotify Inhalten über die iOS Sonos App auf diesen Lautsprechern (dabei ist irrelevant welches der Geräte verwendet wird) bricht nach ein paar wenigen Stunden die Internetverbindung der Fritzbox ab. D.h. keines meiner Geräte zuhause (nicht nur Sonos Lautsprecher, sondern auch Windows Notebook, iPad, iPhone, Amazon Echo, etc..) kann mehr eine Internetverbindung via WLAN oder LAN aufbauen. Es hilft nur noch ein Restart der Fritzbox.

Das Problem liegt eindeutig an der Sonos Nutzung. Verwende ich diese nicht habe ich über Tage/ Wochen keine Probleme. Setze ich die Lautsprecher ein tritt das Problem nach wenigen Stunden auf.

Die Sonos Lautsprecher sind mittlerweile alle per LAN Kabel an die Fritzbox angeschlossen (macht aber keinen Unterschied, Problem tritt bei LAN aber auch WLAN Verbindung auf; WLAN ist mittlerweile auf den Sonos Geräten auch komplett deaktiviert). Allen Geräten sind feste IP Adressen zugewiesen (macht auch keinen Unterschied ob ich dynamisch oder statisch die IP Adressen vergebe). Die Fritzbox wurde bereits ausgetauscht, also kein Hardwareproblem der Fritzbox. Das Problem ist unabhängig von der FritzOS Version (tritt unter 6.5 aber auch 7.01 auf).

Das komplette System lief bis ca. Oktober 2018 völlig problemlos. Mir gehen mittlerweile die Ideen aus was ich noch tun könnte. Das Einzige was mir noch einfällt wäre ein Firmware Downgrade des kompletten Systems auf einen Stand August/September 2018. Weiß aber nicht ob und wie so etwas gehen könnte.

Gibt es irgendjemand der ähnliche Probleme hat bzw. jemand vom Sonos Support der mich unterstützen kann?

Dieser Beitrag ist geschlossen für weitere Beiträge

52 Antworten

Liegt bestimmt nicht an der Sonos-Firmware. Setze bitte eine Diagnose (Link) ab und antworte hier mit der Bestätigungsnummer, damit ein Techniker sich das anschauen kann.
Abzeichen
Hallo, habe Diagnoseinformationen verschickt, Bestätigungsnummer lautet 1589307265. Falls irgendwelche Logfiles auszuwerten sind: Das Problem trat gestern (27.1.) im Zeitraum 14.30 - 18:00 Uhr letztmalig auf.
Der Beschreibung nach ist es ein Broadcast Storm, doch der setzt ein sendendes WLAN-Modul voraus, so viel ich weiß; Du hast es jedoch auf allen Komponenten deaktiviert.
D.h. keines meiner Geräte zuhause (nicht nur Sonos Lautsprecher, sondern auch Windows Notebook, iPad, iPhone, Amazon Echo, etc..) kann mehr eine Internetverbindung via WLAN oder LAN aufbauen.Kannst Du mal genau auflisten (oder noch besser eine kleine Zeichnung) welche Geräte ALLE wie miteinander verbunden sind !?
- bitte auch zusätzliche Switche und PL-Adapter / Repeater berücksichtigen.
Abzeichen
Anbei nun eine Darstellung meiner Infrastruktur. Dazu noch ein paar wichtige Anmerkungen:

- Wenn es zum Problem kommt kann keines der grünen Geräte mehr eine Internetverbindung über die Fritzbox herstellen; dabei ist es unabhängig ob das Gerät über den Switch oder direkt mit der Fritzbox verbunden ist
- Interessanterweise funktioniert der "Intranet" Datenverkehr zwischen den grünen Geräten auch dann noch, d.h. z.B. ein iPad kann die IP Cam noch problemlos erreichen
- zur Steuerung der Sonos Komponenten wird ausschließlich die Sonos iPhone App verwendet
Ist das WLAN der Fritzbox deaktiviert oder das WLAN-Modul jeder Sonos-Komponente?

P.S. Beides, wie ich gerade gesehen habe.
Abzeichen
Ja genau, WLAN in jeder Sonos Komponente und auf der FritzBox deaktiviert.
Ich bin nur Laie was Netzwerktechnik angeht, aber wenn ich mir die Grafik anschaue, dürfte der Engpass in der Verbindung Netgear Orbi zum Netgear Nighthawk-Switch zu suchen sein.
Abzeichen
Bin zwar IT'ler aber jetzt auch nicht wirklich Netzwerker: Frage wäre bei dieser Vermutung dann für mich warum z.B. iPad und iPhone problemlos mit der IP Camera kommunizieren können, da ist die Verbindung genau iPad -> Netgear Orbi -> Netgear Switch -> IP Camera. Und wenn das Problem zwischen Orbi uns Switch wäre, weshalb kann dann der Win Desktop der direkt an der Fritzbox hängt auch keine Internetverbindung aufbauen? Der verwendet Orbi und Switch gar nicht?

Ich denke der Fehler tritt schon auf der Fritzbox auf, die Frage wäre nur was ist die Ursache, was bringt bei Sonos Verwendung die Fritzbox in diesen inkonsistenten Zustand?
Benutzerebene 6
Abzeichen +3
Bin zwar IT'ler aber jetzt auch nicht wirklich Netzwerker: Frage wäre bei dieser Vermutung dann für mich warum z.B. iPad und iPhone problemlos mit der IP Camera kommunizieren können, da ist die Verbindung genau iPad -> Netgear Orbi -> Netgear Switch -> IP Camera. Und wenn das Problem zwischen Orbi uns Switch wäre, weshalb kann dann der Win Desktop der direkt an der Fritzbox hängt auch keine Internetverbindung aufbauen? Der verwendet Orbi und Switch gar nicht?

Ich denke der Fehler tritt schon auf der Fritzbox auf, die Frage wäre nur was ist die Ursache, was bringt bei Sonos Verwendung die Fritzbox in diesen inkonsistenten Zustand?


Hallo,

am Sinnvollsten ist es, wenn du mal ein Minimal-Setup aufbaust.
Also nur die Fritzbox und eine verkabelte Sonos-Komponente.
Teste dann mal, ob das Problem auch auftritt.

Gruß,
Daniel
Bin zwar IT'ler aber jetzt auch nicht wirklich Netzwerker: Frage wäre bei dieser Vermutung dann für mich warum z.B. iPad und iPhone problemlos mit der IP Camera kommunizieren können, da ist die Verbindung genau iPad -> Netgear Orbi -> Netgear Switch -> IP Camera. Und wenn das Problem zwischen Orbi uns Switch wäre, weshalb kann dann der Win Desktop der direkt an der Fritzbox hängt auch keine Internetverbindung aufbauen? Der verwendet Orbi und Switch gar nicht?
Die Antwort findet sich in der Funktionsweise des Sonossystems, seinem Umgang mit Broadcast- und Multicastpaketen. Inwieweit es für das Spanning Tree Protocol eine Rolle spielt, wenn das WLAN-Modul der Komponenten deaktiviert ist, kann ich nicht sagen.
Abzeichen
Danke für den Hinweis, kann ich bei Gelegenheit mal über Nacht testen. Aber es ist sicherlich einleuchtend dass das bei einem Einfamilienhaus mit div. Komponenten und 4 Personen organisatorisch nicht ganz trivial ist mal eben das komplette Netzwerk abzuklemmen und nur noch einen Sonos an die Fritzbox anzuschließen 🙂 Das kann jetzt aber auch nicht wirklich der einzige Lösungsansatz sein, immerhin lief die Netzwerkkonfiguration in unveränderter Weise ja über zwei Jahre bis letzten Herbst stabil. Was findet sich denn in den übermittelten Supportinformationen? Gestern haben wir um 14:30 Uhr sämtliche Sonos Wiedergaben gestoppt, sind aus dem Haus gegangen und als wir 18 Uhr zurückgekommen sind war das Problem da. Kann in den Sonos Logs irgendwelcher Datentraffic o.ä. in genanntem Zeitraum identifiziert werden?
Abzeichen
Ehrlich gesagt klang für mich anfangs das von Pergugilliam genannte Schlagwort Broadcast Storm am plausibelsten, irgendetwas im Kontext Sonos überschwemmt die Fritzbox, so dass diese ein generelles Problem bekommt. Ein Neustart der Fritzbox löst ja immer das Problem zumindest temporär (könnte ja sein, da dann "überschwemmte Puffer etc. wieder initialisiert werden). Nur wie kann es denn zu so einem Broadcast Storm kommen? Was aus meiner Zeichnung so nicht hervorgeht: Ich habe ein paar der Sonos One als Stereopaar konfiguriert, hat das irgendwelchen Einfluss?
Ehrlich gesagt klang für mich anfangs das von Pergugilliam genannte Schlagwort Broadcast Storm am plausibelsten, irgendetwas im Kontext Sonos überschwemmt die Fritzbox, so dass diese ein generelles Problem bekommt. Ein Neustart der Fritzbox löst ja immer das Problem zumindest temporär (könnte ja sein, da dann "überschwemmte Puffer etc. wieder initialisiert werden). Nur wie kann es denn zu so einem Broadcast Storm kommen? Was aus meiner Zeichnung so nicht hervorgeht: Ich habe ein paar der Sonos One als Stereopaar konfiguriert, hat das irgendwelchen Einfluss?

https://de.wikipedia.org/wiki/Broadcast-Sturm

Falls der Nighthawk-Switch konfigurierbar ist, sollte er so eingestellt sein, dass er Spanning Tree Protocol und IGMP-Snooping unterstützt. Was nicht ins Gewicht fällt, solange nur eine Sonos-Komponente verkabelt ist. Ich musste auf ähnliche Weise wie Du erfahren, dass mein Cisco-Router STP nicht unterstützt, Abhilfe schaffte ein entsprechender Switch.
Abzeichen
Würde mir evtl.ein Sonos Boost etwas helfen, der dann direkt an die Fritzbox angeschlossen wird und gegen den sich alle meine Sonos per WLAN verbinden? Damit würde ich quasi meine komplette bisherige Infrastruktur bis auf die Fritzbox von den Sonos separieren?
Der Boost wäre eine Lösung, dafür muss jedoch das WLAN-Modul der Player wieder aktiviert werden. Wenn es zu Frequenzüberschneidungen mit Orbi kommt, müssen die Funkkanäle entsprechend angepasst werden. Die Frequenzbereiche der Kanäle 1,6,11 überschneiden sich nicht. Wenn Sonos z.B. Kanal 6 zugewiesen wird, sollte Orbi Kanal 1 oder 11 fest zugewiesen werden. Heißt, es gäbe folgende Kanalkombinationen durchzutesten: 1/6 bzw. 6/1, 6/11 bzw. 11/6, 11/1 bzw. 1/11.
Abzeichen
Ok, ein Versuch wäre es wert. Die Reichweite des Boost müsste für ca. 180qm (Sonos stehen im EG und 1 OG) ausreichend sein, richtig? Mein Switch kann IGMP Snooping (per Default bereits aktiv) und das STP (das würde ich heute abend mal aktivieren). Wenn das nichts hilft würde ich dann mal den Weg über den Boost versuchen. Das ist mal ein Ansatz, wenn andere User hier im Forum weitere Hinweise haben gerne melden, ich bin da wirklich für alles offen 🙂
Die Reichweite des Boost hängt von den Gegebenheiten des Gebäudes ab, durch eine dicke Betondecke geht das Signal wahrscheinlich nicht. Wenn Du den Boost im Sonos Shop bestellst, hast Du ein 100tägiges Rückgaberecht.
Anbei nun eine Darstellung meiner Infrastruktur. Dazu noch ein paar wichtige AnmerkungenWelchen Switch hast Du denn da genau ?!?
- ich finde nur den hier >> https://www.netgear.com/home/products/networking/switches/Nighthawk-switches/GS808E.aspx

Warum hast Du denn den PC direkt an der Fritte und nicht auch am Switch ?!
Abzeichen
Der PC ist direkt angeschlossen, da er quasi neben der Fritzbox steht (der Switch ist etwas entfernt davon). Ja, ich habe diesen Switch und der unterstützt Broadcast filtering: "Prevent massive transmission of broadcast packets forwarded to every port of the switch". Das klingt für mich zumindest mal nach STP?
Ja, ich habe diesen Switch und der unterstützt Broadcast filtering: "Prevent massive transmission of broadcast packets forwarded to every port of the switch". Das klingt für mich zumindest mal nach STP?Ne, das hat zunächst mal nichts mit STP zu tun.

Folge im 1. Schritt mal dem Rat von Daniel und baue eine "Minimal-Konfiguration" auf.

Oder alternativ ...
... häng mal die SONOS-Geräte ALLE an die Fritte und den PC dafür an den Switch.
Die Fritte hat ja 4 LAN-Ports.
Verwende Port_1 als Uplink zum Switch.
An Port_2 bis 4 hängst Du Deine SONOS-Geräte
- bleibt halt eins zunächst auf der Strecke und muss aus bleiben
Oder Du schaltest alternativ die WLAN-Interfaces wieder ein und versorgst das 4. SONOS-Gerät dann über das SONOS-WLAN.
- musst halt auf die Kanal-Verteilung achten wie oben bereits beschrieben.
- SONOS nutzt ein 802.11g-WLAN mit 20 MHz Bandbreite im 2,4Ghz-Band
Da das Netgear Orbi meines Wissens 802.11n mit 40 MHz BB im 2,4G benutzt musst Du halt Kanal 1 (oder 11) für SONOS, und Kanal 11 (oder 1) fürs Orbi einstellen.
- alle anderen Kanäle sind tabu, weil sich sonst Interferenzen und gegenseitige Beeinflussungen ergeben.

Ich geh mal davon aus, dass Dein S8000 die Fritte flutet ... warum auch immer !? - falsche Einstellung oder ... !?
- ich finde aber keine ausreichenden Unterlagen zur Konfiguration von diesem "Teil" ... 😞
Abzeichen
Ok, kann ich ja mal versuchen. Hinweis aber noch zum Switch: Wie in der Zeichnung vermerkt wurde der Switch bereits getauscht, d.h. zunächst hatte ich einen Cisco, nun den Netgear. Wenn es wirklich der Switch wäre der die Fritzbox flutet müssten beide herstellerübergreifend das selbe Problem gehabt haben. Der Cisco lief ja auch ohne Infrastruktur- und Konfigurationsveränderungen mit Sonos über 1,5 Jahre problemlos. Dann fingen die Probleme im letzten herbst an und seitdem habe ich die komplette Inftrastruktur bereits ausgetauscht (Fritzbox neu, Switch von Cisco zu Netgear, Netgear Orbi neu) um einen Hardwaredefekt auszuschliessen.
Ich sagte ja lediglich "Ich geh mal davon aus ...", - betrachte das also mehr als Vermutung und "wage Hypothese" ...
... das kann auch ganz was anderes sein.
Dazu müsste man aber eine ganzes Stück tiefer in die Analysen einsteigen.
- Logs oder / und zumindest die Einstellungen vom Switch und auch der Fritte.
Außerdem weiß ich nicht was sich bei Dir ggf. seit der Zeit, oder besser zu dem Zeitpkt., seit dem Du die Probleme beobachtest hast zusätzlich geändert hat !?
- das kann eine ganze Kleinigkeit sein welche man überhaupt nicht mehr auf dem Schirm hat.
Du sagst ja selbst, Du kommst aus der IT, wenn auch nicht direkt aus dem Netze-Bereich. Ich glaube aber, ich brauch Dir nicht erzählen was alles ausschlaggebend sein kann, wenn man solch eine Ursache eingrenzen bzw. identifizieren will.

Wenn Du also nicht in tiefe Analysen einsteigen willst / kannst (erstmal warum auch immer), dann bleibt zur (möglichst systematisches) trial and error.
Wie gesagt, ich weiß nicht welche Optionen dieser Switch bietet, weil ich (auf die Schnelle) dort keine Unterlagen bzgl. Konfiguration usw. gefunden habe.
- wenn Du was hast, dann poste den Link.
- ich hab jedenfalls keine Lust mich da für dich auf die Suche zu machen 🆒

Grundsätzlich ist Dein Netz-Aufbau vollkommen ok.
- die Frage ist halt, was mach bzw. wie arbeitet der Switch da an dieser Stelle und was kann er, bzw. was kann er ggf. nicht !?
Abzeichen
Hallo Peter,

ja die Frage stelle ich mir ja auch die ganze Zeit: Was hat sich im Herbst verändert, dass das System nun instabil wird?! Netzwerktechnisch wurde nichts verändert, aber natürlich ändern diverse Devices ständig Firmwareversionen etc. Eine tiefe Analyse ist eben organisatorisch schwierig und zeitlich sehr aufwändig, daher bleibt mir eigentlich nur ein strukturiertes trial and error zu versuchen.

Das habe ich gestern abend dann auch gestartet. Im ersten Schritt wollte ich mal den Switch isolieren ohne gleich alles an Infrastruktur und Devices lahmzulegen. Ich habe nun also mein Orbi Mesh System direkt per LAN an die Fritzbox angeschlossen (hing bisher am Switch). Alle Sonos Geräte habe ich resettet und dann per WLAN an die Orbi angeschlossen.

D.h. bisher war die End to End Verbindung: Fritzbox -> Switch -> LAN -> Sonos
Neu sieht das nun wie folgt aus: Fritzbox -> LAN -> Orbi -> Sonos

Gestern abend lief dann Sonos einige Zeit stabil, heute morgen konnten alle Devices noch auf das Internet zugreifen. Mal schauen, das ist ein erstes positives Anzeichen, evtl. hilft diese Umstellung ja schon. Ich denke heute abend/morgen früh kann man das besser einschätzen.

ich melde mich wieder......
Abzeichen
Hallo,

also der Switch scheint es nicht zu sein, nach drei Tagen hatte ich das selbe Problem wieder. Ich habe mich jetzt als kurzfristige Maßnahme für einen Workaround entscheiden: Ich habe auf einem RaspberryPI ein Shell Script geschrieben, welches einmal täglich über das TR-064 Interface der Fritzbox einen Restart der Fritzbox durchführt. Ist zwar im Grundgedanken etwas schräg, läuft aber als Crontab Job auf dem PI vollautomatisch. Mal schauen ob das mittelfristig mal Ruhe gibt bis ich das Thema irgendwann im Detail analysieren kann.....