Frage

Aussetzer mit Spotify und Sonos


Abzeichen

Hey,

ich bin seit einer Woche neuer Sonos Nutzer und bin soweit auch ganz zufrieden. Ich nutze Audible, Internetradio und Streaming von meinem macbook ohne Probleme. Nur Spotify ist leider echt zickig. Hier habe ich oft Stotterer oder Aussetzer bei einzelnen Boxen, manchmal sogar Abbrüche.

 

ich habe eine Synfonisk, einen One und einen One SL und hierbei gilt: je mehr Boxen ich nutze desto instabiler ist Spotify. Es ist auch egal ob über Airplay oder via Sonos App.

 

Router ist eine Fritzbox 7490 und ein Fritz Repeater (die eigentlich Problemlos laufen). 
 

ich weiss es gibt hier Spotifytopics wie Sand am Meer, aber ich finde leider nichts hilfreiches. Es gibt auch einen Fehlerdump, die 1458340308.

 

Woran Könnte das liegen? danke euch!


21 Antworten

Benutzerebene 7
Abzeichen +3

@NettiXXL

Wenn bei Gruppierung ein Raum ganz ausfällt, dann liegt es wohl am Repeater, denn diese Geräte sind nicht komplett kompatibel mit Sonos. 
Du müsstest dafür Sorgen, dass sich alle Sonosgeräte direkt mit dem Wlan des Routers verbinden und nicht mit dem Repeater. Auf Dauer hilft da nur, dem Repeater eine eigene SSID zu geben, oder die Sonosgeräte per Mac Adressen Filter von der Anmeldung am Repeater auszuschließen. Sollten sich nicht alle Sonosgeräte in Reichweite des Router Wlans befinden, müsste man auf den Betrieb per SonosNet wechseln und mind. ein Sonosgerät dauerhaft per Lankabel mit dem Router verbinden. 
https://support.sonos.com/s/article/3209?language=de
Gruß,

Ralf

Abzeichen

Das mit den mac adressen ist ne gute Idee, werde ich versuchen. Ssid wollte ich nicht ändern weil da zu viel dran hängt. Wie ist der boost als Alternative? Könnte ich den auch an den repeater hängen (der repeater ist per lankabel mit dem router verbunden)?

 

Ein bisschen schade finde ich es übrigens schon dass sich Geräte in gehobenem Preissegment (vor allem wenn man mehrere hat) von so etwas Alltäglichem wie einem repeater stören lassen.

Benutzerebene 7
Abzeichen +3

Den Boost sollte man direkt an den Router hängen. 
Wenn dein Repeater aber per Lankabel (hoffentlich aber nicht per PowerLan übers Stromnetz) mit dem Router verbunden ist, dann müsste es doch eigentlich möglich sein, ihn als Access Point zu betreiben. Damit gäbe es keine Probleme bzgl. Sonos. Da muss man nur darauf achten, dass die DHCP Server Funktion am AP deaktiviert ist und nur der Router die IP Adressen vergibt. 

Benutzerebene 6
Abzeichen +3

Den Boost sollte man direkt an den Router hängen. 
Wenn dein Repeater aber per Lankabel (hoffentlich aber nicht per PowerLan übers Stromnetz) mit dem Router verbunden ist, dann müsste es doch eigentlich möglich sein, ihn als Access Point zu betreiben. Damit gäbe es keine Probleme bzgl. Sonos. Da muss man nur darauf achten, dass die DHCP Server Funktion am AP deaktiviert ist und nur der Router die IP Adressen vergibt. 

 

Korrekt. :relaxed:

Abzeichen

Hmm, der repeater fungiert tatsächlich nur als ap, dhcp ist deaktiviert (nein und kein power lan). Allerdings haben beide die selbe ssid. aber irgendwas scheint da ja trotzdem zu stören?!

 

übrigens btw: ich habe schon ein paar mal gelesen dass die sonosboxen nur 2,4 ghz wlan könnten, stimmt das?
 

 

Hmm, der repeater fungiert tatsächlich nur als ap, dhcp ist deaktiviert (nein und kein power lan). Allerdings haben beide die selbe ssid. aber irgendwas scheint da ja trotzdem zu stören?!

 

übrigens btw: ich habe schon ein paar mal gelesen dass die sonosboxen nur 2,4 ghz wlan könnten, stimmt das?
 

 

Machen wir es kurz und schmerzlos :wink:, egal wie die Repeater jetzt konfiguriert sind.

 

Alle Repeater ausstecken, 10 Min. warten und danach die Wiedergabe starten. Wenn es läuft wie es laufen soll, können die Repeater wieder eingesteckt werden.


Wenn das hilft, hast du folgende Optionen:

Wenn die Repeater einen eigenen Mac-Filter haben, dann kann man dort die Mac-Adressen der Sonos-Player eintragen, sodass sich diese nicht mehr damit verbinden oder du änderst die SSID der Repeater. Ansonsten musst du immer darauf achten, dass sich kein Player mit dem/den Repeatern verbindet. Also, wenn ein Update ansteht, vorher die Repeater ausschalten, das gleiche gilt auch, wenn ein Update für den Router ansteht oder dieser aus einem anderen Grund neu gestartet werden muss.


Oder: EINEN Player dauerhaft mit dem Router verkabeln, wie folgt vorgehen, dadurch wechselt das System in die Betriebsart SonosNet:

1) Alle Repeater ausschalten
2) Einen Player (bei einem Stereopaar den linken) dauerhaft mit dem Router verkabeln
3) Anschließend das WLAN-Kennwort wie folgt zurücksetzen: Sonos Controller-App für iOS oder Android: Einstellungen --> System --> Netzwerk --> WLAN-Setup --> Fortfahren/Weiter. Klicke im nächsten Bildschirm auf Zurücksetzen. Manchmal verdeckt die Handy-Tastatur die Zurücksetzen-Schaltfläche. Entfernen von WLAN-Informationen aus Sonos

4) Mindestens 10 Min. warten. Erst wenn unter 'Einstellungen --> Über mein Sonos-System' neben jedem Player WM:0 steht, dürfen die Repeater wieder ans Netz.


Für Fälle, wo kein Player mit dem Router verkabelt werden kann, wurde der Boost konzipiert.

https://www.sonos.com/de-de/shop/boost.html

 

 

Nachtrag: Steht der Funkkanal der Fritzbox auf Autokanal? Wenn ja, bitte einen festen Kanal zuweisen, indem du die Kanäle 1, 6, 11 durchtestest. Fritzbox und Repeater auf denselben Kanal setzen. Mit etwas Glück reicht das, wenn die Repeater richtig als Access Points konfiguriert sind.

Abzeichen

Okay, vielen Dank für die guten Antworten.

 

ich habe im Wohnzimmer eine Soundbar, die ich gerne per koaxial in Sonos einbeziehen würde. Da eignet sich doch der Port für oder? Und dann könnte ich den doch direkt per lankabel einbinden und mein Problem müsste gelöst sein oder nicht? Ich habe mich noch gefragt wofür der 2. lan anschluss am port ist?

Benutzerebene 7
Abzeichen +3

@NettiXXL 

Ja, der Port hat einen digitalen Koax Ausgang, über den deine Soundbar dann mit Sonos Inhalten versorgt werden kann. Wenn der Port per Lankabel an den Router kommt, dann arbeitet dein System auch im SonosNet. 
Der zweite Lanport kann theoretisch genutzt werden, um andere Geräte darüber per Lan mit dem Netzwerk bzw. Internet zu verbinden. 
Ich rate dir aber davon ab, da es Bandbreite benötigt und zudem eine eher langsame Lanverbindung ist. 
Grüße,

Ralf
 

Abzeichen

Muss man verstehen warum sonos hier keinen 1000mbit lanport eingebaut hat?

Benutzerebene 7
Abzeichen +3

Muss man verstehen warum sonos hier keinen 1000mbit lanport eingebaut hat?

Evtl. weil die Performance der eigentlichen Hauptaufgabe des Gerätes, nämlich das Streaming, darunter leiden würde…!? :thinking: Letztendlich wissen es wohl nur die Entwickler. 
Gruß,

Ralf

Abzeichen

Also ich habe mittlerweile einen speaker per kabel angeschlossen und trotzdem abbrüche.

 

1071254242

Benutzerebene 6
Abzeichen +3

Also ich habe mittlerweile einen speaker per kabel angeschlossen und trotzdem abbrüche.

 

1071254242

 

Hast du das bei bestimmten Liedern/Alben/Playlisten oder generell bei allem Content von Spotify?

Also ich habe mittlerweile einen speaker per kabel angeschlossen und trotzdem abbrüche.

 

1071254242

 

Welchen Speaker?

 

Hast du die die WLAN-Zugangsdaten aus dem System entfernt? Wenn nicht:

  1. Schalte bitte alle Repeater vorübergehend aus
  2. Tippe in der Sonosapp unter Einstellungen auf System > Netzwerk > Netzwerke. Wähle das WLAN-Netzwerk aus, das du entfernen möchtest und tippe auf Entfernen
  3. Mindestens 10 Min. warten, danach überprüfen, ob in der Sonosapp unter 'Einstellungen --> System --> Über mein Sonos-System' neben jedem Player WM:0 steht. Wenn ja, dürfen die Repeater wieder ans Netz
Abzeichen

Nein, generell bei Spotify. Bei den letzten Abbrüchen stand ich bei dem Symfonisk (Diagnosenummer oben). Und gestern beim One mit der Diagnosenummer 1750482625.

Abzeichen

Aso und wlan daten sind entfernt.

Abzeichen

Niemand eine Idee? Ich find es echt nervig, so viel geld für die Boxen auszugeben und dennoch dauernd diese Verbindungsabbrüche zu haben.

@NettiXXL, Spotify über die Sonosapp, Spotify Connect oder Spotify über Alexa?

Abzeichen

Sonos App und Spotify Connect bzw Spotify via Airplay.

@NettiXXL, stelle als ersten Lösungsansatz SonosNet auf Kanal 1 und Router auf Kanal 6. Wenn das keine Besserung bringt, dreh’s um, setze den Router auf 1 und SonosNet auf 6. Teste und berichte bitte. Auf iOS oder Android: Einstellungen --> System --> Netzwerk --> SonosNet-Kanal

Abzeichen

@NettiXXL, stelle als ersten Lösungsansatz SonosNet auf Kanal 1 und Router auf Kanal 6. Wenn das keine Besserung bringt, dreh’s um, setze den Router auf 1 und SonosNet auf 6. Teste und berichte bitte. Auf iOS oder Android: Einstellungen --> System --> Netzwerk --> SonosNet-Kanal

Hey Greta,

ich habe jetzt den letzten Monat viel rumprobiert, die Kanäle vom Sonosnet und des Routers im 2,4 GHz Netz durchprobiert. Leider habe ich weiterhin mit Spotify massive Probleme und Verbindungsabbrüche. Diese passieren v.a. via Airplay, aber auch über die Sonos App direkt. Aufgefallen ist mir auch, dass ich v.a. am Symfonisk Abbrüche habe, aber auch an der anderen, nicht kabelgebundenen, Sonosbox.

@NettiXXL, ein Lösungsansatz wäre, das System wie folgt neu zu starten.

 

  1. Schalte bitte alle Repeater vorübergehend aus
  2. Starte zunächst die Fritzbox neu, abwarten bis sie vollständig hochfährt
  3. Verkabelten Player neu starten (abwarten, dass die LED zu blinken aufhört)
  4. Restliche Komponenten neu starten (immer abwarten, dass die LED zu blinken aufhört)
  5. Mindestens 20 Min. warten (dauert normalerweise nicht so lange, doch die Symfonisk brauchen manchmal etwas, um sich ins SonosNet einzugliedern). Danach dürfen die Repeater wieder ans Netz

 

Berichte bitte, ob der Neustart etwas gebracht hat. Wenn nicht, setze bitte eine Diagnose ab und antworte hier mit der Bestätigungsnummer, dann schaut ein Techniker noch darauf.

Eine Diagnose senden (Klick mich!)

Antworten