LG OLED65E7V mit Sonos Soundsystem

  • 16 September 2023
  • 23 Antworten
  • 291 Ansichten

Abzeichen

Hallo zusammen

 

Ich habe mich hier lange durchgeschaut und leider immer noch keine Lösung für mein Problem gefunden. Das Problem ist auch nicht allzu gross, denn: Mit Apple TV funktioniert mein Sonos Soundsystem. Ich muss einfach via Menu (lange auf den rechten Knopf drücken) das Sonos auswählen (heisst bei mir Wohnzimmer). Dann funzt das Ding, auch mit meinem Sub und den beiden Ones. So kann ich z.B. Youtube und Netflix und die anderen Apps von Apple TV mit tollem Sound geniessen.

Das Problem ist nur, dass ich das auf meinem normalen LG OLED-Menu mit der normalen Fernbedienung nicht kann. Ich habe z.B. die PS5 oder wenn ich Filme über USB schauen will kein Apple Menu (funktioniert alles über die LG-Bedienung) und kann folglich auch nicht “Wohnzimmer” auswählen. Mein Sound geht aber über Optical auf die Arc, das habe ich so eingestellt, aber die Arc ist dann nicht mit dem ganzen System (also mit den beiden One und der Sub) verbunden. Irgendwie kommuniziert dies nicht richtig. Wie gesagt habe ich bei Apple TV einen Workaround, indem ich das “Wohnzimmer” manuell auswählen kann, beim normalen TV geht das nicht. Hat hier jemand eine Idee, was ich noch machen könnte?

 

Viele Grüsse
Ben


Dieser Beitrag ist geschlossen für weitere Beiträge

23 Antworten

... Mein Sound geht aber über Optical auf die Arc, das habe ich so eingestellt, aber die Arc ist dann nicht mit dem ganzen System (also mit den beiden One und der Sub) verbunden. Irgendwie kommuniziert dies nicht richtig. Wie gesagt habe ich bei Apple TV einen Workaround, indem ich das “Wohnzimmer” manuell auswählen kann, beim normalen TV geht das nicht. Hat hier jemand eine Idee, was ich noch machen könnte?

Hallo Ben ( @Ben Hur ), warum verwendest Du überhaupt die Toslink-Verbindung?! - Dein TV hat doch einen HDMI-ARC Port. Das sollte prinzipiell einwandfrei funktionieren. Du musst halt nur die richtigen Einstellungen vornehmen.

PS: Ich gehe jetzt einfach mal davon aus, dass Du die beiden One als Rear-Speaker zur Arc hinzu konfiguriert hast (also als Surround-Setup), und diese nicht als separaten Raum parallel zur Arc betreibst !?

Abzeichen

Hey Peter, danke für die Antwort. Du hast natürlich Recht, da habe ich mich vertan: ich habe die Arc natürlich mit HDMI an den TV angeschlossen. Und wie du richtig sagst, sind die beiden One als Rear mit dem Sub und Arc als Surround zusammengeschlossen. Der TV checkt das aber irgendwie nicht bzw. sieht einfach nur die Arc als Surround. Auch bei Apple TV ist das Standardmässig so, dort kann ich aber immerhin das Surround-Setup (wenngleich manuell) auswählen.

Hi Ben, das ist dann Einstellungssache im LG. - Thema HDMI Passthrough usw.

Da bin ich dann aber raus da ich keinen LG habe.

Da meldet sich dann sicherlich noch einer der anderen Foren-Mittglieder / Mitleser. 

Benutzerebene 7
Abzeichen +4

@Ben Hur

Hi… 

Wenn du per Menü des AppleTV „Wohnzimmer“ wählst, ist das eine Airplay Wiedergabe. Da hast du dann auch keinen echten Mehrkanalton. 
Du musst in der Sonos App in den Einstellungen des Raumes der Arc das TV Setup ausführen und Autoplay aktivieren. Dann nimmt die Arc automatisch Signale vom TV per HDMI (e)ARC an und spielt sie im Surround Setup mit Sub und Rearspeakern ab. 
Die Arc ist aber korrekt mit dem HDMI Eingang des TV verbunden, der (e)ARC fähig ist, richtig!? Falls es nicht funktioniert, teste bitte ein anderes HDMI Kabel. 
Wie hast du die Audioeinstellungen des LG TV eingestellt?

Abzeichen

Hallo Schlumpf, vielen Dank für den Input und sorry die späte Antwort.

 

Also das Menu habe ich denke ich entsprechend eingestellt mit Autoplay. Ebenfalls habe ich den TV beim Arc angeschlossen und mehrere HDMI Kabel probiert. Die Einstellungen des TVs siehst du auch auf den Fotos. Zum Musikhören ist die Anlage tipptopp, fürs TV schauen ist aber Airplay offenbar die einzige Möglichkeit, überhaupt das ganze System zu nutzen. Nur geht das leider nur bei Apple TV.

Einstellungen Handy

 

TV Autoplay

 

Einstellungen TV

 

 

Einstellungen TV2

 

 

 

 

 

@Ben Hur, ich melde mich kurz zu Wort. Rufen Sie bitte den Google Play Store auf und aktualisieren Sie die Sonos-App.

 

Der Sub ist aus dem Surroundverbund verschwunden. Starten Sie ihn bitte einmal neu, taucht er danach wieder auf? → “Wohnzimmer (LS+RS+?)”

Abzeichen

Vielen Dank, habe ich gemacht - ändert aber nichts am Problem. Allgemein scheint bei mir die App etwas Mühe zu haben, ich habe sie diese Woche sicher schon dreimal geupdatet, so oft wird es kaum Updates geben. Aber wie gesagt hängt das Problem kaum damit zusammen.

 

 

@Ben Hur, zur Fehlerbehebung sollen die Grundvoraussetzungen gegeben sein. 🙂

 

Sie haben einen Surroundverbund, Sie brauchen die Tonausgabe über Airplay nicht.

Ich nehme an, Sie haben eine IR-Fernbedienung, haben Sie diese angelernt?

In der Sonos-App unter ‘Einstellungen → System → [Fernsehzimmer]’ → (runterscrollen zu) Heimkino → Fernbedienung einrichten’

 

Zusätzlich ...

In der Sonos-App unter ‘Einstellungen → System → [Fernsehzimmer]’ → (runterscrollen) → “TV-Autoplay” einschalten

… dann schaltet die Arc automatisch auf TV-Modus um, wenn Sie den Fernseher einschalten.

 

 

Was genau klappt denn nicht, hören Sie keinen Fernsehton?

Benutzerebene 7
Abzeichen +4

@Ben Hur 

Warum verbindest du denn die Arc optisch mit dem TV per Adapter? Der TV hat doch einen HDMI (e)ARC Anschluss. 
Gibt es ein Untermenü zu „Audioausgabe“?
Welche Optionen gibt es außer „automatisch“ bei DTV Audioeinstellung?

 

Abzeichen

Natürlich. Ja, das habe ich beides gemacht - siehe auch oben. Grundsätzlich haben Sie recht, dass ich die Tonausgabe über Airplay nicht brauche. Leider ist dies aber offensichtlich die einzige Möglichkeit, auf meinem TV Sound über den Surroundverbund zu hören. Weshalb auch immer…

 

Und nochmals: ich höre den TV-Ton nur durch die ARC, nicht aber durch den Surround (2 Ones und Sub), obwohl diese angeschlossen sind und z.B. bei Spotify oder eben auch Airplay wunderbar funktionieren.

Abzeichen

@Superschlumpf 

Glaube das ist einfach der Anschluss (ist der HDMI2-Anschluss), der so beschrieben ist. Ich habe die Arc via HDMI angeschlossen, wüsste gar nicht, wie ich dort ein optisches Kabel einstecken könnte.

 

Ein Untermenu gibt es nicht, es gibt nur die gleichzeitige Audiowiedergabe mit internen TV-Boxen.

Bei DTV ist MPEG, Dolby Digital, Dolby Digital Plus, HE AAC und Auto aufgeführt.

 

Irgendwie habe ich das Gefühl, dass die ARC nicht mit den anderen Geräten kommuniziert. Komisch ist nur, dass das nur beim TV-sehen so zu sein scheint.

Abzeichen

Übrigens habe ich einen sehr ähnlichen Beitrag gefunden:

 

Die Sache mit dem Router habe ich auch gecheckt. Ev. ist es ein LG OLED Problem. Ich finde es aber “etwas” übertrieben, aus diesem Grund einen neuen TV kaufen zu müssen. Zumal der TV eigentlich sehr ok is.

@Ben Hur, was passiert, wenn Sie DTV auf Dolby Digital oder Dolby Digital Plus (= Atmos) setzen? Spielen die Surrounds dann mit? Film mit passender Tonspur vorausgesetzt. Welches Tonformat zeigt der Wiedergabebildschirm der Sonos-App?

Benutzerebene 7
Abzeichen +4

@Ben Hur

Guten Morgen… so langsam kommt Licht ins Dunkel. 
Das mit „optisch“ war ja falsch von dir ausgedrückt. Hatte ich vergessen und war ja oben schon geklärt. Was aber imho bisher untergegangen ist und mir nicht klar war ist die Tatsache, dass die Arc sehr wohl Ton spielt und „nur“ Sub und Rearspeaker nicht. Zudem sieht man auf einem deiner Screenshots, dass da temporär der Sub fehlt und mit ? angezeigt wird. Es dürfte sich also wahrscheinlich um ein Verbindungsproblem von Sub u. Rearspeakern imnerhalb des Surround Wlans handeln. Da dort bei TV Ton über den Digitaleingang höhere Datenraten laufen als beim Streaming im Musikmodus (auch per AirPlay), macht sich das Problem evtl. nur dort bemerkbar. 
Dass du passende Audioformate mit Mehrkanalton abspielst, setze ich mal voraus. Wenn nur Stereo PCM ankommt, wäre es durchaus normal, dass die Rearspeaker stumm oder fast stumm bleiben können. 
Es gibt aus meiner sicht nun mehrere mögliche Ursacen:

  1. Ist die Arc per Lankabel angeschlossen? Wenn ja, muss in deren Einstellungen trotzdem Wlan eingeschaltet sein. Falls es ausgeschaltet oder defekt ist, würde man in den Einstellungen bei „über mein System“ für Sub und Rearspeakergeräte WM1 statt WM0 sehen. Prüf das bitte mal. 
     
  2. Das 5 GHz Wlan, das die Arc exklusiv zur Verbindung mit Sub und Rears erzeugt funktioniert zwar (wenn Sub u. Rears WM0 anzeigen), aber wird gestört. Dann bitte mal anderen Kanal für 5 GHz Wlan am Router einstellen, damit das das Netz der Arc nicht stört. Falls ein Nachbarnetz stört wird es schwierig. Und bitte andere Funkquellen wie Smarthomegeräte, Hubs etc. mal testweise ausschalten. 

Ich habe gestern zu erwähnen vergessen, dass über Airplay nur Stereo ankommt. Da spielt sowieso nur die Arc; manchmal sind schwach auch die Rücklautsprecher zu hören, abhängig davon wie die Tonspur abgemischt ist.

Benutzerebene 7
Abzeichen +4

Ich habe gestern zu erwähnen vergessen, dass über Airplay nur Stereo ankommt. Da spielt sowieso nur die Arc; manchmal sind schwach auch die Rücklautsprecher zu hören, abhängig davon wie die Tonspur abgemischt ist.

Nee, das stimmt so nicht. AirPlay spielt nicht im TV Modus, sondern im Musikmodus. Entsprechend spielen auch bei Stereo die Rearspeaker mit, ggf. sogar „voll“. Das deckt sich ja auch mit der Erfahrung des TE. 

Und nochmals: ich höre den TV-Ton nur durch die ARC, nicht aber durch den Surround (2 Ones und Sub), obwohl diese angeschlossen sind und z.B. bei Spotify oder eben auch Airplay wunderbar funktionieren.

 

Ich hatte das als Airplay und Spotify (Connect) über iPhone interpretiert.

 

Hieß es früher nicht, Airplay über Apple TV spiele nur Stereo? Ich bin da nicht auf dem Laufenden. Ich teste es heute mal.

Benutzerebene 7
Abzeichen +4

@Hedy L.

Ja, AirPlay überträgt grundsätzlich nur Stereo, egal von welchem Gerät. Es kommt also Stereo an der Arc an, wenn der TE den Ton vom AppleTV dorthin streamt. Aber das ist dann eben nicht der TV Modus der Arc, so dass die Rearspeaker immer auch bei Stereo mitspielen. 
 

Dafür würde es ggf. reichen, wenn die Rearspeaker als Fallback nur über 2,4 GHz mit dem Router verbunden sind. Deswegen meine Vermutung, dass die Ursache im TV Modus eine 2,4 GHz Fallback Verbindung oder eben eine schlechte 5 GHz Verbindung zur Arc ist, die im Musikmodus nicht auffällt. 
 

Benutzerebene 7
Abzeichen +4

@Hedy L. 

PS:

Das was du oben über Stereo und Rearspeaker geschrieben hast, käme nur zum Tragen, wenn Stereo im TV Modus gespielt wird. Wäre das aber hier der Fall, müsste meistens trotzdem zumindest ein leises Signal auf den Rearspeakern zu hören sein. Der TE sagt ja aber es wäre immer Stille auf Rears und halt sogar auch auf dem Sub. Deswegen würde ich ein Stereosignal als Ursache ausschließen. 

Abzeichen

Hallo zusammen, vielen Dank für die Antworten. Also, ich habe alle Register gezogen, bisher noch ohne Erfolg. Wie gesagt spielt aber Airplay das Surround System. Ich habe nun in meinem Router gesehen, dass die Sonos auch im 2.4 GHz und nicht im 5 GHz drin ist. Das könnte ich ev. noch versuchen, zu ändern. Ansonsten habe ich versuchsweise die Arc wieder ans LAN Kabel angeschlossen, geändert hat sich dadurch nichts, genauso wie die verschiedenen Sound Modi am TV etc.

 

Was ich auch mal noch versuchen könnte, ist alle Sonos geräte an dieselbe Stromleiste anzuschliessen. Ich habe diese separat und einmal per gesteuerte Steckdose. Dürfte ja keinen Unterschied machen, ev. hat dadurch aber das System noch mehr Mühe, sich als Unit zu verstehen… (man weiss ja nie! :)).

 

 

Benutzerebene 7
Abzeichen +4

@Ben Hur

Wäre cool, wenn du die Fragen oben beantwortest und mal in der Sonos App schaust, ob an Sub und Rears WM0, WM1 oder WM2 steht. Und bitte dazu schreiben, ob die Arc in dem Moment per Lankabel angeschlossen ist oder nicht. 
Funktioniert die denn grundsätzlich auch ohne Lankabel? Hört sich jedenfalls so an. 
Und was is mit Störquellen wie z. B. Smarthomegeräten?

Hast du den 5 GHz Kanal des Router Wlans mal geändert?

Oder ruf direkt beim Support an und mach Diagnosen mit dem Mitarbeiter. Der sieht dann direkt viel mehr und wir sparen uns die ganzen Fragen hier. 

Abzeichen

Ja das habe ich auch geprüft, ist alles wm0. Die Arc ist momentan mit Lan angeschlossen, vorher aber mit WLAN.

Smarthomegeräte habe ich sonst keine.

Den 5 GHz Kanal vom Router habe ich höchstens vor ca. 2 Jahren mal geändert.

 

Ich rufe beim Support an, danke für die Mühen!

 

Benutzerebene 7
Abzeichen +4

@Ben Hur 

Ok, dann ist zumindest das Wlan Modul der Arc aktiv und in Ordnung. 
Dann wäre in der Tat interessant, welches Tonformat bzw. aus welcher App des Apple TV du etwas abspielst. Also wenn du es nicht per AirPlay versuchst… falls da Stereo in der Sonos App angezeigt wird, kann auf den Rearspeakern kaum was ankommen. Höchstens minimal oder halt gar nicht.