Beantwortet

Sonos App für Android friert ein (Version 9.2.1)


Benutzerebene 1
Abzeichen +1
Hallo Community,

ich habe ein Problem mit der Sonos Android App auf meinem Samsung Galaxy S8 (alles Standard), welches ich aber auch schon mit dieser App auf dem Galaxy S6 hatte.

Die App funktioniert nur nach einem Neustart des Mobiltelefons einwandfrei, allerdings jedesmal nur beim ersten Aufruf. Sobald ich sie aus dem Hintergrund hole, friert die App ein oder das Display bleibt sogar völlig schwarz. Ich kann sie dann nur noch abschießen, funktionieren wird sie erst nach einem Neustart des Mobiltelefons wieder.

Hat jemand dasselbe Problem?

Danke und Grüße,
Heiko
icon

Beste Antwort von Son Osone 12 November 2018, 19:51

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

38 Antworten

Benutzerebene 6
Abzeichen +3
Also: seit 36 Stunden funktioniert der Android Controller einwandfrei. Kein Einfrieren mehr.

Ich habe die Musikbibliothek aktualisiert und speziell einen der Pfade der Bibliothek im Desktop-Controller des Notebooks gelöscht. Die Musikdateien befinden sich auf dem Notebook. Der betreffende Pfad kam mir komisch vor, da er wie ein Netzwerkpfad aussah (//ASUS-ZENBOOK-13/Music). So als ob der Desktop-Controller auf dem ASUS Notebook über das Netzwerk "von aussen" auf das Notebook zugreifen müsste. Daneben gab es noch den (lokalen) Pfad C:/Users/Admin/Music im Desktop-Controller definiert.

Den ersten Pfad habe ich gelöscht. Seitdem läuft alles perfekt.

Der Android-Controller greift übrigens über den besagten Pfad //ASUS-ZENBOOK-13/Music über das WLAN-Netz auf die Musikdateien auf dem Notebook zu.

Vielleicht hilft die Beschreibung mal jemandem.

Grüße,
Heiko


Hallo Heiko,

danke für dein Feedback, was anderen sicherlich auch helfen kann. :)

Gruß,
Daniel
Benutzerebene 1
Abzeichen +1
Also: seit 36 Stunden funktioniert der Android Controller einwandfrei. Kein Einfrieren mehr.

Ich habe die Musikbibliothek aktualisiert und speziell einen der Pfade der Bibliothek im Desktop-Controller des Notebooks gelöscht. Die Musikdateien befinden sich auf dem Notebook. Der betreffende Pfad kam mir komisch vor, da er wie ein Netzwerkpfad aussah (//ASUS-ZENBOOK-13/Music). So als ob der Desktop-Controller auf dem ASUS Notebook über das Netzwerk "von aussen" auf das Notebook zugreifen müsste. Daneben gab es noch den (lokalen) Pfad C:/Users/Admin/Music im Desktop-Controller definiert.

Den ersten Pfad habe ich gelöscht. Seitdem läuft alles perfekt.

Der Android-Controller greift übrigens über den besagten Pfad //ASUS-ZENBOOK-13/Music über das WLAN-Netz auf die Musikdateien auf dem Notebook zu.

Vielleicht hilft die Beschreibung mal jemandem.

Grüße,
Heiko
Benutzerebene 6
Abzeichen +3
OK, hier die Diagnoseinfo vom Android Controller: 798260356

VG, Heiko



Hallo,

starte bitte alle Sonos-geräte neu und versuche es dann noch ein weiteres Mal.
Bitte dann auch eine Diagnose absenden.

Gruß,
Daniel
Benutzerebene 1
Abzeichen +1
OK, hier die Diagnoseinfo vom Android Controller: 798260356

VG, Heiko
Benutzerebene 6
Abzeichen +3
Gerne und danke, Daniel.

1795939445
Vom Desktop Controller gesendet.


Hi,

um den Crashlog zu sehen, muss die Diagnose vom betroffenen Controller erstellt werden.

Gruß,
Daniel
Benutzerebene 1
Abzeichen +1
Gerne und danke, Daniel.

1795939445
Vom Desktop Controller gesendet.
Benutzerebene 6
Abzeichen +3
Hallo zusammen,

bei mir gibt es gute Neuigkeiten: Momentan funktioniert alles tadellos, die Mobile App friert nicht mehr ein!
[...]
Werde weiter testen und Feedback geben.


Ich nehme alles zurück, die Mobile App friert nach wie vor regelmäßig ein, außer beim ersten Aufruf nach Starten des Smartphones. Zudem verliert das System auch regelmäßig über Nacht die Einstellung des lokalen Radiosenders der an die Connect zur Stereoanlage gestreamt wird, ca. alle 2 oder 3 Tage.
Wenn ich Alexa anspreche, um den Radiosender wieder auf die Connect zu schalten, hört mich Alexa zwar (Bestätigungston kommt), Alexa antwortet aber nicht und führt das Kommando auch nicht aus. Nur mit der Desktop App kann ich den Radiosender auf die Connect schalten.

Ich habe eine relative einfache Systemkonfiguration (Connect an der Stereoanlage, Playbase an TV mit zwei ONEs als Rearspeaker). Von meinen ca. 60 Apps auf dem Smartphone hat ausschließlich die Sonos App Probleme.


Hi,

sende uns bitte noch eine Diagnose, damit wir uns das ansehen können.

Gruß,
Daniel
Benutzerebene 1
Abzeichen +1
Hallo zusammen,

bei mir gibt es gute Neuigkeiten: Momentan funktioniert alles tadellos, die Mobile App friert nicht mehr ein!
[...]
Werde weiter testen und Feedback geben.


Ich nehme alles zurück, die Mobile App friert nach wie vor regelmäßig ein, außer beim ersten Aufruf nach Starten des Smartphones. Zudem verliert das System auch regelmäßig über Nacht die Einstellung des lokalen Radiosenders der an die Connect zur Stereoanlage gestreamt wird, ca. alle 2 oder 3 Tage.
Wenn ich Alexa anspreche, um den Radiosender wieder auf die Connect zu schalten, hört mich Alexa zwar (Bestätigungston kommt), Alexa antwortet aber nicht und führt das Kommando auch nicht aus. Nur mit der Desktop App kann ich den Radiosender auf die Connect schalten.

Ich habe eine relative einfache Systemkonfiguration (Connect an der Stereoanlage, Playbase an TV mit zwei ONEs als Rearspeaker). Von meinen ca. 60 Apps auf dem Smartphone hat ausschließlich die Sonos App Probleme.
Benutzerebene 6
Abzeichen +3
Hallo Daniel,

danke der Nachfrage, das System läuft seitdem störungsfrei.

Ich hatte einen Play:5; Gen.1 wieder aktiviert und die alte Konfiguration war gleich wieder da.
Als zweite Komponente habe ich dann den zurückgesetzten ZP:120 eingebunden, lief auch ohne Probleme, danach den ganzen Rest des Systems. Seitdem läuft alles gut, die oben beschriebenen Fehler konnten nicht mehr reproduizert werden.

Habt Ihr eine mögliche Ursache gefunden?
Wo wird die aktuelle Konfiguration abgespeichert, auf jedem Player oder BOOST?
Kann man die Konfiguration extern speichern und wo?

Noch eine Frage zu TuneIn, über die iOS App bekomme ich TuneIn nicht mehr, über Desktop Controller kann ich TuneIn auswählen.


Gruß
Peter


Es scheint hier ein Problem mit dem Betriebssystem gegeben zu haben.
Das solltest du auf jeden Fall weiter beobachten und dich ggf. wieder melden.

Das mit TuneIn auf iOS ist mir ein Rätsel.
Kannst du einen Screenshot erstellen?
Bringt das Entfernen und Hinzufügen der App etwas?

Gruß,
Daniel
Abzeichen
Hallo Daniel,

danke der Nachfrage, das System läuft seitdem störungsfrei.

Ich hatte einen Play:5; Gen.1 wieder aktiviert und die alte Konfiguration war gleich wieder da.
Als zweite Komponente habe ich dann den zurückgesetzten ZP:120 eingebunden, lief auch ohne Probleme, danach den ganzen Rest des Systems. Seitdem läuft alles gut, die oben beschriebenen Fehler konnten nicht mehr reproduizert werden.

Habt Ihr eine mögliche Ursache gefunden?
Wo wird die aktuelle Konfiguration abgespeichert, auf jedem Player oder BOOST?
Kann man die Konfiguration extern speichern und wo?

Noch eine Frage zu TuneIn, über die iOS App bekomme ich TuneIn nicht mehr, über Desktop Controller kann ich TuneIn auswählen.


Gruß
Peter
Benutzerebene 6
Abzeichen +3
Hallo Daniel,

wie beim letzten mal habe ich die Diagnosedaten vom iPad Mini gesendet
Bestätigungsnumme: 1843280633

Danke und Gruß
Peter


Hallo Peter,

wie verhält sich das System, wenn du den ZP:120 wieder hinzufügst?

Gruß,
Daniel
Abzeichen
Hallo Daniel,

wie beim letzten mal habe ich die Diagnosedaten vom iPad Mini gesendet
Bestätigungsnumme: 1843280633

Danke und Gruß
Peter
Benutzerebene 6
Abzeichen +3
Hallo Daniel,

Netzwerkaufbau:
der BOOST ist über ein CAT6 Kabel mit dem Kabelmodem von AVM verbunden.
Der Rest ist SonosNet....

Alle Player sind aus (stromlos), einen ZP120 habe auf die Werkseinstellungen zurückgesetzt und ein neues System eingerichtet.
Die SONOS APP auf dem iPad friert nicht mehr ein.

Viele Grüße
Peter


Hi,

kannst du davon eine Diagnose absenden?
Es kann sein, dass sich etwas im Betriebssystem "aufgehangen" hat.
Du kannst dann wieder deine anderen Player einschalten und den ZP:120 wieder zum alten System hinzufügen.

Gruß,
Daniel
[...] Bei der Einrichtung des "Test-Systems" via SONOS APP habe ich festgestellt das TuneIn nicht in der Auswahl der Musikdienste zu finden ist. Ist TuneIN nicht mehr verfügbar???
Stimmt. Kann aber nicht mehr als ein vorübergehender Serverausfall sein.


Gruß,
Peri
Abzeichen
Hallo Daniel,

wie geht es jetzt weiter?
soll ich alle Player zurücksetzen?

Bei der Einrichtung des "Test-Systems" via SONOS APP habe ich festgestellt das TuneIn nicht in der Auswahl der Musikdienste zu finden ist. Ist TuneIN nicht mehr verfügbar???

Gruß
Peter
Abzeichen
Hallo Daniel,

Netzwerkaufbau:
der BOOST ist über ein CAT6 Kabel mit dem Kabelmodem von AVM verbunden.
Der Rest ist SonosNet....

Alle Player sind aus (stromlos), einen ZP120 habe auf die Werkseinstellungen zurückgesetzt und ein neues System eingerichtet.
Die SONOS APP auf dem iPad friert nicht mehr ein.

Viele Grüße
Peter
Benutzerebene 1
Abzeichen +1
Hallo zusammen,

bei mir gibt es gute Neuigkeiten: Momentan funktioniert alles tadellos, die Mobile App friert nicht mehr ein!

Das einzige, was ich verändert habe, ich habe die Musikdienste mittels der App hinzugefügt, statt mit dem Desktop Controller. Kann mir zwar nicht vorstellen, dass das was verändert hat, aber im Moment funktioniert alles.

Werde weiter testen und Feedback geben.
Benutzerebene 6
Abzeichen +3
Hallo Peri,

danke für die schnelle Antwort.
Ich habe den Fehler reproduziert, nachdem ich die APP wieder gestartet habe, wurden vom iPad die Diagnoseinfos gesendet.
Hier ist die Bestätigungsnummer: 2001059846



bei weiteren Tests habe ich die folgenden Ergebnisse bekommen:

Iphone 5S, SW 10.3.3 (14G60)
reproduzierbarer Fehler, einfrieren der SONOS APP, wie iPad Mini

iPad Mini 2, SW 12.0.1 (16A404)
reproduzierbarer Fehler, gemeldet und Diagnose-Info gesendet
Bestätigungsnummer: 2001059846

iPad Air, SW 12.0.1 (16A404)
Fehler nicht immer reproduizierbar.




Viele Grüße
Peter


Hi,

kannst du uns deinen Netzwerkaufbau erläutern?
Schalte mal alle Sonos-Geräte aus und setze einen Player zurück auf die Werkseinstellungen.
Richte dann mal nur mit diesem Player ein neues System ein und teste, ob das Problem auch auftritt.

Gruß,
Daniel
Abzeichen
Hallo Peri,

danke für die schnelle Antwort.
Ich habe den Fehler reproduziert, nachdem ich die APP wieder gestartet habe, wurden vom iPad die Diagnoseinfos gesendet.
Hier ist die Bestätigungsnummer: 2001059846



bei weiteren Tests habe ich die folgenden Ergebnisse bekommen:

Iphone 5S, SW 10.3.3 (14G60)
reproduzierbarer Fehler, einfrieren der SONOS APP, wie iPad Mini

iPad Mini 2, SW 12.0.1 (16A404)
reproduzierbarer Fehler, gemeldet und Diagnose-Info gesendet
Bestätigungsnummer: 2001059846

iPad Air, SW 12.0.1 (16A404)
Fehler nicht immer reproduizierbar.




Viele Grüße
Peter
Benutzerebene 6
Abzeichen +3
Hi Marco,

keine Änderung, weder nach dem Ausschalten der Sperrbildschirmkontrollen, noch nach dem Entfernen aller Musikdienste aus den Einstellungen.
Die App stürzt auch ab, ohne dass ich sie vorher in den Hintergrund schicke. D.h. wenn ich z.B. das Einstellungsmenü verlasse, einen Raum anwähle und die Bedienungselemente für den Raum erscheinen, geht nichts mehr.


Hi,

kannst du uns davon auch eine Diagnose zusenden?

Gruß,
Daniel
Benutzerebene 1
Abzeichen +1
Hi Marco,

keine Änderung, weder nach dem Ausschalten der Sperrbildschirmkontrollen, noch nach dem Entfernen aller Musikdienste aus den Einstellungen.
Die App stürzt auch ab, ohne dass ich sie vorher in den Hintergrund schicke. D.h. wenn ich z.B. das Einstellungsmenü verlasse, einen Raum anwähle und die Bedienungselemente für den Raum erscheinen, geht nichts mehr.
Benutzerebene 3
Abzeichen +3
Hi Daniel,
Desktop-Controller war schon immer installiert. Habe Musikdienst (nur Amazon Music) und Musikbibliothek gelöscht, getestet. Mobile App fror immer noch ein.
Mobile App gelöscht, Musikdienst und Musikbibliothek über Desktop-Controller wieder hinzugefügt, Mobile App neu installiert und angemeldet. Mobile App friert immer noch ein bzw. blockiert Android System sekundenlang.
Daraufhin Diagnose erstellt: Bestätigungsnummer 915091393
Danke für Eure Bemühungen!
Grüße,
Heiko


Schalte in den erweiterten Einstellungen der Sonos App bitte einmal die Sperrbildschirmkontrollen aus und schaue dann bitte ob das Problem dann noch auftritt.
Wenn es immer noch auftritt, entferne bitte alle hinzugefügten Musikdienste aus den Einstellungen und teste erneut.

Bitte führe die beiden Tests nacheinander aus, damit man sehen kann, bei welchem Test es eine Änderung im Verhalten gibt.
Abzeichen
Hallo Peri,

danke für die schnelle Antwort.
Ich habe den Fehler reproduziert, nachdem ich die APP wieder gestartet habe, wurden vom iPad die Diagnoseinfos gesendet.
Hier ist die Bestätigungsnummer: 2001059846


Viele Grüße
Peter
[...] Ist Euch das schon bekannt ?
Habe gerade versucht, es nachzustellen, gelingt mir nicht. Aber da Du schreibst, dass Du es reproduzieren kannst, mach das bitte und setze innerhalb von 15 Min. eine Diagnose ab und antworte hier mit der Bestätigungsnummer, damit ein Techniker sich das anschauen kann.


Gruß,
Peri
Abzeichen
Hallo Son Osone und alle Beteiligten,

es sieht so aus als habe ich das gleiche oder ein ähnliches Problem mit der Sonos iOS App auf dem iPad, beide SW (iOS 12.0.1 und SONOS 9.2) sind auf dem neuesten Stand.
Reproduzierbarer Fehler:
Ich habe die SONOS APP gestartet und benutzt, und öffne jetzt Safari.
Wenn ich jetzt wieder zur geöffneten SONOS APP zurückgehe ist diese nicht mehr bedienbar.
Nach einiger Zeit schließt sich die SONOS APP, den Grund kenne ich nicht, jetzt starte ich sie neu und alles funktioniert wieder.

Ist Euch das schon bekannt ?

Danke und viele Grüße
Peter