Beantwortet

Seit Update auf 13.4 werden keine Albumcover mehr angezeigt


Abzeichen +1

Hallo zusammen,

seit dem letztes Sonos-Update auf Version 13.4 werden keine Albumcover mehr in den Controllern (Windows, Android) angezeigt. Betrifft die eigene Musikbibliothek auf dem NAS (Synology). Die Cover sind jeweils als folder.jpg in den entsprechenden Verzeichnissen abgespeichert. Bis zum letzten Update gabs damit keine Probleme.

Einigen Kollegen im englischen Forum ist das auch schon aufgefallen: Link
Sieht so aus, als hätte Sonos mal wieder einen Fehler eingebaut. Bitte an die Entwickler weiter geben und zügig fixen.

Vielen Dank

icon

Beste Antwort von Spunk 7 December 2021, 19:50

Original anzeigen

Dieser Beitrag ist geschlossen für weitere Beiträge

40 Antworten

Ja, ich fand es auch interessant. Habe deswegen heute zuerst einmal geschaut, ob unter 13.4 bei mir auch keine Cover mehr angezeigt werden. Sie wurden aber angezeigt. Erst danach habe ich unter DSM 7 die SMBv1 deaktiviert, und siehe da: keine Anzeige von Covern mehr. Sodann zurück nach SMBv1, und alle Cover wurden wieder angezeigt. 

Benutzerebene 7
Abzeichen +3

@McKinsey 

Ok, Danke… dann sind wir zumindest einen Schritt weiter. Bleibt dann die Frage, was bei @Spunk anders war und warum es bei ihm schon mit SMB1 nicht mehr funktioniert hat. 

Abzeichen +1

Ich häng mich hier mal dran, weil ich seit 13.4 ein Problem habe, das mit dem hier beschriebenen Problem (Nicht-Anzeigen der Cover) zu tun haben könnte.

Auf meinem QNAP befinden sich in meinem Musikverzeichnis mehr als 65.000 Musikdateien. Um das 65.000-Song-Limit zu umgehen, hatte ich für jedes Album eine m3u-Playlist erzeugt, und dann diese Playlists indizieren lassen. Somit habe ich auch weiterhin Zugriff auf jeden Song - ein Nachteil: Ich kann nicht mehr nach Songs suchen.

Das ganze hatte ich hier beschrieben:
 

Seit 13.4 kann ich keinen Song mehr abspielen. Es erscheint jedes mal die Fehlermeldung “Wiedergabe von …. nicht möglich. Zugriff auf …. wurde verweigert.”

Benutzerebene 7
Abzeichen +3

@Frank_2 

Hast du noch SMB1 eingestellt, oder dein NAS bereits auf SMB2/3 umgestellt?

Abzeichen +1

Auf meinem NAS habe ich nichts verändert. Mindest-SMB-Version: SMB v1. Maximal-SMB-Version: SMB v3.

Ich habe bewusst die Einstellungen auf meinem QNAP-NAS nicht geändert, da ich in diesem Thread lese, dass Covers nicht angezeigt werden, wenn man SMB v1 deaktiviert.

Benutzerebene 7
Abzeichen +3

@Frank_2 

Das soll auch nicht als Lösung gedacht sein, sondern erstmal nur helfen, die Ursache einzugrenzen. 
Da du maximal SMB 3 am NAS zugelassen hast, vermute ich, dass dies nun auch genutzt wird. Kannst du bitte mal auf NUR SMB1 beschränken und testen, ob die m3u PL dann funktionieren?

Das könnten dann alles Hinweise darauf sein, dass aktuell mit SMB 2/3 bestimmte Funktionen wie m3u PL und cover.jpg / folder.jpg nicht funktionieren. Dann kann man abklären ob die nur mit SMB1 kompatibel sind, oder Sonos bzgl. SMB 2/3 etwas nachbessern kann. 
Aber dafür muss man die Ursache eben erstmal ausmachen…

Abzeichen +1

OK, Eingrenzung gelungen. Ich hab auf dem QNAP NAS die maximale SMB-Version auf SMB 1 eingestellt, dann funktionieren m3u-Playlisten wieder und ich konnte Songs abspielen (und Cover der in dem jeweiligen Ordner abgelegten folder.jpg werden angezeigt). Ich musste noch nicht mal den NAS neu starten.

Überraschung: Anschließend habe ich die maximale SMB-Version wieder auf SMB 3 hochgestellt, den NAS weiterhin nicht neu gestartet, ich kann weiterhin Songs abspielen (und die Cover werden weiterhin angezeigt).

Das ist zumindest ein Workaround, bis Sonos den Bug hoffentlich fixt.

Abzeichen +1

Update: Knappe Stunde später: max. SMB-Version aus QNAP steht weiterhin auf SMB 3, Songs können nicht abgespielt werden. NAS wurde nicht neu gestartet. Das Abspielen unter SMB 3 war eben nur temporär möglich.

Benutzerebene 7
Abzeichen +3

@Frank_2 

Ok, dann ist jetzt zumindest klar, dass aktuell mit SMB 2/3 noch nicht alle Funktionen rund laufen. 
Dazu gehören anscheinend die m3u Playlisten und die folder/cover.jpgs. 
Ich denke, dass Sonos wohl noch am SMB Support arbeitet und bisher erste Funktionalität, aber noch kein finaler Stand integriert ist. 
Offiziell ist SMB 2/3 ja auch noch nicht als Feature angekündigt bzw. vorgestellt. War eher ein Zufallsfund. 😉

Abzeichen +1

Mit Version 13.4.1 ist das Problem behoben. 

 

//edit: zu früh gefreut. Es werden jetzt zwar einige, aber leider längst nicht alle Cover angezeigt. Zudem laden die Cover sehr lahm. Aber immerhin wird wohl an dem Problem gearbeitet.

Mit Version 13.4.1 ist das Problem behoben. 

 

//edit: zu früh gefreut. Es werden jetzt zwar einige, aber leider längst nicht alle Cover angezeigt. Zudem laden die Cover sehr lahm. Aber immerhin wird wohl an dem Problem gearbeitet.

Erst mal danke für den Hinweis! Aber in der Tat: zu früh gefreut. Auch bei 13.4.1 werden bei mir Album Cover nur dann angezeigt, wenn auf der DS als Mindestprotokoll SMB Version 1 aktiviert ist.

Abzeichen +1

bei mir Album Cover nur dann angezeigt, wenn auf der DS als Mindestprotokoll SMB Version 1 aktiviert ist.

Seltsam. Ich habe als Mindestprotokoll SMB2 eingestellt. Allerdings werden grob geschätzt nur 70-80% der Cover angezeigt. Also der große Durchbruch war das jetzt noch nicht.

Abzeichen +1

OK, Eingrenzung gelungen. Ich hab auf dem QNAP NAS die maximale SMB-Version auf SMB 1 eingestellt, dann funktionieren m3u-Playlisten wieder und ich konnte Songs abspielen (und Cover der in dem jeweiligen Ordner abgelegten folder.jpg werden angezeigt). Ich musste noch nicht mal den NAS neu starten.

Überraschung: Anschließend habe ich die maximale SMB-Version wieder auf SMB 3 hochgestellt, den NAS weiterhin nicht neu gestartet, ich kann weiterhin Songs abspielen (und die Cover werden weiterhin angezeigt).

Das ist zumindest ein Workaround, bis Sonos den Bug hoffentlich fixt.

Und ich kann berichten, dass die m3u-Playlisten wieder funktionieren - selbst wenn ich auf meinem QNAP-NAS die minimale SMB-Version auf SMB2 stelle.

Bei mir werden bisher alle Covers angezeigt (auch mit minimale SMB-Version = SMB2), allerdings gibt es bei mir keine folder.jpg-Dateien größer als 1000x1000 Pixel.

Das Laden dauert in der Tat etwas, was sich besonders zeigt, wenn man ganze Alben bzw. viele Titel auf einmal der Liste hinzufügt, weil man dann merkt, wie die Covers nacheinander für jeden einzelnen Track geladen und angezeigt werden.

Abzeichen +1

Ich stelle hier mal eine vielleicht naive Frage: Kann die Unterstützung von SMB2/3 auch zur Folge haben, dass das 65.000 Track-Limit sich jetzt erhöht hat? Könnte das jemand vielleicht mal testen, dessen Trackanzahl seiner indizierten Musikbibliothek sich in dieser Größenordnung befindet? Danke im Voraus!

Benutzerebene 7
Abzeichen +3

@Frank_2 

Die SMB Version hat keinen Einfluss auf die maximale Anzahl indizierbarer Dateien. 
Die ist durch die Speichergröße der ältesten/ schwächsten Geräte limitiert, die noch in S2 unterstützt werden. Wenn diese Geräte wie Play3, Play1, Connect, Playbar irgendwann mal komplett raus sind, kann ich mir vorstellen, dass sich daran etwas ändert.