Beantwortet

Fritz.Box-Mediathek und Sonos (meine Loesung)


Abzeichen +1
'Alle paar Jahre' habe ich das Problem, die Musikbibliothek an einer Fritz.Box über Sonos zu nutzen. Gründe für 'Neueinrichtung': Wechsel der Fritz.Box (kaputt, neuer o.ä.), neues USB-Laufwerk (kaputt, zu klein, schneller o.ä.).
Und jedes Mal das gleiche Drama: Wie ging das nochmals??? Recherche und nicht immer sofort die fertige Lösung als Kochrezept gefunden... Deshalb schreibe ich jetzt hier meine Lösung auf... (und sei es wenigstens für mich beim nächsten Male...)

Mein System:
MacBook mit MacOSX 10.13
Sonos Desktop-Controller 8.6
Fritz.Box 7580 OS 6.92
USB-Laufwerk TOSHIBA MK2035GSS (2''), USB 2.0, 180GByte, NTFS-formatiert

(Meine) Vorgehensweise:
1. formatiertes Laufwerk anschließen, Musikbibliothek über Fritz.Nas hochladen, indizieren lassen
2. In der Fritz.Box Heimnetz->Mediaserver aktivieren und neuen Namen ohne einen Punkt "." vergeben; bei 'Medienquellen im Heimnetz' habe ich 'Keine Einschränkung' vergeben. Anm.: U.U. ist diese Namensänderung nicht notwendig; habe ich aber nicht nochmals geprüft.
3. In der Fritz.Box Heimnetz->Fritz!Box-Name habe ich einen Namen ohne Punkt eingetragen. Anm.: Dürfte auch nicht notwendig sein; ich habe aber mehrere Fritz.Boxen im Netz und will sie schnell unterscheiden können.
4. In der Fritz.Box System->Fritz!Box-Benutzer einen neuen Benutzer (für) Sonos anlegen (Benutzernamen und Passwort); Zugang aus dem Internet habe ich nicht freigegeben; Berechtigungen nur 'Zugang zu NAS-Inhalten' markiert und (!) das gewünschte (freigegebene) Verzeichnis über 'Verzeichnis hinzufügen' ausgewählt; VPN-Zugang habe ich nicht freigegeben.
5. Im Sonos Desktop-Controller Verwalten->Einstellungen-Musikbibliothek->Musikbibliothek mit "+" Hinzufügen neue Bibliothek starten; im folgenden Fenster 'Netzwerkgerät auswählen; als Pfad eingeben \\fritz.box\ eingeben; anschließend wird nach Benutzername und Kennwort gefragt; alles bestätigen und Fertig! Anm.: Backslash erreicht man auf dem Mac mit und "/". Ich habe aber festgestellt, dass es neuerdings auch nur mit einem Slash "/" geht (war früher nicht so, nach meiner Erinnerung). Danach wird die Musikbibliothek aktualisiert und steht im Sonos-Controller zur Verfügung.

Ich hoffe, das hilft auch anderen.
icon

Beste Antwort von ReDi 5 Juli 2018, 14:53

(Meine) Vorgehensweise (korrigiert):
1. Formatiertes Laufwerk anschließen, Musikbibliothek über Fritz.Nas hochladen, indizieren lassen
2. In der Fritz.Box Heimnetz-> Speicher(NAS) aktivieren, betreffenden Speicher auswählen; unter 'Heimnetzfreigabe' Zugriff über Netzlaufwerk (SMB) aktivieren und Freigabenamen/-gruppe festlegen (am besten ohne Sonder- und Interpunktionszeichen)
3. In der Fritz.Box Heimnetz->Mediaserver aktivieren und neuen Namen ohne einen Punkt "." vergeben; bei 'Medienquellen im Heimnetz' habe ich 'Keine Einschränkung' vergeben. Anm.: U.U. ist diese Namensänderung nicht notwendig; habe ich aber nicht nochmals geprüft.
4. In der Fritz.Box Heimnetz->Fritz!Box-Name habe ich einen Namen ohne Punkt eingetragen. Anm.: Dürfte auch nicht notwendig sein; ich habe aber mehrere Fritz.Boxen im Netz und will sie schnell unterscheiden können.
5. In der Fritz.Box System->Fritz!Box-Benutzer einen neuen Benutzer (für) Sonos anlegen (Benutzernamen und Passwort); Zugang aus dem Internet habe ich nicht freigegeben; bei Berechtigungen nur 'Zugang zu NAS-Inhalten' markiert und (!) das gewünschte (freigegebene) Verzeichnis über 'Verzeichnis hinzufügen' ausgewählt; VPN-Zugang habe ich nicht freigegeben.
6. Im Sonos Desktop-Controller Verwalten->Einstellungen-Musikbibliothek->Musikbibliothek mit "+" das Hinzufügen einer neuen Bibliothek starten; im folgenden Fenster 'Netzwerkgerät auswählen; als Pfad eingeben \\fritz.box\Freigabenamen eingeben; anschließend wird nach Benutzername und Kennwort gefragt; eingeben und bestätigen und Fertig!

Anm.: Backslash erreicht man auf dem Mac mit Shift und Alt und "/". Ich habe aber festgestellt, dass es neuerdings auch mit einem Slash "/" geht (war früher nicht so, nach meiner Erinnerung). Danach wird die Musikbibliothek aktualisiert und steht im Sonos-Controller zur Verfügung.

So, ich hoffe, dass es das nun war.

Nachtrag: Wenn man Text mit dem Kleiner- und Größer-Zeichen eingibt, wird er hier nicht wiedergegeben. Wie in vielen Foren. Daran hatte ich nicht mehr gedacht, als ich die erste Fassung oben schrieb... So ging was verloren...
Original anzeigen

18 Antworten

Abzeichen +1
Leider ist mein Beitrag oben fehlerhaft, lässt sich aber nicht editieren. Wie in manchen anderen Foren hier das gleiche Problem. Warum kann man hier als Autor nicht Fehler beseitigen???
Abzeichen +1
(Meine) Vorgehensweise (korrigiert):
1. Formatiertes Laufwerk anschließen, Musikbibliothek über Fritz.Nas hochladen, indizieren lassen
2. In der Fritz.Box Heimnetz-> Speicher(NAS) aktivieren, betreffenden Speicher auswählen; unter 'Heimnetzfreigabe' Zugriff über Netzlaufwerk (SMB) aktivieren und Freigabenamen/-gruppe festlegen (am besten ohne Sonder- und Interpunktionszeichen)
3. In der Fritz.Box Heimnetz->Mediaserver aktivieren und neuen Namen ohne einen Punkt "." vergeben; bei 'Medienquellen im Heimnetz' habe ich 'Keine Einschränkung' vergeben. Anm.: U.U. ist diese Namensänderung nicht notwendig; habe ich aber nicht nochmals geprüft.
4. In der Fritz.Box Heimnetz->Fritz!Box-Name habe ich einen Namen ohne Punkt eingetragen. Anm.: Dürfte auch nicht notwendig sein; ich habe aber mehrere Fritz.Boxen im Netz und will sie schnell unterscheiden können.
5. In der Fritz.Box System->Fritz!Box-Benutzer einen neuen Benutzer (für) Sonos anlegen (Benutzernamen und Passwort); Zugang aus dem Internet habe ich nicht freigegeben; bei Berechtigungen nur 'Zugang zu NAS-Inhalten' markiert und (!) das gewünschte (freigegebene) Verzeichnis über 'Verzeichnis hinzufügen' ausgewählt; VPN-Zugang habe ich nicht freigegeben.
6. Im Sonos Desktop-Controller Verwalten->Einstellungen-Musikbibliothek->Musikbibliothek mit "+" das Hinzufügen einer neuen Bibliothek starten; im folgenden Fenster 'Netzwerkgerät auswählen; als Pfad eingeben \\fritz.box\Freigabenamen eingeben; anschließend wird nach Benutzername und Kennwort gefragt; eingeben und bestätigen und Fertig!

Anm.: Backslash erreicht man auf dem Mac mit Shift und Alt und "/". Ich habe aber festgestellt, dass es neuerdings auch mit einem Slash "/" geht (war früher nicht so, nach meiner Erinnerung). Danach wird die Musikbibliothek aktualisiert und steht im Sonos-Controller zur Verfügung.

So, ich hoffe, dass es das nun war.

Nachtrag: Wenn man Text mit dem Kleiner- und Größer-Zeichen eingibt, wird er hier nicht wiedergegeben. Wie in vielen Foren. Daran hatte ich nicht mehr gedacht, als ich die erste Fassung oben schrieb... So ging was verloren...
Zunächst danke für diesen Thread, eine solche Anleitung gibt es glaube ich noch nicht. 🙂


Leider ist mein Beitrag oben fehlerhaft, lässt sich aber nicht editieren. Wie in manchen anderen Foren hier das gleiche Problem. Warum kann man hier als Autor nicht Fehler beseitigen???
Man kann, leider nur innerhalb der ersten 60 Minuten.


Gruß,
Peri
Abzeichen +2
In diesem Fall greifst Du, wie vorgesehen, per SMB auf die Fritzbox zu. Der Medienserver ist nicht relevant. Sonos erkennt die zwar im Hidden-Webinterface, mag die aber nicht nutzen. Vermutlich gibt es nur einen Medienserver, der überhaupt funktioniert. Welcher? Keine Ahnung.
Vorhandene Windows- und UPnP-Server kann man in den "Erweiterten Einstellungen" aktivieren.
Abzeichen +2
Das ist natürlich aktviert. Leider ist es aber bekannt, dass Sonos nur ganz bestimmte UPNP Server unterstützt. Mein Plex geht auch nicht.
Abzeichen +1
Vorhandene Windows- und UPnP-Server kann man in den "Erweiterten Einstellungen" aktivieren.

War und ist bei mir aktiviert. Änderte nichts. Habe allerdings einen Weg gefunden; s. vorstehenden (korrigierten) Beitrag von mir.
Abzeichen +1
[quote=Perpugilliam]Zunächst danke für diesen Thread, eine solche Anleitung gibt es glaube ich noch nicht. 🙂

Danke für die 'Blumen'!
Das ist natürlich aktviert. Leider ist es aber bekannt, dass Sonos nur ganz bestimmte UPNP Server unterstützt. Mein Plex geht auch nicht.
Schau mal unter "Musikdienste hinzufügen" nach.^^
Abzeichen +2
Entscheidend ist unter http://ip-adresse:1400/support/review unter Media Servers die Spalte "CanBeDisplayed". Da steht überwiegend "false"
Abzeichen +2
Das ist natürlich aktviert. Leider ist es aber bekannt, dass Sonos nur ganz bestimmte UPNP Server unterstützt. Mein Plex geht auch nicht.
Schau mal unter "Musikdienste hinzufügen" nach.^^


Ich meine den UPNP Server vom Plex. Der Dienst braucht den Fernzugriff, was für mich keine Option ist. Ich binde den Windows-Server nun per SMB ein.
Das ist natürlich aktviert. Leider ist es aber bekannt, dass Sonos nur ganz bestimmte UPNP Server unterstützt. Mein Plex geht auch nicht.
Schau mal unter "Musikdienste hinzufügen" nach.^^

Okay, unsere Beiträge haben sich überschnitten.
Abzeichen +1
In diesem Fall greifst Du, wie vorgesehen, per SMB auf die Fritzbox zu. Der Medienserver ist nicht relevant. Sonos erkennt die zwar im Hidden-Webinterface, mag die aber nicht nutzen. Vermutlich gibt es nur einen Medienserver, der überhaupt funktioniert. Welcher? Keine Ahnung.

Ja, ich hatte schon vermutet, dass der Mediaserver in der Fritz.Box für Sonos nicht relevant ist. Punkt (3) in meiner 'Anleitung' könnte also entfallen, soweit es den Sonos-Controller betrifft.
Ich will jetzt allerdings nicht tiefer in die Theorie als Autodidakt einsteigen, aus nicht weiter experimentieren. So wie ich es beschrieben habe, sollte es eigentlich auch bei anderen funktionieren. Bin aber dankbar für Korrekturen und/oder Ergänzungen. Dann aber am besten wieder als vollständiges 'Kochrezept', damit nicht an verschiedenen Stellen die Infos zusammengetragen werden müssen.
Das 'Sahnehäubchen' wäre dann, wenn das Kochrezept bei jedem Schritt um technische/theoretische Hintergründe angereichert würde... 🙂
@ReDi: Es passt schon so, wie es ist. Wem es wichtig ist zu versuchen seinen FritzBox-Medienserver einzubinden, der wird sich schon melden, wenn er beim Einrichten scheitert.
Abzeichen +1
Entscheidend ist unter http://ip-adresse:1400/support/review unter Media Servers die Spalte "CanBeDisplayed". Da steht überwiegend "false"
Leider lehnt meine FritzBox den Zugriff über diesen Port ab...
Abzeichen +1
@ReDi: Es passt schon so, wie es ist. Wem es wichtig ist zu versuchen seinen FritzBox-Medienserver einzubinden, der wird sich schon melden, wenn er beim Einrichten scheitert.
Sie haben sicher Recht... Nochmals Dank für die Anerkennung... 😃
Danke - so wurde auch mir geholfen ... mich wundert es schon warum von Sonos oder Fritz das nicht mal im Detail erklärt wird
Abzeichen +1
Danke - so wurde auch mir geholfen ... mich wundert es schon warum von Sonos oder Fritz das nicht mal im Detail erklärt wird
1. gern geschehen! :$
2. Sonos ist für AVM (FritzBox) unbedeutend - AVM (FritzBox) für Sonos. Ich hatte telefonischen Kontakt mit dem Support beider. Keiner kennt den anderen; wenn man Glück hat, hat der ein oder andere Supportmitarbeiter von dem anderen Unternehmen schon mal gehört. Das war's dann aber auch. Und solange sich User der beiden Systeme untereinander helfen können, warum sollte man Zeit und Geld für die Bereitstellung eigener Lösungen investieren? Das ist doch der Hintergrund bei allen Providern, User-Foren anzubieten... :8

Antworten

    Cookie-Richtlinen

    Wir machen Gebrauch von Cookies um Ihr Erlebnis zu personalisieren und zu optimisieren. Wenn Sie zustimmen, stimmen Sie unseren Bestimmungen bzgl. Cookies zu. Klicken Sie hier um mehr über unsere Cookies zu erfahren.

    Akzeptieren Cookie-Einstellungen