Frage

Auf 1/2 iPhones: Musikdienste ausgegraut ("Durchsuchen der Musikdateien nicht möglich..")


Abzeichen
Hi Community,

ich bin ratlos. Sonos funktioniert auf iPhone 1 und iPad einwandfrei. iPhone 2 funktioniert die Steuerung von Sonos auch, dh. vor, zurück, lauter und leiser. Allerdings sind alle Musikdienste ausgegraut. Ich kann also nach keinen Songs suchen, keine Musikdienste hinzufügen und auch sagt die App ich sei nicht angemeldet.

Musikdienste:
"Durchsuchen der Musikdateien nicht möglich - beim Herstellen der Verbindung mit Spotify ist ein Problem aufgetreten."

Kontoanmeldung:
"Netzwerkproblem..."

Habt ihr eine Ahnung woran das liegen könnte? Dinge, die ich schon versucht habe:

- Sonos Neustart inkl. Router
- Controller Zurücksetzen
- Wlan Unterstützung deaktiviert

Danke euch!!

VG
Chris

Dieser Beitrag ist geschlossen für weitere Beiträge

30 Antworten

Benutzerebene 6
Abzeichen +3
Hi, Diagnose vom funktionierenden Gerät kommt gleich heute Abend.
Ja ich denke dass über die Corporate Funktion ggf. ein zusätzlicher DNS Server definiert ist.


Hi,

kannst du mal die DNS-Einstellungen prüfen und ggf. notieren?
Nicht, damit du mir die DNS-Einstellungen verrätst, keine Sorge.
Nimm die Einstellung mal raus und prüfe, ob das einen Einfluss darauf hat.

Gruß,
Daniel


Du meinst mit dem Firmentelefon oder? Welche Einstellungen soll ich rausnehmen?


Hi,

beim betroffenen Telefon prüfst du die DNS-Einstellungen:
https://appleinsider.com/articles/18/04/22/how-to-change-the-dns-server-used-by-your-iphone-and-ipad

Gruß,
Daniel
Ich denke den Ansatz kann Dir nur die IT-Abteilung Deiner Firma liefern.
Abzeichen
Diensthandys sind halt nicht für private Zwecke vorgesehen (wenngleich der Dienstgeber ein Auge zudrückt).

Mein AG hat das explizit erlaubt + habe ich die Bestätigung, dass von dieser Seite keine Einschränkungen oder Blocks vorgenommen wurden. Dh. das Problem müsste sich lösen lassen. Die Hinweise Richtung AirWatch und DNS sind sicherlich richtig, mir fehlt momentan nur der Ansatz den Ursprung zurück zu verfolgen..
Diensthandys sind halt nicht für private Zwecke vorgesehen (wenngleich der Dienstgeber ein Auge zudrückt).
Abzeichen
Also ich hab die Einstellungen unter DNS verglichen und sie sind beide gleich.
Aktuell finde ich unter dem betroffenen iPhone das Sonos System gar nicht mehr - beim anderen hingegen schon...
Abzeichen
Hi, Diagnose vom funktionierenden Gerät kommt gleich heute Abend.
Ja ich denke dass über die Corporate Funktion ggf. ein zusätzlicher DNS Server definiert ist.


Hi,

kannst du mal die DNS-Einstellungen prüfen und ggf. notieren?
Nicht, damit du mir die DNS-Einstellungen verrätst, keine Sorge.
Nimm die Einstellung mal raus und prüfe, ob das einen Einfluss darauf hat.

Gruß,
Daniel


Du meinst mit dem Firmentelefon oder? Welche Einstellungen soll ich rausnehmen?
Benutzerebene 6
Abzeichen +3
Hi, Diagnose vom funktionierenden Gerät kommt gleich heute Abend.
Ja ich denke dass über die Corporate Funktion ggf. ein zusätzlicher DNS Server definiert ist.


Hi,

kannst du mal die DNS-Einstellungen prüfen und ggf. notieren?
Nicht, damit du mir die DNS-Einstellungen verrätst, keine Sorge.
Nimm die Einstellung mal raus und prüfe, ob das einen Einfluss darauf hat.

Gruß,
Daniel
Abzeichen
Hi @Sonos,

Anbei die Diagnose Nr. vom funktionierenden iPhone: 1444841028

Danke für euer Feedback!

Viele Grüße
Christian
Abzeichen
Hi, Diagnose vom funktionierenden Gerät kommt gleich heute Abend.
Ja ich denke dass über die Corporate Funktion ggf. ein zusätzlicher DNS Server definiert ist.
Benutzerebene 6
Abzeichen +3
1818536739

Danke nochmal für die Hilfe!
@Sonos: Danke für euer Feedback!


Hi,

ist die Diagnose von dem betroffenen Iphone?
Kannst du uns auch eine Diagnose vom funktionierenden Gerät zusenden?
Es scheint hier Probleme mit der DNS-Abfrage zwischen Iphone, Sonos und dem Router zu geben.
Ist in den Netzwerkeinstellungen des Iphone ein separater DNS-Server eingetragen?

Gruß,
Daniel
Abzeichen
1818536739

Danke nochmal für die Hilfe!
@Sonos: Danke für euer Feedback!
Also erst einmal vielen Dank euch für Hilfe, Antworten und Mühen. Ich habe das Problem verstanden. Was ich allerdings nicht verstehe ist warum ich trotzdem Sonos über mein Dienst Handy bedienen kann oder das Ganze direkt über Spotify steuern kann. Gibt es also hier einen Work Around?
Setze eine Diagnose ab und antworte hier mit der Bestätigungsnummer, damit ein Techniker sich das anschauen kann. Wenn es mit dem Zertifikat zusammenhängt, gibt es keinen Workaround. Ich gehe mal davon aus, dass Du Zertifikate nicht eigenmächtig entfernen und auch das iPhone nicht zurücksetzen darfst.
Abzeichen
Also erst einmal vielen Dank euch für Hilfe, Antworten und Mühen. Ich habe das Problem verstanden. Was ich allerdings nicht verstehe ist warum ich trotzdem Sonos über mein Dienst Handy bedienen kann oder das Ganze direkt über Spotify steuern kann. Gibt es also hier einen Work Around?
Wie meinst du das? Wo kann ich das denn nachsehen? Ich sehe keinen Verweis auf Air Play Block
Da gibt es auch keinen Hinweis. Wie gesagt ist ein Zertifikat, musst Du mit Deiner Firma abklären, Sonos kann da nichts machen, weil sie nicht einfach fremde Sicherheitsbestimmungen umgehen dürfen. Betrifft in Deinem Fall nicht nur Airplay.

https://de.community.sonos.com/controller-und-software-223391/airplay-code-fehlt-6743582/index1.html#post16033663
Abzeichen
Wie meinst du das? Wo kann ich das denn nachsehen? Ich sehe keinen Verweis auf Air Play Block
Ein Firmentelefon? Dann dürfte ein Sicherheitszertifikat vom Dienstgeber der Grund sein, Airplay funktioniert z.B. ebenfalls nicht, weil ein Code abgefragt wird. Müsste ebenfalls unter Geräteverwaltung zu finden sein.
Abzeichen
Also ich kann mich anmelden (erscheinen 4 Play1 - aus irgendeinem Grund fehlen eine Play1 und die Playbar, aber ok).
Unter Geräteverwaltung sehe ich keinen Hinweis auf ein Apple Beta Zertifikat.
Mein iPhone (Firmentelefon) wurde letzte Woche auf einen neuen E-Mail Account migriert. Office 365 und damit auch wahrscheinlich ein neues Zertifiat installiert. Aber ich weiß nicht wie das im Zusammenhang stehen könnte.
Bist du mit dem Gerät vielleicht in einer Apple Beta?
Kannst du dich mit dem iPhone auf dieser Seite anmelden?
https://www.sonos.com/myaccount/products/

In dem Fall scheint in den 'Einstellungen --> Allgemein --> Geräteverwaltung' ein Zertifikat auf, dass das iPhone für die Beta berechtigt.
Benutzerebene 7
Abzeichen +3
Bist du mit dem Gerät vielleicht in einer Apple Beta?
Kannst du dich mit dem iPhone auf dieser Seite anmelden?
https://www.sonos.com/myaccount/products/
Abzeichen
Nein hab ich leider nicht - auch schon versucht aber ohne Erfolg.
Ich war eine Woche im Urlaub - hatte den Router aus und danach gings nicht mehr. Vorher ging es 😕
Benutzerebene 7
Abzeichen +3
Hast du das Gerät im Router irgendwie extra eingestellt?
Wirf es mal aus der Verbindungsliste im Router raus und dann neu anmelden am WLAN.
Abzeichen
Hi,

anbei drei Screenshots. Musik läuft, aber Durchsuchen ist nicht möglich. Ebenso wenig kann ich mich hier auf meinem Konto anmelden. Daher vermute ich, dass irgendetwas die Verbindung zu Sonos Servern bzw. die Weiterleitung zu den Musikdienste Servern blockt...
Könntest Du mal einen Screenshot posten?
Abzeichen
Ich hab auch schon daran gedacht. Aber nein. Wie gesagt die normalen controls und aktuelle playliste lassen sich steuern.
Benutzerebene 7
Abzeichen +3
Hi Chris,
eventuell eine VPN Verbindung auf dem zweiten iPhone eingerichtet?
Sollte dann gar nicht gehen, aber man weiß ja nie 😃
Gruß
Armin