Frage

Abbruch von Amazon Music-Listen mit Alexa


Abzeichen
Hallo zusammen,
mit Amazon Prime hat mich ein bekanntes Problem erwischt:
Werden Playlisten oder Zufallswiedergabe mit Alexa aufgerufen, bricht die Wiedergabe i.d.R. nach dem ersten Titel ab.
Rufe ich dieselbe Liste direkt mit Sonos auf, läuft sie problemlos durch.

Die bei diesem Problem immer wieder empfohlene Neuinstallation des Alexa-Skills habe ich jetzt mehrfach durchgeführt - sie verschiebt das Problem maximal um 2 bis 3 Titel oder einen Tag nach hinten; dann taucht es erneut auf.

Vorsorglich habe ich gerade nach dem letzten Abbruch eine Diagnose gestartet: ID 1609766606
Zugang zum Internet mit Unitymedia und Fritzbox 6590.

Vielen Dank und beste Grüße
Achim

Dieser Beitrag ist geschlossen für weitere Beiträge

21 Antworten

Benutzerebene 6
Abzeichen +3
Hallo zusammen,
mit Amazon Prime hat mich ein bekanntes Problem erwischt:
Werden Playlisten oder Zufallswiedergabe mit Alexa aufgerufen, bricht die Wiedergabe i.d.R. nach dem ersten Titel ab.
Rufe ich dieselbe Liste direkt mit Sonos auf, läuft sie problemlos durch.

Die bei diesem Problem immer wieder empfohlene Neuinstallation des Alexa-Skills habe ich jetzt mehrfach durchgeführt - sie verschiebt das Problem maximal um 2 bis 3 Titel oder einen Tag nach hinten; dann taucht es erneut auf.

Vorsorglich habe ich gerade nach dem letzten Abbruch eine Diagnose gestartet: ID 1609766606
Zugang zum Internet mit Unitymedia und Fritzbox 6590.

Vielen Dank und beste Grüße
Achim


Hallo,

kannst du mal alle Sonos-Geräte neu starten, den Skill aus- und wieder einschalten, sowie noch eine Diagnose (inkl. Feedback) zusenden?

Gruß,
Daniel
Abzeichen
Hi,

den selben Fehler habe ich. Ich hatte auch schon die Geräte ausgeschaltet und die Skills wieder aktiviert, aber es ändert nichts an dem Verhalten

Beste Grüße
Boris
Hi,

den selben Fehler habe ich. Ich hatte auch schon die Geräte ausgeschaltet und die Skills wieder aktiviert, aber es ändert nichts an dem Verhalten

Beste Grüße
Boris

Stelle den Fehler bitte nach und setze innerhalb von 15 Min. eine Diagnose (Link) ab und antworte hier mit der Bestätigungsnummer, damit ein Techniker sich das anschauen kann.
Abzeichen

Hallo,

kannst du mal alle Sonos-Geräte neu starten, den Skill aus- und wieder einschalten, sowie noch eine Diagnose (inkl. Feedback) zusenden?

Gruß,
Daniel


Vielen Dank für die schnelle Antwort.

Ich habe jetzt (in der Reihenfolge)
- den Skill ausgeschaltet (Browser)
- alle Sonos-Geräte neu gestartet
- den Skill erneut aktiviert (Browser)
- nochmal alle Sonos-Geräte und
- alle Dots neu gestartet
- eine neue Diagnoseinfo erstellt, ID 1600586343

Noch ein Nachtrag:
Ich hatte heute (vorher) wieder den Fall, dass Alexa den Start der Wiedergabe auf Sonos verweigerte, da angeblich Amazon-Music (prime) auf einem anderen Gerät wiedergegeben würde. Es waren aber alle Dots und alle Sonos-Geräte stumm, PC, Tablet und Laptop aus und auf dem Handy lief auch nichts.
Offensichtlich hat da mit dem Beenden der Wiedergabe die Abmeldung oder Freigabe bei Amazon-Music nicht richtig funktioniert.
I.d.R. sind drei Play 1 gruppiert, die Wiedergabe wird fast immer über Alexa beendet.
Liegt in der zwangsweisen Abmeldung der kurzzeitige Erfolg der Neuinstallationen?

Zur Zeit funktioniert es, aber nach allen Erfahrungen mit den bisher durchgeführten Neuinstallationen ist das nur eine Frage der Zeit.

Gibt es eigentlich außer gekoppelten Funksteckdosen eine Alternative zum dem früheren reboot von Sonos-Geräten über den Browser? Meist sind die Kabel gut verborgen, die Geräte im Haus verteilt und das ganze entwickelt sich zu einem prima Fitness-Programm ;-)

Nochmal vielen Dank und Grüße
Achim
Abzeichen

Stelle den Fehler bitte nach und setze innerhalb von 15 Min. eine Diagnose (Link) ab und antworte hier mit der Bestätigungsnummer, damit ein Techniker sich das anschauen kann.


Ich habe jetzt (in der Reihenfolge)
- den Skill ausgeschaltet (Browser)
- alle Sonos-Geräte neu gestartet
- den Skill erneut aktiviert (Browser)
- nochmal alle Sonos-Geräte neu gestartet
- eine neue Diagnoseinfo erstellt, ID 680834492

Danach spielt Alexa über die Sonos bei "Alexa, spiele Band" weiter nur ein Lied der Band und verstummt danach.

Beste Grüße
Boris
[...] Gibt es eigentlich außer gekoppelten Funksteckdosen eine Alternative zum dem früheren reboot von Sonos-Geräten über den Browser? Meist sind die Kabel gut verborgen, die Geräte im Haus verteilt und das ganze entwickelt sich zu einem prima Fitness-Programm ;-)
Derzeit leider nicht. Ich mache es über den Sicherungskasten.
Abzeichen
Derzeit leider nicht. Ich mache es über den Sicherungskasten.
Dann doch eher Schaltsteckdosen 🙂

Zurück zum Thema:
Das war's dann auch bei meiner gefühlten 127. Neuinstallation. 24 Stunden! :@
Nach dem Test gestern lief die erste längere Playlist heute Morgen noch einwandfrei, jetzt wird wieder nach dem ersten Titel abgebrochen.
Hier die neue ID 2076649092

Nehmt's bitte nicht übel, aber euer einziger Rat zur ständigen Neuinstallation macht schon einen eher hilflosen Eindruck.

Schöne Ostern,
Gruß
Achim
Nehmt's bitte nicht übel, aber euer einziger Rat zur ständigen Neuinstallation macht schon einen eher hilflosen Eindruck.
Alexa scheint die Verbindung zu Amazon Web Services zu verlieren. Warum das so ist, muss abgeklärt werden. Wenn Du nach einem Abbrechen der Wiedergabe Alexa nach Geräten suchen lässt, funktioniert es dann wieder für eine Weile?
Abzeichen
Wenn Du nach einem Abbrechen der Wiedergabe Alexa nach Geräten suchen lässt, funktioniert es dann wieder für eine Weile?
Danke, ja, sieht im Moment so aus. Ist zumindest einfacher als die Sonos-Neustarts
Wenn Du nach einem Abbrechen der Wiedergabe Alexa nach Geräten suchen lässt, funktioniert es dann wieder für eine Weile?
Danke, ja, sieht im Moment so aus. Ist zumindest einfacher als die Sonos-Neustarts

Meinst Du damit Neustarts des Systems? Was hast Du eigentlich, Amazon Echos oder Sonos ONE/Beam?
Abzeichen

kannst du mal alle Sonos-Geräte neu starten, den Skill aus- und wieder einschalten, sowie noch eine Diagnose (inkl. Feedback) zusenden?

Gruß,
Daniel

Sonos Play1 3x und Playbar 1x
Alexa div. Dots 2. und 3. Generation und Spot
kein(!) Sonos mit "eingebauter Alexa"
Abzeichen

Was hast Du eigentlich, Amazon Echos oder Sonos ONE/Beam?


Bei mir sind es eine Beam und eine ONE
Betreibst Du Sonos über WLAN oder ist z.B. die Playbar mit der Fritzbox verkabelt? Autorisiere den Sonos-Skill bitte nach folgender Anleitung neu:


1. Im Browser Amazon Alexa aufrufen.
2. Sollten unter 'Smart Home' --> Geräte noch die Sonos Player gelistet sein, diese verwerfen und sollte unter --> 'Smart Home Skills' (wie hier abgebildet) der Sonos Skill aktiviert sein, bitte deaktivieren.




3. Danach aus Amazon Alexa abmelden und die Chronik des Browsers löschen, anschließend wieder bei Amazon Alexa anmelden (Browserverlauf löschen ist eventuell nicht notwendig, ich habe es vorsichtshalber gemacht)
4. Unter 'Skills' nach Sonos suchen, den Skill aktivieren und den Anweisungen folgen




5. Neustart aller Amazon Echos
6. Neustart aller Sonos-Komponenten


Viel Erfolg,
Peri

Was hast Du eigentlich, Amazon Echos oder Sonos ONE/Beam?


Bei mir sind es eine Beam und eine ONE


Bitte Folgendes versuchen:


- Vergewissere Dich zunächst, dass im Sonos Controller (Mobilgerät) in den Raumeinstellungen von ONE und BEAM der Sonos Skill entfernt ist. Danach zu einem PC wechseln.
- Im Browser Amazon Alexa (Link!) aufrufen. Sollten unter 'Smart Home --> Geräte' noch die Sonos Player gelistet sein, diese verwerfen und sollte unter --> 'Smart Home Skills' (wie hier abgebildet) der Sonos Skill aktiviert sein, bitte deaktivieren.




- Danach aus Amazon Alexa abmelden und die Chronik des Browsers löschen, anschließend wieder bei Amazon Alexa anmelden (Browserverlauf löschen ist eventuell nicht notwendig, ich habe es vorsichtshalber gemacht)
- Unter 'Skills' nach Sonos suchen, den Skill aktivieren und den Anweisungen folgen.





Schau im Anschluss im Mobilgerät unter den Raumeinstellungen von ONE und BEAM nach, ob Alexa dort aufscheint. Falls nicht, rufe den Reiter "Sprachdienste" auf, tippe auf 'Amazon Alexa' und befolge die Anweisungen.


Viel Erfolg,
Peri
Abzeichen

Bitte Folgendes versuchen:

...

Viel Erfolg,
Peri


Habe ich gemacht, auch danach wird nur ein Song gespielt

Beste Grüße
Boris
Benutzerebene 6
Abzeichen +3

Bitte Folgendes versuchen:

...

Viel Erfolg,
Peri


Habe ich gemacht, auch danach wird nur ein Song gespielt

Beste Grüße
Boris


Hallo,

kannst du davon bitte auch eine Diagnosenummer erstellen?

Gruß,
Daniel
Abzeichen


Hallo,

kannst du davon bitte auch eine Diagnosenummer erstellen?

Gruß,
Daniel


Die ID ist 531279461

Beste Grüße
Boris
Benutzerebene 6
Abzeichen +3


Hallo,

kannst du davon bitte auch eine Diagnosenummer erstellen?

Gruß,
Daniel


Die ID ist 531279461

Beste Grüße
Boris


Jetzt schließe bitte mal ein Sonos-Gerät via LAN an und teste es erneut.
Abzeichen
Hallo zusammen,
da man den Tipp von Peri häufiger in den Foren-Seiten findet, hatte ich ihn natürlich schon vor meiner ersten Meldung mehrfach ausgeführt. Wie beschrieben erfolglos.

Über die Feiertage habe ich mal nicht am Skill sondern bei den erkannten Geräten angesetzt und alle(!) Geräte wie SmartHome und auch eben Sonos entfernt und neu eingerichtet.
Im Unterschied zu allen bisherigen Versuchen habe ich das bewusst nicht mit dem Browser gemacht, sondern Alexa ihren Job machen lassen: "Alexa, suche Geräte". Die Zusammenfassung der erkannten Geräte in Räumen / Gruppen habe ich auch wieder nicht mit dem Browser, sondern mit der Smartphone-App (Android 9, Sonos 10.1.2) durchgeführt, den notwendigen Neuaufbau der Routinen ohnehin.

Seitdem laufen Playlisten, Prime-Radiosender etc. durch, auch wenn sie sprachgesteuert über Alexa gestartet wurden. Hoffentlich hält das noch eine Zeit :8

Ich kann mir durchaus vorstellen, dass die Browser-Variante zumindest für Einrichtungen langsam aber sicher obsolet wird.

Danke für eure Hilfe!

Beste Grüße
Achim
Benutzerebene 6
Abzeichen +3
Hallo zusammen,
da man den Tipp von Peri häufiger in den Foren-Seiten findet, hatte ich ihn natürlich schon vor meiner ersten Meldung mehrfach ausgeführt. Wie beschrieben erfolglos.

Über die Feiertage habe ich mal nicht am Skill sondern bei den erkannten Geräten angesetzt und alle(!) Geräte wie SmartHome und auch eben Sonos entfernt und neu eingerichtet.
Im Unterschied zu allen bisherigen Versuchen habe ich das bewusst nicht mit dem Browser gemacht, sondern Alexa ihren Job machen lassen: "Alexa, suche Geräte". Die Zusammenfassung der erkannten Geräte in Räumen / Gruppen habe ich auch wieder nicht mit dem Browser, sondern mit der Smartphone-App (Android 9, Sonos 10.1.2) durchgeführt, den notwendigen Neuaufbau der Routinen ohnehin.

Seitdem laufen Playlisten, Prime-Radiosender etc. durch, auch wenn sie sprachgesteuert über Alexa gestartet wurden. Hoffentlich hält das noch eine Zeit :8

Ich kann mir durchaus vorstellen, dass die Browser-Variante zumindest für Einrichtungen langsam aber sicher obsolet wird.

Danke für eure Hilfe!

Beste Grüße
Achim


Hallo Achim,

danke für diese Rückmeldung.
Ich gebe das auch mal an die Spezialisten weiter.

Gruß,
Daniel
[...] Über die Feiertage habe ich mal nicht am Skill sondern bei den erkannten Geräten angesetzt und alle(!) Geräte wie SmartHome und auch eben Sonos entfernt und neu eingerichtet.
Im Unterschied zu allen bisherigen Versuchen habe ich das bewusst nicht mit dem Browser gemacht, sondern Alexa ihren Job machen lassen: "Alexa, suche Geräte". Die Zusammenfassung der erkannten Geräte in Räumen / Gruppen habe ich auch wieder nicht mit dem Browser, sondern mit der Smartphone-App (Android 9, Sonos 10.1.2) durchgeführt, den notwendigen Neuaufbau der Routinen ohnehin.

Seitdem laufen Playlisten, Prime-Radiosender etc. durch, auch wenn sie sprachgesteuert über Alexa gestartet wurden. Hoffentlich hält das noch eine Zeit :8

Ich kann mir durchaus vorstellen, dass die Browser-Variante zumindest für Einrichtungen langsam aber sicher obsolet wird.

Der große Unterschied ist hier, dass Du die Alexa-Gruppen neu eingerichtet hast, die man wie die Routinen ohnehin nur in der Mobilen Alexa-App zusammenstellen kann. Und Alexa kann nur dann nach Geräten suchen, wenn der Skill bereits eingerichtet ist. Ich werde demnach weiterhin auf den Browser setzen, denn die Mobile Alexa-App arbeitet nicht anders, allerdings über den standardmäßigen Android- oder iOS-Browser.


Jedenfalls bedanke ich mich für den Hinweis mit den Alexa-Gruppen, muss ich mir merken.